To our customers,

Old Company Name in Catalogs and Other Documents

On April 1%, 2010, NEC Electronics Corporation merged with Renesas Technology
Corporation, and Renesas Electronics Corporation took over all the business of both
companies. Therefore, although the old company name remains in this document, it is a valid
Renesas Electronics document. We appreciate your understanding.

Renesas Electronics website: http://www.renesas.com

April 1%, 2010
Renesas Electronics Corporation

Issued by: Renesas Electronics Corporation (http://www.renesas.com)

Send any inquiries to http://www.renesas.com/inquiry.
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Notice

All information included in this document is current as of the date this document isissued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful atention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any lossesincurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the devel opment of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errorsin or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’ s quality grade, as
indicated below. Y ou must check the quality grade of each Renesas Electronics product before using it in aparticular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not bein any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances, machine tools; personal electronic equipment; and industrial robots.
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.
“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose adirect threat to human life.
Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physica injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as aresult of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sdes office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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Cautions

Keep safety first in your circuit designs!

1

Renesas Technology Corp. puts the maximum effort into making semiconductor products better and more reliable, but
there is always the possibility that trouble may occur with them. Trouble with semiconductors may lead to personal
injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate measures such as (i)
placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or (iii) prevention against any
malfunction or mishap.

Notes regarding these materials

1

These materids are intended as a reference to assist our customers in the selection of the Renesas Technology Corp.
product best suited to the customer's application; they do not convey any license under any intellectual property rights,
or any other rights, belonging to Renesas Technology Corp. or athird party.

Renesas Technology Corp. assumes no responsibility for any damage, or infringement of any third-party's rights,
originating in the use of any product data, diagrams, charts, programs, algorithms, or circuit application examples
contained in these materials.

All information contained in these materials, including product data, diagrams, charts, programs and algorithms
represents information on products at the time of publication of these materials, and are subject to change by Renesas
Technology Corp. without notice due to product improvements or other reasons. It is therefore recommended that
customers contact Renesas Technology Corp. or an authorized Renesas Technology Corp. product distributor for the
latest product information before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.

Renesas Technology Corp. assumes no responsibility for any damage, liability, or other loss rising from these
inaccuracies or errors.

Please a so pay attention to information published by Renesas Technology Corp. by various means, including the
Renesas Technology Corp. Semiconductor home page (http://www.renesas.com).

When using any or al of the information contained in these materials, including product data, diagrams, charts,
programs, and agorithms, please be sure to evaluate all information as atotal system before making afinal decision on
the applicability of theinformation and products. Renesas Technology Corp. assumes no responsibility for any
damage, liability or other loss resulting from the information contained herein.

Renesas Technology Corp. semiconductors are not designed or manufactured for use in a device or system that is used
under circumstances in which human lifeis potentially at stake. Please contact Renesas Technology Corp. or an
authorized Renesas Technology Corp. product distributor when considering the use of a product contained herein for
any specific purposes, such as apparatus or systems for transportation, vehicular, medical, aerospace, nuclear, or
undersea repeater use.

The prior written gpproval of Renesas Technology Corp. is necessary to reprint or reproduce in whole or in part these
materials.

If these products or technol ogies are subject to the Japanese export control restrictions, they must be exported under a
license from the Japanese government and cannot be imported into a country other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the country of destination
is prohibited.

Please contact Renesas Technology Corp. for further details on these material's or the products contained therein.







IMPORTANT INFORMATION
READ FIRST

* READ thisuser's manual before using thisemulator product.
« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully under stand its mechanism.

Emulator Product:
Throughout this document, the term "emulator product” shall be defined as the following
products produced only by Renesas Technology Corp. excluding all subsidiary products.

e Emulator station

e User system interface cables

e PCinterface board

e Optional SIMM memory module
e Optiona board

The user system or a host computer is not included in this definition.

Purpose of the Emulator Product:

This emulator product is a software and hardware development tool for systems employing the
Renesas microcomputer (hereinafter referred to asthe MCU). This emulator product must only be
used for the above purpose.

Limited Applications:

This emulator product is not authorized for usein MEDICAL, atomic energy, aeronautical or
space technology applications without consent of the appropriate officer of a Renesas sales
company. Such useincludes, but isnot limited to, use in life support systems. Buyers of this
emulator product must notify the relevant Renesas sales offices before planning to use the product
in such applications.

Improvement Policy:

Renesas Technology Corp. (including its subsidiaries, hereafter collectively referred to as
Renesas) pursues a policy of continuing improvement in design, performance, and safety of the
emulator product. Renesas reserves the right to change, wholly or partialy, the specifications,
design, user's manual, and other documentation at any time without notice.

Target User of the Emulator Product:

This emulator product should only be used by those who have carefully read and thoroughly
understood the information and restrictions contained in the user's manual. Do not attempt to use
the emulator product until you fully understand its mechanism.

It is highly recommended that first-time users be instructed by usersthat are well versed in the
operation of the emulator product.
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LIMITED WARRANTY

Renesas warrants its emulator products to be manufactured in
accordance with published specifications and free from defectsin
material and/or workmanship. Renesas, at its option, will repair or
replace any emulator products returned intact to the factory,
transportation charges prepaid, which Renesas, upon inspection,
determine to be defective in material and/or workmanship.

The foregoing shall constitute the sole remedy for any breach of
Renesas warranty. See the Renesas warranty booklet for details on
the warranty period. Thiswarranty extends only to you, the original
Purchaser. It isnot transferable to anyone who subsequently purchases
the emulator product from you. Renesasis not liable for any claim
made by athird party or made by you for athird party.

DISCLAIMER

RENESAS MAKES NO WARRANTIES, EITHER EXPRESS OR
IMPLIED, ORAL OR WRITTEN, EXCEPT AS PROVIDED
HEREIN, INCLUDING WITHOUT LIMITATION THEREOF,
WARRANTIESASTO MARKETABILITY, MERCHANTABILITY,
FITNESS FOR ANY PARTICULAR PURPOSE OR USE, OR
AGAINST INFRINGEMENT OF ANY PATENT. IN NO EVENT
SHALL RENESASBE LIABLE FOR ANY DIRECT, INCIDENTAL
OR CONSEQUENTIAL DAMAGES OF ANY NATURE, OR
LOSSES OR EXPENSES RESULTING FROM ANY DEFECTIVE
EMULATOR PRODUCT, THE USE OF ANY EMULATOR
PRODUCT, OR ITSDOCUMENTATION, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. EXCEPT AS
EXPRESSLY STATED OTHERWISE IN THISWARRANTY,
THISEMULATOR PRODUCT ISSOLD "ASIS", AND YOU
MUST ASSUME ALL RISK FOR THE USE AND RESULTS
OBTAINED FROM THE EMULATOR PRODUCT.

RENESAS




State Law:

Some states do not allow the exclusion or limitation of implied warranties or liability for
incidental or consequential damages, so the above limitation or exclusion may not apply to you.
Thiswarranty gives you specific legal rights, and you may have other rights which may vary from
State to state.

The Warranty is Void in the Following Cases:

Renesas shall have no liability or legal responsibility for any problems caused by misuse,
abuse, misapplication, neglect, improper handling, installation, repair or modifications of the
emulator product without Renesas' prior written consent or any problems caused by the user
system.

All Rights Reserved:

This user's manual and emulator product are copyrighted and all rights are reserved by
Renesas. No part of this user's manual, all or part, may be reproduced or duplicated in any form,
in hard-copy or machine-readable form, by any means available without Renesas prior written
consent.

Other Important Things to Keep in Mind:

1. Circuitry and other examples described herein are meant merely to indicate the characteristics
and performance of Renesas' semiconductor products. Renesas assumes no responsibility for
any intellectual property claims or other problems that may result from applications based on
the examples described herein.

2. Nolicenseisgranted by implication or otherwise under any patents or other rights of any third
party or Renesas.
Figures:

Some figures in this user's manua may show items different from your actual system.

Limited Anticipation of Danger:

Renesas cannot anticipate every possible circumstance that might involve a potential hazard.
The warnings in this user's manual and on the emulator product are therefore not all inclusive.
Therefore, you must use the emulator product safely at your own risk.

m
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SAFETY PAGE
READ FIRST

* READ thisuser's manual before using this emulator product.

« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully understand its mechanism.

DEFINITION OF SIGNAL WORDS

A This is the safety alert symbol. Itis used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

A DANGER DANGER indicates an imminently hazardous situation which, if not

avoided, will result in death or serious injury.

A WARNING WARNING indicates a potentially hazardous situation which, if not
avoided, could result in death or serious injury.
A CAUTION CAUTION indicates a potentially hazardous situation which, if not
avoided, may result in minor or moderate injury.
CAUTION CAUTION used without the safety alert symbol indicates a

potentially hazardous situation which, if not avoided, may result
in property damage.

NOT E emphasizes essentia information.

RENESAS



AWARNING

Observe the precautions listed below. Failure to do so
will result in a FIRE HAZARD and will damage the user
system and the emulator product or will result in
PERSONAL INJURY. The USER PROGRAM will be
LOST.

1. Do not repair or remodel the emulator product by
yourself for electric shock prevention and quality
assurance.

2. Always switch OFF the E6000 emulator and user system
before connecting or disconnecting any CABLES or
PARTS.

3. Always before connecting any CABLES, make sure that
pin 1 on both sides are correctly aligned.

4. Supply power according to the power specifications and
do not apply an incorrect power voltage. Use only the
provided power cable.

RENESAS




CAUTION

This equipment has been tested and found to comply
with the limits for a Class A digital device, pursuant to part 15
of the FCC Rules. These limits are designed to provide
reasonable protection against harmful interference when the
equipment is operated in a commercial environment. This
equipment generates, uses, and can radiate radio frequency
energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio
communications. Operation of this equipment in a residential
area is likely to cause harmful interference in which case the
user will be required to correct the interference at his own
expense.

A
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I ntroduction

The E6000 emulator is an advanced realtime in-circuit emulator, which allows programs to be devel oped and debugged
for the H8 family microcomputers.

The E6000 emulator can either be used without a user system, for developing and debugging software, or connected viaa
user system interface cable to a user system, for debugging user hardware.

High-performance Embedded Workshop (hereafter referred to as HEW) is a Graphical User Interface intended to ease the
development and debugging of applications written in C/C++ programming language and assembly language for Renesas
microcomputers. Itsaim isto provide a powerful yet intuitive way of accessing, observing and modifying the debugging
platform in which the application is running.

HEW is a powerful development environment for embedded applications targeted at Renesas microcontrollers. The main
features are:

* A configurable build engine that allows you to set-up compiler, assembler and linker options via an easy to use
interface.

* Anintegrated text editor with user customizable syntax coloring to improve code readability.
» A configurable environment to run your own tools.

« Anintegrated debugger which allows you to build and debug in the same application.

* Version control support.

HEW has been designed with two key aims; firstly to provide you, the user, with a set of powerful development tools and,
secondly, to unify and present them in away that is easy to use.

RENESAS



About This Manual

This manual is comprised of two parts: HEW Part and Emulator Debugger Part.

HEW Part: Information on the basic “look and feel” of the HEW and customizing the HEW environment,
and detail of the HEW’ sbuild function.

Emulator Debugger Part: Preparation before use, E6000 emulator functions, debugging function, tutorial, and hardware
and software specifications of the EG000 emulator.

This manual does not intend to explain how to write C/C++ or assembly language programs, how to use any particular
operating system or how best to tailor code for the individua devices. These issues are left to the respective manuals.

Microsoft”, MS-DOS, Windows”, Windows NT" are registered trademarks of Microsoft Corporation.
Visua SourceSafeis atrademark of Microsoft Corporation.
IBM isaregistered trademark of International Business Machines Corporation.

All brand or product names used in this manual are trademarks or registered trademarks of their respective companies or
organizations.

Document Conventions
This manual uses the following typographic conventions:

Tablel Typographic Conventions

Convention Meaning
[Menu->Menu Option] Bold text with *->’ is used to indicate menu options
(for example, [File->Save As...]).
FILENAME.C Uppercase names are used to indicate filenames.
“enter this string” Used to indicate text that must be entered (excluding the “” quotes).
Key + Key Used to indicate required key presses. For example, CTRL+N means

press the CTRL key and then, whilst holding the CTRL key down,
press the N key.

) When this symbol is used, it is always located in the left hand margin.
It indicates that the text to its immediate right is describing “how to”

(The “how to” symbol) .
do something.

Components

Check all the components described in the component list unpacking. If the components are not complete, contact a
Renesas sales office.

RENESAS
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1. Overview

This chapter describes the fundamental concepts of the High-performance Embedded Workshop. It isintended to
give users who are new to Windows® extra help, filling in the details that are required by later chapters.

11 Workspaces, Projectsand Files

Just as aword processor allows you to create and modify documents, the High-performance Embedded
Workshop allows you to create and modify workspaces. A workspace can be thought of as a container of
projects and, similarly, a project can be though of as a container of project files. Thus, each workspace contains
one or more projects and each project contains one or more files. Figure 1.1 illustrates this graphically.

PROJECT

]
(~]

WORKSPACE

Figure 1.1: Workspaces, Projectsand Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can aso be linked hierarchically within aworkspace, which means that when one project is built all of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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1.2 The Main Window

The HEW main window appears as shown in figure 1.2.
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Figure 1.2: HEW Main Window

There are three main windows; the workspace window, the editor window and the output window. The
workspace window shows the projects and files which are currently in the workspace, the editor window
provides file viewing and editing facilities and the output window shows the results of a various processes (e.g.
build, version control commands and so on).

121 TheTitleBar

Thetitle bar displays the name of the currently open workspace, project and file. It aso contains the standard
minimize, maximize and close buttons. Click the minimize button to minimize the HEW on the windows start
bar. Click the maximize button to force HEW to fill the screen. Click the close button to close the HEW (this has
the same effect as selecting [File->Exit] or pressng AL T+F4).

122 The Menu Bar

The menu bar contains nine menus: File, Edit, View, Project, Options, Build, Tools, Window and Help. All of
the menu options are grouped logically under these headings. For instance, if you wanted to open afile then the
file menu iswhere you will find the right menu option, if you wanted to set-up atool then the tools menu isthe
correct selection. The following sectionswill cover the functions of the various menu options, as they become
relevant. However, at this stage, it is worth taking a few moments to familiarize yourself with the options that
each menu provides.
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123 TheToolbars

The toolbars provide a shortcut to the options, which you will use the most often. There are eight default
toolbars. Bookmarks, Debug, Debug Run, Editor, Search, Standard, Templates, and VVersion Control (as shown
in figure 1.3 to 1.10). Toolbars can be created, modified and removed via the [T ools->Customize...] menu
option (see chapter 5, “Customizing the Environment”, for further information).

Mext Bookmark  Previous Bookmark

Toegle Bookmark Glear All Bookmarks

n&a®

Figure 1.3: Bookmarks Toolbar

Toeele Breakpoint Command Line

Enable/Dizable Breakpoint
View Dizaszembly

| Radix
|
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Figure 1.4: Debug Toolbar

Feset GPU Step QOver

Go to Cursor Step QOut
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Figure 1.5: Debug Run Toolbar

Mew File Print Find Toegle Bookmark
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Figure 1.6: Editor Toolbar
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Figure 1.7: Search Toolbar
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Figure 1.8: Standard Toolbar
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Figure 1.9: Templates Toolbar
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Figure 1.10: Version Control Toolbar

When the Standard toolbar or atoolbar is docked, it has a control bar as shown in figure 1.11 (i). If you want to
move the docked Standard toolbar, click and drag its control bar to the new location. Figure 1.11 (i) shows the
Standard toolbar when it is docked and figure 1.11 (ii) shows the Standard toolbar when it is floating.

» |[SEE o dalmm|

W

B3 % |[Dsbug sl o=

Figure 1.11: Standard Toolbar, Docked and Floating

2 To dock the menu bar or atoolbar:
1. Double-click on thetitle bar of afloating menu bar or toolbar.
or:

2. Drag the title bar of afloating menu bar or toolbar and draw it toward an edge of a docked window, menu
bar, toolbar or the HEW main frame, on whose edge you would like to dock the window, until the shape
of the floating bar changes.

2 Tofloat the menu bar or atoolbar:
1. Double-click on the control bar of a docked menu bar or toolbar.
or:

2. Drag the control bar of adocked menu bar or toolbar and draw it away from the edge of the HEW main
frame and from an edge of the other docked windows, menu bar or toolbar.

RENESAS




124 The Workspace Window

The “Workspace” window when the HEW islaunched only hasa single pane. Thisisthe “Projects’ tab. If a
workspace is opened then the workspace window displays two default tabs. The “Projects’ tab shows the
current workspace, projects and files (figure 1.12). Y ou can quickly open any project file or dependent file by
double clicking on its corresponding icon.

E@ dema

E@ Projectl
Ea Praject Files
| ! cl.=rc
. main.c
sh_hwefe.c
sh_intv.sre
E| a Dependenmes
f||e1 h

e [E] file2h

Mavigation tab

Projects tab ——|

@ Projects l =] Mawigation I

Figure 1.12: Workspace Window Projects Tab

The“Navigation” tab provides jumpsto various textual constructs within your project’s files. What is actually
displayed within the navigation tab depends upon what components are currently installed. Figure 1.13 shows
ANSI C functions. See chapter 2, “Build Basics’, for more information on the “Workspace” window.

..... _an[]
----- & hw_initializel)
----- L35 | Ing_ennl[WElFiD e

""" %] SCI0_ISR_ERI)
""" ] SCI0ISR_RAI)
""" 4] SCI0_ISR_TEN)
""" ] SCI0_ISR_T=I)
----- ] SCI_ClearBuffers()
""" ] SCI_GetBlock()

----- “1 50 GetF!:-tE!ueSlze[]
@pmje.;ts QNawgahun I

Figure 1.13: Workspace Window Navigation Tab

2 Toadlow the “Workspace” window or the “Output” window docking:
Click the right mouse button anywhere inside the “Workspace” window or the “Output” window. Then a

pop-up menu will be displayed. If [Allow Docking] is checked, docking is allowed; otherwise, docking is not
allowed. Select [Allow Docking] to check or uncheck it.

When [Allow Docking] is checked, you can dock a window, atoolbar or amenu bar to the edge of the HEW
main window or to the edge of another docked window. Alsoif [Allow Docking] is checked, you can float them
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“above’ the other HEW windows or outside the HEW main window. Figure 1.14 (i) shows a docked
“Workspace” window, and figure 1.14 (ii) shows a floating “Workspace” window.

x|
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=- @ dema

== @ Projectl
B3 Project Files
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= @ Projectl
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chrc

. main.c

sh _hwcfe.c

Hes sh_intw.src

Projects tab —

@ijectx I &1 Mavigation |

=
; ) Projects | =_1havigafion J-J-

Figure 1.14: Workspace Window, Docked and Floating

When the “Workspace” window or the “Output” window is docked, it has a control bar as shown in figure 1.15.
If you want to move a docked window, click and drag its control bar to the new location.

'Close' buthon

-1 |

Figure 1.15: Control Bar of Docking Window

2 Todock the “Workspace” window or the “Output” window:

[Allow Docking] must be checked on the pop-up menu of the window to dock the “Workspace” window or
the “Output” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
inside the window.) Then you have two ways to dock the window.

1. Double-click on the control bar of a floating window.

or:

2. Drag thetitle bar of afloating window and draw it toward an edge of a docked window, menu bar or
toolbar, or the HEW main frame, on whose edge you would like to dock the window, until the shape of
the floating window changes.
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2 Tofloat the “Workspace” window or the “Output” window:
[Allow Docking] must be checked on the pop-up menu of the window to float the “Workspace” window or
the “QOutput” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
inside the window.) Then you have two waysto float the window.
1. Double-click on the control bar of a docking window.
or:
2. Drag the control bar of adocked window and draw it away from the edge of the HEW main frame and

from an edge of the other docked windows, menu bar or toolbar.

2 To hidethe “Workspace” window or the “ Output” window:
Click on the close button, which islocated in the top right corner of the window. Or push the right mouse
button anywhere inside a floating window and select [Hide] on the pop-up menu.

2 Todisplay the “Workspace” window or the “Output” window:
Select [View->Workspace] or [View->Output], respectively.

125 The Editor Window

The editor window is where you will work with the files of your project. The HEW allows you to have many
files open at one time, to switch between them, to arrange them and to edit them in whichever order you want to.
By default, the editor window is displayed in a notebook style, where each text file has a separate tab (as shown
in figure 1.16).

The editor contains a gutter on the left-hand side of the window. The gutter in HEW can be configured to
contain many columns. Each column can refer to a different component’s capability. In figure 1.16 the editor is
displayed with the debugger address column and the standard column. The standard column allows the user to
configure the position of bookmarks and software breakpoints quickly and easily.

v —
F w) I
4 FILE isbrk.c wy
e DATE tThu, Auz 16, 2001 #/
J#  DESCRIPTION :Program of shrk wy
f# CPU TYPE TEHTO20 wy
f L2
i* This file is generated by Hitachi Project Generator (¥er.2.1). *i
£ £
i !

tinclude <stddef.h>
finclude <stdio.h>
tinclude “sbrk.h”

extern char #_slptr;
extern void srand{unsizned int}; b

static wunion |

long  dummy : S Dummy for 4-byte boundary #/
char heap[HEAPSIZE]; /# Declaration of the area manazed %/
i by shrk #/
theap_area ;
static char #brk={char #)kheap_area;/% End address of area assizned wy
i i
KN | »

<l resetprgcl-::'}' dbsctc <+ shrkc I

Figure 1.16: Editor Window
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The editor window can be customized via the “Format Views’ dialog box, which can be invoked viathe [T ools-
>Format Views...] menu option. Thisdialog alows you to configure fonts, colors, tabs and so on for the editor
window. It also alows the user to change the look of other views, which have been installed by HEW. If you
would prefer to use your favorite editor rather than the HEW internal editor then specify your alternative in the
“Options’ dialog box, which can be invoked via the [Tools->Option...] menu option. For further details on how
to use and configure the editor, refer to chapter 4, “Using the Editor”.

1.2.6 The Output Window

The “Output” window by default hasfour tabs on display. The “Build” tab shows the output from any build
process (e.g. compiler, assembler and so on). If an error is encountered in a source file then the error will be
displayed in the build tab along with the source file name and line number. To quickly locate a problem, double
click on the error to jump to the source file and line.

ES|
i

4[> Build 4 Debug A Find in Files & Version Control /

Figure 1.17: Output Window

The“Debug” tab shows the output from any debugger process. Any debug component that needs to display
information will send its output to this window.

The“Find in Files” tab displaysthe results of thelast “Find in Files” action. To activate find in files, select the
[Edit->Find in Files...] menu option, the toolbar button. For further details on how to use find in files, refer to
chapter 4, “Using the Editor”.

The“Version Control” tab displays the results of version control actions. Thetab isonly displayed if aversion
control systemisin use. For further details on version control, refer to chapter 7, “Version Control”.

127 The Status Bar

The status bar displays information as to the current state of the HEW. Figure 1.18 shows the seven sections of
the status bar.

Displ HE statur .
ISpiays Sl Readonly status  Line number. Column nurmber.

Insertion hode.

Ready |Read-'write 214 l1 s . | 4
|

GCaps lock. Murm lock

Figure 1.18: StatusBar
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13 TheHelp System

The help menu is the rightmost menu on the HEW menu bar. It contains the menu option “ Contents” which,
when selected, takes you to the main HEW help window.

To obtain help on specific dialogs click on the context sensitive help button, which islocated in the top right-
hand corner of each dialog box (as shown in figure 1.19).

jﬂ
Context sensitive help butten

Cancel butten

Figure 1.19: Help Button

When thisis clicked, the mouse pointer will change to a pointer with a question mark above it. Whilst the mouse
pointer isin this state, click on the part of the dialog box that you require assistance on.

Alternatively, select the control that you require help for and then press the F1 key.
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14 Launching the HEW

To run the HEW, open the “ Start” menu of Windows®, select “ Programs’, select “High-performance Embedded
Workshop” and then select the shortcut of the “High-performance Embedded Workshop 2”. By default, the
“Welcome!” dialog box shown in figure 1.20 will be displayed.

Welcome!
— Optiors;
] & ‘Create a new project workspace
Cancel |
" Open a recent project workspace: Administration... |
é IE:'\Hew\demn'\demo.hws j
=

g " Browse to another project warkspace

Figure 1.20: Welcome! Dialog

To create a new workspace, select “Create a new project workspace”, and click “OK”. To open one of recent
project workspaces, select “Open arecent project workspace”, select a workspace from the drop-down list, and
click “OK”. The recent project workspace list displays the same information as that seen in the workspace most
recently used filelist. Thislist appears on the file menu. To open aworkspace by specifying aworkspace file
(.HWSfile), select “Browse to another project workspace”, and click “OK”. To register atool to or unregister a
tool from the HEW, click the “ Administration...” button (see chapter 5, “Tool Administration” for details).
Click the “Cancel” button to use the HEW without opening a workspace.

15 Exiting the HEW

The HEW can be exited by selecting [File->Exit], pressing AL T+F4 or by selecting the close option from the
system menu. (To open the system menu, click theicon at the upper-left corner of the HEW title bar.) If a
workspace is open then the same workspace closedown procedure is followed as described in the previous
section.

16 Component System Overview

The HEW allows the user to extend the HEW functionality by adding additional components to the system. This
is achieved by registering the component in the Tools Administration dialog box. These components can add
windows, menus and toolbars to the HEW system. Examples of the components are the debugger and builder
components of HEW. The debugger component adds all of the menus and toolbars associated with the debugger
and the builder component does the same for the build functionality. The componentsyou have registered in the
system will modify thelook and feel of HEW. In some cases you may not have some of the menus which you
can seeinthismanual. For instance if the debugger component is not installed you will not have the “Debug”
menu in the HEW main window.

10
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2. Build Basics

This chapter explains the general functions of the HEW whilst the more advanced features can be found in
chapter 3, “ Advanced Build Features’.

2.1 The Build Process

Thetypical build processis outlined in figure 2.1. This may not be the exact build process, which your
installation of HEW will use as it depends upon the tools that were provided with your installation of HEW (e.g.
you may not have a compiler for instance). In any case, the principles are the same - each step or phase of the
build takes a set of project files and then builds them, if al succeeds then the next step or phase is executed.

@ BUILD %
COMPILER
Source Files
Ijl ﬂ—' ASSEMBLER
=1
—‘ Assembler
/ Source Files
Project
LINKER Object
Files
Library
Files ‘
Load
Module

Figure 2.1: Typical Build Process

In the example shown in figure 2.1 the compiler is the first phase, the assembler is the second phase and the
linker isthe third and final phase. During the compiler phase, the C source files from the project are compiled in
turn, during the assembler phase, the assembler source files are assembled in turn. During the linker phase al
library files and output files from the compiler and assembler phases are linked together to produce the load
module. This module can then be downloaded and used by the debugger functionality in HEW.

The build process can be customized in several ways. For instance, you can add your own phase, disable a phase,
delete phases and so forth. These advanced build issues are left to chapter 3, “ Advanced Build Features’. In this
chapter, only the general principles and basic features will be detailed.

11
RENESAS




2.2 Project Files

In order for the HEW to be able to build your application, you must first tell it, which files should be in the
project, and how each file should be built (figure 2.2).

Add Project Files

Remove Project Files

Project
Debug: ON . _ *T
Optimize: OFF Set Compiler Options
List File: YES c
Source Files
Debug: OFF =
Optimize: OFF Set Assembler Options
List File: YES Assembler
Source Files
Debug: ON . . —_—
Silent  YES Set Linker options j
Map File: YES Library
Files

Figure 2.2: Editing a Project
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221 Adding Filesto a Project

Before you can build your gpplication you must first inform the High-performance Embedded Workshop, which
filesit, is composed of.

2 Toadd afilesto aproject:

1. Select [Project->Add Files...], select [Add Files...] from the “Workspace” window’ s pop-up menu (see
figure 2.3), or press | NS when the “Workspace” window is selected.

Figure 2.3: Project Pop-up Menu

2. The“Add" diaog will be displayed.
3. Select thefile(s), that you want to add and then click “Add”.

13
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There are anumber of other waysto add new files to the project. These are described below:

»  Clicking right button on an open file in the editor window displays a pop-up menu option (figure 2.4). If the
fileisaready in the project then the “Add File to Project” menu option isdisabled. Selecting the “Add File
to Project” then adds the file to the current project.

Build File “dbsetc”

Cut Citr [+
Copy Citr [+
Paste Cirl+\

Gddl Eile o) Froject

Eind.. Cirl+F
Find In Files.. F4
Feplace Citrl+H
Goto Line Citrl+G
Match Braces Citr [+
Book marks 3
Templateg 3
Toeele Breakpoint Fa

Efiatle/Disatle Breaknaint. Gl

Figure 2.4: Editor Window Pop-up Menu

* IntheHEW it isalso possibleto “Drag and Drop” files from Windows Explorer onto the workspace
window. These fileswill be automatically added to the project and are displayed in the folder in which they
were dragged to.

Note: If you add afileto a project when it is an unrecognized file type then it will till be added to the project.
Certain functions will be disabled with reference to thisfile. When thisfileisdouble clicked in the workspace
window instead of opening the file in the editor the open operation is passed to Windows operating system. The
default open operation isthen carried out as if the file was opened in Windows Explorer. To view the current
defined extensions use the “File Extensions’ dialog (see the section on file extensions later in this chapter).

14
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222 Removing Filesfrom a Project

Files can be individualy removed from a project, selections of files can be removed or dl files can be removed.

2 Toremove filesfrom aproject:

1. Select [Project->RemoveFiles...], or select [Remove Files...] from the “ Projects’ tab’'s pop-up menu in
the Workspace window (see figure 2.5). The “Remove Project Files’ dialog will be displayed (figure 2.6).

Open dbzect.c

@ Build dbzcte

Hitachi SuperH RISC engine Standard Toolchain..

#fidd Files.. NS
Femove Files..

Exclude Build dbscte

(ot £ VS

[@, BEmayve framm YiE
% et from VoE

g tiect aut fram Vs
2 et i o Vs
@ (et VT etatus

Configure Wiew..

| v &llow Dockine
Hide

Properties

Figure 2.5: Projects Tab Pop-up Menu

Remove Project Files

Project files: ok

[c:\hew'demohdemol

il

hewhdematdema Cancel
[=:Shewhdemohdemo]
intprg. src [ \hewtdemnoderno] Eemave
rezetprg.arc [=:Shewhdemohdemo] —
shrk.c [z:\hewhdema'.demo]
stacksct zc [=:Shewhdemohdemo] Remave Al
vectthbl zrc [z:\hewhdema'.demo]

| 2

Figure 2.6: Remove Project Files Dialog

15
RENESAS




2. Select thefile or files which you want to remove from the “ Project files” list.
3. Click the“Remove” button to remove the selected files or click “Remove All” to remove al project files.
4. Click “OK” to remove the files from the project.
2 Toremove selected files from a project:
1. Select thefiles, which you want to remove, in the “Projects’ tab of the “Workspace” window. Multiple
files can be selected by holding down the SHIFT or CTRL key.

2. Pressthe DEL key. Thefileswill be removed.

16
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223 Excluding a Project File from Build
A filein aproject can be individually excluded from build on a configuration by configuration basis.

2 Toexcludeafilein aproject from build:
1. Push the right mouse button on afile, which you want to be excluded from build, in the “ Projects” tab of
the “Workspace” window.
2. Select [Exclude Build file], where <file> is the selected file, from the pop-up menu (figure 2.5). Then a
red cross will be put on the file' sicon, and the file will be excluded from build.

224 Including a Project Filein Build
An excluded file can be included in the project again.

2 Toinclude afile which has been excluded from build:
1. Push the right mouse button on afile, which has been excluded from build, on the “Projects’ tab of the
“Workspace” window.
2. Select [Include Build file ], where <file> is the selected file, from the pop-up menu. Then ared cross will
be removed from the file’sicon, and the file will be included in build.

23 File Extensions and File Groups

The HEW can identify files by their extension. The system defines certain extensions depending upon the tools,
which are being used. For example, if you are using a compiler then the .c extension will be in the “C source
file” group and be used as input to the compiler phase (figure 2.1, Typica Build Process). Additionally, the
HEW allows you to define your own extensions. For example, if the project you are devel oping uses assembler
source files the default extension may be .src. If you would like to use a different extension instead of .src

(e.g. .asm) then you can define a new extension and request that the HEW treatsit in the same way asa.srcfile.

File extensions and file groups can be viewed and modified viathe “File Extensions’ dialog (figure 2.7). Thisis
invoked by selecting [Project->File Extensions...]. Thisdiaog displaysal of the extensions and file groups,
which are defined within the current workspace.

Extension | Group - Ok I

D *.abs Absalute file

*.inc Assembly include file Cancel |

#.lis Assembly list file i

*.zrc Azzembly source fila ==
E#*n C header file Remove |
[Epist G list file =

*c C source file Open with...

*hpp G+t header file
*lpp o list file

D*.cpu CPU information file

Ei*avn e e T e mal _Ij
] 3

Figure 2.7: File Extensions Dialog

17
RENESAS




The “File Extensions’ list shown in figure 2.7 isdivided into two columns. On the left are the file extensions
themselves, whilst on the right are the file groups. Many file extensions can belong to the same group. For
example, assembler source files may have several extensionsin asingle project (e.g. .src, .asm, .mar €tc) as
shown in figure 2.8.

CI1C]C] C1C]

.SRC .ASM -MAR LB .LPF

Assembler source files C source files Library files

Figure 2.8: File Extensionsand Groups

When creating a new extension you should consider whether the extension belongs to a group, which is already
defined, or whether you need to create anew file group. If you are adding a completely new type of file then you
will want to create anew file group. This process is described below.

18
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2 Tocreate anew file extension in anew file group:

1. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed
(figure 2.7).

2. Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.9).

3. Enter the extension, which you want to define into the “ File extension” field. It is not necessary to type
the period ( . ) character. Thedrop list contains al extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

4. Select the “ Extension belongs to anew group” option and enter a description, which defines this new file
group.

5. Atthisstageit ispossible to change the associated application. There are four available choicesin the

“Open” with drop list. These arelisted below:

*  Editor
* None
e Other

e Windows default
If the editor is selected, the open file function in the workspace window causes the file to be opened in the
HEW editor. If noneis selected then the open operation is disabled when the open file function is
attempted. Selecting “Other” allows you to configure an another tool for the open file operation. See“To
associate an application with a file group” for more details. If the “Windows default” option is selected
then the open file function in the workspace window passes the open file to the Windows operating
system. Thisthen selects the default behavior for thisfile extension as defined in Windows Explorer.

6. Click “OK” to add the extension to the “File Extensions” list.

—File extension:
* I :I Cancel |

—File group:

& Extension kelongs to an existing group:

[Absolute file =l

" Extension belongs to a new group:

—Associated application:
Open " Absolute file™ with:
Windows default j

TlEalifie.

Il

Bemuye

Figure 2.9: Add File Extension Dialog (New Group)
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If you want to create a new extension because your project uses a different extension from those accepted by the
HEW. For example, a phase might by default use the extension .asm but the HEW only recognizes .src. Then
you need to create a new extension and add it to an existing file group. This processis described below.

) To create anew file extension in an existing file group:

1. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed
(figure 2.7).

2. Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.10).

3. Enter the extension, which you want to define into the “ File extension” field. It is not necessary to type
the period ( . ) character. The drop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

4. Select the “Extension belongs to an existing group” option and select which group you would like to add
this new extension.

5. Click “OK” to add the extension to the “File Extensions” list.

—File extension:

®-  |asm -
Cancel

i

—File group:

& Extension kelongs to an existing group:

IAssemny source file j

" Extension belongs to a new group:

—Associated application:
DOpen " Assermbly source file™
Fditor i

TlEalifie.

It

Bemuye

Figure 2.10: Add File Extension Dialog (Existing Group)

In addition to opening afile with the editor, the “File Extensions’ dialog allows you to associate any application
with any file group so that when you double click on afilein the “Projects’ tab of the “Workspace’ then the
appropriate application islaunched with the file. Figure 2.11 shows the association between a word processor
and the extension .DOC.
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Extension | Giroup Al Ok I
* Ipp Co+ list file

Teat editor —-@ *.opp C++ source file Cancel |
D*.cpu CPU information file

Werd processer ——EF + doc Documents Add..
*.exp Expanded assembly source file Remave |
Librarian -@*.Iib Library file =
EEAE Library list file Opeer with.,
*.sct Library section list file
*.rnap Lirkage map filz
*.fsy Linkage symbal file
Mo applization —— ] #.0bj Object file

Ers Prarrnmacsad M cniwna fila i
i T

Figure 2.11: File Groupsand Applications

2 To associate an application with a file group:
1. Select the file group to be associated from the “File Extensions’ dialog (figure 2.11).
2. Click the“Open with...” button. The“Modify File Extension” dialog will be displayed (figure 2.12).

Modify Fil

Group:

Linkage map file

—Associated application:

Open " Linkage map file™ with:

Mo ne
Edlitor

Other
Windows default

Cancel |

Figure 2.12: Modify File Extension Dialog
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3. Select “None€” to remove any association, select “Editor” to open thistype of file in the internal/external
editor or select “Other” if you want to open thistype of file with a specific application. If you select
“Other” then you can select from any previously defined application from the drop-down list or specify a
new application.

4. Click “Add..."” to define anew application. The “Add Application” dialog will be displayed (figure 2.13).




Add Application EE3
Hame:
I Cancel |

LCormmand [excluding parameters]:

I Ll Browsze. . |

Parameters:

| il

Initial directany:

I Ll Browsze. . |
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Figure 2.13: Add Application Dialog

5. Enter the name of the tool into the “Name” field. Enter the full path to the toal in the “ Command” field
(do not include any parameters). Enter the parameters that are required to open afilein the “ Parameters’
field. Be sure to use the $(FULLFILE) placeholder to specify the location file (see appendix C,
“Placeholders’, for more information on placeholders and their uses). Enter theinitia directory, in which
you would like the application to run, into the “Initial directory” field. Click “OK” to create the

application.

6. Click “Modify..."” to modify an application. The “Modify Application” dialog will be displayed. This
dialog isthe same asthe “Add Application” dialog described above except that the “Name” field isread

only. Modify the settings as desired and then click “OK".
7. Click “OK” to set the application for the selected file group.
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24 Specifying How to Build a File

Once you have added the necessary files to the project the next step isto instruct the HEW on how to build each
file. To do this, you will need to select a menu option from the “Options” menu. The contents of this menu
depend upon which tools you are using. For example, if you are using a compiler, assembler and linker then
there will be three menu options, each one referring to one of the tools.

2 To set optionsfor abuild phase:
1. Select the options menu and find the phase whose options you would like to modify. Select this option.
2. A dialog will be invoked which alows you to specify the options.
3. After making your selections, click “OK” to set them.

To obtain further information, use the context sensitive help button or select the areain which you need
assistance and then press F1.
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25 Build Configurations

The HEW allows you to store dl of your build optionsinto a build configuration (figure 2.14). This means that
you can “freeze” all of the options and give them a name. Later on, you can select that configuration and all of
the options for all of the build phaseswill be restored. These build configurations a so alow the user to specify
debugger settings for a build configuration. This means that each configuration can be targeted at a different end
platform. (See Emulator Debugger Part in this manual, for further information).

Figure 2.14 shows three build configurations; “ Default”, “MyDebug” and “MyOptimized”. In the first
configuration, “Default”, each of the phases (compile and assemble) are set to their standard settings. In the
second configuration, “MyDebug”, each of the files are being built with debug information switched on. In the
third configuration, “MyOptimized”, each of the files are being built with optimization on full and without any
debug information. The devel oper of this project can select any of those configurations and build them without
having to return to the options dialogs to set them again.

"Default" "MyDebug" "MyOptimized"
Configuration Configuration Configuration
=S Debug: ON Debug: ON Debug: OFF
- 'Optimize: OFF 'Optimize: OFF Optimize: ON
List File: YES | List File: NO | H List File: NO | H
C
Source Files
= Debug: OFF Debug: ON Debug: OFF
Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | | List File: NO | H List File: NO | H
Assembler
Source Files
C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimized

Figure 2.14: Configurationsand File Options
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251 Selecting a Configuration
The current configuration can be set in two ways:
Either:

1. Select it from the drop down list box (figure 2.15) in the toolbar.

[R

LI
Release

Figure 2.15: Toolbar Selection
or:

1. Select [Options->Build Configurations...]. Thiswill invoke the “Build Configurations’ Dialog (figure
2.16).

Build Configurations

Build configurations: 0k
Debug
Release Cancel

ail.

Add...

HEmove

!

Current configuration:

Debug j

Figure 2.16: Build Configurations Dialog

2. Select the configuration that you want to use from the “Current configuration” drop down list.
3. Click “OK” to set the configuration.
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252 Adding and Deleting Configurations

Y ou can add a new configuration by copying settings from another configuration or delete a configuration. These
three tasks are described below.

2 Toadd anew configuration:
1. Select [Options->Build Configurations...] to display the “Build Configurations’ dialog (figure 2.16).
2. Click the“Add...” button. The “Add Configuration” dialog will beinvoked (figure 2.17).

Add Configuration

Configuration name: IMPCDHHQ
Cancel |
Bazed on configuration: IDehug j

Configuration directary: c:vhew' demaotdemai iy Caonfig

Figure2.17: Add Configuration Dialog

3. Enter the new configuration name into the “Configuration name” field. Asyou enter the new
configuration name, the directory underneath changes to reflect the configuration directory that will be
used. Select one of existing configurations, from which you want to copy a configuration, out of the drop-
down list of the “Based on configuration” field. Click “OK" on both dialogs to create the new
configuration.

2 To remove aconfiguration:
1. Select [Options->Build Configurations...] to display the “Build Configurations’ dialog (figure 2.16).
2. Select the configuration that you want to remove and then click the “ Remove” button.
3. Click “OK" to close the “Build Configurations’ dialog.
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2.6 Building a Project

The outline of the build processis shown in figure 2.1.

261 Building a Project

The build option only compiles or assembles those files that have changed since the last build. Additionally, it
will rebuild source files if they depend upon afile that has changed since the last build. For instance, if thefile
“test.c” #include' sthefile “header.h” and the latter has changed since the last build, the file “test.c” will be
recompiled.

2 To perform abuild:
Select [Build->Build] or click the build toolbar button (£#]) or press F7 or click the right mouse button on a
project icon in the “Projects’ tab of the “Workspace” window and select [Build] from the pop-up menu.

The build al option compiles and assembles all source files, irrespective of whether they have been modified or
not, and links all of the new object files produced.

2 Toperform abuild all:
Select [Build->Build All], or click the build al toolbar button (&), or click the right mouse button on a
project icon in the “Projects’ tab of the “Workspace” window and select [Build All] from the pop-up menu.

Both the build and the build al will terminate if any of the project files produce errors.

26.2 Building Individual Files
The High-performance Embedded Workshop lets you build project filesindividually.

2 Tobuild anindividua file:
1. Select the file which you want to build from the project window.
2. Select [Build->Build File], click the build file toolbar button (8) or press CTRL +F7 or click the right
mouse button on afileicon in the “ Projects’ tab of the “Workspace” window and select [Build <file>]
from the pop-up menu.
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26.3 Stopping a Build
The High-performance Embedded Workshop allows you to halt the build process.

2 To stop abuild:
1. Select [Build->Stop Build] or click the stop build toolbar button (#%). The build will be stop after the
current file has been built.
2. Wait until the message “Build Finished” appearsin the “Output” window before continuing.
2 Toforcibly terminate a current tool
1. Select [Build->Terminate Current Tool]. The HEW will attempt to stop the tool immediately.

Note: Do NOT assume that any output from the tool you terminated isvalid. It is recommended that you delete
any output files produced and ensure that the phase is executed again.

264 Building Multiple Projects
The High-performance Embedded Workshop lets you build multiple projects and configurations at once.

2 To build multiple projects:

1. Select [Build->Build Multiple]. Thefiguredisplayed in figure 2.18.

2. Thebuild multiple gives you the choice of which projects and configurations should be built. To select
which projects and configurations need to be built select the check box next to the project —
configuration combination you want to build. For example, in figure 2.18 if you wanted to build the
entire “hewtest2” project you would check the “ hewtest2-Debug” and the “hewtest2-Release” selections
and leave al other check boxes unchecked.

3. When you are happy with your chosen selection click the build button and the HEW will then build the
projects and configurations you have chosen.

4.  If you want to build all the projects which you choose, you click the build all button.

5. Results from the build are displayed in the build window in the same way as the normal build process.

Build Multiple E3

[ Jhewtest]-Debug - i
[ hevatest]-Release
[ hevatests-Debug Build Al
[ hevatests-Release
[ hevatest3-Debug

C | |
[ hewtest3-Release nee
[ 1hevatestd-Debug

[ hevatestd-Release
[ 1hevatest5-Debug

[Jhewtest5-Release _ILI
4 I I 3

Figure 2.18: Build Multiple Dialog

26.5 The Output Window

When atool executes (i.e. compiler, assembler, linker etc.) its output is displayed in the “Output” window. If any
of the tools produce any errors or warnings then they are displayed along with the source file name and the line
number at which the error islocated. To quickly locate a specific bug, double click on agiven error/warning to
invoke the current editor.
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2.6.6 Controalling the Content of the Output Window

It is often useful to display low-level information (such as the command line options that are being applied to a
file) during abuild. The HEW allows you to specify whether or not you want such options displayed in the
“QOutput” window during a build, build al or build file operation via the “Tools Options’ dialog.

2 Toview or hide extrainformation during a build:

1. Select [Tools->Options...]. The“Options’ dialog will be displayed.

2. Select the“Build” tab (figure 2.19).

3. Set the three check boxesin the “ Show” group as follows. “Command line” controls whether the
command line is shown as each tool is executed. “ Environment” controls whether the environment is
shown as each tool is executed. “Initial directory” controls whether the current directory is shown as each
tool is executed.

Options EE3

Build |Editnl | Workspace | Confimation |

— Errarg and warnings:

[ Stop build if the no. of emors exceed:

I 1]
™ Stop build if the na. of warnings exceed: I 1]

 Shaw:
[ Command line
[" Enwironment

[ Initial directon

ak. I Cahicel

Figure 2.19: Options Dialog Build Tab
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2.7 File Dependencies

A typical project will contain dependencies between files, for example, one C file may “#include” one or more
header files. In complex projects, source files will include (or depend upon) others and this can quickly become
difficult to manage. However, the HEW provides a dependency scanning mechanism whereby all filesin a
project are checked for dependencies. Once compl ete, the project window will display an up-to-date list with dl
the project file dependencies.

2 To update aproject’s dependencies:
Select [Build->Update All Dependencies] or click the right mouse button on a project icon in the “ Projects’
tab of the “Workspace” window and select [Update All Dependencies] from the pop-up menu.

Initially, the dependencies for all files are contained within the “ Dependencies’ folder (figure 2.20.i).

2.8 Configuring the Workspace Window

If you click the right mouse button anywhere inside the “ Projects’ tab of the “Workspace’ window, a pop-up
menu will beinvoked. Select the “ Configure View...” menu option to modify the way in which information is
displayed. The following four sections detail the effect of each option on the “ Configure View” dialog.

281 Show Dependencies under Each File

If you select “ Show dependencies under each file”, the dependent files are shown under the including source file
asaflat structure, i.e. the files themselves become folders (figure 2.20.ii). If this option is not selected then a
separate folder contains all dependencies (figure 2.20.i).

L El@ dema e E@ dema
El@ Projectl E@ Projectl
Ela Project Files e cl.srs
cll=re main.c
main.c filelh
shrk.c -] filezh
sh_hwcfe.c shrk.c
sh_intw.src sh_hwefe.c
Ela Dependencies sh_intw.src
filalh
fila2h
@ijectx l@:INavigaﬁun I @ Projects l L | Mawigation I

Figure 2.20: Dependencies under Each File
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282 Show Standard Library Includes

By default, any dependent files found in standard include paths will not be shown (figure 2.21.i). For example, in
C code, if you write an include statement such as “#include <stdio.h>" then stdio.h will not be listed asa
dependent file. To view such system include files, select the “ Show standard library includes’ option (figure
2.21.i).

L E@ demo g E@ demo
E'@ Projectl El@ Projectl
Ea Project Files Ea Project Files
E cl.sre L L[F] obere
main.c =] mainc
shrk.c =] sbrke
sh_hwefec E] sh_hweifec
L sh_intw.src =] sh_intvsrc
Dependencies
stddefh
=] stdich
) Projects l@Na\rigaﬁnn I 2] Projects l | Mavigation I

Figure2.21: Standard Library Includes

283 Show File Paths

If “Show file paths” is selected, all of the filesin the project window are shown with their full path, i.e. from a
drive letter (figure 2.22).

B3 oihewhdemademo hws
= [Project]
B4 Project Files

- C:\HewtdemohdernotcO.src
E] CHewtdemo'demotmain.c
C:\Hewtdemohdernahshrk. o
C:\Heswhdemo'dermaohsh_hwefg
e C:\Hesdemohdernohsh_inky. sre

N Z Projects l | Navigation I

Figure 2.22: File Paths Shown
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2.9 Setting the Current Project

A workspace can contain more than one project but only one of the projects can be active at any time.  This
active project is the one which build actions and debug operations can be performed on. It ispossible to change
the builder or debugger options for the project. An active project is displayed in bold.

2 To set aproject asthe current project:
1. Select the project from the “ Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Set as Current Project] option.
or:

1. Select the project, which you want to make active from the [Project->Set Current Project] sub-menu.

210 InsertingaProject into a Workspace

When aworkspace is created, it contains only one project but, after it is created, you can insert new or existing
projects into a workspace.

2 Toinsert anew project into a workspace:
1. Select [Project->Insert Project...]. The“Insert Project” dialog will be displayed (figure 2.23).
2. Setthe“New Project” option.
3. Click OK. The “Insert New Project” dialog will be invoked.
4. Enter the name of the new workspace into the “Name” field. This can be up to 32 charactersin length and

contain letters, numbers and the underscore character. As you enter the project name the HEW will add a
subdirectory for you automatically. This can be deleted if desired.

5. Click the“Browse...” button to graphically select the directory in which you would like to create the
project. Alternatively, you can type the directory into the “Directory” field manually.

6. The“Project type” list displaysall of the available project types (e.g. application, library etc.). Select the
type of project that you want to create from thislist.

7. Click “OK" to create the project and insert it into the workspace.

Note:  When anew project is being inserted, the CPU family and tool chain cannot be specified asthese

properties are already defined by the workspace (i.e. al projects within the same workspace target the
same CPU family and toolchain).

Insert Project 2 | x|
Inser
& ; Cancel |

" Esisting project:

Erawse.. |

Figure2.23: [Insert Project] Dialog
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2 Toinsert an existing project into a workspace:
1. Select [Project->Insert Project...]. The“Insert Project” dialog will be displayed.
2. Setthe“Existing Project” option.
3. Enter the full path of the project database file (HWPfile) into the edit field or click “Browse...” to
search for it graphicaly.
4. Click “OK” to insert the existing project into the workspace.

Note:  When an existing project is being inserted into a workspace, the CPU family and tool chain upon which

that project is based must match those of the current workspace. If they do not then the project cannot be
inserted into the workspace.

211  Specifying Dependencies between Projects

The projects within aworkspace can be dependent upon one another so that when one project is built, al its
dependent projects are built first. Thisisuseful if another project uses one of the othersin the workspace. For
example, imagine that a workspace contains two projects. Thefirst project isalibrary that isincluded by an
application project. In this case the library must have been built and up to date before the second application can
build correctly. To achieve this situation we can specify the library as a dependent (i.e. child) project of the
application project. Thiswould then alow thelibrary to be built first if it is out-of-date.

When a dependent project is built the HEW attempts to match the configuration in the dependent project with
that of the current project. This meansthat if the current configuration is “Debug” then the HEW will attempt to
build the “Debug” configuration in the dependent project. |If this matched configuration does not exist then the
HEW will use the configuration that was last used in the dependent project.

2 To make projects depend upon another:
1. Select [Project->Dependent Projects]. The “ Dependent Projects’ dialog will be displayed.(figure 2.24)
2. Select the project to which you would like to add dependents to. When you do this, the “ Dependent
projects’ list will display all of the projects in the workspace (excluding the selected project).
3. The“Dependent projects’ list has a check box for each project listed. Set the associated check boxes to
make those projects depend upon the selected project.

4. Click “OK” to confirm the new project dependencies.

Dependent Projects EHE
Froject: QK

I main_project j
Cancel |

i

Figure 2.24Dependent Projects dialog
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212  Removing a Project from a Workspace

2 To remove aproject from aworkspace:
1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Remove Project] option.
or:
1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Pressthe DEL key.

Note: You cannot remove the current project from the workspace.

213 Loading/Unloading a Project to/from a Workspace

2 Toload aproject to aworkspace:
1. Select the project that has been unloaded from the “ Projects’ tab of the “Workspace” window.
2. Click the right mouse button to invoke a pop-up menu and select the [L oad Project] option.

2 Tounload a project from aworkspace:
1. Select the active project from the “Projects” tab of the “Workspace” window.
2. Click the right mouse button to invoke a pop-up menu and select the [Unload Project] option.

Note: Itispossibleto select several projects at the same time and load or unload al of them. Thisis more
efficient than loading or unloading each of the projectsindividualy.

34
RENESAS



214  Relative Projects Pathsin the Workspace

In the High-performance Embedded Workshop when you add a project to the workspace you can choose to add
the project to the workspace using arelative path. This allows you to position a project above the workspace
directory and it will still be relocated correctly if you relocate the HEW workspace. The project is aways
relative to the workspace so if the project is one directory above the workspace before it is moved the HEW will
try to find the project in the same relative location after the relocation procedure. Thisis especialy useful if you
are using a project shared between more than one workspace.

In older versions of the HEW this project would not have been relocated and would have still tried to access the
original project path. The older version of the HEW could only relocate the projects, which werein a
subdirectory of the workspace directory. Thisis gtill the standard behavior for the High-performance Embedded
Workshop.

2 To change aprojects relative path flag:
1. Select the project in the workspace window.
2. Right click and then select properties.
3. Click the“Project relative file path” checkbox to switch on or off the relative file path feature. (figure

2.25)
4. Click “OK”.
21x

M arne: demo oK I
Lacation: C:YHew2\demohdema'dema. hwp

Cahicel |
Last modified: 21:47:43, Thursday, February 27, 2003
CPU Farnily: H85 H8/300
Tool chain: Hitachi HES H8/300 Standard Toalchain
Yersion; R0.20
¥ Froject relative file path

Figure 2.25: Properties Dialog
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3.  Advanced Build Features

This chapter explains the more advanced build concepts.

31 The Build Process Revisited

Chapter 2, “Build Basics’ began by describing the build processin terms of a compiler, an assembler and a
linker (figure 2.1). Thiswill be the case for most insta lations of the HEW. However, if you want to begin
changing the build process (e.g. adding and removing phases) then it isimportant to understand more about the
way in which abuild functions.

311 What isa Build?

Building a project means applying a set of tools upon certain input filesin order to produce the desired output.
Thus, we apply a compiler upon C/C++ source filesin order to create object files, we apply an assembler upon
assembler source filesin order to create object files and so forth. At each step or “phase” of the build, we apply a
different tool upon adifferent set of input files. Figure 3.1 presents another view of the build process.

B seon 5

= -0

Phase 1 Input Files ‘ Phase 1 Output Files
I N e
Phase 2 Input Files ‘ Phase 2 Output Files

= o0

Phase 3 Input Files

Phase 3 Output Files

Phase X Input Files ' Phase X Output Files

Figure 3.1: Build Process
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The High-performance Embedded Workshop provides the ability to change this build process viaits “Build
Phases” dialog, which can be, accessed via the [Options->Build Phases...] (figure 3.2). On the left-hand side
are the phases that are defined in the current project (Figure 3.2 shows a standard set of build phases). The
remainder of this chapter details the various functions that the “Build Phases’ dialog provides.

Build Phazes
Build et | Build File Order | File Mappings |
Build phase order:
[w]SH CAC++ Library Generator Add... |
[w]SH CAC++ Cannpiler -
[w|SH Aszembler f |
B
HEemayve
e |
[t B |
P I I _,I Import... |

ak. | Cancel |

Figure 3.2: Build Phases Dialog
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3.2 Creating a Custom Build Phase

If you want to execute another tool before, during or after a standard build process then this can be achieved by
creating your own (i.e. custom) build phase.

Select [Options->Build Phases...] to invoke the “Build Phases’ diaog (figure 3.2) and then click the “Add...”
button. Thiswill invoke the new build phase wizard dialog (figure 3.33).

Thefirst step (as shown in figure 3.3a) asks whether you want to create an entirely new phase or whether you
want to add a system phase. A system phaseisa*“ready made’ phase which is already defined within the
toolchain you are using (e.g. compiler, assembler, linker, librarian, etc.) or a utility phase (e.g. file copy,
complexity analyzer etc.).

The“Add an existing system phase” button isinactive if no more system phases are available. Select the “Create
anew custom phase” button to create your own build phase.

Mew Build Phase - Step 1 of 4 HE

wihat type of phasze would you like ta add 7

* Create a new custom phasze

€0 feddl | & existing epsten phase:

Syztem Phaze | Wergion |

< Each | Hewt » | Cancel

Figure 3.3a: New Build Phase Dialog (Step 1)
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The second step (figure 3.3b) asks what type of phase you would like to create. There are two choices: multiple
or single. When amultiple phase is executed, the command is applied to each file in the project of acertain file
group. For example, if you set the input file group to be C source files then the command will be executed once
for each C sourcefilein the project. A single phase is executed once at most during a build.

New Build Phase - Step 2 of 4
)
Wwhat tppe of phaze would vou like to create?

& Multiple phase:

The cammand is applied to each file in a file group.
An example of this type of toal iz a compiler or assembler.

Select input file group:

' Single phase:

The command iz only ever executed once per build.
An example of this type of toal iz a linker.

< Back | Heut » | Cancel

Figure 3.3b: New Build Phase Dialog (Step 2)

Theinput file group list contains the current file groups defined for the project. It is possible to define multiple
input file groups by selecting the “Multiple Groups...” entry in the input file group list. Selecting thislist entry
displaysthediaog in figure 3.3c.

Select Groups

[ ssembly source file =] ok
[ |Binary file

[ 1C header file Cancel
[1C list file

(w|C zource file

[ |C++ header filz

[ 1C++ list file

;i:i++ source file

[ |CPU infarmation file

[ |Expanded azsembly zource file _Ij
[l | | »

Figure 3.3c: Modify multipleinput file groups
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Once this choice has been made the inpuit file group selection is displayed as “Multiple Groups...” Thisdialog
allows the user to choose multiple input file groups for the custom phase being added to the project. To select a
file group check the box next to the file groups name. One or more file groups can be selected in this dialog.

Thethird step (figure 3.3d) requests the fundamental information about the new build phase. Enter the name of
the phase into the “ Phase name” field. Enter the location of the program file into the “Command” field (do not
insert any command line options as these options are specified via the [Options] menu of the HEW menu bar).
Specify the default options for the phase (i.e. what options you would like new files to take when added to the
project) into the “Default options” field. If you have a preferred directory in which you would like this program
to run from (i.e. where you want the current working directory to be set to before the tool is executed) then enter

it into the “Initia directory” field.

Hew Build Phasze - Step 3 of 4
]

Phaze name:

IMyF‘hase

Command [exchuding parameters):

Ic:'\tnnls\mytnnl.er:e{

Default options:

Ll Browsze... |

|$[FULLFILE]

Initial directan:

|$[EDNFIGDIF|]

i
| Browse. |

< Back |

Hewt » |

Cancel |

Figure 3.3d: New Build Phase Dialog (Step 3)
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The fourth and final step (figure 3.3e) alows you to specify any environment variables, which the phase requires.

Mew Build Phase - Step 4 of 4
)

Does the command require any ervironment vaniables to be sety

If =0, enter them into the: lizk below:

ENv=1024
i |
e |
KN I

[ Eead Output On Fly

< Back | Finish | Cancel |

Figure 3.3e: New Build Phase Dialog (Step 4)

To add anew environment variable click the“ Add...” button (the dialog shown in figure 3.4 will be invoked).
Enter the variable name into the “Variable” field and the variable' s value into the “Value” field and then click
“OK” to add the new variable to the list of the fourth step. To modify an environment variables select the
variablein the list and then click the “Modify...” button. Make the required changes to the “Variable” and
“Value’ fields and then click “OK” to add the modified variable to the list. To remove environment variables
select the variable that you want to remove from the list and then click the “Remove” button.

Environment ¥arnable EHE

Wariable:
T
Cancel |

Ic: wdos e mytools o windowes o temp | 3 I| Eéﬁ':ﬂ::;

Walue:

Figure 3.4: Environment Variable Dialog

If the tool you are adding can display its output as the tool is running then use the ‘ Read Output On Fly’ option.
Thiswill display the tool output as each line of output happens. If this option is set to off then the HEW will
store all output, which is being displayed by the tool, and display it in the output window when the tool has
finished its operation. This can be a problem when the tool is running an operation that might take many
minutes, asit is difficult to see the progress of the current execution.

Note: Using ‘Read Output On Fly’ can cause problems when using certain tools on certain operating systems.
If you are having problems with tools locking up or freezing in HEW then uncheck the ‘ Read Output On
Fly’ option.

Click the “Finish” button to create the new phase. By default the new phaseis added to the bottom of the “Build
Phase Order” list in the “Build Order” tab of the “Build Phases’ dialog (Figure 3.2).
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33 Ordering Build Phases

In astandard build (shown in figure 3.5), you could add a phase at four different positions: before the compiler,
before the assembler, before the linker or after the linker. Y ou may place your own custom phases or move
system phases to any position in the build order. It isimportant to remember that if the output of your custom
phase can be input into another phase then the phase order must be correct if the build is to behave as intended.

@ BEGIN E

<
| «

| «

(]

®

LINK

(~]

Figure 3.5: Typical Build Process

The build phase dialog provides facilities for ordering build phases via the “Build Phases’ dialog. It has two tabs,
which are concerned with the ordering of phases: “Build Order” and “Build File Order”.

43
RENESAS




331 Build Phase Order
The“Build Order” tab (figure 3.6) displays the current order in which phases will be executed when the build

currently enabled. By clicking this box, the phase can be toggled on or off.

Build Phazes
Build et | Build File Order | File Mappings |

Build phase order:

[w]SH CAC++ Library Generator Add... |
[w]SH CAC++ Cannpiler -

w]5H Aszzembler Ll ele |

e |

[t B |

4 I I _,I Import... |

ak. | Cancel |

Figure 3.6: Build Phases Dialog Build Order Tab
In addition the following operations can be performed:

2 Toremove aphase:
1. Select the phase that you would like to remove.
2. Click the“Remove” button.
2 To view the properties of a system phase:
1. Select the system phase that you would like to examine.
2. Click the“Modify..."” button.
2 Tomoveaphase:
1. Select the phase that you would like to move.
2. Click the“Move Up” or “Move Down” button.
2 Toimport aphase:
1. Click theimport button. A dialog is displayed which allows the user to browse to an existing project to
import a custom phase from.
2. Choose thelocation of the project you wish to import a custom phase from. Once selected adialogis
displayed which lists the custom phases in the imported project.
3. Selecting aphase name and then clicking properties displays the custom phase details. Thisalowsyou
to decide whether the phase does the functionality you require.
4. Once you have decided which phase to import highlight it in the list and then click OK. The phase will
then be added to the build phases dialog at the bottom of the build order.
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2 To modify acustom phase:
1. Select the custom phase that you would like to modify.
2. Click the“Modify...” button. The modify phase dialog will be invoked with the “Command” tab selected
(figure 3.7).
3. Change the contents of the fields as appropriate.
4. Setthe“Don’'t check for input file(s) existence before executing” check box if you don’t want the HEW
to abort the execution of the phaseif any of the input filesdon’t exist.

Modify MyPhase

Command | Enviromment I

LCormmand [excluding parameters]:
IE:\tnnIs\mytnnl.eHe | 3 | Browsze... |

Initial directong:

[$ICONFIGDIR] | Browse. |

™ Don't check for input filefs) existence before executing

[ Bead Dutput On Fly

ak. I Cancel

Figure 3.7: Modify Phase Dialog Command Tab

5. Select the “Environment” tab (figure 3.8) to edit the environment settings for the phase.

6. Usethe“Add...”, “Modify..."” and “Remove’ buttons to add, modify and remove environment variables.
The operation is the same as discussed in the previous section.

7. Click “OK” when al modifications have been made.

Modify MyPhase
Command ~ Environment |
Environment settings:

PaTH=c: \dos;c: ools
SHOWALL=FALSE

EMv=1024 e |
Eemnowe |

ak | Cancel |

Figure 3.8: Modify Phase Dialog Environment Tab
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332 Build File Phase Order

If you were to select a C source file from the “Workspace” window and then activate [Build->Build File] (or
press &) you would expect the file to be compiled. Likewise, if you were to select an assembly source file from
the workspace window and then activate [Build->Build File] you would expect the file to be assembled. The
connection between file group and which phase(s) to execute is managed by the “Build File Order” tab of the
“Build Phases’ dialog (figure 3.9).

Build Phases EE3

Build Order  Build File Qrder | File Mappingz I

File group: Phasze arder:
Azzembly zource file [w] Coornpiler
[w|tyPhase $

C++ gource file

Y

| il
ak. I Cancel |

Figure 3.9: Build Phases Dialog Build File Order Tab

Thelist displaysall of the current phases that will be executed when the build file operation is selected upon the
file group shown in the “File group” list box. In figure 3.9 the “C sourcefile” file group is selected and the
“Compiler” and “MyPhase” phases are associated with it.

Entriesin the “Phase order” ligt, of the “Build File Order” tab, are added automatically as new entries are added
to the “Build Order” tab. For example, if you were to add a phase which takes C source files as input then this
phase will be automatically added to the list of phases to execute when a build file operation is applied toa C
source file. If you don’t want a certain phase to execute when [Build->Build Fil€] is selected then clear the
check box to the left of the phase name in the “ Phase order” list.
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34 Setting Custom Build Phase Options

Once you have defined a custom phase, you will want to specify the command line options that should be used
when it is executed. Each defined phase has a menu option on the [Options] menu. To specify options for that
phase select it. The dialog that will be invoked depends upon whether the custom phase selected was a multiple
or single phase (according to the selection of phase type in figure 3.3b).

Phasel... Options 21x|

IDebug j DDliDnslﬂutputFiIes Dependent Files

= IE hewtest - Command:

-3 T source file = I|:|:\_hew-files\Dns&windows executables\CMOLINE EXE

hewteaszt
initzch.c Optians:
Ophons:

2 FULLFILE

shrk.c H )

vecthl.c

hetestl

C source file Placeholder:

hewtestd o

Ref File path + name hd Inzert
initzct o =

intpra.c

shrk.c -
| v

aF. I Cancel |

Figure 3.10: Custom Options Dialog

Thedidog in figure 3.10 is acustom phase options dialog. The implementation of which is dightly different
depending on whether you are using amultiple or single shot phase. On the |eft-hand side is the project and file
list. Itispossibleto select multiple projects and filesin the same way as Windows explorer to modify the
options for more than one selection. On the right-hand side are the 3 optionstabs. Thisiswhere you set the
options that you want to apply to the selected file(s). Y ou can also choose which configuration information is
being viewed from the configuration list on the upper left of the dialog box. Each configuration islisted along
with aspecial entry named “Multiple configurations...”. If you select multiple configurationsthen adialog is
displayed which allows you to select more than one configuration. This method is used throughout HEW for
modifying multiple configurations at once.
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341 Options Tab

The“Options’ tab (figure 3.11) alows you to define the command line options that will be passed to the phase.
The “Command” field displays the command, which was entered when you defined the phase (figure 3.3d).
Enter into the “Options” field the command line arguments that you would like to pass to the command. If you
want to insert a placeholder, select the relevant placeholder from the “Placeholder” drop-down list box and then
click the “Insert” button. For a detailed description of placeholders see appendix C, “Placeholders’.

Option:s | Cutput FiIesI Diependent FiIesI

Cammand:
IC: YHewh ToolchaingHitachivSHYWA1 DAEIMYLbr.exe

Options:
-sub=$[COMFIGDIRMbuildlib.zub

Placeholder:

" - - | rt bt
Configuration directan j Inzert :I—— fzf.zlaceho:;er

ak. I Cahicel |

Figure 3.11: Custom Options Options Tab
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342 Output Files Tab

The “Output Files” tab (figure 3.12) is where you can specify the output file or filesthat will be produced by the

phase. Before each file is passed into this phase, the HEW checks that the output files are of aless recent date
than the input file. If so, the phase will be executed for that file (i.e. input files have been modified since the

output file or files were last produced). If the files are up to date then the phase will not be executed.

Note: If no output files are specified, the phase will execute regardless.

Options  Output Files | Dependent Files I

Output files:

KN [

Add...

Modify... |
_Benore |

Bemove

o]

Figure 3.12: Custom Options Output Files Tab

2 Toadd an output file:

1. Click “Add...”. The“Add Output File’ dialog will be invoked (figure 3.13).

2. Enter thefile path or browse to it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

Flaceholder popup menu

fidd Cutput File

Ll Bromsze..

Cancel |

Figure 3.13: Add Output File Dialog
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2 To modify an output file:

1. Select the output file that you would like to modify.

2. Click “Modify...". The “Modify Output File" dialog, which isthe same as figure 3.13 except the title,

will be invoked.

3. Maodify the fields as required and then click the “OK” button to add the modified entry back to thelist.
2 Toremove an output file:

1. Select the output file that you would like to remove.

2. Click the“Remove” button.

343 Dependent FilesTab

The “Dependent Files” tab (figure 3.14) iswhere you can specify the dependent files that are needed by the
phase. Before each file is passed into this phase, the HEW checks that the dependent files are of a more recent
date than the input file. If so, the phase will be executed for that file (i.e. dependent files have been modified
since theinput file or files were last modified). If not, the phase is not executed for the files.

Dptinnsl Output Files  Dependent Files |

Add...

$[CDNFIGDIF|]\F|IEE ob|
${COMNFIGDIR]4File?. obj ;

${CONFIGDIR]WFilsS obi Madiy... |
oW Hewbwork zphProjecthDebughFileT. obj
c:WHewWwfork sphProject\Debug'File2. obj Remove

oW Hewbwork zphProjecthDebughFile3.obj
c:WHewWwfork sphProject\Debug'Filed. abj

i

Figure 3.14: Dependent Files Tab in Custom Options
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To add adependent file:

1. Click “Add...”. The“Add Dependent File" dialog will be invoked (figure 3.15).
2. Enter thefile path or browseto it using the “Browse...” button.

3. Click “OK” to add this output fileto the list.

Placeholder popup menu

fidd Depandant Fils : 2 x|

Ll Browsze.. | Cance| |

Figure 3.15: Add Dependent File Dialog

To modify adependent file:
1. Select the dependent file that you would like to modify.

2. Click “Modify..."”. The “Modify Dependent File” dialog, which is the same as figure 3.15 except thettitle,

will be invoked.
3. Modify the fields as required and then click the “OK” button to add the modified entry back to thelist.
To remove a dependent file:
1. Select the dependent file that you would like to remove.
2. Click the“Remove” button.
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35 File Mappings

By default, the filesinput to a phase are only taken from the project, i.e. all project files of the type specified in
the “Select input file group” drop-down list on the “New Build Phase” dialog (figure 3.3b). If you would like a
phase to take files output from a previous phase (i.e. intermediate files) then you must define thisin the “File
Mappings’ tab of the “Build Phases’ dialog (figure 3.16).

Build Phaszes 2 | x|

Build Order I Build File Order  File Mappings |

Intermmediate file mappingz for build;

Source | Destination | File Group | Add. . I

Agzembler Linker Object file
Campiler Linker Object file ldifi..

HEmove |

ak Cancel

Figure 3.16: Build Phases Dialog File Mappings Tab
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A file mapping states that you would like the HEW to pass output files of a certain type produced by one phase
(referred to as the source phase) to another phase (referred to as the degtination phase). Such intermediate files
are passed in addition to the project files.

2 Toadd afile mapping:

1
2.

Click “Add...”. The “Define File Mapping” dialog will be invoked (figure 3.17).

Select the file group, which you want to pass between the phases from the “File group” drop-down list
box.

Select the source phase (i.e. which phase generates the files) from the “ Source phase” drop-down list box.

Select the destination phase (i.e. which phase takes these files) from the “ Destination phase” drop-down
list box.

Click “OK” to create the new mapping.

Define File Mapping

i,

File group:

| Object file I e
Source phase:

I.t’-‘n.ssembler j

Destination phaze:

Figure 3.17: Define File Mapping Dialog

To modify afile mapping:
1.

Select the mapping to be modified.

2. Click “Modify..."” button. The “Define File Mapping” dialog will be invoked (figure 3.17).
3.
4. Click “OK” to commit the changes.

Modify the options as necessary.
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3.6 Controlling the Build

By default, the High-performance Embedded Workshop will execute al of the phasesin abuild and only stop if
afatal error is encountered. Y ou can change this behavior by setting the controls on the “Build” tab of the
“Options’ dialog (figure 3.18).

Options EE3

Build |Editnl | Workspace | Confimation |

— Errarg and warnings:

[ Stop build if the no. of emors exceed:

I 1]
¥ Stop build if the no. of warnings exceed: I 10

 Shaw:

[ Command line
[" Enwironment

[ Initial directon

ak. I Cahicel

Figure 3.18: Options Dialog Build Tab

Select [Tools->Options...] to invoke the dialog. If you want to stop the build when a certain number of errors
are exceeded then set the “ Stop build if the no. of errors exceed” check box and then specify the error count limit
in the edit field to the right. If you want to stop the build when a certain number of warnings are exceeded then
set the “ Stop build if the no. of warnings exceed” check box and then specify the warning count limit in the edit
field to theright.

Note:  Irrespective of what these controls are set to, the build will always halt if afatal error is encountered.

In addition to specifying error and warning count limits, the “Build” tab also alows you to request that the
command line, environment and initial directory of each execution should be displayed. Check the appropriate
check boxes as necessary.
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3.7 L ogging Build Output

If you would like to write the results of each build to file then invoke the “ Customize” dialog by selecting
[Tools->Customize...] and select the“Log” tab (figure 3.19). Set the “ Generate log file” check box and then

enter the full path of the log file into the “Path” field or browse to it graphically by clicking the “Browse...”
button.

Customize EHE

Toolbarsl Cnmmandsl tdenu I Debugger Log |Hel|:| I

¥ Generate log fils:

Path:

|$[WDF|KSF'DIH]\$MDHKSPNAME].IDd Ll Browse... |

ak. I Cancel

Figure 3.19: Tools Customize Dialog Log Tab
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3.8 Changing Toolchain Version

If two or more versions of the same toolchain are registered in the HEW, you can choose a version of the
toolchain on the “ Change Toolchain Version” dialog shown in Figure . To invoke the dialog, select [Tools-
>Change Toolchain Version...]. Choose one of the versions from the “ Available versions’ drop-down list and
click the “OK” button to enforce your choice.

Change Toolchain Yersion EHE
Toolchain name: Hitachi SuperH RISC engine
Current version: B.0.4

Cancel

I

Available versions: IB 02 j
__ . Irtoermatien

Toolchain build phazes:

Build phase | Wergion |

OptLinker 70
SH Azzembler 5.0B
SH CAC++ Compiler .04
SH CAC++ Librany Generator 1.0

Figure 3.20: Change Toolchain Version Dialog

To show information of toolchain components select atool from the “ Toolchain build phases’ list on the
“Change Toolchain Version” dialog and click the“Information” button. Then atool information dialog (figure
3.21) will show you the information of the tool. Click the “Close” button to close the dialog.

SH C/C++ Compiler Information EHE
Infiormation:
SuperH RISC engine CAC++ Compiler Wer, 7.0 ;I

Copyright [C] 1992,2007 Hitachi,Ltd. Hitachi Software Enginesring Co. Ltd.
Lizensed Material of Hitachi Ltd. Hitachi S oftware Engineering Co..Ltd]

Figure 3.21: Toolchain Information Dialog
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3.9 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to use another
debugger then you must add it to the Tools menu (as described in chapter 6, “Customizing the Environment”.

The “Debugger” tab of the “ Customize” dialog (figure 3.22) is where the HDI-related information is configured.
Y ou may wish to use an older version of the debugger if certain targets are not currently supported in the new
environment. Invokeit by selecting [T ools->Customize...] and then selecting the “ Debugger” tab.

Toolbarsl Cnmmandsl Menu  Debugger |Lng I Help I

¥ Use external debugger

HO location [W4.0 or greater):

IEZ\HEW'\HD|5'\S|M'\SH'\Hdi.EHE p | Browse. . |

Sezsion file:

I$[I:EINFIGDIFE]'\$[F'FHEIJECTNAME].hds Ll Browse... |

Cownload module;

I$[I:EINFIGDIFH]'\$[F'FHEIJECTNAME].ahs{ Ll Browse... |

ak. I Cahicel

Figure 3.22: Customize Dialog Debugger Tab

When an external debugger is used, check ‘Use external debugger’ and then set the following items. Firstly, the
location of the HDI executable must be specified. This must be version 4.0 or greater otherwise the behavior is
not guaranteed. The second item of dataisthe session file. Thistells HDI which session to load when it is
launched. Finally, the location of the download module is required. This alows the HEW to automatically
switch to HDI when the download modul e changes after a build.

Click the “Launch External Debugger” toolbar button to invoke HDI with the specified session file:

After abuild, if the download module has been updated, the HEW will switch back to HDI to enable immediate
debugging. Whilst using HDI, double clicking in any source window will switch back to the HEW with the
source file open at the line which was double clicked.
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310 Generating a Makefile

The HEW allows you to generate a makefile, which can be used to build parts of your workspace without HEW.
Thisis particularly useful of you want to send a project to a user who does not have the HEW or if you want to
version control an entire build, including the make components.

2 To generate amakefile:

1. Ensurethat the project, which you want to generate a makefile for, is the current project.

2. Ensurethat the build configuration that you want to build the project with is the current configuration.
3. Select [Build>Generate M akefil€].
4

Once this menu has been selected adialog is displayed which asks the user what parts of the workspace
need to be added to the makefile. (See figure 3.23.)

5. Select the radio button which is relevant for your make file and then click OK.

Generate make file

x|
& For the current configuration in the currently active project DK I
= For all corfigurations in the cumently active projsct Cancel |

= For all configurations and all projects in the curent workspace

Figure 3.23: Generate makefile Dialog

The HEW will create a subdirectory “make” within the current workspace directory and then generate the
makefileintoit. It is named after the selection, with a.mak extension for example the current project and
configuration(e.g. project_debug.mak). The executable HMAKE.EXE, located in the HEW installation directory,
is provided for you to execute the makefiles generated by the HEW. It is not intended to execute makefiles,
which have been user modified.

2 To execute amakefile:
1. Open acommand window and change to the “make” directory where the makefile was generated.
2. Execute HMAKE. Its command lineis HMAKE.EXE <makefile>.

Note:  The degree portability of a generated makefileis entirely dependent upon how portable the project itself
is. For example, any compiler options, which include full paths to an output directory or include file
directory, will mean that, when given to another user with adifferent installation, the build will probably
fail. In general use placeholders wherever possible — using a full, specific path should be avoided when
possible.
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4. Using the Editor

This chapter describes how to use the editor that is provided with the High-performance Embedded Workshop.

41 The Editor Window

The editor window (figure 4.1) contains the file windows that are being viewed or edited. Only one window is
active at anytime. Thiswindow is called the active window (or current window) and itstitle bar will appear a
different color from that of the others (“dbsct.c” is the active window in figure 4.1). All text operations such as
typing, pasting text and so forth only affect the active window. To switch to another source file window (i.e. to
make some other window the active window) there are a number of methods:

e Clickonitifitisvisible.

*  PressCTRL+TARB to cycle through the windows one after another.

e Select the window by name from the “Window” menu.

* Sdectitstab at the bottom of the editor window.

When afile has been edited, an asterisk (*) is appended to the window’ s title bar. The asterisk remains there
until thefileissaved. The asterisk isalso removed if al of the edited changes are undone in the current window.

o
e
o
e
o
e
o
e

FILE ‘db=ct o

DATE :Thu, Aug 1e, 2001
DESCRIPTION :Setting of B.R Section
CFT TYFE JSHY0Z20

Thi= file i= generated by Hitachi Project Generator (Ver. 2.1).

fpragmna section SDSEC
=tatic const struct

char #rom_=; % Start address of the initialized data ==
char *rom_e: <% End addres=s of the initialized data =zect
char #*ram_=: % Start address of the initialized data =e=
IDTBL[ 1= 4 A
4 3
ol resetprgc ¢ dbscte ol shrk.c

Figure 4.1: Editor Window
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4.2 Working with Multiple Files

Thefile areais where you will work with the files of your project. The editor alows you to have many files open
at one time, to switch between them, to arrange them in different configurations and to edit them in whichever
order you want to. The operations that you can perform upon the windows are typical of most Windows®
applications and they can be found under the [Window] menu:

e [Window->Cascade]
Arrange al open windows so that they overlap, with the top left of each window visible.
e [Window->Tile Horizontally]
Arrange all open windows in sequence (horizontally) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Tile Vertically]
Arrange all open windows in sequence (vertically) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Arrange | cons)
Line up all minimized windows at the bottom of the editor window.
e [Window->Close All]
Close al open editor windows.

The files within the editor can be displayed in a“notebook” style. This means that each file has a separate tab
associated with it to aid in navigating between files.

2 To show filesin notebook:
1. Select [Tools->Options...]. The “Tools Options” dialog box will be displayed. Select the “Editor” tab.
2. Set the “ Show filesin notebook” check box as appropriate.
3. Click “OK” for the new settings to take effect.

421 TheEditor Toolbars

The editor has four related toolbars: Editor, Search, Bookmarks and Templates. They provide a shortcut to the
functions of the editor, which you will use most often. The following sections describe each buttons function.
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422 Editor Toolbar Buttons

O New File

The new file button creates a new source file window with a default name. When you save the file, you can
specify your own filename.

(== Open File

Click this button if you want to open afile. It invokes a standard file chooser - select the file which you want to
open and then click “Open”.

= SaveFile
Saves the active sourcefile.
=] Save All Files

Savesdl of thefilesin the editor.

= Print File
To print the contents of the current window, click this button.
3 Cut

Clicking this button will remove the current text selection and place a copy of it onto the Windows® clipboard
(it can be pasted back to a file with a paste operation).

Copy
This button allows you to copy the current text selection into the Windows® clipboard.
=) Paste

The paste button copies the contents of the clipboard into the active window at the position of the insertion
cursor.

i Find

Click thisbutton if you want to find a certain text string in the current file. It invokes afind dialog box where
you can specify the search parameters.

iy Find in Files

To search severdl files for atext string then click this button. All find results are displayed in the “Find in Files”
tab of the “ Output” window. For further information, refer to the “ Searching and Navigating Through Files”
section later in this chapter.

1} Match Braces

The match braces button highlights text between braces of type{ }, [] and (). Thisis particularly useful when
attempting to find out the structure of C/C++ code blocks which are opened with { and closed with }. To useit,
select the open brace to match from, or place the cursor before it, and then click this button. For further
information on brace matching, refer to the “Brace Matching” section later in this chapter.
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ar Insert Template

To insert a pre-defined template at the current cursor position, click thistoolbar button. The “Insert Template”
dialog box will be invoked. Select atemplate name and then click OK. For further information on templates,
refer to the “Templates’ section later in this chapter.

ma| Toggle Bookmar k

The High-performance Embedded Workshop editor provides standard bookmark capabilities. To set a bookmark,
select the line to mark and click this button (a green mark will then appear in the blank on the left side of the
editor window). To remove a bookmark, select the line to remove abookmark and click this button (the mark in
the blank on the left side of the editor window will disappear). For further information on bookmarks, refer to the
“Bookmarks” section later in this chapter.

423  Search Toolbar Buttons

Gy Find in Files

To search severdl files for atext string then click this button. All find results are displayed in the “Find in Files”
tab of the “ Output” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

i) Find

Click this button if you want to find a certain text string in the current file. It invokes a find dialog box where
you can specify the search parameters.

& Find Next
Finds the next occurrence of the current search string.

H Find Previous

Finds the previous occurrence of the current search string.

424 Bookmarks Toolbar Buttons

) Toggle Bookmarks

Sets a bookmark at the current line or clears a bookmark at the current line.
& Next Bookmark

Jumps to the next bookmark in the current file from the current line.

ﬁﬁ Previous Bookmark

Jumps to the previous bookmark in the current file from the current line.
&  Clear All Bookmarks

Clearsdl bookmarksin the current file.
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425 Templates Toolbar Buttons

I Define Template

Specify template text for subsequent insertion.
T Insert Template

Insert the template selected in the drop-down list at the current cursor position.
4.3 Standard File Operations

431 Creating a New File

2 To create anew editing window:
Select [File->New] or click the new file toolbar button (L) or press CTRL +N.

The window will be given an arbitrary name by default. Y ou can provide a new name when you save thefile.

432 Saving aFile

2 To save the contents of an editing window:
1. Ensure that the window, whose contents you want to save, is the active window.
2. Select [File->Save] or click the save file toolbar button (&) or press CTRL+S.

3. If thefile has nat been saved before, afile save dialog box will be displayed. Enter afilename, specify a
directory and then click OK to create the file with the name given, in the directory specified.

4. If the file has been saved before, then the file will be updated (no dialog box will be displayed).
2 To save the contents of an editing window under a new name:

1. Ensure that the window, whose contents you want to save, is the active window.

2. Select [File>Save As...].

3. Afilesavedialog box will be displayed. Enter afilename, specify adirectory and then click OK to create
the file with the name given, in the directory specified.

433 Saving all Files

2 To save the contents of every open editor window:

1. Select [File->Save All] or click the save all files toolbar button (i).

2. If any of thefiles has not been saved before, afile save didog box will be displayed. Enter a filename,
specify adirectory and then click OK to create the file with the name given, in the directory specified.

3. If any of thefiles have been saved before, then the file will be updated (no dialog box will be displayed).
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434 Opening a File

2 Toopenafile:

1. Select [File->Open...] or click the open file toolbar button (&) or press CTRL +O.

2. Anopen file dialog box will be displayed. Use the directory browser (on the right) to navigate to the
directory in which the file you want to open islocated. Use the “Files of type” combo box to select the
type of file you want to open (or set it to “All Files (*.*)" to see every filein adirectory).

3. Onceyou have located the file select it and click “Open”.

The High-performance Embedded Workshop keeps track of the last five files that you have opened and adds
them to the file menu under the “Recent Files’ sub-menu. This gives you a shortcut to opening files which you
have used recently.

2 To open arecently used file:
Select the [File->Recent Files] menu option and from this sub-menu select the desired file.

You can also open afileviathe “Projects’ tab of the “Workspace” window. Either double click the file you want
to open or select it, click the right mouse button (to invoke a pop-up menu) and then choose the [Open <file>]
menu option (where <file> is the name of the file selected).

435 Closing Files

2 Tocloseindividua files select one of the following methods:
O Double click on the editor window’s system menu (located at the top left of each window when not
maximized).
0 Click on the editor window’s system menu (located at the top left of each window when not maximized)
and select the “Close” menu option.
O Ensurethat the window that you want to closeis the active window and then press CTRL +F4.
0 Ensurethat the window that you want to closeis the active window and then select
[File->Close].
0 Click on the close button (located at the top right of each window when not maximized).
2 Tocloseal windows at once:
Select [Window->Close All].
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44 Editing a File

The High-performance Embedded Workshop editor supports standard editing functionality. Thisis available
through the usual methods (i.e. the menu, toolbar and keyboard shortcuts) and is additionally supported viaa
pop-up menu (or local menu) that isloca to each editor window. To invoke it, place the pointer in an open

window and click the right mouse button. Table 4.1 outlines the basic operations that are provided by the editor.

Table4.1 Basc Editing Operations
Operation Effect Action
Cut Removes highlighted text and places it on the Click the cut toolbar button
Windows® clipboard Select [Edit->Cut]
Select [Cut] - local menu
Press CTRL+X
Copy Places a copy of the highlighted text into the  Click the copy toolbar button
Windows® clipboard Select [Edit->Copy]
Select [Copy] - local menu
Press CTRL+C
Paste Copies the contents of the Windows® Click the paste toolbar button
clippgard into the aqtive window at the Select [Edit->Paste]
position of the insertion cursor
Select [Paste] - local menu
Press CTRL+V
Delete Removes highlighted text (it is not copied to  Select [Edit->Clear]
the Windows® clipboard) Select [Clear] - local menu
Press Delete
Select All Selects (i.e. highlights) the entire contents of  Select [Edit->Select All]
the active window Select [Select All] - local menu
Undo Reverses the last editing operation Select [Edit->Undo]
Select [Undo] - local menu
Press CTRL+Z
Redo Repeats the last “undone” editing operation Select [Edit->Redo]

Select [Redo] - local menu
Press CTRL+Y
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4.5

Sear ching and Navigating through Files

The High-performance Embedded Workshop editor provides find, replace and file navigation functionality. The
following three sections detail how to use these features.

451

Finding Text

2 To search for text in the current file:

1
2.

3.

Ensure that the window, whose contents you want to search, is the active window.
Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Find...], press CTRL +F, select [Find...] from the editor window’sloca menu or click the
find toolbar button (#}). The “Find” dialog box will be displayed (figure 4.2).

Find EE

Find what: Istring ﬂ Fitnd Mext |
™ Match whole word only Direction——— Cancel |

™ Match case ' Up
' Dawn

™ Fegular expression

9.

Figure 4.2: Find Dialog

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find what” field.
If you would like to search for character string as a whole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to
Appendix B, “Regular Expressions’ for further information.
The “Direction” radio buttons allow you to select the direction of the search. Selecting “Down” means
that the search will be performed from the insertion cursor towards the bottom of the file. Selecting “Up”
means that the search will be performed from the insertion cursor towards the top of the file.
Click the “Find Next” button to begin the search. Click “Cancel” to stop the find action.

The High-performance Embedded Workshop editor also allows you to search for a string across many files.
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452

Finding Text in Multiple Files

2 To search for text in many files:

1.

Select [Edit->Find in Files...], select [Find in Files...] from the editor window’s local menu or click the
find in files toolbar button (Egl4). The “Find in Files’ dialog box will be displayed (figure 4.3).

Find In Files EE3

Find: IMyStruct j
C |

In files/types: I“.c:;“.cpp;“.e:-tp;".fsy;“.h;“.hpp;“.inc;“.lis;".lp j &l

Diirectomy Ic:'\hewkdemn'\demo ﬂ Browse. . |

™ Match case ¥ Search sub directories

™ Fegular expressions

Figure4.3: Find in Files Dialog

Enter the text that you want to search for into the “Find” field, or select a previous search string from the
drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find” field.
Enter the file extensions of the files you would like to search into the “In files/types’ field. If severa
extensions are specified be sure to separate them with acomma (e.g. *.c,*.h).
Enter the directory in which you would like to search files into the “ Directory” field. Alternatively you
may browse to the desired directory graphically if you click the “Browse...” button.
If you would like to search the directory specified and all directories below it then check the “ Search sub
directories’ check box. If you just want to search the single directory specified in the “ Directory” field
then ensure that this check box is not checked.
If you would like to search for character string as awhole word then check the “Match case” check box.
When this option is not selected, the search will be for any string that is matched by the search string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
Click “Find” to begin the search. Any matches found will be displayed in the “Find in Files” tab of the
“QOutput” window. To jump to an instance of the string, double click on the desired entry in the “ Output”
window.
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453 Replacing Text

Replacing text is similar to finding text, as discussed in the previous section. The difference isthat when the text
is found you have the option to replace it with other text.

2 Toreplacetextin afile:

1. Ensure that the window, whose contents you want to replace, is the active window.

2. Position the insertion cursor at the point from which you want to start your search.

3. Select [Edit->Replace...], press CTRL +H or select [Replace...] from the editor window’s local menu. A
replace dialog box will be displayed (figure 4.4).

4. Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the replace operation, the selected text will
be automatically placed into the “Find what” field.

5. Enter the text that you want to replace the search string with into the “Replace with” field, or select a
previous replace string from the drop-down list box.

Replace 2xl
Find what: |string LI Find Mext I
Replace with: frumeric =l Replace |

[~ Match whole word only Replace h———— Replace &ll |

[~ Match case " Belection

[~ Reeular expreszion f+ Whale file Cancel |

&l open files

Figure 4.4: Replace Dialog

6. If you would like to search for character string as awhole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.

7. 1f you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.

8. If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to

appendix B, “Regular Expressions’ for further information.

If you clicked “Find Next”, the editor will search for the first occurrence of the search string. Click
“Replace” if you want to replaceit. Click “Replace All” to replace al occurrences or click “Cancel” to
stop the replace action. If you select “Selection” in “Replace In”, selected range of the text isreplaced. If
you select “wholefile”, the whole files are replaced. If you select all open files, al filesthat are
currently open in the editor have the replace operation carried out on them.

©
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454

Jumping to a Specified Line

2 Tojumptoalineinafile

1
2.

Ensure that the window, whose contents you want to replace, is the active window.

Select [Edit->Goto Line...], press CTRL+G. or select [Goto Line...] from the editor window’ s local
menu. A goto line dialog box will be displayed (figure 4.5).

Enter into the dialog box the number of the line that you want to go to, and then click “OK”.
Theinsertion cursor will be placed at the start of the line number specified.

Line number |1
ak. I Cancel |

Figure 4.5: Goto Dialog
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4.6 Bookmarks

When working with many large files at atime, it can become difficult to locate specific lines or areas of interest.
Bookmarks enable you to specify lines that you want to jump back to at a subsequent time. One example of its
useisinalarge C file where you may want to set a bookmark on each function definition. Once a bookmark has
been set, it exists until it isremoved or the fileis closed.

2 To set abookmark:
1. Placetheinsertion cursor on the line to mark.
2. Select [Edit->Bookmarks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button (3 ).

3. A green mark appearsin the blank on the left side of the line to indicate the presence of an active
bookmark.

2 To remove abookmark:
1. Placetheinsertion cursor on the marked line.
2. Select [Edit->Bookmarks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmar k] from the local menu or click the toggle bookmark toolbar button (23 ).
3. The mark will be removed and the line will return to normal text.
) To jump to the next bookmark in afile:
1. Ensurethat the insertion cursor is somewhere within the file to be searched.
2. Select [Edit->Bookmarks->Next Bookmark], press F2 or select [Bookmarks->Next Bookmark] from
the local menu or click the next bookmark toolbar button ( wm ).
2 Tojump to the previous bookmark in afile;
1. Ensurethat the insertion cursor is somewhere within the file to be searched.
2. Select [Edit->Bookmar ks->Previous Bookmark], press SHIFT+F2 or select [Bookmar ks->Previous
Bookmark] from the local menu or click the previous bookmark toolbar button ( ﬁﬁ ).
2 Toremoveal bookmarksin afile:
1. Ensure that the window, whose bookmarks you want to remove is the active window.

2. Select [Edit->Bookmarks->Clear All Bookmarks] or select [Bookmar ks->Clear All Bookmarks]
from the local menu or click the clear all bookmarks toolbar button (2 ).

4.7 Printing a File

2 Toprint afile
1. Ensure that the window, whose contents you want to print, is the active window.
2. Select [File->Print...], or click the print toolbar button (&) or press CTRL +P.
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4.8 Configuring Text Layout

The following sections detail how to set-up the layout of the text within the editor windows.

481 Page Set-up

When you print afile from the High-performance Embedded Workshop editor, the settings in the print dialog
box affect the way in which thefileis printed (e.g. double or single sided). Control over how the text is
formatted on the page can also be controlled via the page set-up option. This allows you to specify the margins
(top, bottom, left and right) of your printouts. It is often necessary to set this because some printers cannot print
to the edges of an A4 page. Furthermore, some users have their own layout requirements (e.g. alarge left hand
margin so that code can be placed in an A4 binder).

2 To set-up the page margins:
1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).
2. Enter into the edit fields the margins required (set the “inch” or “mm” radio buttonsto set the
measurements).
3. Click “OK” for the new settings to take effect.

Page Setup HE
M argin:

Lt [E Bioht o |
Top lg— Bottam: lg—

@ilnch ) om
Header:
i3
Footer:
| i3
()8 I Cancel |

Figure 4.6: Page Setup Dialog

2 To set-up the page header and footers:

1. Sdlect [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the header and footer edit fields the text required to be displayed. All normal placeholders are
available along with page numbering, text justification and date fields. These are all expanded before
the page isto be printed.

3. Click “OK” for the new settings to take effect.
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482 Changing Tabs

2 Tochangetab size:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7)).
2. Enter into the “Tab size” field the number of desired tabs.
3. Click “OK” for the tab setting specified to take effect.

Options EE3

Build  Editor |W0rkspace| Cnnfirmationl

— Spacing:
i

=

¥ Enable auta indentation

Tah size: I 4

— General:
¥ Save files before executing any tools [ Show files in noteboak:
™ Prompt before saving files ¥ Enable spntax colaring
— Extemnal editor:

[ Usze extemal editar:

ak. I Cahicel

Figure 4.7: Options Dialog Editor Tab

When aTAB key is pressed in the editor a tab character is usually stored in the file. However, sometimesit is
preferable to store spaces instead. The representation of tab characters can be controlled via the “ Options’ dialog.

2 To use spaces astabs:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Setthe“Use spacesastabs’ check box as appropriate.
3. Click “OK” for the tab setting specified to take effect.
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4.8.3 Auto Indentation

When you press return in a standard editor the insertion cursor will move to the next line down, at the first
column (i.e. against the left hand side of awindow). Auto Indentation is afeature which, when return is pressed,
places the insertion cursor on the next line (as before) but under the first non-white space character of the
previousline. This enables you to type neat C/C++ or assembler code faster as you don't have to type leading
spaces or tabs yourself.

Figure 4.8 illustrates two examples. Thefirst (i) shows the effect of pressing return when the auto indentation
feature isdisabled - theinsertion cursor returns to the | eft-hand side of the window on the next line. When the
line“int z=20" istyped, it is not aligned with the previous two lines. The second example (ii) shows the effect of
pressing return when auto indentation is enabled - the insertion cursor drops underneath the “i” of the previous
line. Now, when theline “int z=20" istyped, it is automatically aligned (i.e. automatically indented).

void myfunction(void)

{

void myfunction(void)

{

int x=5; int x=5;
int y=10; int y=10;
inty ;| inty: un
int z=20; int z=20;
i) Auto Indentation Disabled ii) Auto Indentation Enabled

Figure 4.8: Effect of Auto Indentation

2 To enable/disable Auto Indentation:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the“Enable auto indentation” check box accordingly.
3. Click “OK” for the setting of the auto indentation check box to take effect.

73
RENESAS




4.9 Splitting a Window

The High-performance Embedded Workshop editor allows you to split atext window into two. Figure 4.9 shows
the split bar button which islocated just underneath the maximize button at the top right hand corner of any text
window.

Figure 4.9: Split Bar Button

2 To split awindow:
Double click on the split bar button to split the window in half or click on the split bar button, keep the button
pressed, move the mouse down and then rel ease the mouse button at the point you want to split the window.
2 To adjust the position of the split bar:

Click on the split bar itself, keep the button pressed then move the bar to the new position and then release
the button.

2 Toremove the split bar:
Double click on the split bar or move the split bar to the top or bottom of the window.
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410 Configuring Text

The following sections detail how to change the appearance of the text displayed in the editor windows.

4.10.1 Changing the Editor Font

The High-performance Embedded Workshop allows you to specify the font to be used in itsinternal editor. All
editor windows, regardless of thefile type, use the same font.

2 To change the editor font:
1. Select[Tools->Format Views...]. The “Format Views’ dialog will be displayed. Select the Source icon
in the tree (figure 4.10).
2. Select the desired font from the “Font” list.
3. Select the size of the font from the “Size” list.
4. Click “OK” to confirm the new editor settings.

Format Views EE3

Source
53 4
iy Selected Test
L[y Test
f-[[7] Aszembly include file
i1 &szembly izt file
i1 &szembly source file Farnt

il A
C list file

| »

Font |

C zource file

C++ header file Gize

C+ ligt file

C+ gource file |1|:I jv
Expanded aszembly :
He:x file |-
Library information file
Linkage map file
Linkage symbol file &

o] d
Sl | FelEdify | Eemnowe | QK. I Cancel

[
[
[
-
-
-
-
-
-
-
-
-
-
-

reppppooee

HEW Sample Text

=5

Figure 4.10: Format Views Dialog Font Tab
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411  Syntax Coloring

To enhance code readability, the HEW editor can display specific strings (i.e. keywords) in different colors. For
instance, C source code comments could be shown in green and C types (e.g. int) could be shown in blue.

The coloring method used can be specified on afile group by file group basis. For example, you can define
different color schemes for a C sourcefiles, text files, map files or even your own files.

2 To change exigting colors:
1. Select[Tools->Format Views...]. The “Format Views' dialog will be displayed.

2. Select theitem underneath theicon in the tree you wish to modify the colour for. This should be the file
type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-processor).

3. Select the“Colour” tab.

4. Modify the “Foreground” and “Background” color lists as desired. The color “ System” refersto the
current window foreground and background settings in control panel.

5. Click “OK” for the new colorsto take effect.

2 To create new keyword groups:
1. Select[Tools->Format Views...]. The “Format Views’ dialog will be displayed.
2. Select thefiletypein the tree to which you wish to add the new keyword group.
3. Click “Add..."” underneath the tree. The “Add Category” dialog box will be displayed (figure 4.11). Enter
the name of the keyword group in the “Category Title” field, then click “OK” to create the new keyword
group.

Add Category 7] x|
Cateqgary Title: QK I

f
Cancel |

Figure4.11: Add Category Dialog

2 To create new keywords:
1. Select[Tools->Format Views...]. The “Format Views' dialog will be displayed.

2. Select the item underneath the source view icon in the tree you wish to modify the syntax highlighting
for. Thisshould bethe file type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-
processor).

3. Select the“Keywords” tab (figure 4.12).
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Figure 4.12: Format Views Dialog K eywords Tab

4. Click the“Add...

" button to add a keyword. Then the “Add Keyword” dialog (figure 4.13) will be

launched. Specify akeyword in the “Keyword” field and click “OK” to close the didog. To remove a
keyword, select the keyword and click the “Remove” button.

Add Kepword HE

Keyword:

Cancel |

Figure 4.13: Add Keyword Dialog

When you create anew file, syntax coloring will not be active as a new file does not initially have an extension
(new files are named arbitrarily by the editor without an extension). In order to activate syntax coloring, you
must save the new file with a name, which has one of the above extensions.

2 To disable/enable syntax coloring:

1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable syntax coloring” check box as necessary and then click “OK”.
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412

Templates

When developing software it is often necessary to enter the same text repeatedly, for instance, when typing a
function definition, for loop or acomment block for a function. The HEW editor allows you to specify a block of
text (or template) which can be inserted into the currently active editor window. Thus, once atemplate has been
defined, it can be automatically inserted without the need to re-enter it manually.

4121

2

78

Defining a Template

To define atemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu, press CTRL +T or click on the define template toolbar button (“[F')). The dialog shown in

figure 4.14 will be displayed.

2. Click “Add”. A dialogisdisplayed that asksyou to enter your chosen template name. This name must
be unique otherwise a duplicated template name message will be displayed and the template will not be

added.

3. If you want to modify an existing template use the “ Template name” drop down menu to select which

template you want to modify.

4. Enter the desired text into the “ Template text” text area. Y ou can copy text from another editor window
and then paste it into thisdialog using CTRL+V.

5. Enter the following keywords to insert specia information when the template is inserted:

Menu Entry Placeholder Replaced With

Time $(TIME) Current time

Date asDMY $(DATE_DMY) Current date, in dd/mm/yy form

Date asMDY $(DATE_MDY) Current date, in mm/dd/yy form

DateasYMD $(DATE_YMD) Current date, in yy/mm/dd form

Date as Text $(DATE_TEXT) Current date in text form

Line $(LINE) First line number of template insertion

User $(USER) Current windows user

File $(FULLFILE) Name of thefile

Filename $(FILE) Name and full path of thefile

Project Name $(PROINAME) Current project name

Workspace Name $(WORKSPNAME) Workspace name

Cursor position $(*) Insertion cursor — Positions the cursor
in this position after template has been
inserted

6. Enter the $(*) character to specify where the insertion cursor is to be placed after the template has been
inserted. If thisis not specified then the insertion cursor will be placed after the last character in the
template (asin anormal paste operation).
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Figure 4.14: Define Template Dialog

4122 Deleting a Template

2 Toddete atemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu, press CTRL+T or click on the define template bookmark toolbar button ( I ). Thedialog
shown in figure 4.14 will be displayed.

2. Use the Template name drop down list to select the name of the template you wish to remove and then
click the “Remove” button.

3. Clicking “OK" saves the template changes and dismisses the dialog.

4123 Insertinga Template

2 Toinsert atemplate:
1. Select atemplate in the toolbar, then click the insert template toolbar button (T ), select [Edit->
Templates->Insert Template...] or select [Templates-> Insert Template...] from the local menu. The
dialog is dismissed and the chosen template is added to the current editor window.

4.12.4  BraceMatching

Complicated source code can often become unwieldy, especially when blocks of C code are deeply nested within
each other or when complex logic statements are expressed within an ‘if’ clause. To help in such situations, the
High-performance Embedded Workshop editor provides a match brace feature which highlights text between
bracesof type{ }, () and[].

2 Tofind amatching brace:
1. Either highlight the open brace to match from or place the cursor beforeit.

2. Click the match braces toolbar button ({ }), press CTRL+B, select [Edit->M atch Braces] or sdlect
[Match Braces] from the local menu.

To check the structure of an entire file, place the cursor at its start and then repeatedly invoke the match brace
operation. The editor will successively highlight each pair of bracesin turn until there are no more to match.
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413 Editor Column Management

The editor in HEW has the ability to manage columns apart from the main editor column. These can be added
and used by debugger feature. Y ou can choose the column to display/undisplay.

«# tutorial ¢

0x00000a0c
0=00000al6

0=00000218
0xz00000a20

0x00000a2c
0x00000a2e
0x=00000a36
0=z00000a38

0x00000a3a
000000244

0x00000a62
0x00000a66
0z00000a72
0z00000a74

KN

=101 x|

#include <no_float_h> j
#include {stdio.h>

#include <math.h>

#include <{stdlib.h>

void main{void);

void sort{long =a});

void change({long *a);

extern void srand{unsigned int};

void main{void)

{

w1

long a[18], min, max;

long j;

int i;

srand{1);

printf{"#itH Data Input #Hn™);

For({ i=8; i<1e; i++ ){

j = rand();
if(j < @3¢
j=-is

a[i] = j;
printf{"a[%d]=%ld\n",i,a[i]};

sort{a});
printf("=x= Sorting results x==\n"});
for{ i=8; i<10; i++ ){
printf(“a[%d]=%Lld\n",i,a[i]);
¥ -

min — ar AT

Figure 4.15: Editor Columns

2 Toswitch off acolumnin al source files:
1. Right click on the editor window.
2. Click the “Define Column Format...” menu item.
3. The“Global Editor Column States” dialog is displayed.
4. The“Check status’ shows whether the column is enabled or not. If it ischecked it isenabled if the
check box is gray this means that in some files the column is enabled and in other files it is not.

5. Click “OK” for the new column settings to take effect.

2 To switch off a column in one sourcefiles:
1. Right click on the editor window, which you wish to remove a column from, and the editor pop-up is

displayed.

2. Click the Columns menu item and a cascaded menu item appears. Each column is displayed in this pop-
up menu. If the columnisenabled it hasatick next toitsname. Clicking the entry will toggle whether
the column is displayed or not.
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Global Editor Column States

[w]Cowerage
[w] Editor

[w]Source Address Cancel |

Figure 4.16: Global Editor Column States Dialog
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5.  Tools Administration

Y ou control the components, which can be used by the High-performance Embedded Workshop viathe “Tools
Administration” dialog (figure 5.1), which isinvoked via [Tools->Administration...]. Modification of the
“Tools Administration” dialog box is only possible when no workspace is open, while only reference is possible
when aworkspace is open.

Tools Administration d |

Reqiztered compaonents: oK I
Camponent | Yersion = c I
=43 Taolchains $|

- §{ Hitachi SuperH RISC engine Standard Toolch...  6.0.0 Beai
=23 System Tools Lter...l
{39 Hitachi M apiew 1.0 Urredgist |
----- {f' Hitachi H Series Librarian [nterface 11 =HEAEE
----- “ Hitachi Call w/alker 1.0 B |
----- 3 Utility Phazes
=3 Debugger Components Export... |
-E] Generic Label Yiew ECx 1.0 —

tanitar platfarm 1.0 Search disk... |
} sH2CRU 1.0 s =
Genernc 10 Wiew ECH 1.0 Tool infarmation. .. |

- EZ| SRecord object reader 1.0

mlﬁ F utarzing Caranmnants | _lﬂ Uninztaller. . |
4 » -

[ Show all components

Current HEW toolz databaze location;

Id: Shewhexeiwinhdebug Modify... |

Figure 5.1: Tools Administration Dialog (Example)
There arefive standard types of component:

» Toolchain - aset of build phases (e.g. compiler, assembler, and linker). These components provide the build
capability.

e System Tool - an application (.EXE) which can be launched from the “Tools’ menu. They are often provided
as extra applications, which support the toolchain (e.g. an external debugger like the HDI or an interactive
graphical librarian).

» Utility Phase - a“ready made” build phase which supports some specific build functionality (e.g. analyze
complexity of source code, count lines of source code, etc.). These components provide added functionality
to the build that is not toolchain specific.

» Debugger Component —a component that supports some specific debugger functionality (e.g. Target
platform, Object reader, etc).

» Extension Component —a component that provides key functionality in a certain area of the HEW system.
These components cannot be unregistered when installed (e.g. The HEW builder, debugger and flash
support).
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51 Tool Locations

The HEW maintains the locations of HEW compatible components automatically as each new tool isinstalled.
After installation, the HEW stores information about the component (including itslocation) — thisis referred to
asregistration. Although initia registration is automatic, during the course of development or if you want to
manage the tools being used in your projects more effectively, you may need to register components yourself.
The remainder of this chapter discusses registration and how it affects you.

52 HEW Registration Files (*.HRF)

When a HEW compatible component (i.e. toolchain, system tool or utility phase) isinstalled, part of its
installation will include afile with the extension .HRF (figure 5.2.i). Thisfile, named a“HEW Registration File”,
describes the component to the HEW. The process of registration refers to loading a component’s .HRF file into
the tools administration dialog (figure 5.2.ii).

i. INSTALL ii. REGISTER
C:\
MyTool MyTool
I:I MYTOOL.HRF _I:I MYTOOL.HRF g
. ) HEW
bin E bin
etc etc
help help

Figure5.2: HRF File Location and Registration

In order to use a component with HEW it must first be registered. The “Tools Administration” dialog (figure 5.1)
shows all currently registered components. To accessit, ensure no workspaces are open and then select [Tools
->Administration...]. If you attempt to access tools administration when there is a workspace open the tools
administration dialog is opened but cannot be modified. When HEW isinstalled by default any new tools are
automatically registered.

HEW stores tool information in atool database file. By default thisis created in the HEW application directory,
however if you are working in a network environment this directory may be set to another location. It ispossible
to change the tool directory location.

2 To change the tools location:

1. Select[Tools->Administration...].

2. Click the“Madify” button for the “ Current HEW tools database location” field.
3. Select the directory under which the new tool islocated, then click “OK”.
4

Thiswill switch the directory and change the tool location to the new directory. It will be necessary to
scan for any new tools that may be in this location thisis achieved by using the scan disk or register tool
functionality.
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53 Registering Components

The HEW will automatically attempt to register any new componentsinstalled since the last time it was invoked.
However, in some circumstances you may need to register components yourself.

531 Searching Drivesfor Components
In some casesit is useful to search adrive for HEW compatible components. Thisis especialy useful if the

HEW installation was deleted or corrupted as it can recreate your tool information instantly.

2 To search for components:

1. Click the“Search Disk..."” button on the “Tools Administration” dialog (figure 5.1). The “ Search Disk for
Components” dialog will be displayed (figure 5.3).

Search Dizk for Components

. . . . Cloze
Select the directony in which to begin the search:; —
Ic:'\hew

Browsze. .

¥ Include subfolders Start

Located components:

U,

Componet Werzsion | HRF Location Begister

i g andard Toolc... [ oolch :
Hitachi H&5 H3/300 Standard Toolchain 30a0  chhew\Toolch | Register Al
Hitachi H Series Librarian Interface 1.0 c:\hewhToolck
Cygriuz GMUPro SH w332 ohhewhToolch
1&F ICCHE Toolchain 1.23a  cihhewh\Toolck
a | ol

Search Status: 5 file(z] found

Figure 5.3: Search Disk for Components Dialog

Enter the directory in which you would like to search into the top field or browse to it graphically by
clicking the “Browse...” button.

Check the “Include subfolders” check box if you would like to search the directory specified and all
directories below it.

Click the “ Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.
5. Theresults of the search are shown in the “Located components” list. Select a component and click

“Register” to register an individual component or click “Register All” to register all located components.
6. Click “Close” to exit the dialog.
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532 Registering a Single Component

The HEW allows you to navigate directly to a single component in order to register it. The HEW Registration
File (*.HRF) islocated in the root directory of acomponent’sinstallation.

2 To register acomponent:
1. Click the“Regigter...” button on the “Tools Administration” dialog. A standard file open dialog will be
launched with itsfile filter set to “HEW Registration Files (*.hrf)".
2. Navigate to the .HRF file of the component you would like to register, select it and then click “ Select”.
3. A dialog will be invoked which displays information regarding the selected tool. Click “Register” to
confirm that you want to register the tool or click “Closeg”’ to abort the operation.

54 Unregistering Components

The components, which are registered with the HEW, affect the way in which it behaves. For example, every
compatible system tool, which isregistered, will be added to the tools menu when anew project is created.
Sometimes this may not be desirable. If so, open the “Tools Administration” dialog, select the component from
the “Registered components’ list and then click the “Unregister” button. A dialog will be invoked which asks
you to confirm thisaction. Click “Yes' to confirm the action.

Note:  Unregistering a component does not remove its installation from hard disk. It simply removes the
information, which the HEW was storing about that component (i.e. it “disconnects’ it from the HEW).
The action can be easily reversed at anytime by registering the tool (see above). If you want to remove a
component from the hard disk (i.e. uninstall a component) then refer to the section “ Uninstalling
Components’ |ater in this chapter.
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55  Viewing and Editing Component Properties

To view information regarding a component, select it from the “Registered components” list and then click the
“Properties’ button. The properties dialog will be displayed with the “ General” tab selected (figure 5.4). Thistab

displays the name, version and location of the selected component. None of the information on thistab is

editable.

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties B [E4

MHame Hitachi SuperH RISC engine Standard
Wersion : 51.0
Lozation : cMhewsT oolchainghHitachibSHYWET0

ak. I Cancel |

Figure 5.4: Properties Dialog General Tab

Select the “Information” tab to view any information about the component (figure 5.5). This may include

copyright information, enhancements, bug fixes, user notes and so on.

Hitachi SuperH BISC engine Standard Toolchain 5.1.0 Propertie: [ E3

General Environment
Information:
Hitachi SuperH RISC engine Standard Toolchain Wer, 5.1.0 ﬂ

CAC++ Compiler Wer, 5.1

Azzember Wer 4.2

Optlinker  Yer. 1.1

[Likage Editar Wer. 6.0D] LI

ak. I Cahicel |

Figure5.5: Properties Dialog I nformation Tab
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Select the “Environment” tab, if it exists, to view and edit a component’ s environment settings (figure 5.6). This
dialog is most commonly used to modify the environment of atoolchain.

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties B [E4

General | Information  Enviranment

Ervironment wariables:

[SHE_LIE=c-hhewT oolchainssHitachihg H451 D4

SHC_TMP=cA\TEMF HModify... |
1| | _’I Remove |

Figure 5.6: Properties Dialog Environment Tab

To add anew environment variable, click the“Add...” button (the dialog shown in figure 5.7 will be invoked).
Enter the variable name into the “Variable” field, the variable’svalue into the “Value” field and then click “OK”
to add the new variable to the “ Environment” tab. Placeholder pop-up menus are included to ensure that the
environment can be specified as flexibly as possible. For a detailed description of placeholders see appendix C,
“Placeholders’.

To modify an environment variable, select the variable that you want to modify from the “ Environment” tab and
then click the “Modify..."” button. Make the required changes to the “Variable” and “Value” fields, and then
click “OK” to add the modified variable to the “Environment” tab. To remove an environment variable, select it
and then click the “Remove” button.

Environment ¥arnable EHE

Wariable:
T
Cancel |

Ic: wdos e mytools o windowes o temp | 3 I| Eéﬁ':ﬂ::;

Walue:

Figure5.7: Environment Variable Dialog
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56

Uninstalling Components

The HEW provides abuilt in uninstaller method, which can remove unregistered components.

2 Touninstall acomponent:

1. Select[Tools->Administration...].
2. Click on the uninstaller button. The “Uninstall HEW Tool” dialog isinvoked (figure 5.8).
Uninstall HEW Tool 7l x|
Select the directary in which ta begin the zearch for tools: ﬂl
Browsze... |
v Include subfolders
Located Toolz which can be uninstalled:
Component | Yerzion | Installation Directony Wrimetall |
1| | i
Search Status:  Idle
Figure5.8: Uninstall HEW Tool
3. Enter the directory in which you would like to search into the top field or browse to it graphically by
clicking the “Browse...” button.
4. Check the “Include subfolders’ check box if you would like to search the directory specified and all
directories below it.
5. Click the “Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “Stop” button to halt the search at any time.
6. Theresults of the search are shown in the “Located Tools which can be uninstalled” ligt. Select a
component and click “Uninstall” to uninstall a component.
7. Click “Exit” to exit the dialog.

A component may only be uninstalled if it is not currently registered with the HEW. If you attempt to uninstall a
tool, which is registered, then the dialog shown in figure 5.9 will be displayed. In such a case, you must return to
the “Tools Administration” dialog via[Tools->Administration...], unregister the tool and then invoke the tool
uninstaller again.
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ToolUninstaller

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 is curently registerad: vou may not uninztall & toal that is registered with
HE"W.

Flease uze HEW to unreqister the Tool and then select "Retry' to uningtall.

: Cancell

Figure5.9: Unableto Uninstall Tool

If atool is not registered with the HEW then the dialog shown in figure 5.10 will be displayed when the
“Unregister” button is clicked. This confirmation dialog displays all of the files and folders that will be deleted.
If you are certain that these files and folders can be deleted then click the “Yes” button. To abort the uninstall
click the“No” or “Cancel” buttons.

Confirmation EHE

The fallowing files and folders will be deleted:

c:vhew' T oolchainz \HitachivSHYE1 0N zample
c:hewh T oolchaingHitachivSHYWAT Dhinclude

o vhewt ToolchainsiHitachinSHYWST0Mib

c:hewh ToolchaingyHitachit5HY51 04 bin

o vhewt ToolchainsiHitachinSHYWET DM Rew
c:hewh T oolchaingHitachibSHYE1 DA binhdwichy.exe
o vhewt ToolchainsiHitachinSHYWST DMbinvshic. exe
c:hewh ToolchaingHitachitSHYE1 DAbintshcasm.exe
c:vhew' T oolchains ' HitachitSHYS10Mbinhs ko mag
c:vhewh T oolchaingHitachivSHYWA1 Dhbintshcern, off

o vhewt ToolchainsiHitachinSHYWSTMbinskicfit exe
o vhewt Toolchaing'HitachiySHYET0Mbintshogen. exe
c:vhew' T oolchains ' HitachitSHYET10MBinhshchip. msg
c:hewh ToolchaingHitachibSHYS1 DM binhshcmd] exe
c:vhew' T oolchains \HitachitSHYE10MBinhshopep. exe LI

c:hewh T oolchaingyHitachivSHYA1 Dhehe toolchain, bk ﬂ

Are You sure you want to delete the above files and folders?

Figure 5.10: Confirmation Dialog
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5.7 Technical Support |ssues

The “Tools Administration” dialog is also capable of displaying information regarding “hidden” system
components. These are part of the HEW itself that cannot be unregistered/registered manually. If you check the
“Show all components’ check box on the tools administration dialog, extra component folders are displayed (see
figure 5.11).

Tools Administration d |

Reqiztered compaonents: Ok I

Camponent | Yersion B c I

-] Swstem Tools $|
[ Uility Phases .

i Reqister...

([ Debugger Components ﬁl

- ([ Extension Components WUriregister |

E| a F'ro|ectGenerators

i . achi SH Pra rato 2 Froperties |

E| a Werzion Contral Syslem Ezport... |

¢ bea] CustomCS 20 -

E| a Toolchain Suppart Search disk... |
i 21

------ . Hitachi SH Toolchain Supporter

El a Definition Parser Tool infarmation. .. |

------ . Cusztorn Parzer 1.0

hd Uninstaller... |
1| | Bl

¥ Show all components

Current HEW toolz databaze location;

Id: Shewhexeiwinhdebug Modify... |

Figure 5.11: All Components Shown

When seeking technical support, you may be asked to give detail s about some or al of these components. To do
so, open the respective folder, select acomponent and click the “ Properties’ button. The properties dialog that
will be invoked behaves in the same way as discussed previoudly in this chapter, with the exception that thereis
no “Environment” tab.

The HEW also has a feature, which outputs tool information regarding the registered componentsto afile. This
allows you to retrieve information on the entire HEW system. This information can then be sent to your
technical support contact if you are experiencing problems with the HEW.

2 To output tool information:
1. Click the[Tools->Administration] menu item.
2. Click the“Tool information...” button. A standard windows file save dialog is displayed.
3. Choosethe filelocation and click OK.
4. A fileiscreated in the chosen location with the current registered tool setup of the HEW 2.1.
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5.8 Custom Project Types

The [Project->Create Project Type...] menu itemin HEW allows you to create atemplate for your project.
This menu item takes the settings of the current project and then creates a project type for you. The user can
specify the name of the new type and style of the project generation wizard. Once created these project types
appear in the “Tools Administration” dialog and are initially hidden in the system components part of the tools
administration tree. To export one of the custom project generators select the “Export” button on the “Tools
Administration” dialog. The execution environments of the custom project generators are packaged on the
execution file that can beinstalled. When thisfile is executed on the target user’ s machine, the custom project
generator isinstalled.
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6.  Customizing the Environment

6.1 Customizing the Toolbar

The High-performance Embedded Workshop provides 2 standard toolbars as detailed in chapter 1, “ Overview”.

In addition to these, you may also construct your own toolbars viathe “ Customize” dialog (figure 6.1).

Customize EE3

Cnmmandsl fdenu I Debuggerl Log I Help I

Toolbars:

E ditir ¥ Show Tooltips Mew...

(v Templates Fieset |
[w]Ciebug

[w]*ferzion Control

Tioslbar name;:
Editor

ak. I Cahicel

Figure 6.1: Customize Dialog Toolbars Tab

2 To create anew toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.
2. Click the“New...” button. The dialog shown in figure 6.2 will be displayed.
3. Enter the name of the new toolbar into the “Toolbar name” field.
4. Click “OK” to create the new toolbar.

Mew Toolbar EE3

Taolbar narne:
IM T oolbad
Cahicel |

Figure 6.2: New Toolbar Dialog
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When anew toolbar is created it will appear undocked (i.e. “floating”) and empty.

2 To add buttons to atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Commands’
tab (see figure 6.3).

2. Browse the available buttons by selecting the button categories from the “ Categories’ list. Select a button
from the “Buttons” areato display information on its operation.

3. Click and drag a button from the dialog onto the toolbar.

Customize EE3
Toolbars  Commands | GET] I Debuggerl Log I Help I

Categories: — Buttonz

HE & &+ =@
# Gy | {1 T @

Bookmark z
Templates

Select a cateqary, then click a button to see itz description. Drag the buttan
to any toolbar

Description
lrﬂpen an exizting document

ak. I Cahicel

Figure 6.3: Customize Dialog Commands Tab
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To remove buttons from atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Commands’
tab (see figure 6.3).

2. Click and drag a button from the toolbar onto the “Buttons’ area.
To remove a user defined toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the user-defined toolbar from the “ Toolbars” list, and the “Reset” button in figure 6.1 changes to
the “Delete” button. Then click the “Delete” button.

To reset a standard toolbar back to itsorigina state:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the standard toolbar from the “Toolbars’ list and then click the “Reset” button.

To show or hide toolbar tooltips:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Set the“Show Tooltips’ check box as desired.

To modify the toolbar name of atoolbar created by a user:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Inthe“Toolbars’ list, select atoolbar, which has been created by a user and whose name you, want to
modify.

3. Modify the name of the toolbar in the “Toolbar name” filed.
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6.2

Customizing the Tools Menu

The“Tools" menu can be customized to include your own menu options.

2 Toadd anew menu option:

1

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the“Menu” tab
(see figure 6.4). Thefirst thing for you to decide is whether you are adding a global application wide
tool (“Application widetools.”), which will be available to all of your workspaces. Or whether you wish
to add a workspace wide tool (“Workspace wide tool:”), which isonly valid for the current workspace.
Once you have made the choice choose the relevant section of the dialog.

Customize EE3

Toolbarsl Commands Menu |Debugger| Log I Help I

Application wide tools:

M arme | Wersion |

o,

|

Eemave

Workspace wide tools:
M arme | Wersion | Add...

MEdit.

EEmove

|

ak. | Cahicel |

N o ok w

96

Figure 6.4: Customize Dialog Menu Tab

Click the“Add..."” button (the dialog shown in figure 6.5 will be invoked). If you would like to add an
existing system tool to the menu then select the “ Select from existing system tools” radio button, choose
the tool from the drop-down list and then click “OK”. Alternatively, if you would like to add atool of
your own then follow the remaining steps.

Enter the name of the tool into the “Name” field.

Enter the command, excluding arguments, into the “ Command” field.

Enter any arguments that you would like to pass to the command into the “ Arguments” field.

Enter an initial directory in which you would like the tool to run, into the “Initial directory” field.

Click “OK” to add the menu option to the “ Tools” menu.
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Add Tool

% Define new user bool

— Tool details:

i

Cancel
Hame :
IEr:pInler
Carrnand :
|$MINDIF|]\E:<p|0rer.e:<e Ll ﬁmwse_,_l
Arguments :
| i3
Initial directary :
[$ITEMFDIR] ] Bgowse...l

" Select from existing system tools:

IHitachi Mapwiew [verzion 1.0] j

Figure 6.5: Add Tool Dialog

New menu options are added to the bottom of thelist (i.e. bottom of the tools menu) by default. The order of
menu optionsin the “Tools” menu can aso be modified.

2 To modify amenu option:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).
2. Select the menu option that you would like to modify and then click the “Modify...” button.
3. Make the desired changes on the “Modify Tool” didog (figure 6.6) and then click “OK”.

ModifyT ool HE
= . Cancel |

Command ;

|$[WINDIF|]\E:4|:IDrer.e:<e | 3 | Browse. . |
Argunents

| i3

Initial directary :

[$(TEMPDIR) Ll A |

Figure 6.6: Modify Tool Dialog

2 Toremove amenu option:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).
2. Select the menu option that you would like to remove and then click the “Remove” button.

97
RENESAS




6.3 Configuring the Help System

The High-performance Embedded Workshop provides context sensitive help within the editor window. In other
words, if you select some text in the editor window and then press F1, the High-performance Embedded
Workshop will attempt to locate help on that selected item. The help files, which will be searched, are listed in
the “Help” tab of the “Customize” dialog.

2 Toaddanew helpfile:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Help” tab
(seefigure 6.7).

Customize EE3
Toolbarsl Cnmmandsl GET] I Debuggerl Log Help |
Help files:
D ezcription | File Name Add...
HEemave |
1] | ©
Ciefault help file;
INnne j
ak. I Cahicel |

Figure 6.7: Customize Dialog Help Tab

2. Click the“Add...” button. The “Add Help File” dialog will be displayed (figure 6.8).

3. Enter adescription of the help fileinto the “Title” field.

4. Enter the full path of the help file into the “ Path” field (or browse to it graphically by clicking on the
“Browse...” button).

5. Click “OK" to define the new help file.

Add Help File [ 7] x|

Title:

= Ok,

IF'rogramming inAMSIC 4'
Cancel |

Path:

Ic:'\fileskhelp'\ansi.hlp Browsze. I

Figure 6.8: Add Help File Dialog
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To make a help file the default choice, select it from the “ Default help file” drop-down list or set it to “(None)” if
you would like to be prompted for ahelp file when F1 is pressed.

6.4 Specifying Workspace Options

The High-performance Embedded Workshop allows you to control several aspects of a workspace viathe
“Options’ dialog (figure 6.9). To invokeit select [Tools->Options...], and select the “Workspace” tab.

Options EE3

Buld | Edter ‘Workspace | Confimation |

" ‘Open last workspace at start-up

¥ Eestore files on opening workspace
™ Display workspace information dislog on opening workspace
[ Save workspace befare executing any toals

[ Prompt before saving workspace

Ciefault directomy for new workzpaces;

Crihew? Browse. . |

ak. I Cahicel

Figure 6.9: Options Dialog Wor kspace Tab

The following sections explain the options available on this tab.

6.4.1 Open last workspace at start-up

Set this check box if you would like the High-performance Embedded Workshop to automatically open the last
workspace you opened when it islaunched.

6.4.2 Restore the files on opening wor kspace

When you close aworkspace, the HEW stores, which files were open. When you open a workspace, the HEW
can restore (i.e. open) the same files so that you can continue your session in exactly the same state as when you
left it. If you would like the files associated with a workspace to be opened when you open a workspace then set
this check box.
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6.4.3 Display wor kspace information dialog on opening wor kspace

When many workspaces are being used, it is sometimes difficult to remember exactly what was contained within
each workspace. To help resolve this, the High-performance Embedded Workshop alows you to enter a textual
description of each workspace.

2 To enter aworkspace description:

1. Select the workspace icon from the “ Projects’ tab of the "Workspace” window.

2. Click the right mouse button to invoke the pop-up menu and then select the “ Properties’ option. The
dialog shown in figure 6.10 will be displayed.

3. Enter the description into the “Information” field.

4. Check the “ Show workspace information on workspace open” check box if you want aworkspace
properties dialog to be launched on opening aworkspace. This check box has the same role as the
“Display workspace information dialog on opening workspace” on the “Workspace” tab of the “Options”

dialog.
5. Click “OK” to save the description on the “Information” diaog. Click the “Cancel” button not to save the
description.
Workzpace Properties EHE
Mame: demo
Location: C:hew2hprojectyShdemot.demo. s
Lastmodified:  16:0%58, Thursday, August 16, 2001 Cancel |
CPU farnily: SuperH RISC engine
Tool chain: Hitachi SuperH Standard
Information:
Mo workspace information available ;I

¥ Show workspace information on workspace open

Figure 6.10: Workspace Properties Dialog

When a workspace is opened, the High-performance Embedded Workshop can display thisinformation so that it
is possible to determine whether the workspace is the desired workspace. To display this information on opening
aworkspace, set the “ Display workspace information dialog on opening workspace” check box.

6.4.4 Save wor kspace befor e executing any tools

To force the High-performance Embedded Workshop into saving the current workspace before executing any
build phases (i.e. build, build all or build file operations) or version control commands set the “ Save workspace
before executing any phases’ check box.

6.4.5 Prompt befor e saving wor kspace

In addition to the above check box, set thisto prompt before saving.
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6.4.6 Default directory for new wor kspaces

When anew workspace is created the High-performance Embedded Workshop invokes the “ New Workspace”
dialog. One of the fields on this didog is the directory in which the new workspace will be created. By defaullt,
thisis the root directory. However, if you would like to set this default directory to another location (e.g.
“C:\Workspaces”) then enter the desired directory into the field or browse to it graphically viathe “Browse...”
button.

6.4.7 Prompt before saving session

Checking this option will force the High-performance Embedded Workshop into displaying a prompt before the
session is saved to disk.
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6.5 Using an External Editor

The High-performance Embedded Workshop allows you to use an external editor. Once an external editor has
been specified, it will be launched when the following actions are performed:

Double clicking on afilein the “Projects’ tab of the “Workspace” window.
Double clicking on an entry in the “Navigation” tab of the “Workspace” window.
Double clicking on an error/warning in the “Build” tab of the “ Output” window.
Double clicking on an entry in the“Find in Files’ tab of the “ Output” window.
Selecting the [Open <file>] option from the “Workspace” windows pop-up menu.
Clicking the “Launch Editor” toolbar button.

To specify an external editor:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 6.11).

Build  Editor |Workspace| Confirmationl

— Spacing;

(] Tab size: I 4

¥ Enable auto indentation

— General:
¥ Save files before executing any toals ™ Show files in notebook
™ Prompt befare saving files ¥ Enable spntax coloring
— External editar:

™ Use gxtemal editor;

| i |

ak. I Cancel

Figure 6.11: Options Dialog Editor Tab
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2. Check the “Use external editor” check box.

The “External Editor” dialog will be displayed (figure 6.12).

External Editor

LCommand:
IE:\WINDDWS\Notepad.EHe Browsze... | Ok |

Arguments to open file: Cancel |
i3

|$[FULLFILE]

Arguments to open file at Jine:

|$[FULLFILE] |L|

Figure 6.12: External Editor Dialog

3. Enter the path of the executable (without any arguments) into the “Command” field.

4. Enter the arguments required to open afileinto the “ Arguments to open file” field. Use the $(FULLFILE)
placeholder to represent the path of the file to be opened.

5. Enter the arguments required to open afile at a specific line into the “ Arguments to open file at ling” field.
Use the $(FUL LFILE) placeholder to represent the path of the file to be opened and the $(LINE)
placeholder to represent the line number at which the cursor should beinitially positioned.

6. Click “OK” to define the editor.
Note:  When using an externd editor be aware of the following issues:

« Each time you invoke the external editor, in whichever way, a separate instance of the editor will be launched.
* You must save your own files before you perform abuild file, build or build al operation.

6.6 Customizing File Save

The High-performance Embedded Workshop allows you to customize file save on the “ Editor” tab of the
“Options’ dialog (figure 6.11). To open the tab, select [Tools->Options...] and click the “Editor” tab.

The following sections explain the options related to file save.

6.6.1 Save files befor e executing any tools

To force the High-performance Embedded Workshop into saving edited files before executing any build phases
(i.e. build, build al or build file operations) or version control commands, set the “ Save files before executing
any tools’ check box.

6.6.2 Prompt before saving files

In addition to the above check box, set thisto prompt before saving.
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6.7 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to use another
debugger then you must add it to the “Tools” menu.

The “Debugger” tab of the “ Customize” dialog (figure 6.13) is where the HDI-related information is configured.
Y ou may wish to use an older version of the debugger if certain targets are not currently supported in the new
environment. Invokeit by selecting [T ools->Customize...] and then selecting the “ Debugger” tab.

Toolbarsl Cnmmandsl Menu  Debugger |Lng I Help I

¥ Use external debugger

HO location [W4.0 or greater):

IEZ\HEW'\HD|5'\S|M'\SH'\Hdi.EHE p | Browse. . |

Sezsion file:
|$[I:EINFIGDIFH]'\$[F'FEEIJECTNAME].hds Ll Browse. .. |

Cownload module;

I$[I:EINFIGDIFH]'\$[F'FHEIJECTNAME].ahs{ Ll Browse... |

ak. I Cahicel

Figure 6.13: Customize Dialog Debugger Tab

To use an external debugger, check the “Use external debugger” checkbox and specify the items described below.
There are three items of information, which need to be specified. Firstly, the location of the HDI executable must
be specified. This must be version 4.0 or greater otherwise the behavior is not guaranteed. The second item of
dataisthe session file. Thistells HDI which session to load when it is launched. Finally, the location of the
download moduleis required. This allows the HEW to automatically switch to HDI when the download module

changes after abuild. Click the “Launch External Debugger” toolbar button to invoke HDI with the specified
session file.

After abuild, if the download module has been updated, the HEW will switch back to HDI to enable immediate
debugging. Whilst using HDI, double clicking in any source window will switch back to the HEW with the
source file open at the line which was double clicked.

104
RENESAS



6.8 Using Custom Placeholders

Throughout the High-performance Embedded Workshop the user can use a number of pre-defined placeholders
for directory definitions. For example the user can use the “$(PROJDIR)” variable to signify the current HEW
project directory. This makesit much easier to relocate projects and keep al of the paths correct.

The High-performance Embedded Workshop also has the ability to define custom placeholders. This meansyou
can enter your own custom placeholder definition and decide upon its directory value. Once defined this
placeholder becomes available throughout the rest of the HEW system.

The placeholders can be defined on an application wide level so the placeholders are available to all workspaces
and projects that use the HEW. The other method of defining the placeholders is using the workspace wide
custom placeholders this means the placeholders can only be used in the current workspace. Thislistisonly
available when you have a workspace open.

Customize EHE
Toolbarsl Eommandsl Menuy  Placeholders | Debuggerl Log I Help I

Application wide custom placeholders:

Flaceholder | Directory |

Workspace wide custom placeholders::

Flaceholder | Directory | Add...

()8 | Cancel |

Figure 6.14: Customize Dialog Placeholder Tab

2 To add a custom placeholder:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the
“Placeholders’ tab (figure 6.14).

2. Choose whether you need to use an “Application wide custom placeholder” or “Workspace wide custom
placeholder”. Click “Add” on the adjacent button to the list you require.

3. Thediaog, add “New Custom Placeholder” diaog is displayed. (figure 6.15)

4. Inthefields provided choose a suitable name for the placeholder and a description of what the
placeholder means.

5. Then choose adirectory, which relates to this placeholder. It is possible to use placeholders that are
already defined in this field such as $(PROJDIR).
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Mew Custom Placeholder [ %]
Placehalder:
I Cancel |

Description:

Diirectory:

I Browse... |

Figure 6.14: New Custom Placeholder Dialog

6.9 Using Confirmation Dialog Boxes

The HEW allows users to specify many itemsfor confirmation even in asingle operation. These items are
usually set by default. However, it may be annoying to handle the confirmation dialog boxesif you take the same
operation severa times. Use the [Confirmation] page of the [Options] dialog box to control those confirmation
dialog boxes.

2 Toview the content of [Display confirmation dialogs for]:
1. Select [Tools>Options...]. Then select the “Confirmation” tab (figure 6.16).
2. Itemsto be confirmed are listed in the dialog box.
3. Totoggle acheckmark for an item, select the checkbox on the left of the item’s name.

Build | Editar | Workspace Gonfirmation

— Digplay confirmation dialoes for:

wSplazh Screen = Set All |

(w|Dizplay Welcome dialog
[ |Load Program Clear All |
[ |Unload Program

[ J5ave Memary

whitialize Target

(w|Download modules after build
(w|Load memary

(w]'Werify memary

(wSave memary

(wIFill memary

(v Test memary

w|Delete All Labels

(w|Delete Label

[ ILoading Labels LI

QK. I Cancel

Figure 6.16: Confirmation Page for Optional Dialog Boxes
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7. Version Control

The High-performance Embedded Workshop provides facilities for connecting to a version control tool. Some of
the reasons why version control tools are used with a project are:

* To maintain theintegrity of aproject.
* To store each stage of a project.
* Toenabledifferent users to co-develop a project by controlling revisionsto its source files.

Figure 7.1 illustrates atypica project where aversion control system isin use. This shows three users who al
use the same-shared network drive to exchange source code. The version control system provides access and
updates to the source files.

NETWORK

Figure 7.1: Version Control
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7.1 Selecting a Version Control System

Initialy, the version control sub-menu will appear as shown in figure 7.2. At thistime only the [Version
Control->Select...] option is available because aversion control systemis not yet active for the current
workspace.

1
_| Administration. . vlﬂl T J

[Ehatae iaE chaT Ve,

Select. .
Customize... [EOmfiEuTE..
Options... [ EadFTES]
Yol [ il
)1 CanmotExterma Mebuggen.. [% _emolve fiels]
S NER ]
Format Wiews. .. # [Ehenk Wt EleE]

= ChecklhFile(s)
(&) Stafus of Filels]

Figure 7.2: Version Control Sub-Menu

2 To select aversion control system:
1. Select [Version Control->Select...]. The diaog shown in figure 7.3 will be displayed. Thisdialog lists
all of the supported version control systems.
2. Select the desired version control system from the “Version control systems’ list and click the “ Select”
button. The “Current version control system” is changed to reflect the new selection.
3. Click the“OK” button to confirm the selection.

Select Yersion Control System

Werzion control systems; ak
Customn YES

Cancel

Select

adil

Current verzion control system:

Mone

Figure 7.3: Select Version Control System Dialog
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Note:  Only those version control systems which have been installed with the HEW will appear in the “ Select
Version Control System” dialog (figure 7.3).

Once aversion control tool is selected you will notice that the [Version Control->Configure...] option has now
become available.

The next chapter discusses the usage of the custom version control system.
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8.  Using the Custom Version Control System

The custom version control system is a configurable addition to the High-performance Embedded Workshop,
which allows you to connect to aversion control system aready installed on your machine. To clarify further,
the High-performance Embedded Workshop does not provide a version control tool itself, only a means by
which you can integrate the version control system, which you use into your workspaces and projects.

8.1 Defining Version Control Menu Options

The custom version control system allows you to invoke a version control command either by selecting an
option from the [Tools-> Version Control] sub-menu or by clicking a version control toolbar button. When
either of these actions are performed, the associated commands are executed and the output is displayed in the
“Version Control” tab of the “Output” window.

2 To execute aversion control menu option or toolbar button:

1. Select whichever items you would like to apply the version control command to from the “Workspace”
window. This may include a workspace, project(s), folder(s) and file(s). When the command is selected,
all of the files will be extracted from the selected items and passed, in turn, to the version control
command. For example, if you select the workspace icon then all of thefilesin all of the projects will be
passed, in turn, to the version control command. Thiswill include any system files. For exampleif you
select the project item then

2. Select the required menu option from the [Tools->Version Control] sub-menu or click the desired
version control toolbar button.

The custom version control support allows you the most flexibility in specifying how aversion control systemis
to be used. To configureit, select [Version Control->Configure...]. The“Version Control Setup” dialog will be
displayed (figure 8.1).
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Yersion Control Setup EHE

Commatds l F'miecls] General]

System menu options and toolbar buttons
Rt mmm——
Check In File(s
Check Out File(s)
Get File(s)
Remove Filgls)
Status of File(s)

:

Modify...

User menu options

1L

0K, I Cancel ‘ Expott... | Impeort... | .

Figure 8.1: Version Control Setup Dialog Commands Tab
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The“Commands’ tab contains two lists of menu options. The first list, “ System menu options and toolbar
buttons’, represents those menu options which always appear on the version control sub-menu. These menu
options also have an associated toolbar button on the version control toolbar. The second list, “User menu

options”, represents those additional user defined options which are added to the bottom of the version control

sub-menu. Figure 8.2 shows the structure of the version control sub-menu.

(@) =t

Histary of Filels)
Unda Check out of Filels)

Syaterm
Defined
Cipticn

User
Diefined
Cipticn

Figure 8.2: Version Control Sub-Menu

811 System Menu Optionsand Toolbar Buttons

In order to invoke commands from the toolbar or the system defined options of the [Tools->Version Control]
sub-menu, you must first define the associated commands that should be executed when they are activated. The

names of the options and their intended action are listed in table 8.1.

Table8.1: System Menu Option

Option Description

Add File(s) Add selected file(s) to version control system.

Remove File(s) Remove selected file(s) from version control system.

Get File(s) Get a read only local copy of the selected file(s) from version control system.

Check In File(s) Put back, i.e. update, the selected file(s) in version control system with the
local copy.

Check Out File(s)  Get a writable local copy of the selected file(s) from version control system.

Status of File(s) View the status of the selected file(s).

2 To modify asystem menu/ toolbar option:

1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.

2. Select the option to be modified from the “ System menu options and toolbar buttons” list and then click

the “Madify...” button. The dialog shown in figure 8.3 will be displayed. This figure shows a dialog

when “Add File(s)” has been selected for example.

3. Commands are added viathe “Add...” button. See the section, “ Defining Version Control Commands”,

later in this chapter for further information.

4. Closethe “Define Command for “<command>"" dialog by clicking “OK".

5. Closethe“Version Control Setup” dialog by clicking “OK”.
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Define Commands for “Add File[s]"

Commands

dd
Tt
HEemayve

I e

LLLERE

Fal w2 e

114

Figure 8.3: Modify System Menu Option (Example)
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812

User menu options

Y ou can create as many user defined menu options as you like, name them how you want and define their order

in the menu. User defined menu options do not appear on the version control toolbar.

2 To create anew version control menu option:
Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

1.
2
3.
4. Commands are added to the menu option viathe “Add...” button. See the section, “ Defining Version

o

. Click the*Add..” button. The dialog shown in figure 8.4 will be displayed.

Enter the name of the menu option into the “Option” field.

Control Commands”, later in this chapter for further information.
Close the “Add Menu Option” dialog by clicking “OK”.
Close the “Version Control Setup” dialog by clicking “OK”.

Add Menu Option

Diption ;

IMprlion

LCorrmands:

Cancel

Tt
HEemayve
I e

Fal w2 e

L LLAE]

Figure 8.4: Add Menu Option Dialog
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2 Toremove an existing version control menu option:

1.
2.

3.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

Select the menu option to be removed from the “User menu options” list and then click the “Remove”
button.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To modify an existing version control menu option:

1
2.

3.
4.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

Select the menu option to be modified from the “User menu options” list and then click the “Modify...”
button beside the list. The dialog shown in figure 8.4 will be displayed. (Thetitle of the dialog is“Modify
Menu Option™.)

Modify the commands as necessary and then click “OK”.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To change the ordering of version control menu options:

1.
2.

116

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
Select the menu option to be moved and then click the “Move up” and “Move down” buttons as
necessary.

Close the “Version Control Setup” dialog by clicking “OK”.
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8.2 Defining Version Control Commands

Commands are defined when the“Add...” or “Modify..."” buttons are clicked on the dialogs shown in figure 8.3
and figure 8.4. In either case, the dialog shown in figure 8.5 isinvoked.

Add Command EE3

— Command ;

- |
Wergion control executable ; 4|
IVI'\VSS'\W|N32\SS.BHE Browse...

— Cancel |

Arguments
IHistory $[YCOIR)HFILENAME] Y $USERNAME), $(PASS ﬂ

Initial directony ;

[$FILEDIF] P Bowse. |

— Executable return code

&' Return code of executable is not meaningful

" Command has failed if the retun code is 1ot Equal To ﬂ ID

Figure 8.5: Add/Modify Command Dialog

2 To define acommand:
1. Enter thefull path of the command into the “Version control executable” field or browse to it graphically
by clicking the “Browse...” button.
2. Enter the arguments for the command into the “ Arguments” field.
3. Enter theinitial directory in which you would like to run the executable from into the “Initial directory”
field or browse to it graphically by clicking the “Browse...” button. In most cases this should be set to the
“$(FILEDIR)" placeholder, i.e. execute the command from the same directory asthe file.

4. Set the “Executable return code” options as described in the following section.
5. Click “OK” to define the new command.

821 Executablereturn code

If the return code of the command(s) can be used to indicate a failure then you should select the “Command has
failed if the return codeis’ option and set the two fields to the right as required.

If the “Command has failed if the return codeis’ option is selected then the HEW will check the return code of
each command to determine whether a failure occurred. If so, no further commands will be executed and any
other processes which would follow the commands (e.g. build) will not be executed.

If the “Return code of tool is not meaningful” option is selected then the HEW will not check the return code of
each. Consequently, all commands will execute regardless.
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8.3 Specifying Arguments

It is obvious that arguments must be specified correctly, otherwise the version control tool executed will not
function as intended. However, it is aso important, when using custom version control support, to specify the
argumentsin aflexible way as a single version control command can be applied to more than one file. To
facilitate this, the “Arguments’ field has a placeholder button (refer to appendix C, “Placeholders’, for anin
depth discussion of placeholders) which, when clicked on, invokes a pop-up menu of available placeholders
(figure 8.6). An explanation of each placeholder and how their values are derived can be found in table 8.2,
Arguments Field Placeholders.

l User login name
User login password
“ersion control directory
Camment
File path + name
Filename
File leaf
File extension
File directory
Configuration directory
Project directory
Workspace directory
Temp directory
Command directory
Windows directory
Windows system directory
Workspace name
Project name

Configuration name

Figure 8.6: Arguments Field Placeholder Pop-up Menu
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Table8.2: Arguments Field Placeholders

Placeholder Value and How its Determined

User login name Current user login (“General” tab)

User login password Current user password (“General” tab)

Version control directory “Virtual” version control mapping (“Projects” tab)
Comment Comment specified before command execution
File path + name Full path and name of file involved in operation
Filename Filename (including extension) of file involved
File leaf Filename (excluding extension) of file involved
File extension Extension of file involved in operation

File directory Directory of file involved in operation
Configuration directory Current configuration directory

Project directory Current project directory

Workspace directory Current workspace directory

Temp directory Temporary directory

Command directory Version control executable directory

Windows directory Directory where Windows® is installed
Windows system directory Directory where Windows® system files exist
Workspace name Current workspace name

Project name Current project name

Configuration name Current configuration name

8.3.1 Specifying File L ocations

When referring to afile’ slocation, be sure to use a placeholder, otherwise the command will only relateto a
hardwired file. For example, let’simagine that a version control executable has been selected which usesa—-GET
command to obtain aread only copy of afile. The “Arguments’ field could be specified as:

-GET “c:\vc\files\project\main.c”

However, when executed, this command can only ever get the file MAIN.C. To resolve this problem, HEW uses
a system of placeholders and directory mappings. The latter tell the HEW which “working” directories (i.e.
where source files are being worked on) map to which “controlled” directories (i.e. where the sourcefiles are
stored in the version control system). Mappings between these two directory systems can be specified via the
“Projects’ tab of the " Version Control Setup” dialog (figure 8.7).
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Yerzion Control Setup

Commands  Frojects |Genera||

Shove details Far project : I Frojecti j

— Details ;

Yergion control directorny mappings ©

Source Directory | Werzion Control Directany Add...
c:wwark happlicationhprojectl = wchawhapphproject]
o mark happlicationhsrc whvwchawhapphan b iy, |
o hwork hahared whwch ot zhared —
HEemayve |
N I -1
Enwironment :
Add..
el it

EEmmvE

f

ok I Cancel Ewpont... Import. ..

Figure 8.7: Version Control Setup Dialog Projects Tab

2 To define anew mapping:

1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, and the dia og shown in figure 8.7 will be displayed.
2. Click the“Add...” button that is next to the “Version control directory mappings’ list. The dialog shown
in figure 8.8 will be displayed.
3. Enter the source (i.e. “working”) directory into the “ Source directory” field or browse to it graphically by
clicking the “Browse...” button.
4. Enter theversion control directory (i.e. “controlled”) directory into the “Version control directory”.
Yerzion Control Directory Mapping 2 | x|
Source directary : ak.
Ic:'\work'\shared ﬂ Browse... I Cancel |
Yerzion control directon ©
I:-:Z wechawhshared
Figure 8.8: Version Control Directory Mapping Dialog
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2 To modify an existing mapping:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be modified from the “Version control directory mappings’ list and then click the
“Modify...” button. The dialog shown in figure 8.8 will be displayed.
3. Make the necessary changes to the two directories and then click “OK” to confirm the edits.
2 To remove an existing mapping:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be removed from the “Version control directory mappings’ list and then click the
“Remove’ button.

Once the mappings have been defined you can use the “Version control directory” placeholder, $(VCDIR), to
represent the directory in which the project file is stored. Consider the scenario shown in figure 8.9. Here are
three directories, which are mapped from a shared version control drive (X:\) to alocal drive where the
development is being done (C:\).

LOCAL - C:\

Mapped To

NETWORK - X:\

E:

C:\work\application\projectl

iy

=

X:\vc\sw\app\projectl

Bl

C:\work\application\src

=

X:\ve\sw\app\src

E:

C:\work\shared X:\vc\sw\shared

Figure 8.9: Example Mappings

Now let’simagine that a version control executable has been selected which uses a—GET command to obtain a
read only copy of afile. In order to get dl of the filesin a project we need to use the following command:

- GET “$(VCDI R)\ $( FI LENAVE) "

When the HEW executes the command for a given project file, it will replace $(VCDIR) for the equivalent
version control directory in the file mapping.

For example, suppose FILEL.C islocated at:
c:\work\application\projecti\filel.c
If the get command is applied to FILEL.C then:

(2) X:\ve\sw\app\projectl is substituted for $(VCDIR) as thisis the version control directory mapping for
c:\work\application\projectl.
(2) FILEL.C is substituted for $(FILENAME).
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Project File: C:\work\application\projectl \ filel.c

Arguments: $(VCDIR) \ $(FI LENAVE)

@ )

Command: X:\vc\swapp\projectl \ filel.c

Figure 8.10: Example of Substitution

8.3.2 Specifying Environment
Select the “Projects’ tab of the “Version Control Setup” dialog to view the current settings (figure 8.7).

To add a new environment variable click the “Add...” button beside the “Environment” list (the dialog shown in
Figure will beinvoked). Enter the variable nameinto the “Variable” field, the variable’s value into the “Vaue’
field and then click “OK” to add the new variable to the “Environment” list.

Environment ¥ariable

iT'analgIe : 0
Cahicel

Walle —l
> | Placeholder

I | POpUR MEny

HH
X

Figure 8.11: Environment Variable Dialog

To modify an environment variable, select the variable that you want to modify from the “ Environment” list and
then click the “Modify...” button beside it. Make the required changes to the “Variable” and “Vaue’ fields and
then click “OK” to add the modified variable back to the list. To remove an environment variable, select the
variable that you want to remove from the “ Environment” list and then click the “Remove” button beside it.
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8.3.3 Specifying Comments

If acommand contains the placeholder “ S(COMMENT)” then the HEW will request that you enter the comment
when the command is executed (viathe dialog as shown in figure 8.12).

Please Enter Comment EE3

File: c:\hewtdemohdemohsbrlk. c

Cancel |
Comment

[ Apply comment to al files

Figure 8.12: Please Enter Comment Dialog

Y ou may specify acomment for each file or, if you would like to specify the same comment for al files, check
the “Apply comment to al files’ check box before clicking “OK”.
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8.34

Specifying a User Name and Password

Most version control toolswill require you to pass a user name and password on the command linein order to
keep files secure and to keep a record of which files were changed by which users. The custom version control
support provides two placeholders “ User login name”, $(USERNAME), and “User login password”,
$(PASSWORD). When the command is executed, these placeholders will be replaced with the current settingsin
the “General” tab of the “Version Control Setup” dialog (figure 8.13).

Yersion Control Setup

Eommandsl Projects General |

— Execution :

¥ Prompt before executing command
[ Bunin DOS ‘Window

[ Use forward slash ' as version control directory delimiter

— Usger details :

Uzer: JHAREK,

s

Password ;

— Configuration file:
Current verzion contral configuration file:

C:AHew Project1WCustomy 25 hve

ok Cancel Ewpont...

Import. ..
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Figure 8.13: Version Control Setup Dialog General Tab
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In order to give the 3(USERNAME) and $(PASSWORD) fields avalue you will first need to login. If you have
not logged in before a command is executed which uses either of these placeholders then you will be prompted
to do so before the command can be executed.

2 Tologin (i.e. specify auser name and password):

1

g s~ wDN

Click the“Login...” button. The dialog shown in figure 8.14 will be displayed.

Enter your user name into the “User name” field.

Enter your password into the “Password” field.

Re-type your password again into the “ Confirm password by retyping it below” field.

Click “OK” to set the new user name and password. If there is any inconsistency between the two
versions of the password which you entered then you will be requested to type your password again.

Uzer name : ok I
JHARE,
I Cancel |

Pazsword

Ixmmmm

Confirm password by retyping it belov

Figure8.14: Login Dialog
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84 Controlling Execution

The “Genera” tab of the“Version Control Setup” dialog (figure 8.13) allows you to control the way in which
the version control tool is executed. It also shows the full path to the current version control configuration file.

8.4.1 Prompt befor e executing command

If this check box is set then, before any version control commands are executed, adialog is displayed (figure
8.15) which lists al of thefilesinvolved in the operation. Files may be deselected by clearing the associated
check box. Clicking “OK” will apply the command to each of the selected files. Clicking “Cancel” will abort the
operation.

History [ 7] x|

Filez

widemo.c  [c:hhewidemohdemao)

(wzbrk.c [z:\hewhdema'.demo] Cancel |
(v vectthl zrc [o:hhewdemohdemao)

KN — Il

Figure 8.15: Command Prompt Dialog (Example)

8.4.2 Run in DOS Window

By default, the output of the version control commandsiis redirected to the “Version Control” tab of the “Output”
window. If you would rather run each command in a separate DOS window then set this check box.

8.4.3 Useforward slash ‘/" asversion control directory delimiter

By default, when the HEW substitutes the placeholder $(V CDIR) it uses the backward slash character ‘\" to
divide directories. However, if the version control system you are using uses a forward slash character (e.g.
Visua SourceSafe) to divide directories then set the “Use forward slash */* as version control directory
delimiter”.

85 Importing and Exporting a Set-up

Each workspace can have a different version control set-up. The HEW allows you to store the version control
settings independently so that you can import them into other workspaces. This greatly reduces the amount of
timeit takes to configure the same version control settings across several workspaces.

2 To export aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Click the“Export..." button. A standard file save dialog will be displayed. Browse to the directory in
which you would like to save the configuration.

3. Enter the name of the file and then click “OK”.
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2 Toimport aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Click the“Import..."” button. A standard file open dialog will be displayed. Browse to the * .HVC file
which you would like to import.

3. Sdect thefile and then click “OK”.
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9. Using Visual SourceSafe

The High-performance Embedded Workshop provides specific support for the Visua SourceSafe version control
system. At the time of writing, the HEW can only attach to versions 5 and 6 of Visua SourceSafe.

The Visua SourceSafe version control system associates a project in your workspace with aproject inside a
Visual SourceSafe database. It alows you to quickly invoke the standard commands either by selecting an option
from the [T ools->Version Control] sub-menu or by clicking aversion control toolbar button.

9.1 Attaching Visual SourceSafeto a Workspace

The following sections describe how you can associate Visua SourceSafe with your current workspace.

9.11 Selecting Visual SourceSafe
First, you need to select Visual SourceSafe as the version control system.

2 TouseVisua SourceSafe 5.0 or 6.0:

1. Select [Tools->Version Control->Select...]. The“Select Version Control System” dialog will be
displayed (figure 7.3) which lists al of the supported version control systems.

2. Select the“Visua SourceSafe 5.0/6.0” entry from the Version Control Systems list and click the “ Select”
button.

3. Click “OK" to confirm the selection. The SourceSafe Login dialog is displayed (figure 9.1).

4. Enter your Visual SourceSafe login into “Username” and password into “ Password”.

5. Enter into Database path the full path to the Visual SourceSafe database (i.e. SRCSAFE.INI) into which
you would like to add this project.

6. Click “OK". The “Create SourceSafe Project” didog isinvoked (figure 9.2).

7. The“Project name” field displays the name of the project (i.e. folder) to be created in the database. If
necessary you can change this name to another.

8. Thetree underneath the “ Project name” field shows the structure of the database specified in step 6.
Select the folder into which you would like to create the folder specified in the “Project name” field.

9. Click “OK".

10. HEW will require you to repeat steps 7-9 for as many projects as are present in the current workspace.

SourceSafe Login EHE

Uzernarne: I
Password: I ﬂl

Latabaze path: I Browsze. . |

Figure 9.1: SourceSafe L ogin Dialog
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Create SourceSafe Project

PBroject name: ] i
Iprniect

Cahicel |
$/project

-

||

Figure 9.2: Create Sour ceSafe Project

The HEW has now created the necessary projects within Visual SourceSafe and sets-up the version control
toolbar and menu for immediate access. However, although the Visual SourceSafe projects themselves have
been created, no files have been added to them.

9.1.2 Adding filesto Visual SourceSafe

The previous section has only established the mappings between the project directory on your hard disk (i.e. the
working directory) and the project directory in Visual SourceSafe (i.e. the controlled directory). Although the
project directory (and any subdirectories) on your hard disk may contain many source files whereas the directly
its mapped to in Visua SourceSafe will beinitially empty.

Firstly, you must select Visual SourceSafe as the version control system.

2 Toaddafileor filesto Visua SourceSafe:

1. Select thefile(s), which you would like to add to Visua SourceSafe. You may also select afile folder,
project folder, aworkspace folder or combination thereof. When selecting the project or workspace
folder then the system files will be added to the selected filelist. For example, selecting the project folder
will also add the project file to thefilelist. If the project fileis then checked out and the version is newer
than when it was last |oaded you will be asked whether you want to reload the project.

4. Click the Add Files toolbar button ( @?) or select the [Tools->Version Control->Add Files] menu
option.

When you add filesto Visual SourceSafe the local versionsin your working directory will become read only. To
check that the add files operation was carried out as you expected, or to quickly review the status of all of the
filesin aproject:

1. Select the poject folder whose files you want to check.

2. Click the Status of Filestoolbar button ( (&) ) or select the [T ools->Version Control->Status of Files]
menu option.

3. Thestatus of each file will be displayed in the “Version Control” tab of the “Output” window. The
information shown includes whether the file is added to the project, if the file is checked out and, if it is
checked out, who did so.
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9.2 Visual SourceSafe Commands
The following 8 operations are available:

* Add afileto version control

* Remove afile from version control

» Getaread only copy of afileor files

» Check out aread/write copy of afileor files (i.e. for editing)

e Check inapreviously checked out file or files (i.e. update Visual SourceSafe with the edits made)
» Undo apreviously check out operation on afile or files (i.e. cancel any edits made)*

* View the status of afile

* View the history of afile*

*These commands can only be accessed viathe [Tools->Version Control] sub-menu whereas all of the other
commands can be accessed from both the toolbar and menu.

921 Removing a File from Version Control

Although files appear in your HEW project (in the “ Projects’ tab of the “Workspace” window, Visua
SourceSafe is not necessarily controlling them.

2 Toremoveafileor filesfrom Visua SourceSafe:
1. Select thefile(s), which you would like to remove from Visual SourceSafe. Y ou may aso select afile
folder, project folder, a workspace folder or combination thereof.
2. Click the Remove Files toolbar button ( @- ) or select the [Tools->Version Control->Remove Files]
menu option.

922 Getting a Read Only Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. However, it is possible for any user to obtain aread only copy of any file.

2 Toget aread only copy of afileor files from Visual SourceSafe:
1. Select the file(s), which you would like to get from Visua SourceSafe. Y ou may also select afile folder,
project folder, a workspace folder or combination thereof.
2. Click the Get Filestoolbar button ( % ) or select the [Tools->Version Control->Get Files] menu
option.

923 Checking Out a Writable Copy of a File from Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes a writable copy of the file from Visua SourceSafe
and placesit on your local drive. Thiscan only be done if another user does not already check out the file or files
in question.

2 To check out awritable copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to check out from Visua SourceSafe. You may also select afile
folder, project folder, a workspace folder or combination thereof.

2. Click the Check Out Filestoolbar button ( 5 ) or select the [Tools->Version Control->Check Out
Files] menu option.
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9.24 Checking In a Writable Copy of a Fileinto Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users.

2 Tocheck in editsmadeto afileor filesin Visua SourceSafe:
1. Select the file(s) upon which you would like to check back into Visual SourceSafe. You may also select a
file folder, project folder, a workspace folder or combination thereof.

2. Click the Check In Filestoolbar button ( 2 ) or select the [Tools->Version Control->Check In] menu
option.

9.25 Undoing a Check Out Operation

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of the file from Visual SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users. However, if the check out operation was carried out by mistake, or perhaps
isno longer required, then the operation can be undone.

2 Toundo acheck out of afile or files from Visua SourceSafe:

1. Select the file(s) upon which you would like to undo a previous check out operation. Y ou may also select
afilefolder, project folder, a workspace folder or combination thereof.

2. Select the [Tools->Version Control->Undo Check Out] menu option.

9.2.6 Viewing the Status of a File

Although files appear in your HEW project (in the Projects tab of the Workspace window), Visua SourceSafeis
not necessarily controlling them. Of those files, which are being controlled by Visua SourceSafe, some will be
checked in and others will be checked out (i.e. being edited by a user). The status command displays the current
status of afile or file(s).

2 Toview the status of afileor filesin Visua SourceSafe:
1. Select the file(s) whose status you would like to view. You may also select afile folder, project folder, a
workspace folder or combination thereof.

2. Click the Status of Filestoolbar button ( @. ) or select the [Tools->Version Control->Status of Files]
menu option.

9.2.7 Viewing the History of a File

Visual SourceSafe controlsthe edits to the filesin its projects and allows you to view the complete history of
these edits right back to the time that the file was first added to the project.

2 Toview the history of afileor filesin Visual SourceSafe:
1. Select the file(s) whose history you would like to view. You may also select afile folder, project folder, a
workspace folder or combination thereof.
2. Select the [T ools->Version Control->Show History] menu option.
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9.3 Visual SourceSafe Integration Options

You can control the way in which the history and status commands are displayed by selecting [Tools->Version
Control->Configure...].

To display the results of ahistory command in adialog box then check the “Display dialog box for history”
check box or clear it if you would rather display the output in the “Version Control” tab of the “Output” window.
To display the results of a status command in adialog box then check the “Display dialog box for file status”
check box or clear it if you would rather display the output in the “Version Control” tab of the “Output” window.
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Emulator Debugger Part
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Sectionl Overview

11 Features

The breakpoint, memory map, performance, and trace can be set through the dia og box.
O Intuitive user interface

0 Online help

O Common display and operability

Supported host interfaces

The PCI interface, PC card (PCMCIA) interface, USB interface, or LAN interface can be used for connecting
to the host computer.

Realtime emulation

Realtime emulation of the user system is enabled at the maximum operating frequency of the CPU.
Excellent operability

Using the HEW enables user program debugging using a pointing device such asamouse. The HEW
enables high-speed downloading of load module files.

Various debugging functions

Various break and trace functions enable efficient debugging. Breakpoints and break conditions can be set
by the specific window, trace information can be displayed on a window, and command-line functions can be
used.

Memory access during emulation
During emulation, the memory contents can be read and modified.
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12 Warnings

CAUTION

READ the following warnings before using the emulator product.
Incorrect operation will damage the user system and the emulator
product. The USER PROGRAM will be LOST.

1. Check al components against the component list after unpacking the emulator.

2. Never place heavy objects on the casing.

3. Do not place the emulator in places where:

»  The temperature becomes high such asin direct sunlight or near a heater. For details, refer to section 1.3,
Environmental Conditions.

*  Thetemperature or humidity changes greatly.

* Thereisalot of dust.

* Thereisalot of vibration. For details, refer to section 1.3, Environmental Conditions.

Protect the emulator from excessive impacts and stresses.

Only supply the specified voltage and power-supply frequency.

When moving the emulator, take care not to vibrate or damage it.

After connecting the cable, check that it is connected correctly. For details, refer to section 2, Preparation

before Use. Supply power to the connected equipment after connecting al cables. For the supplying

procedures, refer to section 2.7, System Check. Cables must not be connected or disconnected while the

power ison.

N o ok~
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1.3 Environmental Conditions

CAUTION

Failure to do so will cause illegal operation in the user system, the
emulator product, and the user program.

Observe the conditions listed in table 1.1 when using the emulator.

Table1.1 Environmental Conditions

Item Specifications

Temperature Operating: +10°C to +35°C
Storage: —10°C to +50°C

Humidity Operating: 35% RH to 80% RH, no condensation
Storage:  35% RH to 80% RH, no condensation
Vibration Operating: 2.45 m/s* max.
Storage: 4.9 m/s’ max.

Transportation: 14.7 m/s’ max.
Ambient gases  No corrosive gases may be present

1.4 Emulator External Dimensions and M ass

Table1.2 Emulator External Dimensions and Mass

Item Specifications
Dimensions 219 x 170 x 54 mm
Mass 1,000 g

RENESAS

137



138
RENESAS



Section 2 Preparation before Use

21 Emulator Preparation

Unpack the emulator and prepare it for use as follows:

A WARNING

READ the reference sections shaded in figure 2.1 before using the
emulator product. Incorrect operation will damage the user system and
the emulator product. The USER PROGRAM will be LOST.

Reference

Unpack the emulator Component list
I

Check the components against
the component list

Setup

Section 3
Set up the emulator

- Insert the optional board
- Install the HEW
- Connect the interface cable

Turn on the user system Section 4
(Only when the user system is connected)

Turn on the emulator Activation
I

Start the HEW

Figure2.1 Emulator Preparation Flowchart

22 Installing Emulator’s Software

Toinstall the HDI, refer to the Setup Guide for the E6000 Emulator supplied together with the emulator.
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2.3 Connecting to the User System
To connect the emulator to a user system, proceed as follows:

» Connect the user system interface cable head to the user system.
* Plug the cable body into the emulator.
» Plug the cable body into the cable head.

For details of these steps, refer to the User System Interface Cable User's Manual.

Figure 2.2 gives details of the connectors provided on the emulator.

E6000 <« PC interface cable

connector
User system P\\_/\

interface connector

I <— Power connector

External probe ——> <~ Power switch
connector \/'f \/F
Screw Screw

Figure2.2 E6000 Emulator Connectors

231 Example of Connecting the User System Interface Cable Head to the User System

Screw (x 4)

RN
g

] User system interface
| cable head

Figure2.3 Example of Connecting User System I nterface Cable Head to User System

» Ensurethat al power isoff to the emulator and the user system.
* Insert the cable head into the socket on the user system.

Note:  Depending upon the package, it may be possible to orientate this cable head in any position on the socket,
so care should be taken to correctly identify pin 1 on the emulator and socket when installing.
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Screw the cable head to the socket with the screws provided. Progressively tighten the screwsin the sequence
shown in figure 2.4 until al are ‘finger tight'.

© 06

<1

® @

Figure2.4 Sequence of Screw Tightening

Note:  Be careful not to over-tighten the screws as this may result in contact failure on the user system or

damage the cable head. Where provided, use the ‘solder lugs' on the QFP socket to provide extra
strength to the emulator/user system connection.

232 Plugging the User System I nterface Cable Body into the Emulator

Plug the cable body into the emulator, taking care to insert it straight, and push it firmly into place.

User system interface cable body

User system interface cable head

\/ : Emulator

User system interface cable

Figure2.5 Plugging User System Interface Cable Body to Emulator

233 Plugging the User System I nterface Cable Body into the Cable Head

Plug the cable body into the cable head on the user system.
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24 Power Supply

241 AC Adapter

The AC adapter supplied with the emulator must be used at all times.

242 Polarity

Figure 2.6 shows the polarity of the power-supply plug.

5V (outside)

GND (inside)

Figure2.6 Polarity of Power Supply Plug

243 Power Supply Monitor Circuit

The emulator incorporates a power supply monitor circuit which only lights the red LED when a voltage higher
than 4.75 V is supplied. If this LED isnot illuminated, you should check the emulator voltage level. An input
voltage less than 4.75 V could indicate that enough current cannot be supplied to the emulator.

Note:  Use the provided AC adapter for the emulator.

25 SIMM Memory Module

E6000 emulator’ s optional SIMM memory modules are available which provide emul ation memory for user
code without needing a user system. The optional SIMM memory modules are available in different memory
size, but all are partitioned into four equal banks. These banks can be relocated on page boundaries anywherein
the user area. Note that, however, some products do not support the SIMM memory module.

251 Optional SIMM Memory Module Configuration

The configuration of the optional SIMM memory module is controlled by the mapping RAM. Opening the
[Memory] sheet of the [System Status] window allows you to check which optional SIMM memory module, if
any, isinstaled and aso alows the four banks to be relocated to the required addresses from the [Memory
Mapping] dialog box.
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2.6 Hardwar e Interface

All signds are directly connected to the MCU in the emulator with no buffering with the exception of those
listed in section 7, Hardware Specifications Specific to This Product.

26.1 Signal Protection on the emulator
All signals are over/under voltage protected by use of diode arrays. The only exceptions being the AV and Vref.
All ports have pull-up resistors except for analog port.

All V. pins on the cable head assembly are connected together (with the exception of the AV pin), and are
then monitored by the emulator to detect powered user system presence.

26.2 User System Interface Circuits

The interface circuit between the MCU in the emulator and the user system has a signal delay of about 8 nsdue
to the user system interface cable and it includes pull-up resistors. Therefore, high-impedance signalswill be
pulled up to the high level. When connecting the emulator to a user system, adjust the user system to compensate
for propagation delays.

The following diagrams show the equivalent circuit examples of theinterface signals. Theinterface circuits
depend on the MCU type. For details, refer to section 7, Hardware Specifications Specific to This Product.

26.3 Clock Oscillator

The oscillator circuit has been implemented on the user system interface cable head. For details on the oscillator
circuit, refer to the user's manual for each user system interface cable.

26.4 External Probe 1 (EXT1)/Trigger Output

An 8-pin connector, marked EXT1 (on the right under the user system interface cable connector), on the
emulator case accommodates four external probe inputs and two trigger outputs. The pin assignment of this
connector isshown in figure 2.7.

OO0OO0O0OOO | exn
|| |
1 I

|
I
3

GND| GND |
Tuvcc Tsv
Probe Trigger output

Figure2.7 External Probe Connector 1
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Theinterface circuit for the external probe 1 isshown in figure 2.8.

Vce
10 kQ
HD151015 External probe 1, 2, 3, 4

22 Q

Figure2.8 Interface Circuit for External Probe 1

The trigger output is controlled by event channel 8 and is an active low signal. The trigger output is available as
either T5V (within the range from 2.5V to 5 V; does not depend on the user V. level) or TUV . (the user V
level).

The trigger output is an active low signal which is output during 1 bus cycle when a condition of the event
channel 8 is satisfied.

265 External Probe 2 (EXT2)/Trigger Output

A 6-pin connector, marked EXT2 (on the left under the user system interface cable connector), on the emulator
case accommodates four trigger outputs. The pin assignment of this connector is shown in figure 2.9.

000000 |ex
e

Trigger output

Figure2.9 External Probe 2 Connector

Thetrigger output is an active high signal which is output during the read or write cycles when a trace condition
(1 to 4) of the bus monitor function is satisfied. The trigger output is available asuser V. level. Note that,
however, some products do not support the external probe 2 (EXT2).
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2.6.6 Voltage Follower Circuit

CAUTION

1. Do not connect the user system interface cable to the emulator
without user system connection.
2. Turn on the user system before starting up the emulator.

A voltage follower circuit isimplemented on the emulator which allows the user system voltage level from the
user system to be monitored. This monitored voltage level is automatically supplied to the logic on the emulator
and is derived from the emulator power supply unit. This means that no power is taken from the user system
board.

If no user system interface cable is connected to the emulator, the emulator will operate at a specified voltage
and all clock frequencies will be available to the user. If the user system interface cable is attached, the emulator
will match the voltage supplied to the user target in all cases; i.e. even when the user V. is below the operating
voltage for the MCU. You must be careful not to select an invalid clock frequency. When the emulator is
connected to the user system and the user system is turned off, the voltage follower circuit output voltage level is
0 V. Inthis case, the emulator will not operate correctly.

You can set auser V. threshold in the range Vcc max. — 0 V by using the emulator configuration dialog box. If
the user V. drops below thisthreshold, [User System Voltage] in the [Extended Monitor] window will display
Down, otherwise OK is displayed.

threshold

User Vcc level

User Vcc oK — ... oo
threshold | |

Down - - - - - - -

3.3V

E6000
Vcc level

The user system interface
cable is not connected.

Figure2.10 VoltageLevel Monitoring (Examplefor Vcc =3.3V)

145
RENESAS




2.7 System Check

When the software is executed, use the procedure below to check that the emulator is connected correctly. Here,
use the workspace for a tutorial provided on the product.

Refer to section 2.9, Other Methods for Activating the Emulator, for the other activating method to create a new
project or use a workspace for the HEW of the old version.

Connect the emulator to the host compuiter.

Connect the user system interface cable to the connector of the emulator.
Turn on the emulator.

Activate the HEW from the [Programs] in the [Start] menu (figure 2.11).

Aw DR

& ‘Windows Update

High-performance Embedd 3 4
» |E§ﬁ) High-perfarmance Embedded Workshop 2 Help

@ High-performance Embedded Warkshop 2 Read Me
EE'B High-performance Embeddec 5

Programs
@ Accessoties
Documents 4

“«©

Settings 4
Search 4
Help

Run...

CARERCSR =ANA

Windows 2000 Professional

Shut Down...

Figure2.11 [Start] Menu

Note: If ‘LAN Driver’ isnot selected at installation, [Tools] is not displayed.
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5. The[Welcome!] dialog box is displayed.

21x
ity
' ‘Cieate a new project workspace Cancel |
") Mpen arecent project workspace; Administration... |
= | ]
= .
g {~ Browse to another project workspace

Figure2.12 [Welcome!] Dialog Box

To use aworkspace for the tutorial, select the [Browse to another project workspace] radio button and click the
[OK] button.

When the [Open Workspace] dialog box is opened, specify the following directory:
HEW?2 ingtallation destination directory\Tool s\Renesas\DebugComp\Pl atf orm\E6000\xxxx\Tutorial

After the directory has been specified, select the following file and click the [Open] button.

2%

Lok, jr: I@ Tutarial j - IC:F -

Debug_H&5_2237_EA000_Emulator _CP
SoUrce

Filz name: |Tutorial.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure2.13 [Open Workspace] Dialog Box

147
RENESAS




When no compiler package or that of a different version isinstalled, the following message box will be displayed.

High-performance Embedded il

Tukorial

"_\ Tool Chain 'Hitachi H3S,HE300 Standard Toolchain', version oo is missing Fram the Following project(s)
there is no compatible koolchain available

Figure2.14 Message Box

6. The[E6000 Driver Details] dialog box is displayed. Thisdialog box isonly displayed at the first initiation.
When only one of interface driversis selected, this dialog box is not displayed.

EE000 Driver Details

Criver: IEmuIatDr PCI Card Driver j
— Detailz
Interface: IPOI j
Channel: IEmuIatnr PCI Card Interface j

—Configuration
Confieure., |

[~ Chanee driver in start up

Figure2.15 [E6000 Driver Details] Dialog Box

» Inthe[Driver] combo box, select the driver to connect the emulator.
» [Interface] displays the name of the interface to be connected.
» Click the [Closg] button.
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7. Set uptheemulator. During this process, the following dialog box is displayed.

Xl
Attempting to connect the emulator.
The driver program has been initializedEmulator PCI Gard Drwer)
Starting to tranzfer a firmware file.
i
[~ Chanee driver in start up
Cloze |

Figure2.16 [Connecting] Dialog Box

8. When "Connected" is displayed in the [Output] window of the HEW, the emulator initiation is completed.
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E_'ﬁ'ﬁTutl:lrial - High-performance Embeddes hop - [tutorial.cpp] - |EI|5|
<% Flle Edit Wiew Project Options Build Tools Window Help =12
i ] s
- e 1=
El@ Tutarial ) = <% FILE ‘Tutorial . cpp
=-IE Tuterial #% DESCRIPTION :Main Program
EME3 T =
P <% Thi= file iz generated by Hitachi Proj
-
g

-3 Download modules

D Tutorial. abs =
& Projects | ] Mavigation |

oo
endif
<|i

#ifdef _ cplusplus
extern "C"

#endif

woid abort{woid):
#ifdef _ cplusplus

ol

Connected

=
I |

4+ [ Build £ Debug } Find in Files A,

Yersion Control f

Ready

Read-write  [1/64 [1 s

Figure2.17 HEW Window

2.8 Communication Problems

The following message box will be displayed when the emulator power isturned off or the PC interface cableis

not correctly connected.

xxxxx E6000 Emulator

A\

A verification error has occurred during the transfer of a firmmare file.
This iz probably because the emulator has been turned off or another emulator has been connected.

Figure2.18 Error Message

For information on other errors, refer to the Setup Guide for the EG000 Emulator.

2.9 Other Methodsfor Activating the Emulator

Refer to section 4, Preparation before Use.

2.10 Uninstalling the Emulator’s Software

For details on uninstallation, refer to the Setup Guide for the E6000 Emulator.
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Section 3 E6000 Emulator Functions

31 Debugging Features

311 Breakpoints

The emulator provides a comprehensive range of alternative types of breakpoints, to give you the maximum
flexibility in debugging applications and user system.

Har dwar e Break Conditions: Up to 12 break conditions can be defined using the event and range channelsin
the complex event system (CES). For more information about the hardware break conditions, see section 3.2,
Complex Event System (CES).

Program Breakpoints (PC Breakpoints): Up to 256 program breakpoints can be defined. These program
breakpoints are set by replacing the user instruction by a BREAK instruction. In target ROM, only one
breakpoint (on-chip break) can be set.

312 Trace

The emulator incorporates a powerful realtime trace facility which allows you to examine MCU activity in detail.
The realtime trace buffer holds up to 32768 bus cycles, and it is continuoudy updated during execution. The
buffer is configured as arolling buffer, which can be stopped during execution and read back by the host
computer without halting emulation.

The data stored in the trace buffer is displayed in both source program and assembly languages for ease of
debugging. However, if trace filtering is used, only assembly language can be displayed.

The buffer can be set up to store all bus cycles or just selected cycles. Thisis called trace acquisition and uses the
complex event system (CES) to select the parts of the program you are interested in.

It isalso possible to store all bus cycles and then just look at selected cycles. Thisis caled trace filtering.

313 Execution Time Measur ements

The emulator alows you to measure the total execution time, or to measure the time of execution between
specified eventsin the complex event system. Y ou can set the resolution of the timer to any of the following
vaues:

20ns, 125 ns, 250 ns, 500 ns, 1 ps, 2 s, 4 ps, 8 s, or 16 ps.

At 20 ns the maximum time that can be measured is about six hours, and at 16us the maximum time is about 200
days.

314 Performance Analysis

The emulator provides functions for measuring the performance of a program. The performance of the specified
program range can be displayed either as a histogram or in percentage form. A timer resolution of 20 ns, 40 ns,
or 160 ns can be selected. In addition, the execution count of the specified program range can be measured (1 to
65535).
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315 Bus Monitoring

The emulator incorporates a bus monitoring function that monitors and displays the contents of the accessed area
in HDI windows without stopping the program execution. Up to eight blocks of 256 bytes can be monitored. In
addition, the emulator can output trigger signals from external probe 2 (EXT2) when specified addresses (four
points max.) are accessed. Note that, however, some products do not support the bus monitoring function.

3.2 Complex Event System (CES)

In most practical debugging applications, the program or hardware errors that you are trying to debug occur
under acertain restricted set of circumstances. For example, a hardware error may only occur after a specific
area of memory has been accessed. Tracking down such problems using simple PC breakpoints can be very
time-consuming.

The emulator provides a very sophisticated system for giving a precise description of the conditions you want to
examine, called the complex event system. This allows you to define events which depend on the state of a
specified combination of the MCU signals.

The complex event system provides a unified way of controlling the trace, break, and timing functions of the
emulator.

321 Event Channds

The event channels alow you to detect when a specified event has occurred. The event can be defined asa
combination of one or more of the followings:

» Addressor address range

» Addressoutside range

» Read or Write or either

» Data, with an optional mask

* MCU accesstype (e.g.,, DMAC and instruction prefetch)

* MCU access area (e.g., on-chip ROM and on-chip RAM)
* A signal state on one or more of the four external probes

* A certain number of times that the event must be triggered
» Delay cycles after an event

Up to eight events can be combined into a sequence, in which each event is either activated or deactivated by the
occurrence of the previous event in the sequence. For example, you can cause abreak if an I/O register iswritten
to after a specified area of RAM has been accessed.

322 Range Channels
The range channels can be set up to be triggered on a combination of one or more of the following:

» Address or address range (inside the range)

* Read or Write or either

» Data, with an optional mask

* MCU accesstype (e.g.,, DMAC and instruction prefetch)

* MCU access area (e.g., on-chip ROM and on-chip RAM)
* A signal state on one or more of the four external probes
» Delay cycles after an event
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The complex event system can be used to control the following functions of the emulator:

323 Breaks

Use breaks to interrupt program execution when a specified event, or sequence of events, is activated. For
example, you can set up a break to halt execution when the program reads from one address, and then writesto
another address. The break can also optionally be delayed by up to 65535 bus cycles.

324 Timing

Y ou can set up two events and then measure the execution time of the program between the activation of the first
event and second event.

3.3 Hardwar e Features

331 Memory

The emulator provides standard emulation memory as the substitute for on-chip ROM memory and on-chip
RAM memory. When a device type or device mode without an on-chip ROM or on-chip RAM is selected, the
standard emulation memory is disabled. When debugging with only the emulator and the user program and data
are stored in an externa address space, an optional SIMM memory module must be used. The optiona SIMM
memory modules can be separately purchased.

The emulation memory can be mapped in 64-byte units to any number of separate memory blocksin the MCU
address space. Each memory block can be specified using the memory mapping function as user (Target) or
emulator (SIMM memory module) and, in each case, the access can be specified as read-write, read-only, or
guarded.

The definition of each type of memory is asfollows:

Table3.1 Memory Types

Memory Type Description

On-chip Uses the MCU on-chip memory.

User Accesses the user system memory.

Emulator Accesses the emulator emulator SIMM memory module.

The contents of a specified block of memory can be displayed using the memory function. The contents of
memory can be modified at any time, even during program execution and the results are immediately reflected in
all other appropriate windows.

Note that modifying memory contents during program execution has the following time requirements:

1. MCU on-chip ROM or RAM, or emulator SIMM memory module
The emulator modifies the memory contents by temporarily switching the memory bus to the emulator side
without stopping the user program execution. Therefore, the emulator uses the memory bus for up to 80 psin
reading of 256 bytes (25 MHz, on-chip ROM).

2. MCU on-chip I/O, DTCRAM, or user system memory
The emulator stops the user program execution, then modifies the memory contents. Therefore, the user
program stops for a maximum of 2 msin reading 256 bytes (25 MHz, emulation memory).
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332 Clocks

The clock can be specified as emulator internal clock or target clock. The frequenciesthat can be specified as
the emulator internal clock depend onthe MCU. For details, refer to section 8, Software Specifications Specific
to This Product.

333 Probes

External probes 1 and 2 (EXT1 and EXT2) can be connected to the emulator, to make use of signals on the user
system for break or trace. The signal for external probe 1 can be set as the condition for the event detection
system depending on the low or high level. Sincethe signal for external probe 2 outputs high level when the
trigger setting (1 to 4) condition is matched in the bus monitor function, the signal can be used for the trigger
condition for such as an oscilloscope.

3.4 Stack Trace Function

The emulator uses the stack’ sinformation to display the name of the calling function for afunction at which the
program counter is currently pointing. This function can be used only when the load module that has the
Dwarf2-type debugging information isloaded. For the usage of this function, refer to section 6.17, Stack Trace
Function.

3.5 OnlineHelp

An online help explains the usage of each function or the command syntax that can be entered from the
command line window.

Select [Emulator Help] from the [Help] menu to view the emulator help.
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Section 4 Preparation before Use

41 Workspaces, Projects, and Files

Just as aword processor allows you to create and modify documents, HEW allows you to create and modify
workspaces. A workspace can be thought of as a container of projects and, similarly, a project can be though of
as acontainer of project files. Thus, each workspace contains one or more projects and each project contains one
or morefiles. Figure 4.1 illustrates this graphically.

PROJECT

C

PROJECT

PROJECT

WORKSPACE

Figure4.1 Workspaces, Projects, and Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can aso be linked hierarchically within aworkspace, which means that when one project is built all of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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4.2 Method for Activating HEW
To activate the HEW, follow the procedure listed below.

1. Connect the emulator to the host computer.
2. Connect the user system interface cable to the connector of the emulator if you use the user system interface
cable. Thisis not necessary when you do not use the user system interface cable.

3. Turn on the emulator. Be sure to turn on the user system before supplying power to the emulator if you use
the user system.
4. Activate the HEW from [Programs] in the [Start] menu.

5. The[Welcome!] dialog box is displayed.

— Dptions: ok

{* Create a new project workspace: Cancel

" Dpen arecent project workspace: Adrninistration. .
é | -

=

g " Browse to another project workspace

Fet,

Figure4.2 [Welcome!] Dialog Box
[Create a new project workspace] radio button: Creates a new workspace.

[Open arecent project workspace] radio button: Uses the current workspace and displays the history of the
opened workspace.

[Browse to anather project workspace] radio button: Uses the current workspace; this radio button is used when
the history of the opened workspace does not remain.

In this section, we describe the following three ways to start up the HEW:

e [Create anew project workspace] - atoolchainisnot in use

» [Create anew project workspace] - atoolchainisin use

»  [Browse to another project workspace]

The method to create a new workspace depends on whether atoolchain isor isnot in use. Note that this emulator
product does not include atoolchain. Use of atoolchain is available in an environment where the H8S, H8/300

series C/C++ compiler package has been installed. For details on this, refer to the manual attached to the H8S,
H8/300 series C/C++ compiler package.
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421 Creating a New Wor kspace (T oolchain Not Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— O ptionz: ok

' ‘Cieate a new project workspace Cancel

% ") Mpen arecent project workspace; Administration...

| i

Fl

=

g {~ Browse to another project workspace

Figure4.3 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

New Proj e e |

Wiorkspace Mame:

Isample{
Cahicel
Project MName:

Pl

Isample Browsze.

Directory:
IEI: WHew2\zample

CPU family:
{He5 Ha/300 |

Toal chain:

INnne et

Froject tppe:

Figure4.4 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,
it needs not be entered.

[Directory] edit box: Displays the directory in which the workspace will be created. Click the [Browse...]
button to select a directory name or enter a directory name in the [Directory] edit box.

Other list boxes are used for setting the tool chain; the fixed information is displayed when the toolchain has not
been installed.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

— Targets
(w]wyyy EG000 Emulator GPL 2000

EGOD0N Emulator GPU 2600

Taraet type : I."-‘-.II Targets j

< Back I Heut » I Finizh | Cancel |

Figure4.5 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box
against the target platform and then click the [Next] button. For details on the session file, refer to section
4.4, Debugger Sessions.

159
RENESAS




4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

2l

Target name ;

vy EGO00 Emulator CPU 2000

Configuration name :
|Debug_yvyy E6G000_Emulator GF

— Detail options :

Item | Walue |

T ity |

< Back I Hewt » I Finizh | Cancel |

Figure4.6 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] dialog box shown in figure 4.5, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next

target.
Setting of the configuration file nameis the end of the emulator settings.
Click the [Finish] button to display the [Summary] dialog box. Pressing the [OK] button activates the HEW.

5. After the HEW has been activated, the emulator is automatically connected. The message “ Connected” is
displayed on the [Debug] tab in the [Output] window to indicate the completion of connection.
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4.2.2 Creating a New Workspace (Toolchain Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project

workspace] radio button and click the [OK] button.

— O ptionz:

i

=

' ‘Cieate a new project workspace

") Mpen arecent project workspace;

g {~ Browse to another project workspace

i

21x
(1] 4
Cancel

Adminigtration. .

Fl

Figure4.7 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

New Proj e e |

Wiorkspace Mame:

Isample{
Cahicel
Project MName:

Pl

Isample Browsze.

Directory:
IEI: WHew2\zample

CPU family:
{He5 Ha/300 |

Toal chain:
[ Hitachi HB5 HB/300 Standard =l

Froject tppe:
(=)D
@ Azzembly Application
Demonstration

@ EE000 Emulator Application

@ EG000 Emulator dezembly Application

@ EE000 Emulataor Empty Application -
|

4|

Figure4.8 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name. Here, enter ‘test’.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,
it needs not be entered.

[Directory] edit box: Displays the directory in which aworkspace will be created. Click the [Browse...]

button to select a directory or enter the name of adirectory in the [Directory] edit box.

[CPU family] combo box: Select the target CPU family.

[Tool chain] combo box: Select the target toolchain name when using the toolchain. Otherwise, select
[None].

[Project type] list box: Select the project type to be used.

Notes: 1. For the EG000 emulator, the following project types are the same:
[Application] and [E6000 Emulator Application]
[Empty Application] and [E6000 Emulator Empty Application]
2. When [Demonstration] is selected in the emulator, note the followings:
The [Demonstration] is a program for the simulator attached to the H8S, H8/300 compiler package.
To use the generated source file, delete the Printf statement in the sourcefile.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

— Targets
(w]wyyy EG000 Emulator GPL 2000

EGOD0N Emulator GPU 2600

Taraet type : I."-‘-.II Targets j

< Back I Heut » I Finizh | Cancel |

Figure4.9 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box against
the target platform and then click the [Next] button. For details on the session file, refer to section 4.4,
Debugger Sessions.
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4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

2l

Target name ;

vy EAOO0 Emulatar SPL2

Configuration name :
|Debug_yvyy E6G000_Emulator GF

— Detail options :

Item | Walue |

T ity |

< Back I Hewt » I Finizh | Cancel |

Figure4.10 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] dialog box shown in figure 4.9, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next
target.

Setting of the configuration file nameis the end of the emulator settings.

Complete the creation of a new workspace according to the instructions on the screen. This activates the
HEW.

5. After the HEW has been activated, connect the emulator. However, it is not necessary to connect the
emulator immediately after the HEW has been activated.
Select either of the following two ways to connect the emulator: connecting the emulator after the setting at
emulator activation or without the setting at emulator activation. For details on the connection of the
emulator, refer to section 4.5, Connecting the Emulator.
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4.2.3 Selecting an Existing Workspace

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Browse to another project

workspace] radio button and click the [OK] button.

21x
ity
" Create a new project workspace Cancel |
") Mpen arecent project workspace; Administration... |
= | ]
= ! : 3
g * Browse to another project workspace

Figure4.11 [Welcome!] Dialog Box

2. The[Open Workspace] diaog box isdisplayed. Select a directory in which you have created a workspace.
After that, select the workspace file (.hws) and press the [Open] button.

2%

Lok, jr: I@ zample j i IC:F -

sample

Filz name: |sample.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure4.12 [Open Workspace] Dialog Box

3. Thisactivates the HEW and recovers the state of the selected workspace at the time it was saved.
When the saved state information of the selected workspace includes connection to the emulator, the
emulator will automatically be connected. To connect the emulator when the saved state information does not
include connection to the emulator, refer to section 4.5, Connecting the Emulator.
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4.3 Setting at Emulator Activation

When the emulator is activated, the command chain can automatically be executed. It isalso possible to register
multiple load modules to be downloaded. The registered load modul es are displayed on the workspace window.

1. Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box.

Debug Settings d b
IDefauItSession | Target | Options |
------ [ sample Target:

Default Debug Farmat:

{hones j

Download Modules:
File Mame | Qffzet Address | Farm: I

Bemave

Fdmdify..

It

[T

4] | 2+
Ok, I Cancel |

Figure4.13 [Debug Settings] Dialog Box ([Target] Page)

2. Select the product name to be connected in the [Target] combo box.

3. Select the format of the load module to be downloaded in the [Default Debug Format] combo box, then
register the corresponding download module in the [Download Modules] list box.

4. Click the[Optiong] tab.
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-3

2|

IDefauItSession j Target Options

""" & sample Command batch file load timing:

ayy tanet COnnecion

Command Line Batch Processing:

Bemave

[T

L

¥ | Connect up o target of debug go

¥ Download modules after build

Ok, I Cancel

Figure4.14 [Debug Settings] Dialog Box ([Options] Page)

The command chain that is automatically executed at the specified timing is registered. The following three
timings are available:

» At connecting the emulator
» Immediately before downloading
* Immediately after downloading

Specify the timing for executing the command chain in the [Command batch file load timing] combo box. In
addition, register the command-chain file that is executed at the specified timing in the [Command Line Batch
Processing] list box.
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44 Debugger Sessions

The HEW stores all of your builder optionsinto aconfiguration. In asimilar way, the HEW stores your
debugger optionsin asession. The debugging platforms, the programs to be downloaded, and each target
platform’s options can be stored in a session.

Sessions are not directly related to a configuration. This means that multiple sessions can share the same
download module and avoid unnecessary program rebuilds.

Each session’s data should be stored in a separate file in the HEW project. Debugger sessions are described in
detail below.

441 Selecting a Session
The current session can be selected in the following two ways:

» From the toolbar
Select a session from the combo box (figure 4.15) in the toolbar.

JJ g ||Debug j ||Defau|tSession j | P |@ {p3] ‘

Figure4.15 Toolbar Selection

* From the dialog box
1. Select [Options -> Debug Sessions...]. Thiswill open the [Debug Sessions] dialog box (figure 4.16).

Debug sessions: ok

DefaultSession
Sessionyyyy_EG000_Emulatar_CP Cancel
Sessionwecs_EB000_Emulator_CP

|x

Add...
Bemove

Save as...

il

Eroperties

Current session:
Default5ession j

Figure4.16 [Debug Sessions] Dialog Box

2. Select the session you want to use from the [Current session] combo box.
3. Click the [OK] button to set the session.
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44.2 Adding and Deleting Sessions
A new session can be added by copying settings from another session or deleting a session.

e Toadd anew empty session

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Add new session] radio button.

Enter a name for the session.

Click the [OK] button to close the [Debug Sessions] dialog box.

This creates afile with the same name as the entered session name. If the file name aready exists, an
error is displayed.

o 0k wDd PR

Add new

Mame:
Cancel

21
' Add new session oK I

* Use an existing session file

M ame:

Isample
Session file path:

I Browze |

[w ‘Open and maintain link to session fils

[~ Make session file link read only

Figure4.17 [Add new session] Dialog Box
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e Toimport an existing session into a new session file
1. Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).
Check the [Use an existing session file] radio button.
Enter a name for the session.
Browse to the existing session file location that you would like to import into the current project.
If the [Open and maintain link to session file] check box is not checked, the imported new session fileis
generated in the project directory.

If the [Open and maintain link to session file] check box is checked, anew session fileis not generated in

the project directory but islinked to the current session file.

If the [Make session file link read only] check box is checked, the linked session file is used as read-only.
6. Click the [OK] button to close the [Debug Sessions] dialog box.

S S

* Toremovea on
1. Select [Options-> Debug Sessions...] to display the [Debug Sessions| dialog box (figure 4.16).
2. Select the session you would like to remove.
3. Click the [Remove] button.
Note that the current session cannot be removed.
4. Click the [OK] button to close the [Debug Sessions] dialog box.

* Toview the session properties
1. Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
2. Select the session you would like to view the properties for.
3. Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

n Properties
Mame: Sessionxooc EE000_Emulatar_CP i
Location: C:"Hew2hzample! samplehS essiohxoocs EGO00 = |
Lastmodiied:  17:37:11, Thursday, December 12, 2002 _ Cancel |
[~ Eead only

Figure4.18 [Session Properties] Dialog Box
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To make a session read-only

1.

5.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

2. Select the session you would like to make read-only.
3.
4. Check the [Read only] check box to make the link read-only. Thisisuseful if you are sharing debugger-

Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

setting files and you do not want data to be modified accidentally.
Click the [OK] button.

To save a session with a different name

1.

ok w DN

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

Select the session you would like to save.

Click the [Save as] button to display the [Save Session] dialog box (figure 4.19).

Browse to the new file location.

If you want to export the session file to another location, leave the [Maintain link] check box unchecked.

If you would like the HEW to use this location instead of the current session location, check the
[Maintain link] check box.

Click the [OK] button.

2%

Save_in:l@ zample j - IC:F -

|_1 Debug Sessionxoo _E000_Emulatar_CP.hsf
I_1 Debug_wwwy_ES000_Emulatar_CP

I_1 Debug_seees_ES000_Emulatar_CP

"1 Release

DefaultSession.hsf

Sessionyyyy_E6O00_Emulator_CP.hsf

Filz name: | Save I
Save az upe; ISessions [# haf] j Cahicel |

[~ Maintain link

A

443

Figure4.19 [Save Session] Dialog Box

Saving Session | nformation

To save a session
Select [File -> Save Session].
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4.5 Connecting the Emulator
Select either of the following two ways to connect the emulator:

(a) Connecting the emulator after the setting at emulator activation

Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box. It ispossible to
register the download module or the command chain that is automatically executed at activation. For details
on the [Debug Settings] dialog box, refer to section 4.3, Setting at Emulator Activation.

When the dialog box is closed after setting the [Debug Settings] dialog box, the emulator will automatically
be connected.

(b) Connecting the emulator without the setting at emulator activation
Connect the emulator by simply switching the session file to onein which the setting for the emulator use has
been registered.

=10l

@ﬁs.ﬁru‘u;-\e - High-performance Embedc ap
File Edit Yiew Project Options Build Tools ‘Window Help

DeFHe (= (reetTu|lop@sEas: B|a =" & % |7

AR ] ”J@ # ||Debug DefaultS ession 5 ||E = “& B & g i@ J ENENERE
W Defau\lSessioﬂESDD

E--l@ sample
B3 Csource file
¥

) & Proj... | < Navig...

x|
|

Build £ Debug } Find in Files & version Contral §

Ready [ [~ s UM

Figure4.20 Selecting the Session File

In thelist box that is circled in figure 4.20, select the session name including the character string that has been
set in the [Target name] text box in figure 4.10, [New Project — Step 8] dialog box. The setting for using the
emulator has been registered in this session file.

After the session name is selected, the emulator will automatically be connected. For details on the session file,
refer to section 4.4, Debugger Sessions.
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4.6 Ending the Emulator
When using the toolchain, the emulator can be exited by using the following two methods:

» Canceling the connection of the emulator being activated
» Exiting the HEW

(a) Canceling the connection of the emulator being activated

1. Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box (see figure 4.13).

2. Select <None> or another product in the [Target] combo box. When another product is selected, the
connection with that product is started after canceling the connection of the emulator being activated.

3. Turn the emulator off after canceling the connection.

(b) Exiting the HEW

1. Select [Exit] from the [File] menu.

2. A message box isdisplayed. If necessary, click the [Y es] button to save a session. After saving a session,
the HEW exits. If not necessary, click the [No] button to exit the HEW.

High-performance Embe X
& Session has been modified - do wou want ko save it

es Mo | Cancel |

Figure4.21 [Session hasbeen modified] Message Box
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Section 5 Debugging
This section describes the debugging operations and their related windows and dialog boxes.
51 Setting the Environment for Emulation

511 Opening the [Configuration Properties] Dialog Box

Selecting [Options -> Emulator -> System...] or clicking the [Emulator System] toolbar button (IEI) opensthe
Configuration Properties] dialog box.

21x
General |
Device: |Jzer Signalz
EEICE: ¥ User Beset enable
Mode: I?' [advanced mode, single chip) j ¥ User MMl enable
¥ Sirgle chin mode ™| Wser Standby enatile
ind s v User Bus Reguest enable
Clock: | Main10MHz, Subi32kHz =l
Timer Resolution: |125ns j

Flash emon: Eontrol; I vl

¥ Enable read and wiite on the fly
¥ Break on access eror
™ Enable intermal ROM area write

User WCC Thsshold = 400V 4 | [ |

Diriver: |EBDDD LISE Driver
[ Change driver in start up

Ok, I Cancel |

Figure5.1 [Configuration Properties] Dialog Box ([General] Page)

This diadog allows the user to set conditions for the target MCU before downloading a program to the emulator.
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[General] page

[Device]

[Mode]
[Clock]

Selects the MCU to be emulated. To use an MCU not included in the list,
select CUSTOM to specify the functions required for this MCU. See the
hardware manual for details.

Selects the MCU's operating mode.
Selects the speed of the MCU'’s clock and sub-clock.

[Timer Resolution]

[Enable read and write on the
fly]

[Break on access error]

[Enable internal ROM area write]

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this check box if
you require realtime emulation.

When this box is checked, a break (the user program stops) occurs if
your program accesses a guarded memory area or writes to a write-
protected area.

When this box is checked, writing to the internal ROM area is enabled.
For the result of writing, see the [Status] window.

[User VCC Threshold] Sets the voltage level for the user system.

[User Signals] When this box is checked, the reset, NMI, standby, and bus request
signals from the user system are enabled.

[Driver] Displays the E6000 driver that is currently installed.

[Change driver in start up]

When this box is checked, selection of a driver will be available next time
the emulator is connected.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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512 Selectingan MCU Not Included in the List

Selecting [Custom] in [Device] of the [Configuration Properties] dialog box adds the [Custom Device] page to

the dialog box.

General  Custom Device

ROM: r
RéaM:  [16kR |
Fin  [120128Pe |
Modules
W Enable DTC W Enable 1D

W Enable DA& Converter ¥ Enable 1ICO

W Enable Refresh Contraller W Enable [1C1

[V Enable DMALC ¥ Enable wWDT1
¥ Enable TPU3-5 ¥ Enable THMR2-3
¥ Enable Ptk 14

¥ Erable MuliProcesserComunication [SCI1-4]

A/D Conwerter
+ 4reg
" Breg

SCI Select
" SCI0-1
" SCI0-2
" SCI0-3
+ SCI0-4

21|

Ok, | Cancel

Figure5.2 [Configuration Properties] Dialog Box ([Custom Device] Page)

Use this page to specify functions for an MCU not included in the list of MCUs. The items are adopted by the

devicelast selected.

[Custom Device] page

[ROM] Specify the internal ROM area size.

[RAM] Specify the internal RAM area size.

[Pin] Specify the product package.

[Modules] Check this box to validate on-chip peripherals.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. Some emulators may

not support the [Custom Device] function. For details, refer to section 8, Software Specifications

Specific to This Product, or the online help.
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513 Selecting the I nterface to be Connected

Checking [Change driver in start up] on the [Configuration Properties] dialog box allows a selection of the driver
next time the emulator is connected.

EAQ00 Driver Details

Driver: (==

r Details

Interface: IUSB interface ﬂ

Channel: IEBDDD USE Interface j

r— Configuratian

[Canfigure... |
[ Change driver in start up

Figure5.3 [Driver Details] Dialog Box
[Driver]: Selects the driver that connects the HEW and the emulator.
[Details): Sets the details of the driver being connected.

[Interface]: The name of the interface to be connected. This should not be changed in this
emulator.

[Channdl]: Channel for the selected interface. This should not be changed in this emulator.
[Configuration]: Driver setting.

[Configure...]: A dialog box for setting will be displayed when the driver supports the configuration
dialog. Note that thisitem is not available with this emulator.

[Change driver in start up]:
Checking this box selects the driver when the emulator is connected the next time.
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514 Opening the [Memory Mapping] Dialog Box

Selecting [Options -> Emulator -> Memory Resource...] or clicking the [Emulator Memory Resource] toolbar
button ) opens the [Memory Mapping] dia og box.

Memary Mapping ﬂﬂ

System Memory Resources From  To  Mapping Add...
SIMK Maodule: J 00000000 - 0003FFFF On Chip Read-only

TMEB SIMH fitted 00040000 - DOFFAFFF User Guarded
Ram Bases: OOFFEOO00 - DOFFEFBF On Chip Read-write

0 nat used OOFFEFCO - OOFFFYFF User Guarded

1: nat uzed QOFFFE00 - QOFFFFFF On Chip Aead-write Reset

2: not uzed

3 ot uged Close

Target Device Configuration

00000000 - Q003FFFF Intemal ROM J
OOFFBOO0O - DOFFEFEF Internal RAM

DOFFF200 - QOFFFF3F Internal 10

DOFFFFG0 - QOFFFFBF Intermal 10

OOFFFFCO - O0FFFFFF Internal RAM

]

Figure5.4 [Memory Mapping] Dialog Box
This diaog box displays the current memory map. The E6000 H8S supports four blocks of user memory. These
can be 256 kbytes or 1 Mbyte each, depending on the SIMM fitted. Each block can be placed in the address
space on a 256-kbyte or 1-Mbyte boundary.

The memory mapping has agranularity of H'40 (D'64) bytes. Each 64-byte block can be set to the internal
(emulation) or external memory and can be guarded (access-prohibited), write-protected or read-write.

The H8/300 series E6000 generally incorporates an emulation memory.

In the memory map, the memory can be set asan internal (emulation) or external, guarded (access-prohibited),
write-protected, or read/write in a byte unit.

[Add...]: Displays the [Edit Memory Mapping] dialog box, alowing the user to modify the address
range and attributes of a memory map.

[Modify...]: Displays the [Edit Memory Mapping] dialog box, alowing the user to modify the address
range and attributes of a memory map.

[Reset]: Resets the map memory to its default settings.

[Close]: Closes the dialog box.

The memory configuration of the device being emulated is displayed by the [Memory] sheet in the [Status]
window.

Note:  Some emulators may not support the emulation memory or the memory mapping function. For details,
refer to section 8, Software Specifications Specific to This Product, or the online help.
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515 Changing the Memory Map Setting

Clicking the [Add...] button on the [Memory Mapping] dialog box or clicking the [Modify...] button after
selecting the information on the memory map setting you want to change opens the [Edit Memory Mapping]

dialog box.

Edit Memary Mapping llﬂ
Memory Mapping
i I Cancel |

To I

Setting: I On Chip Read-vwrite j

Figure5.5 [Edit Memory Mapping] Dialog Box

Use this dialog box to change the address range and attributes of a memory map.

[From]: Enter the start address of the map range.
[To]: Enter the end address of the map range.
[Setting]: Enter the memory map setting.

The choices given are listed below. The User (external memory) and Emulator (emulation
memory) attributes can be modified.
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On-chip Read-write (Cannot be changed)

On-chip Read-only (Cannot be changed)

On-chip Guarded (Cannot be changed)

User Read-write (Cannot be selected when the single chip mode is selected.)
User Read-only (Cannot be sel ected when the single chip modeis selected.)
User Guarded

Emulator Read-write

Emulator Read-only

Emulator Guarded
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5.2 Downloading a Program
This section describes how to download a program and view it as source code or assembly-language mnemonics.

Note:  After abreak has occurred, the HEW displays the location of the program counter (PC). In most cases,
for exampleif an Elf/Dwarf2-based project is moved from its original path, the source file may not be
automatically found. In this case, the HEW will open a source file browser dialog box to alow you to
manually locate the file.

521 Downloading a Program
A load module to be debugged must be downloaded.

To download a program, select the load module from [Debug -> Download] or select [Download] from the
popup menu opened by clicking the right-hand mouse button on the load module in [Download modules] of the
[Workspace] window.

Note: Before downloading a program, it must be registered to the HEW as aload module. For registration,
refer to section 4.3, Setting at Emulator Activation.
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522 Viewing the Source Code

Select your source file and click the [Open] button to make the HEW open the file in the integrated editor. Itis
also possible to display your source files by double-clicking on them in the [Workspace] window.

w® Tutorial.cpp =10l =]
Qx00001038 wolid tutorial{void) j
0=00001044 i

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;
0=00001046 | 4@ |ohg| @ p_=amn= Sample:;
0xz0000104e | +& (v for{ i=0; 1<10; i++ }{
D=00001050 |-& (% |2 j = rand():
0x00001058 |2 if{j < 03
0=0000105a |2 3 e Ca| S

b

0=0000105c | o ali] = 7:

b
0=00001070 p_sam—r=ort(a):
0=0000107a p_samn—>change{a);
0=z00001082 p_san—:=0=a[0];
0=0000108a p_=samn—r=l=a[l]:; -

Figure5.6 SourceWindow
In this window, the following items are shown on the left as information on lines.

e First column (Source address column): Displays the address information for the source line
*  Second column (Event column): Event information (break)

e Third column (EXT.2 Trigger column): EXT.2 Trigger information

»  Fourth column (Editor column): PC, bookmark, and breakpoint information

The Editor window is displayed in the right part of the Source window.
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Sour ce addr ess column

When a program is downloaded, an address for the current source file is displayed on the Source address column.
These addresses are hel pful when setting the PC value or a breakpoint.

Event column
The Event column displays the following items:
@ - Address condition break by an event or arange channel
*®: Starts time measurement by an event channel
“&: Ends time measurement by an event channel
= Starts a point-to-point range trace
&' Ends a point-to-point range trace
" Haltstrace
These are also set by using the popup menu.
EXT.2 Trigger column
The EXT.2 Trigger column displays the following items:
s EXT.2-1 trigger condition
#ha; EXT.2-2 trigger condition
I EXT.2-3 trigger condition
lhs: EXT.2-4 trigger condition
"-: Two or more EXT.2 trigger conditions
It isalso possible to set them by using the popup menu.
Editor column
Editor column displays the following items:
3: A bookmark is st.
®: A PCBreak is set.
=: PC location
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=) To switch off acolumnin al sourcefiles

Click the right-hand mouse button on the [Editor] window.

Click the [Define Column Format...] menu item.

The [Global Editor Column States] dialog box is displayed.

A check box indicates whether the column is enabled or not. If it ischecked, the column is enabled. If
the check box is gray, the column is enabled in some files and disabled in others.

5. Click the [OK] button for the new column settings to take effect.

AwbdhpE

Global Editor Colunin Ske

[W|E>T.2 Trigger

[w]E vent = =
[w]E ditar Cancel |
[w]Source Address

Figure5.7 [Global Editor Column States] Dialog Box

< To switch off acolumn in one sourcefile
1. Click theright-hand mouse button on the [Editor] window which contains the column you want to
remove to display the popup menu.
2. Click the [Columns] menu item to display a cascaded menu item. The columns are displayed in this
popup menu. |If acolumn isenabled, it hasatick mark next to itsname. Clicking the entry will toggle
whether the column is displayed or not.
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523 Viewing the Assembly-L anguage Code

Click the right-hand mouse button on the [Source] window to open the popup menu and select [Go to
Disassembly] to open the [Disassembly] window at the same address as that for the current [Source] window.

If you do not have a sourcefile, but wish to view code in the assembly-language level, either choose [View ->
Disassembly...], use the Ctrl + D accelerator, or click on the [Disassembly] window’ s toolbar button . The
[Disassembly] window opens at the current PC location and shows [Address] and [Code] (optional) which show
the disassembled mnemonics (with labels when available).

) ly —10] =]

22 woid mainivoid) 3

23 1

24 while {(1){

00001036 40FC BRA @ main: 8

26 T

27

28

29: woid tutorial{wvoid)

tutorial O01006DF3 MOV . L ER3, @-ER7

0000103C O1206DF4 STH.L (ER4-ERG ), @-5F

goooiod40 79370028 SUB. W ¥H'0028,R7

30 {

00001044 OFF3 MOV . L ER7.ER3

31 long a[10]:

32 long 3

KN int 1

34 cla=s Sanple *p =an:

a5

36 p_=zan= new Sanple;
€ 00001046 1480 SUB.L ERO,ERD

goooiloda SEOODZ000 JSR @Sanple:  Sample() 24

0000104C OF86 HOV . L ERO,ERE

37 for{ i=0; 1<10; i++ 3{

0O000104E 1944 SUB. W R4 R4

3B j = randi);

00001050 SEOO11EE JSR @ _rand: 24 -
A Y

Figure5.8 [Disassembly] Window

5.24 Modifying the Assembly-L anguage Code

Y ou can modify the assembly-language code by double-clicking on the instruction that you want to change. The
[Assembler] dialog box will be opened.

2|

Addrezz Code Iremonic;
00001040 79370028 SUB. W

Ok, | Cancel |

Figure5.9 [Assembler] Dialog Box

185
RENESAS




The address, machine code, and disassembled instruction are displayed. Enter the new instruction or edit the old
ingtruction in the [Mnemonic] field. Pressing the [Enter] key will assemble the instruction into memory and
move on to the next instruction. Clicking the [OK] button will assemble the instruction into memory and close
the dialog box. Clicking the [Cancel] button or pressing the [Esc] key will close the dialog box.

Note: The assembly-language display is disassembled from the actual machine code in the debugging
platform's memory. If the memory contents are changed, the dialog box (and the [Disassembly] window)
will show the new assembly-language code, but the content of the [Source] window will not be changed.
Thisisthe same even if the source file contains an assembler.

525 Viewing a Specific Address

When you are viewing your program in the [ Disassembly] window, you may wish to look at another area of your
program's code. Rather than scrolling through alot of code in the program, you can go directly to a specific
address. Select [Set Address...] from the popup menu, and the dialog box shown in figure 5.10 is displayed.

Set Address e
_main
Cancel |

Figure5.10 [Set Address] Dialog Box

Enter the address or label name in the edit box and either click on the [OK] button or press the [Enter] key. The
[Disassembly] window will be updated to show the code at the new address. When an overloaded function or a
class nameis entered, the [Select Function] dialog box opens for you to select a function. For details, refer to
section 5.13.3, Supporting Duplicate Labels.

5.2.6 Viewing the Current Program Counter Address

Wherever you can enter an address or value into the HEW, you can also enter an expression. If you enter a
register name prefixed by the hash character, the contents of that register will be used as the value in the
expression. Therefore, if you open the [Set Address] dialog box and enter the expression #pc, the [Source] or
[Disassembly] window will display the current PC address. It also allows the offset of the current PC to be
displayed by entering an expression with the PC register plus an offset, e.g., #PC+0x100.
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53 Debugging with the Command Line I nterface

Use the [Command Line] window to enter text-based commands instead of window menus and commands.

531 Opening the [Command Line] Window

Choose [View -> Command Line] or click the [Command Line] toolbar button ) to open the [Command
Line] window.

«* Command Line M= E3

-

Figure5.11 [Command Line] Window

Thiswindow allows the user to control the debugging platform by sending text-based commands. A series of
predefined command lines can be called from afile and the output can be recorded in afile. The command can
be executed by pressing the [Enter] key after the command isinput a the prompt (<) on the last line. For
information on the available commands, refer to appendix G, Command Lines, and the on-line help.

If available, the window title displays the current batch and log file names separated by colons.

Pressing the Ctrl + 1 or Ctrl + | keyson the last line displays the command line previously executed.

532 Specifying a Command File

It isuseful to use acommand file when a series of predefined command lines need to be executed. Create a
command file by atext editor and write necessary command lines. The default extension of acommand file
is.hdc.

Choose [Set Batch File...] from the popup menu to open the [Set Batch File] dialog box, in which the name of a
command file (*.hdc) can be specified. Clicking the [OK] button displays the specified command file name as
the window title. Clicking the [Cancel] button closes the dialog box without changing the setting.

Set Batch File 7 | x|

|| LI Browse,. | oK |

Gancel |

Figure5.12 [Set Batch File] Dialog Box
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533 Executing a Command File

Click the [Play] button in the [Set Batch File] dialog box or choose [Play] from the popup menu to execute the
command file. The [Play] menu is displayed in gray while the fileis running and can be used when the command
file execution stops and control returns to the user.

534 Stopping Command Execution

Choose [Stop] from the popup menu to stop command execution. The [Stop] menu becomes valid during
command execution.

535 Specifyinga Log File

Choose [Set Log File...] from the popup menu to open the [Open Log File] dialog box, in which alog fileto
store the command execution results can be specified.

Open Loge File

Log File:

I LI Browse,. | Q;;:el

Figure5.13 [Open Log File] Dialog Box

Enter the name of alog file (*.log). The logging option is automaticaly set and the name of the file is shown on
the window title bar.

Opening a previous log file will ask the user if they wish to append or overwrite the current log.

5.3.6 Starting or Stopping L ogging

Choose [Logging] from the popup menu to toggle logging to file on and off. When logging is active, the button
becomes effective. Note that the contents of the log file cannot be viewed until logging is completed, or
temporarily disabled by clearing the check box. Re-enabling logging will append to the log file.

537 Entering a Full Path to the File

It is recommended that the full path to afileis specified as afile name in the [Command line] window because
the current directory can be moved. However, care must be taken to enter the correct full path to afilewhenitis
entered from the keyboard. To save this trouble, afull path can be easily specified by browsing through files.

Choose [Browse...] from the popup menu to open the [Browse] dialog box. Select afile and click [Open] to paste
the full path to the selected file to the cursor location. This option can only be used when the cursor islocated on
thelast line.

5.3.8 Pasting a Placeholder

Select a placeholder from the [Placeholder] submenu in the popup menu to paste the selected placeholder to the
cursor location. This function is only available when the cursor islocated on the last line.
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54 Looking at Registers

If you are debugging at assembly-language level, then you will probably find it useful to see the contents of the
CPU's generd registers. Y ou can do this by using the [Register] window.

54.1 Opening the [Register] Window

To open the [Register] window, choose [View->CPU->Registers] or click the [Register] toolbar button ().
The [Register] window opens showing all of the CPU's general registers and the values, displayed in

hexadecimal.

1 . —10l =]
Register Name IRegister Value
[ERO H'00000000
[ERL H'00000000
ERZ H'00000000
[ER3 H'00000000
[ER.4 H'00000000
[ER.5 H'00000000
ERG H'00000000
ER7 H'00000000
PC H'000000
CCE -0--N---
1 S 111
MiCH H'00000000
MaACL H'00000000
| 2

Figure5.14 [Register] Window

54.2 Expanding a Bit Register

If aregister isused as a set of flags at the bit level for the control of state, its one-character symbol rather than its
state indicate each bit. Double-click on the register’s name to display the [Register] dialog box and switch each
bit on or off. Checking the box for any bit specifiesit asholding a 1, while removing the check specifiesit asa0.

Regisker - [CCR]

Walue

[ lImaszk.

[ Uzer/Imazk
[ Half-carmy
[ Uzer

:I Cahicel |

Figure5.15 Expanding a Bit Register
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54.3 Modifying Register Contents
To change aregister's content, open the [Edit Register] dialog box in one of the following methods:

» Double-click the register you want to change.
» Select the register you want to change, and choose [Edit...] from the popup menu.

Reqgister - [ERO] 7] x|

Walug:

|H'uuuuuuuu
Setda: Cancel |

IWhnIe Regizter j

Figure5.16 [Edit Register] Dialog Box

Y ou can enter anumber or C/C++ expression in the [Vaug] field. Y ou can choose whether to modify the whole
register contents, amasked area, floating or flag bits by selecting an option from the combo box (the contents of
thislist depend on the CPU model and selected register).

When you have entered the new number or expression, click the [OK] button or press the [Enter] key; the dialog
box closes and the new value iswritten into the register.

544 Using Register Contents

Use the value contained in a CPU register by specifying the register name prefixed by the “#" character, e.g.:
#R1, #PC, #R6L, or #ER3 when you are entering a value el sewhere in the HEW, for example when displaying a
specified address in the [ Disassembly] or [Memory] windows.
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55 Operating Memory

This section describes how to look at memory areasin the CPU's address space. How to look at a memory area
in different formats, how to fill and move a memory block, and how to load and verify a memory areawith a
disk file are described.

551 Viewinga Memory Area

Tolook at a memory area, choose [View -> CPU ->Memory...] or click the [View Memory] toolbar button )
to open the [Memory] window. Thiswill open the [Set Address] dialog box shown in figure 5.17.

|
I Cancel |
End:

Dizplay Data A=
IElyte 1) j

Figure5.17 [Set Address] Dialog Box

Enter the range you wish to display as an address vaue or an equivalent symbol in the [Begin] and [End] fields.
Select the data size for the display from the [Display Data As| combo box. Click the [OK] button or press the
[Enter] key, and the dialog box closes and the [Memory] window opens. The display can be scrolled within the
range of the entered display start and end addresses.

Merarny E x|
Address Data Value -
Ox00000A0C 6DF3 0120 EDF4 2372
Ox00000AR1Z2 7937 0028 0OD74 v
Ox00000A13 7900 0001 SEO0O 0z
Ox00000A1E OCEBE& 7900 1F42 227
Ox00000AZ4 6DFO  SEOO0 OEEBE4 222
Ox00000AZA OB8B7 1955 SEOO 222
Ox00000A30 0OCB80 17F0 OFS86 227
Ox00000A36 4C02Z  17B6  0ODS3 227
Ox00000A3C 1053 0943 0100 2R

Figure5.18 [Memory] Window
There are three display columns:

[Address]: Address of thefirst item in the [Data] column of this row.

[Datal: Datais read from the debugging platform’s physical memory in the access width, and then
converted to the display width.
[Value]: Data displayed in an alternative format.
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55.2 Displaying Data in Different Formats

If you want to change the display format of the [Memory] window, select [Format] from the popup menu. The
dialog box shown in figure 5.19 is displayed.

Format Memary Display

Dizplay Data A=

IEly'te 1) :I
Display Value fs:

I AMSI character :l
Valug Font:

IOnurier MNew j

Figure5.19 [Format Memory Display] Dialog Box

To display and edit memory in different widths, use the [Display Data As] combo box. For example, choose the
[Byte] option and the display will be updated to show the memory areaasindividual bytes.

The data can be converted into different formats, as shown in the second column [Display Value As]. Thelist of
formats depends on the data selection.

The font of the [Display Vaue As] column can be different from the font used to display the data. This s useful
for displaying [double] byte character values when the data is displayed in the [Word] format.

55.3 Splitting Up the Window Display

To verticaly divide the [Memory] window display into two, select [Split] from the popup menu and move the
split-up bar. Moving the split-up bar to the top end or bottom end of the window cancels the split-up display.

554 Viewing a Different Memory Area

To change the memory area displayed in the [Memory] window, use the scroll bars. To quickly look at a new
address, use the [Set Address] dialog box. This can be opened by choosing [Start Address] from the popup menu.

Enter the new address value, and click the [OK] button or press the [Enter] key. The dialog box closes and the
[Memory] window display is updated with the data at the new address. When an overloaded function or a class
name is entered, the [Select Function] dialog box opens for you to select a function.
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555 Modifying the Memory Contents

The memory contents can be modified via the [Edit Memory] dialog box. Move the cursor on the memory unit
(according to the [Memory] window display choice) that you wish to change. Either double-click on the memory
unit or press the [Enter] key. The dialog box shown in figure 5.20 is displayed.

Edit Memory
Current Y alue:
I Cahicel |
Mew Walue:

[5

Figure5.20 [Edit Memory] Dialog Box

A number or C/C++ expression can be entered in the [New Value] field. After you have entered the new number
or expression, click the [OK] button or press the [Enter] key. Then the dialog box closes and the new valueis
written into memory.

The memory contents can a so be modified by moving the cursor on the memory unit and entering the new value
in hexadecima through the keyboard.

55.6 Selectinga Memory Range

If the range to be selected isin the [Memory] window, you can select the range by clicking on the first memory
unit (according to the [Memory] window display choice) and dragging the mouse to the last unit. The selected
rangeis highlighted.

If the memory address range is larger than or outside the [Memory] window, you can enter the start address and
byte count in the respective fields of the [Memory] dia og box.
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55.7 Finding a Valuein Memory
To find avaue in memory, open the [Memory] window and select [ Search] from the popup menu.

The [Search Memory] dialog box shown in figure 5.21 is displayed.

Data:

Search Data ds:
IEly'te 1) LI

[+ Search Egual Data I~ Search Backward

Figure5.21 [Search Memory] Dialog Box

Enter the start and end addresses of the range in which to search (if amemory area was selected in the [Memory]
window, the start and end address values will be automatically filled in) and the data value to search for, and
select the search format. If pattern search is selected as the search format, a byte string of up to 256 bytes can be
searched for. The end address can also be prefixed by aplus (+); the end address will become the (start address)
+ (entered value).

Search conditions other than pattern search are data match/mismatch and search direction. Note that only data
match and forward direction can be selected with pattern search.

Click the [OK] button or press the [Enter] key. The dialog box closes and the HEW searches the range for the
specified data. If the dataiis found, the address at which the data has been found is displayed in the [Memory]
window.

If the data could not be found, the [Memory] window display remains unchanged and a message box informing
that the data could not be found is displayed.

If [Search Next] is selected from the popup menu in the state where data has been found, the search will continue
from the next address.
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55.8 Fillinga Memory Areawith a Value
A value can be st as the contents of a memory address range using the memory fill function.

To fill amemory range with the same value, choose [Fill] from the popup menu of the [Memory] window or
choose [Fill] from the [Memory] drop-down menu. The [Fill Memory] dialog box is shown in figure 5.22.

2l
Begin:
I Cancel |
End:
!
Data:
!
FEormat;
| =

Figure5.22 [Fill Memory] Dialog Box

If an address range has been selected in the [Memory] window, the specified start and end addresses will be
displayed. Select aformat from the [Format] combo box and enter the data value in the [Data] field. On clicking
the [OK] button or pressing the [Enter] key, the dialog box closes and the new value is written into the memory
range.

55.9 Copying aMemory Area

Y ou can copy a memory area using the memory copy function. Select amemory range and then [Copy...] from
the popup menu. The [Copy Memory] dialog box is opened (figure 5.23).

|
Cancel |
End:
|
Degtination:
|
Format:
IEly'te 1) LI
I~ Werify

Figure5.23 [Copy Memory] Dialog Box
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The source start address and end address selected in the [Memory] window will be displayed in the [Begin] and
[End] fields. Checking the [Verify] check box enables copying while comparing the copy source and copy
destination. The copy unit can be selected in the [Format] combo box. Enter the destination start addressin the
[Destination] field and click the [OK] button or press the [Enter] key. Thiswill close the dialog box and copy the
memory block to the new address.

5510 Savingand VerifyingaMemory Area

A memory areain the address space can be saved into a disk file using the memory save function. Open the
[Save Memory As] dialog box by choosing [File -> Save memory...].

IElinary :I
Cahcel |

File name:
|manual.bin LI I

Start addreszs:
|D

End Address:
IH'FFFFI

Figure5.24 [Save Memory As] Dialog Box

Enter the start and end addresses of the memory block that you wish to save, and a name and format for the file.
The [File name] combo box contains the previous four file names used for saving memory.

Clicking the[...] button can open the standard [File Save As] dialog box. On clicking the [OK] button or
pressing the [Enter] key, the dialog box closes and the memory block will be saved into the disk as afile of the
specified format type.

A memory areain the address space can be verified using the memory verify function. Open the [Verify
Memory] dialog box by choosing [File -> Verify Memory...].

Yerify Memory

FEormat;
_Coneel|

Binary hd

File name:

Cancel

| =1
Offzet address:

Figure5.25 [Verify Memory] Dialog Box
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5511 Disabling Update of the Window Contents

Automatic update of the [Memory] window contents, which is performed when user program execution stops
and in other cases, can be disabled. Thisis done by checking [Lock Refresh] in the popup menu.

5512 Updating the Window Contents

The [Memory] window contents can be forcibly updated. Thisis done by checking [Refresh] in the popup menu.

55.13 Comparing the Memory Contents

The contents of two memory blocks can be compared. Open the [Compare Memory] dialog box by selecting
[Memory -> Compare...] from the main menu or by selecting [Compare...] from the popup menu of the
[Memory] window.

Carpare Memary 2 x|

Begin: Qf

I Cancel |

Start Compare:

Format:

I Byte G1) j

Figure5.26 [Compare Memory] Dialog Box

Enter the comparison format ([Format]), the start address ([Begin]) and end address ([End]) of the source
memory area, and the start address ([ Start Compare]) of the destination memory area. If the memory block is
already highlighted in the [Memory] window, the start and end addresses will be automaticaly filled in when the
[Compare Memory] dialog box is opened.

If there is amismatch, the address where it was found is displayed in a message box.
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55.14 LoadingaMemory Areafrom aFile

A file can be loaded to the debugging platform’s memory. Select [Load...] from the popup menu of the
[Memory] window to open the [Load Program] dialog box.

Load Program 2 x|
Format: Open
IElinary j
File name:

| =]
Offget address:

Figure5.27 [Load Program] Dialog Box

Enter the file format ([Format]) and the file name ([File name]). If theload address value is to be changed, enter
the offset value in the offset field ([Offset address]), otherwise enter zero.
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5.6 Viewing the /O Memory

A microcomputer contains on-chip periphera modules. The exact number and type of peripheral modules differ
between devices but the typical modules are a DMA controller, serial communicationsinterface, A/D converter,
integrated timer unit, bus state controller, and watchdog timer. Registers that are mapped to the microcomputer’s
address space controls the on-chip peripheral modules.

The [Memory] window enables you to look at datain continuous memory addresses as byte, word, longword,
single-precision floating-point, double-precision floating-point, or ASCII values. However, registers of different
sizes are allocated to non-continuous memory addressesin the I/O memory. To handle this memory, the HEW
has the [10] window to facilitate checking and setting up of these kinds of registers.

56.1 Opening the [10] Window

To open the [IO] window, select [View -> CPU -> Q] or click the [View I/Q] toolbar button ). Modules that
match the on-chip peripheral modules organize the 1/0O register information. When the [10] window is first
opened, only alist of module namesis displayed.

IO i)

Address Access

I»

OO0FEEDE?
OO0FEEDES H'0ol

#-[1] Interrupt Controller
#-[1] Bus_Controller

#-[]] Data Transfer Control
F-[1] If0 Port_1

F-[1] If0_Port_3

F-[1] If0_Port_4

FH-[1] If0_Port_7

F-[1] If0_Port_3

F-[1] If0 Port R

#-[1] If0_Port_B

F-[1] If0_Port_C

.77 TAN Dot N =
1| | 2]

Figure5.28 [10] Window

5.6.2 Expanding the /O Register Display

To display the names, addresses, and values of the 1/O registers, click the [+] mark at the left of the module name
or select the module name by clicking on it or using the cursor keys and press the [->] key. The module display
will expand to show the individual registers of that peripheral module and their names, addresses, and values.
Clicking the [-] mark at the | eft of the expanded module name or pressing the [<-] key will close the 1/O register

display.

For adisplay in the bit level, click the [+] mark at the |eft of the register name or select the register name by
clicking on it or using the cursor keys and press the [->] key. The register display will expand to show the names
of register bits and values. Clicking the [-] mark at the left of the expanded register name will close the register

bits display.
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5.6.3 Modifying the /O Register Contents

To edit thevaluein an I/O register, double-click or press the [Enter] key on the register to open a dialog box to
modify the register contents. When you have entered the new number or expression, click the [OK] button or
press the [Enter] key; the dialog box closes and the new vaue is written into the register.

5.7 Viewing the Current Status

Choose [View -> CPU -> Status] or click the [View Status] toolbar button ) to open the [Status] window and
see the current status of the debugging platform.

_ (O] x|
Item IStatus I

Target Device Configuration 00oo0000d - QO001lFFFF  Internal ROM
OOFFEBOOO — OOFFEFEF Internal RAM
OOFFF200 — 0OOFFFF3F Internal IO
OOFFFFE0 — OOFFFFEF Internal IO
OOFFFFCO — OOFFFFFF Internal RAM
System Memory Resources SIMM Module:
IME SIMM fitted
Fam Bases:
0: not used
l: not used
Z: not used
2: not used
Program Name Memory Loaded Area
...ator_cpiTutorial. abs H'00000000 - H'00000003
H'00000400 - H'000004E5
H'00001000 - H'0O00015FS
H'0000z000 - H'0000Z2139

| 4[> Memony £ Flatiorm } Events f

Figure5.29 [Status] Window

The [Status] window has three sheets:

e [Memory] sheet
Contains information about the current memory status including the memory mapping resources and the
areas used by the currently loaded object file.

» [Patform] sheet
Containsinformation about the current status of the debugging platform, typically including CPU type and
mode; and run status.

* [Events] sheet
Contains information about the current event (breakpoint) status, including resource information.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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5.8 Reading and Displaying the Emulator Information Regularly

Use the [Extended Monitor] window to know the changing information on the emulator no matter the user
program is running or halted.

Note:  The Extended Monitor function does not affect the execution of the user program since it monitors the
user system or the signal output from the MCU in the emulator by using the emulator’s hardware circuit.

581 Opening the [Extended Monitor] Window

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button displays
thiswindow. The interval of updating the display is approximately 1,000 ms during user program execution or
5,000 ms while breaking, respectively.

=10l x|
Item Value I
Uzer Standbhy Inactive
User NMI Inactive
User Reset Inactive
User Wait Inactive

Uzer System Voltage 0OE
Uzer System VoltageZ Dowm

User Cable Not Commected
Punning status Ereak = Ready
DOM Write No

Target Made 7

Target Clock No Clock
Target Sub Clock No Clock

Figure5.30 [Extended Monitor] Window
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5.8.2 Selecting Itemsto be Displayed

Selecting [Properties...] from the popup menu displays the [Extended Monitor Configuration] dialog box.

Extended Monitor Configuration
— pdate millzecond
Bunning: 100 Ereal: I 1000
Settingz:
Item | Walue -
Uger Standby Inactive
Lzer MM Inactive
Usger Reset Inactive
1 zer W ait Inactive
Usger Syztem Yolage ok |
Uzer Syztem Voltage2 Do
Usger Cable Mot Connected
Running ztatus Break = Ready _ILI
<] | »

Figure5.31 [Extended Monitor Configuration] Dialog Box
This diaog box allows the user to set the items to be displayed in the [Extended Monitor] window.

Note: Theitemsthat can be set in thisdialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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5.9 Displaying Memory Contentsin Realtime

Use the [Monitor] window to monitor the memory contents during user program execution. In the Monitor
function, the realtime operation is retained since the bus monitoring circuit of the emulator sets the read/write
signal of the MCU as atrigger and holds the address bus and data bus values to update the displayed contents of
the memory.

Up to eight points can be set by using the eight monitoring channels on the bus monitoring circuit. 1 to 256 bytes
can be monitored at one point. It is possible that apart or al of monitoring rangesis overlapped.

Note: Monitoring isimpossible for an area, such as an internal timer counter, where no internal read/write
signal is generated to update avalue.

59.1 Opening the [Monitor] Window

To open the [Monitor] window, select [View -> CPU -> Monitor -> Monitor Setting...] or click the [Monitor]
toolbar button ) to display the [Monitor Settings] dialog box.

Manitor Setting ﬂ ﬂ
Monitor Setting |
Name: |manitart
— Optionz
Address: IH'DDFFEF&D
Size [byte]: |H'2D =]
Access [Format]: IEYTE [BSCI ﬂ

v Auto-Refresh at rate [mz) : ID'EIEIEEIU

[+ Reading the Initial ¥alus

— Color
LChange Indicator: Il:hange j
Foreground: [N |~ Background: |:||v|
[ Mapfly
— Detail
IDETﬁIL HOT SUFPORTED! Detail |
— Higtory

| [|
Ok, I Cancel |

Figure5.32 [Monitor Setting] Dialog Box
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[Name]: Decides the name of the monitor window.

[Optiong]: Sets monitor conditions.
[Address]: Sets the start address for monitoring.
[Size]: Sets the range for monitoring.
[Access): Sets the access size to be displayed in the monitor window.

[Auto-Refresh at rate]:

[Reading the Initid Value]:

Setsthe interval for acquisition by monitoring (500 ms at minimum).

Selects reading of the values in the monitored area when the monitor
window is opened.

[Color]: Sets the method to update monitoring and the attribute of colors.

[Change Indicator]:

Selects how to display the values that have changed during monitoring
(available when [Reading the Initial VValue] has been selected).
No change: No color change.

Change: Color is changed according to the [Foreground] and [Background)]
options.

Gray: Those data with values that have not been changed are displayed in
gray.
Appear: A valueisonly displayed after changed.

[Foreground]: Sets the color used for display (available when [Change] has been selected).
[Background)]: Sets the background color (available when [Change] has been selected).
[Mayfly]: A check in this box selects restoration of the color of those data which have
not been updated in a specified interval to the color selected in the
[Background] option. The specified interval isthe interval for monitor
acquisition (available when [Change], [Gray], or [Appear] has been selected).
[Detail]: Sets the items specific to the emulator. Not used with this emulator.
[History]: Displays the previous settings.

Notes: 1. In thisemulator, odd addressees cannot be specified as the start addresses for monitoring.
2. Selection of the foreground or background color may not be available depending on the operating

systemin use.

After setting, clicking the [OK] button displays the [Monitor] window.

204

RENESAS



- HOOFFEFAD =10] x|
Address -
0x00FFEFAQ OD B3 00 00 06 FA ........
Ox00FFEFAS 00 00 00 00 00 Q00 00 00 . .......
O0x00FFEFEQ 00 00 00 00 00 00 00 00 ........
Ox00FFEFES 00 00 10 36 00 00 04 1E P R LI

Figure5.33 [Monitor] Window
During user program execution, the display is updated according to the setting value of the auto-update interval.

Note:  Select [Refresh] from the popup menu when datais not displayed correctly after changing the address or
content of memory.

59.2 Changing the Monitor Settings

Selecting [Monitor Setting...] from the popup menu of the [Monitor] window displays the [Monitor Setting]
dialog box, which alows the settings to be changed.

Colors, the size of accesses, and the display format can be easily changed from [Color] or [Access] of the popup
menu.

593 Temporarily Stopping Update of the M onitor

During user program execution, the display of the [Monitor] window is automatically updated according to the
auto-update interval. Select [Lock Refresh] from the popup menu of the [Monitor] window to stop the update of
display. The characters in the address section are displayed in black, and the update of display is stopped.

Selecting [Lock Refresh] again from the popup menu cancels the stopped state.

594  Deleting the Monitor Settings

Selecting [Close] from the popup menu of the [Monitor] window to be deleted closes the [Monitor] window and
deletes the monitor settings.

595 Monitoring Variables
Using the [Watch] window refersto the value of any variables.

When the address of the variable registered in the [Watch] window exists within the monitoring range that has
been set by the Monitor function, the value of the variable can be updated and displayed.

This function allows checking the content of a variable without affecting the realtime operation.

For the [Watch] window, refer to section 5.14.3, [Watch] Window.
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5.9.6 Hiding the [Monitor] Window

When using the Monitor function to monitor the value of a variable from the [Watch] window, hide the
[Monitor] window for the effective use of the screen.

The current monitoring information is listed as the submenu when selecting [Display -> CPU -> Monitor]. The
list consists of the [Monitor] window name and the address to start monitoring.

When the left of thelist is checked, the [Monitor] window is being displayed.

Selecting items of the [Monitor] window you want to hide from the monitor setting list displays no [Monitor]
window and removes the check mark at the | eft of thelist.

To display the [Monitor] window again, select the hidden the [Monitor] window.

4 3 Monitor Setting... Shift+Cil+E

| v monitor2 - HODFFEODS
monitor] - H'OOFFEFS0

Windows Select. .

Figure5.34 Monitor Setting List

59.7 Managing the [Monitor] Window

Selecting [Display -> CPU -> Monitor -> Windows Select...] displays the [Windows Select] dialog box. In this
window, the current monitoring condition is checked and the new monitoring condition is added, edited, and
deleted in succession.

Selecting multiple monitoring conditions enables a temporary stop of update, hiding, and deletion.

Name Address
monitor2 H'00FFBODS
monitorl H'00FFEF80

Add...

Edit...

Lock Refresh?

Hide?

Bemove

Close |

Figure5.35 Selectionin the[Monitor] Window
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[Add]: Adds a new monitoring condition.

[Edit]: Changes the settings of the selected [Monitor] window (disabled when selecting multiple
items).
[Lock Refresh/Unlock Refresn):

Automatically updates or stops updating the display of the selected [Monitor] window.
[Hide/lUnHide]: Displays or hides the selected [Monitor] window.
[Remove]: Removes the selected monitoring conditions.

[Close]: Closes this dialog box.
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510 Lookingat Labels

Symbol information is included in the debugging information, which is used when the HEW links the user
program source code to the actual code in the memory. Symbol information is aso included in the debug object
file. Thisinformation is alist of names that indicate addresses in the program. These names are called labels in
the HEW. The [Disassembly] window shows the first eight characters of each label instead of the corresponding
address or as apart of an instruction operand *.

Note:  When alabel value matches an operand, the corresponding instruction operand is replaced by the label.
If two or more |abels have the same value, the one that comes first in alphabetical order is displayed.
When [edit control] accepts an address or avalue, alabel can be entered instead.

5.10.1 ListingLabels

Choose [View -> Symbol -> Labels] or click the [View Labels] toolbar button ) tolist all labels defined in
the current debugger session.

e

EP I Address I Nane -
H'00001000 _sbrk
H'00001034 _main
H'00001038 tutoriall)
H'00001104 _ahort
H'0o0ool1oc _ INITECT
H'0000Ll1zZ loopl
H'0000Ll1zC loopZ
H'000011ZE next_loopZ
H'00001132 next_loopl
H'00001144 loop3
H'0000Ll152 loopd
H'00001153 next_loopd
H'0000115C next_loop3
H'oooolles operator newiunsigned long!
H'0000L11EE _ CALL_INIT
H'0000L1ED _ CALL_END
H'Q00011E4 operator delete(void *)
H'0000L1EE _rand
H'0000lZze _srand
H'00001Z32 $DIVLE3
H'00001z3C not_negx -

A | v

Figure5.36 [Label] Window

Y ou can view symbols sorted either alphabetically (by ASCII code) or by address value by clicking on the
respective column heading.

Double-clicking in the [BP] column can set or clear a software breakpoint at the start of the function.
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5.10.2 AddingaLabel

Choose [Add..] from the popup menu and open the [Add Label] dialog box to add alabel:

Aidd Label EHE

MHame: || ﬂ oK I
fAddress: [Ho0oaoao0 =l Gancel |

Figure5.37 [Add Label] Dialog Box

Enter the new label name into the [Name] field and the corresponding value into the [Address] field and press
[OK]. The [Add Label] dialog box closes and the label list is updated to show the new label. When an
overloaded function or a class name is entered in the [Address] field, the [Select Function] dialog box opens for
you to select a function. For details, refer to section 5.13.3, Supporting Duplicate Labels.

5.10.3 EditingaLabel

Choose [Edit...] from the popup menu and open the [Edit Label] dialog box to edit alabel:

Edit Label _main

Mame: |_ma in j CK I

Address: [HoooooToTZ] =l Gancel |

Figure5.38 [Edit Label] Dialog Box

Edit the label name and value as required and then press [OK] to save the modified version in the label list. The
list display is updated to show the new label details. When an overloaded function or a class nameisentered in
the [Address] field, the [Select Function] dialog box opens for you to select a function. For details, refer to
section 5.13.3, Supporting Duplicate Labels.
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5104 DeletingaLabel

To deletealabel, select the label and choose [Delete] from the popup menu. A confirmation message box
appears:

Confirmation Request

Delete Label BTEL

I~ Don't ask this question again

Ok I Cancel i

Figure5.39 Message Box for Confirming L abel Deletion

If you click [OK], the label is removed from the list and the window display is updated. If the message box is not
required then do not select the [Delete Label] option of the [Confirmation] sheet in the HEW [Options] dialog
box.

5.10.5 Deleting All Labels

To delete all the labels from the list, choose [Delete All] from the popup menu. A confirmation message box
appears:

Confirmation Rec

Delete All Labels

I Daon't ask this question again

Cancel i

Figure5.40 Message Box for Confirming All Label Deletion

If you click [OK], al the labels are removed from the HEW system’s symbol table and the list display will be
cleared. If the message box is not required, do not select the [Delete All Labels] option of the [Confirmation]
sheet in the HEW [Options] dialog box.
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5.10.6 LoadingLabelsfrom aFile

A symbol file can be loaded and merged into the HEW's current symbol table. Choose [Load...] from the popup
menu to open the [Load Symbols] diaog box:

Load Symbols

Lok jr: |¢3H83tut j ﬁl Ig
tutarial. spm

File narme: Im_l,l_cnde. aum Open I
Files of lwpe: IS_I,Ime| Files [*.spm)] j Cancel |

Figure5.41 [Load Symbols] Dialog Box

The dialog box operates like a standard Windows® [open file] dialog box; select the file and click [Open] to start
loading. The standard file extension for symbol filesis*“.sym”. When the symbol loading is complete a
confirmation message box may be displayed showing how many symbols have been loaded (this can be switched
off in the [Confirmation] sheet on the HEW [Options] dialog box).

5.10.7 SavingLabesintoaFile

Choose [Save As...] from the popup menu to open the [Save Symbols] dialog box. The [Save Symbols] dialog
box operates like a standard Windows” [Save File As] dialog box. Enter the name for the file in the [File name]
field and click [Save] to save the HEW's current label list to asymbal file. The standard file extension for
symbol filesis*“.sym”.

See appendix E, Symbol File Format, for the symbol file format.

Once afileis specified by the [Save As...] menu, the current symbol table can be saved in the same symbol file
just by choosing [Save] from the popup menu.

5.10.8 Searching for aLabel

Choose [Find...] from the popup menu to open the [Find Label] dialog box:

Find Label

Mame: I ;I o] 4 I
[~ Match Gaze I ;I Gancel |

Figure5.42 [Find Label] Dialog Box
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Enter all or part of the label name that you wish to find into the edit box and click [OK] or press the [Enter] key.
The HEW searchesthe label list for alabel name containing the text that you entered.

Note:  Only the label is stored by 1024 characters of the start, therefore the label name must not overlap
mutually in 1024 characters or less. Labels are case sensitive.

5.10.9 Searching for the Next Label

Choose [Find Next] from the popup menu to find the next occurrence of the label containing the text that you
entered.

5.10.10 Viewing the Source Corresponding to a Label

Select alabel and choose [View Source] from the popup menu to open the [Source] or [Disassembly] window
containing the address corresponding to the label.
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511  Executing Your Program

This section describes how you can execute your program's code. Y ou will learn how to do this by either running
your program continuously or stepping single or multiple instructions at atime.

5111 Running from Reset

To reset your user system and run your program from the reset vector address, choose [Debug->Reset Go], or
click the [Go Reset] toolbar button ([EL]).

The program will run until it hits a breakpoint or abreak condition is met. Y ou can stop the program manually
by choosing [Debug->Halt], or by dlicking the [Hal] toolbar button (&)

Note:  The program will start running from whatever addressis stored in the Reset Vector location. Therefore it
isimportant to make sure that this location contains the address of your startup code.

5.11.2 Continuing Run

When your program is stopped, the HEW will display an yellow arrow mark in the gutter of the line in the editor
and [Disassembly] windows that correspond to the CPU's current program counter (PC) address value. Thiswill
be the next instruction to be executed if you perform a step or continue running.

To continue running from the current PC address, click the [Go] toolbar button , or choose [Debug->Go].

To continue running from a specified address which is not the stop address, change the PC value in one of the
following ways, and click the [Go] toolbar button ([EL]) or choose [Debug->Ga.

» Changethe PC valuein the [Register] window. Refer to section 5.4.3, Modifying Register Contents.
» Place the text cursor (not the mouse cursor) to atarget linein the [Source] or [Disassembly] window, and
choose [Set PC Here] from the popup menu.

5.11.3 Running to the Cursor

Sometimes as you are going through your application you may want to run only a small section of code, that
would require many single steps to execute. Y ou can do this using the Go To Cursor feature.

2 How to use the Go To Cursor

1. Make surethat a[Source] or [Disassembly] window is open showing the address at which you wish to stop.
2. Position the text cursor on the address at which you wish to stop by either clicking in the [Address] field or
using the cursor keys.

3. Choose [Go To Cursor] from the popup menu.

The debugging platform will run your code from the current PC value until it reaches the address indicated by
the cursor's position.

Notes: 1. If your program never executes the code at this address, the program will not stop. If this happens,
code execution can be stopped by pressing the Esc key, choosing [Debug->Halt], or clicking on the
[Halt] toolbar button ().
2. The Go To Cursor feature requires a PC breakpoint - if you have already used all those available, then
the feature will not work.
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5.114 Running from a Specified Address

The [Run Program] dialog box allows the user to run the program from any address. Choose [Debug -> Run...]
to open the [Run Program] dial og box.

Run Program

PBrogram Gounter:
|H'DDDDDDDD|

Beset Go
Temporary PG Breakpoints:

2
x

Cancel

Figure5.43 [Run Program] Dialog Box
The following execution conditions can be specified in this dialog box:

[Program Counter]: Instruction address to start execution. Theinitial valueis
the current PC value.

[Temporary PC Breakpoints]: A temporary PC breakpoint. When execution started
by this dialog box stops, this breakpoint is cleared.

Note: The[Temporary PC Breakpoints] feature requires a PC breakpoint - if you have already used all those
available then the feature will not work.

Clicking the [Go] button starts execution according to the settings. Clicking the [Reset Go] button starts
execution from the reset vector. Clicking the [Cancel] button closes this dialog box without executing
instructions.
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5115 Single Step

To debug your codeit isvery useful to be able to step asingle line or instruction at a time and examine the effect
of that instruction on the system. In the [Source] window, then a step operation will step asingle sourceline. In
the [ Disassembly] window, a step operation will step a single assembly-language instruction. If the instruction
calls another function or subroutine, you have the option to either step into or step over the function. If the
instruction does not perform acall, then either option will cause the debugger to execute the instruction and stop
at the next instruction.

*  Stepping Into a Function

If you choose to step into the function the debugger will execute the call and stop at the first line or instruction of
the function. To step into the function either click the [Step In] toolbar button (), or choose [Debug->Step In].

*  Stepping Over a Function Call

If you choose to step over the function the debugger will execute the call and al of the code in the function (and
any function callsthat that function may make) and stop at the next line or instruction of the calling function. To
step over the function either click the [Step Over] toolbar button ), or choose [Debug->Step Over].

*  Stepping Out of a Function

There are occasions when you may have entered a function, finished stepping through the instructions that you
want to examine and would like to return to the calling function without tediously stepping through al the
remaining code in the function. Or aternatively you may have stepped into a function by accident, when you
meant to step over it and so want to return to the calling function without stepping all the way through the
current function. Y ou can do this with the Step Out feature.

To step out of the current function either click the [Step Out] toolbar button (), or choose [ Debug->Step Out].
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5.11.6 Multiple Steps

You can step severd instructions at atime by using the [Step Program] dialog box. The dialog box aso provides
an automated step with a selectable delay between steps. Open it by choosing [Debug-> Step...].

The [Step Program] dialog box is displayed:

Step Prozram 2l

Steps:

H 00000001

Delay (zeconds)

|1 - 25 geconds j
[~ Step Ower Galls

[~ Source Level Step

814 I Cancel |

Figure5.44 [Step Program] Dialog Box

[Steps): Number of stepsto be executed.

[Delay (seconds)]: Delay between steps when the program is automatically stepped.
Value 0 to 6 can be specified where value 0 indicates the longest delay.

[Step Over Callg]: Selecting this box steps over function calls.

[Source Level Step]: Selecting thisbox steps the program at the source level.

Clicking the [OK] button or pressing the [Enter] key starts step execution.
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512  Stopping Your Program

This section describes how you can halt execution of your application's code. This section describes how to do
thisdirectly by using the [Halt] button and by setting breakpoints at specific locations in your code.

5121 Halting Execution

When your program is running, the [Halt] toolbar button is enabled (ared STOP sign), and when the
program has stopped it is disabled (I:l) (the STOP sign is grayed out). Click on the [Halt] toolbar button, or
choose [Debug->Halt Program].

When the program has been stopped by [Halt], "Stop" is displayed in the [Debug] sheet of the [Output] window.

5.12.2 Standard Breakpoints (PC Breakpoints)

When you are trying to debug your program you will want to be able to stop the program running when it
reaches a specific point or pointsin your code. You can do this by setting a PC breakpoint on the line or
instruction at which to want the execution to stop. The following instructions will show you how to quickly set
and clear simple PC breakpoints. If more complex breakpoint operation is required, use the [Event] window,
which can be opened by clicking the ) button or choosing [View -> Code -> Eventpoints]. For details, refer
to section 5.15, Using the Event Points.

» To set aPC breakpoint in the [Source] window

1. Make surethat the [Disassemble] or a[Source] window is open at the place you want to set a PC
breakpoint.

2. Choose [Toggle Breakpoint] from the popup menu, or press F9, at the line showing the address at which
you want the program to stop.

3. Youwill seeared circle appear in the gutter to indicate that a PC breakpoint has been set.

4. The current breakpoint set can be enabled or disabled by using [Enable/Disable Breakpoint] in the popup
menu.

Now when you run your program and it reaches the address at which you set the PC breakpoint, execution hats
with the message "PC Break" displayed in the [Debug] sheet of the [Output] window, and the [Source] or
[Disassembly] window is updated with the PC breakpoint line marked with an arrow in the gutter.

Note:  When abreak occurs, the program stops just beforeiit is about to execute the line or instruction at which
you set aprogram PC breakpoint. If you choose Go or Step after stopping at the PC breakpoint, then the
line marked with an arrow will be the next instruction to be executed.
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e Toset aPC breakpoint by using the [Breakpoints] dialog box
Selecting [Edit -> Source Breakpoint...] displays the [Breakpoints] dialog box.

Cancel |
Edit Code |
Remaove |
Remaove All |

Figure5.45 [Breakpoints] Dialog Box

The [Breakpoints] dialog box allows the user to view the current breakpoints set. Clicking the [Edit Code] button
displays the source where each breakpoint is set. The [Remove] or [Remove All] button deletes one or all
breakpoints, respectively. The check box of each breakpoint enables or disables the breakpoint.

* Totoggle PC breakpoints
It is possible to toggle the [PC Breakpoints] setting by either double-clicking in the [BP] column of theline
where the PC breakpoint is set or placing the cursor on the line and pressing the [F9] key. The setting to be
toggled depends on the debugging platform.
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513 Elf/Dwarf2 Support

The HEW supports the Elf/Dwarf2 object file format for debugging applications written in C/C++ and assembly
language for Renesas microcomputers. It provides a powerful way of accessing, observing and modifying the
symbolic level debugging information about the user application that is running.

Key Features

» Source level debugging
e C/C++ operators

e C/C++ expression (casting, pointers, references, etc.)

* Ambiguous function names
* Overlay memory loading

¢ Watch - locas, and user defined

e Stack Trace

5131 C/C++ Operators

The C/C++ language operators are available:

55L& N S>> <%, (), <, >, <=5, =5, 15, &4, ||

Buf fer_start + 0x1000
#R1 | B 10001101

((pointer + (2 * increnent_size)) & H FFFF0000) >> D 15

I(flag ~ #ER4)

5.13.2 C/C++ Expressions
Expression Examples

oj ect . val ue

p_oj ect - >val ue

Cl ass: :val ue

*val ue

&val ue

array| 0]

oj ect . *val ue

::g_val ue

Cl ass::function(short)
(struct STR) *val ue

/ISpecifies direct reference of amember (C/C++)
/ISpecifies indirect reference of amember (C/C++)
//Specifies reference of a member with class (C++)
//Specifies apointer (C/C++)

/ISpecifies areference (C/C++)

/ISpecifies an array (C/C++)

//Specifies reference of a member with pointer (C++)
//Specifies reference of aglobal variable (C/C++)
//Specifies amember function (C++)

//Specifies cast operation (C/C++)
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5.13.3 Supporting Duplicate L abels

In some languages, for example C++ overloaded functions, alabel may represent more than one address. When
such alabel nameisentered in adiaog box, the HEW will display the [Select Function] dialog box to display
overloaded functions and member functions.

Seleck Funckion ﬂﬂ

Select Function Mame Set Function Mame

{5 ample::sortilong 1 N
{Sample:sort{lang #, shart] |

— Counter
All Function Select Function Set Function

|2 Functions |2 Functions ID Functions

Cahicel

Figure5.46 [Select Function] Dialog Box

Select overloaded functions or member functionsin the [Select Function] dialog box. Generally, one function
can be selected at one time; only for setting breakpoints, multiple functions can be selected. This dialog box has
three areas.

[Select Function Name]:  Displays the same-name functions or member functions and
their detailed information.

[Set Function Name]: Displays the function to be set and their detailed information.

[Counter]: [All Function] Displays the number of same-name functions
or member functions.
[Select Function] Displays the number of functions displayed
in the [Select Function Name] list box.
[Set Function] Displays the number of functions displayed
in the [Set Function Name] list box.

Selecting a Function

Click the function you wish to select in the [Select Function Name] list box, and click the [>] button. Y ou will
see the selected function in the [Set Function Name] list box. To select al functionsin the [Select Function
Name] list box, click the [>>] button.

Deselecting a Function

Click the function you wish to deselect from the [Set Function Name] list box, and click the [<] button. To
deselect all functions, click the [<<] button. The deselected function will be moved from [Set Function Name]
list box back to the [Select Function Name] list box.
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Setting a Function

Click the [OK] button to set the functions displayed in the [Set Function Name] list box. The functions are set
and the [Select Function] dialog box closes.

Clicking the [Cancel] button closes the dialog box without setting the functions.

5.13.4 Debugging an Overlay Program
This section explains the settings for using the overlay functions.
Displaying Section Group

When the overlay mode is used, that is, when several section groups are assigned to the same address range, the
address ranges and section groups are displayed in the [Overlay] dialog box.

Open the [Overlay] dialog box by choosing [Memory->Configure Overlay].

2l
Addreszs; Section Mame:
QOFFES0N - OOFFEADE oK I
Cancel |

Figure5.47 [Overlay] Dialog Box (at Opening)
This diaog box has two areas: the [Address] list box and the [Section Name] list box.

The [Address] list box displays the address ranges used in the overlay mode. Click to select one of the address
rangesin the [Address] list box.

Section Mame:

R_zample K |
RA_zart

R_change Cancel |

Figure5.48 [Overlay] Dialog Box (Address Range Selected)

The [Section Name] list box displays the section groups assigned to the selected address range.
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< Setting section group

When using the overlay function, the highest-priority section group must be selected in the [Overlay] dialog box;
otherwise the HEW will operate incorrectly.

First click one of the address ranges displayed in the [Address] list box. The section groups assigned to the
selected address range will then be displayed in the [Section Name] list box.

Click to select the section group with the highest-priority among the displayed section groups.

Addreszs; Section Mame:

Cancel |

Figure5.49 [Overlay] Dialog Box (Highest-Priority Section Group Selected)

After selecting a section group, clicking the [OK] button stores the priority setting and closes the dialog box.
Clicking the [Cancel] button closes the dial og box without storing the priority setting.

Note:  Within the address range used by the overlay function, the debugging information for the section
specified in the [Overlay] dialog box is referred to. Therefore, the same section of the currently loaded
program must be selected in the [Overlay] diaog box.
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514 Looking at Variables

This section describes how you can look at variablesin the source program.

5141 Tooltip Watch
The quickest way to look at avariablein your program isto use the Tooltip Watch feature.
< Touse Tooltip Watch:

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the variable
containing basic watch information for that variable.

& o_=am= Sample;
=3 for{ 1=0; i<10; i4++ 3 {
i = rand(): [H'OOD3]
(3 ¢ 03]
1 = -1
ali] = 3:

Figure5.50 Tooltip Watch

5.14.2 Instant Watch

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine and choose [Instant Watch...] from the
popup menu; the [Instant Watch] dialog box will appear and display the variable at the cursor location.

Instant Watch

st {0x7c000088 | istruct strB)

Figure5.51 [Instant Watch] Dialog Box

“+" shown to the left of the variable name indicates that the information may be expanded by clicking on the
variable name, and “-” indicates that the information may be collapsed. Clicking [Add] registersthe variable in
the [Watch] window. Clicking [Close] closes the window without registering the variable in the [Watch] window.

223
RENESAS




5.14.3 [Watch] Window
You can view any vaue in the [Watch] window.
Opening a [Watch] Window

To open a[Watch] window, choose [View->Symbol->Watch] or click on the [Watch] toolbar button ifitis
visble. A [Watch] window opens. Initialy the contents of the window will be blank.

=101 x|
I Walue I Twpe
{ 0x7c000024 | tint[10])
HDA0000a0 { 0x7c000024 } tint}
HDA0000a0 { 0x7c000028 } {int}
HDA0000a0 { 0x7c00002c } {int}
HDA0000a0 { 0x7c000030 } {int}
HDA0000a0 { 0x7c000034 } {int}
HDA0000a0 { 0x7c000038 } {int}
HDA0000a0 { 0x7c00003c } {int}
H0A0000a0 { 0x7c000040 } {int}
HDA0000a0 { 0x7c000044 1 {int}
HDA0000a0 { 0x7c000048 1 {int}
HDA0000a0 { 0x7c00004c } {int}

Figure5.52 [Watch] Window

Thiswindow allows the user to view and modify C/C++-source level variables. The contents of this window are
displayed only when the debugging information available in the absol ute file (*.abs) includes the information on
the C/C++ source program. The variable information is not displayed if the source program information is
excluded from the debugging information during optimization by the compiler. In addition, the variables that are
declared as macro cannot be displayed.

Thefollowing items are displayed.

[Name]: Name of the variable
[Valug]: Value and assigned location.
The assigned location isenclosed by { }.
[Type]: Type of the variable
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The [R] mark shows that the value of the variable can be updated during user program execution.

For updating of the content of the variable that has been registered in the [Watch] window, there are the
following three methods:

1. Usethe Monitor function without halting the user program
The read/write signal of the MCU is set as atrigger and holds the address bus and data bus values to update the
vaue of thevariable.

Note:  Although the realtime operation is retained, the size and number points to be monitored are limited. For
the Monitor function, refer to section 5.9, Displaying Memory Contentsin Reatime.

2. Read the memory content directly from the HEW to update the values without halting the user program since
the bus mastership is owned by the emulator

Note:  While the emulator reserves the bus mastership, the realtime operation is disabled because the CPU stops
operation. This method is only available for accessing the interna ROM, internal RAM, and emulation
memory.

The area used here or this method may not be available depending on the emulator in use. For details,
refer to section 8, Software Specifications Specific to This Product, or [Enable read and write on the fly]
on the [General] page of the [Configuration Properties] dialog box in the online help.

3. Temporarily stops the user program and reads the memory contents

Note: The realtime operation is disabled because the user program is stopped temporarily. This method is only
available for accessing the areas (interna 1/0O, DTCRAM, and user memory) other than those in item 2
mentioned above.

It is possible to recognize the method for updating the value during user program execution according to the
color of the [R] mark.

Blue-outline[R]:  The variable's address is within the range that has been set for the monitoring function and
the datais readable by using the monitoring function.

Blue [R]: An updated value of the data at this |ocation has been read by the monitoring function.

Black-outline [R]:  The variable's address is outside the range that has been set for the monitoring function and
the dataiis not readable by using the monitoring function.

Black [R]: A value has been updated by reading the normal data.

Notes: 1. Thisfunction can be set per variable or per element or body for structures of data.
2. Thecolor of an [R] in the [Name] column changes according to the trace and monitoring settings.

3. Theinformationislost when it is scrolled out of the [Watch] window and when the window is
closed.

4. A variablethat is alocated to aregister cannot be selected for monitoring.
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Adding a Watch Item
Use the [Add Watch] dialog box in the [Watch] window to add Watch items to the [Watch] window.
< To use Add Watch from a [Watch] window:

Open the [Watch] window.
Choose [Add Watch] from the popup menu.
The [Add Watch] dialog box opens:

Add Wiatch 2%

Wariable or expression;

a Cancel

f

Figure5.53 [Add Watch] Dialog Box

Enter the name of the variable that you wish to watch and click [OK]. The variable is added to the [Watch]
window. A variable can be dragged from the [Source] window and dropped into the [Watch] window.

Note: If the variable that you have added isalocal variable that is not currently in scope, the HEW will add it
to the [Watch] window but its value will be blank, or set to a question mark, '?.

Expanding a Watch Item

If awatch item isapointer, array, or structure, then you will see aplus sign (+) expansion indicator to left of its
name, this means that you can expand the watch item. To expand a watch item, double click on it. Theitem
expands to show the elements (in the case of structures and arrays) or data vaue (in the case of pointers)
indented by one tab stop, and the plus sign changesto aminussign (-). If the elements of the watch item also
contain pointers, structures, or arrays then they will aso have expansion indicators next to them.

Expansion
indicater
i i [

Expardeduatch | | = 5 R [0 H'O0000HE { x0I0fFer a0 } flang)
----- R 0] H'000015b { 0x00ef34 } flong]
----- R [ H'0000167e { Dx00ffef8s } flong]
----- R [ H'00001 cfb { 0x00fefBc } flong]
----- R [ H'00002781 { D400ffef30 } flong]
----- R [ H'00003454 { 0x00ff=f34 } flong]
----- R [ H'000041 06 { D40Dffef35 } flong]
----- R [7] H'0000446b { Dx0DffefSc } flong]
----- R [ H'000058.2 { Dx00ffefal } flong]
----- R [ H'0000734b { Dx00ffefad } flong]

Collapsectwatch F-E a { D=00ffef80 } long[10]]

1| | LI

Figure5.54 Expanding a Watch Item

To collapse an expanded watch item, double click on the item again. The item's elements will collapse back to
the single item and the minus sign changes back to a plus sign.
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Editing a Watch Item's Value

Y ou may wish to change the value of awatch variable, e.g. for testing purposes or if the value isincorrect due to
abug in your program. To change a watch item's value use the Edit Value function.

< Editing awatch item'svalue:
Enter avalue directly in the window.

In another way, select the item to edit by clicking on it, you will see aflashing cursor on the item.
Choose [Edit Vaue] from the popup menu.
The [Edit Value] dialog box opens:

Expression: I[D]

Current H'00000KE { 0+00ffefa0

Wallur ok I
Mew ' alue: I

LCancel

Figure5.55 [Edit Value] Dialog Box

Enter the new value or expression in the [New Value] field and click [OK]. The [Watch] window is updated to
show the new value.

227
RENESAS




Deleting a Watch Item

To delete awatch item, select it and choose [Delete] from the popup menu. The item is deleted and the [Watch]
window is updated.

To delete all watch items, choose [Delete All] from the popup menu. All items are deleted and the [Watch]
window is updated.

Specifying Realtime Update

The R mark shown to the left of each variable indicates whether the variable is updated in real time. When an R
mark is displayed in bold face, the value of the corresponding variable will be updated in realtime during user
program execution.

A popup menu containing the following optionsis available in the [Watch] window:

e Auto Update
Marks the selected variable with abold R and updates the variable in real time.
* Auto Update All
Marks al variables with bold Rs and updates al variablesin real time.
* Delete Auto Update
Marks the sel ected variable with an outlined R and cancels realtime update.
* Delete Auto Update All
Marks al variables with outlined Rs and cancels reatime update.

M odifying the Radix
The radix for the selected variable display can be modified by choosing [Radix] from the popup menu.
Saving the [Watch] Window Contentsin a File

To save the contents of the [Watch] window, choose [Save As...] from the popup menu; the Save As diaog box
opens. It allows the user to specify the name of afile and to save the contents of the [Watch] window in thefile.
If the [Append] check box is selected, the window contents are appended to the existing file, and if it isnot
selected, the existing file is overwritten.

Opening a[Memory] Window

The contents of the memory area to which the selected variable is assigned can be displayed in the [Memory]
window. Choose [Go To Memory...] from the popup menu; the [Set Address] dialog box opens, showing the
information (start address, end address, and size) of the selected variable as default. Clicking [OK] opensthe
[Memory] window.
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5.144 [Locals) Window
Thelocal variables and their values can be displayed in the [Locals| window.
Opening the [L ocals] Window

To open the [Locals] window, choose [View->Symbol->Locals] or click the [Locals] toolbar button ().

-1l =

[long[10])
H'O0ffef20 { ERG } [long)
H'O0Da{R4} [irt]
Ox00b0dS { ERE } [claze Sample®)

Figure5.56 [Locals] Window

If alocal variableis not initialized when defined, then the value of the local variable will be incorrect until
another value is assigned to the loca variable.

Thelocal variable values and the radix for local variable display can be modified in the same manner asin the
[Watch] window.
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515 Usingthe Event Points

The emulator has the event point function that performs breaking, tracing, and execution time measurement by
specifying higher-level conditions along with the PC breakpoints standard for the HEW.

5151 PC Breakpoints
When the ingtruction of the specified address is fetched, the user program is stopped. Up to 256 points can be set.

Note that, however, only one PC breakpoint can be set in the ROM area of the user system. This particular
breakpoint is called the on-chip breakpoint, which stops the user program after executing the instruction of the
specified address.

When it is necessary to set two or more PC breakpoints to the external ROM area of the user system, allocate
this area to the emulation memory, copy the code, and then set the PC breakpoints.

5.15.2 Event Points

Event points can be used for higher-level conditions such as the data condition as well as specification of the
single address. Up to 12 event points can be set by using event channels and range channelsin the event
detection system.

When the condition is satisfied, event points are also used as the start/end conditions for execution time
measurement or trace acquisition in addition to halting the user program. Several event points can be used to set
more complex conditions.

Note: Event points acquire the data, test conditions, and execute an action (such as halting the user program)
by the hardware circuit of the emulator. Therefore, adelay of several cycleswill occur from the
satisfaction of the condition to the execution of an action.

5.15.3 Event Detection System

In addition to the 4 range channels, the emulator also has 8 event channels. The event channels have more
functions (such as sequencing or counting) than the range channels.

Event Channels (Ch1 to Ch8):

The emulator has 8 event channels. The event channel can be defined as a combination of one or more of the
followings:

e Anaddress or an address range

e Outside of an addressrange

*  Aread, awrite, or either

» Datawith amask specification

* Busstate

e Area

e Thevalue of four external probe signas

*  Thenumber of timesthe event has occurred

*  Thenumber of delay cycles after the event has occurred
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A maximum of eight points can be used as a combination in a sequence. The emulator is activated or halted by
an occurrence of the previous event in each sequence.

Range Channels (Ch9 to Ch12):
The emulator has 4 range channels. The range channel can be defined as a combination of one or more of the
followings:

e Anaddress or an address range

*  Outside of an address range

* Aread, awrite, or either

» Datawith amask specification

* Busstate

e Area

e Thevalue of four external probe signas

*  Thenumber of delay cycles after the event has occurred

5.154 Signalsto Indicate Bus Statesand Areas

In the event detection system, signalsindicating the MCU'’ s bus states and the accessed areas can be specified as
the event detection condition.

These signals are output from the MCU on the emulator; the signals to be acquired will vary according to the
emulator in use.

The signals to indicate bus states and areas are used to set the [Bus/Area] condition of the event point. They can
also be acquired as the trace information.

The bus state signals are a so used to set the condition not to acquire the trace ([Suppress] option) and in the
Access Count Of Specified Range Measurement mode for measuring the hardware performance ([Access Type]
option).

For the trace function, refer to section 5.16, Viewing the Trace Information. For the hardware performance
function, refer to section 5.20, Analyzing Performance.

The following tables show examples of signalsto indicate the bus states and areas that can be acquired by the
emulator.

Table5.1 Bus State Signals Acquired by the Emulator

Bus State Trace Display (Status) Description

CPU Prefetch PROG CPU prefetch cycles
CPU Data DATA CPU data access cycles
Refresh REFRESH Refresh cycles

DMAC DMAC DMAC cycles

DTC DTC DTC cycles

Other OTHER Others
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Table5.2 AreaSignals Acquired by the Emulator

Area Trace Display (Status) Description
On-chip ROM ROM ROM

On-chip RAM RAM RAM

On-chip 1/0O 16bit 1/0-16 16-bit 1/0

On-chip 1/0 8bit 1/0-8 8-bit I/0

External /0 16bit EXT-16 16-bit EXT (external)
External 1/0 8bit EXT-8 8-bit EXT (external)
DTC RAM RAM/DTC DTCRAM

Note: The signals to indicate the bus states and areas vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

5.155 Opening the [Event] Window

Select [View -> Code -> Eventpoints] or click the [Eventpoints] toolbar button to open the [Event] window.

The [Event] window has the following three sheets:

[Breakpoint] sheet: Displays the settings made for PC breakpoints. It is also possible to set, modify, and
cancel PC breakpoints.

[Event] sheet: Displays or sets event points.

[Trigger] sheet: Displays or setstrigger points.

5.15.6  Setting PC Breakpoints

It is possible to display, modify, and add PC breakpoints on the [Breakpoint] sheet.

=10l
Type State Condition Action

Program Enable PC=H'O000105CiTutorial.cpp/dz) Break

Program Enabhle PC=H'000010CE (Tutorial.cpp/53) EBreak

Program Enable PC=H'OO001772 Break

s i
4 [+ [, Breakpoint £ Event A Trigger f

Figure5.57 [Event] Window ([Breakpoint] Sheet)
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Select [Add...] or the PC breakpoint displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Properties |
General |
~Tupe Addrezs
i € Don't Care ¢ Addiess € Bange
Address Lo [
£ Event & . |H00000000
Address H - [HO0000000
[ Outside Fange
r Data Compare Direction—
[ Compare [T Lze bask " Head
Walue [
- IHD ) write
% Byte £ Wwiod
Mask IH,D g ElthEl

ak I Cancel |

Figure5.58 [Breakpoint/Event Properties] Dialog Box (Setting a PC Break)

In thisdiaog box, select the address condition to set PC breakpoints.

[Typel: Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables

or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options are invalid.

[Event]: Set conditions in detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Set address conditions.

[AdderessLo]: Select asingle address where a PC breakpoint will be set.
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5.15.7  Setting Event Points

On the [Event] sheet, the settings for event points are displayed, modified, and added.

lolx]
Ty¥pe dtate Condition I Action ~
Chl (E) Enable Address=H'00001064 (Tutorial.cpp/37) address bus prefetch Trace

Chz (E) Enahle Addre=s==H'0000107E (Tutorial.cpp/45) address bus prefetch Trace

Ch3 (E) Enable Addrezs=H'00001040 (Tutorial.cpp/49) address area ROM Trace

Chd (E) Enable Address=H'00001140 address area ROM Trace

Chi (E) Enpty

Cheé (E) Eupty

Ch7 (E) Enpty

Chi (E) Enpty

Ch9 (R) Eupty

Chl0(R) Eupty -
4| | |
4| » [ Breakpaint b Event A Trigger /

Figure5.59 [Event] Window ([Event] Sheet)

Select [Add...] or the event point displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

The conditions for the event point are set on the [General], [Bus/Area], [Signals], and [Action] pages. The search
condition for the event point is set by multiple conditions set on these pages.

Notes: 1. Channel 8 hasthe trigger output function. When the condition on channel 8 is satisfied, the low-level
signal will be output from the external probe 1 (EXT1) for abus cycle.
2. When the event point is used as the condition for acquiring the trace information, select [Trace
Acquisition...] from the popup menu. For the trace function, refer to section 5.16, Viewing Trace
Information.

3. If acondition that is unavailable for arange channel is set in editing of the range channels (Ch9 to
Ch12), the selected channel is automatically replaced by an unused event channel (Chl to Ch8).

Table5.3 Conditions Unavailablefor a Range Channel

Condition Related Options

Selecting outside the [Outside Range] on the [General] page
specified address range

Selecting the start or [Start Timer] and [Stop Timer] on the [Action] page
end of the execution
time measurement

Specifying the count [Required number of event occurrences] on the [Action] page
when an event occurs
(twice or more)

Specifying sequencing [Enable Sequencing] on the [Action] page
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(1) [General] page

The address and data conditions are set.

Breakpoint/Event Froperties 2 x|

General |Bus ! twea | Signals | Action |

~ Twpe Address
" PC Break " Don't Care © Addrezs ¢ Range

AddressLe |H 00000000
Address Hi [H 00000000

[T Outside Fange

— Data Compare Direction——
™ Compare = Wse Mask " Read
Walue [

- IH L € Write

¢ Bute & Word
bask— JHD

* Either

Ok, I Cancel |

[Typel:

Figure5.60 [Breakpoint/Event Properties] Dialog Box ([General] Page)

Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options are invalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Sets the address condition.

[Don't carel: Sets no address condition.
[Address]: Allows asingle address to be selected.
[Range]: Allows an address range to be sel ected.

[AdderessLo]: Set asingle address or the start of an address range (available when [Address] or
[Range] has been selected).

[AdderessHi]:  Set the end of an address range (available when [Range] has been selected).

[Outside Range]: Used to negate the range (i.e., the event will occur when the address is outside the
range). Thisis available when [Address] or [Range] has been selected.
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[Data Compare]: Sets the data condition.
[Compare]: Checking this box compares data.
[Use Mask]: Sets amask condition (available when [Compare] has been selected).

[Valug]: Specifies the data bus value as numerics. The size of data for access can also be
selected (available when [Compare] has been selected).

[Byte]: Sets access in bytes as the condition (available when [Compare] has been selected).
[Word]: Sets access in words as the condition (available when [Compare] has been selected).
[Mas]: Sets avalue to be masked. Thisvalue will be ANDed with the value of the data bus

and data condition. The result will be used to compare data (available when [Use
Mask] has been selected).

[Direction]: Selects a condition with read or write cycles.

[Read]: Sets read cycles as the condition.

[Write]: Sets write cycles as the condition.

[Either]: Sets either read or write cycles as the condition.
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(2) [Bug/Ared] page

Use this page to set the bus status and the memory area being accessed.

Breakpoint/Event Properties

General Bus/Area | Signalsl Actionl

— Bus State —hrea

I~ CFU Frefetch = Or-chip BOK
[T CRU Data [ On-chip Bat
[ Befiesh [™ | On-chip 40 16 bit
[T DMAC [™ | On-chip /0 8 bit
[T DIc [™ | External 16 bit
™| Dther = Esternal & bit

I~ DL Rk

¥ Don't Care

21|

[ o ]

Cancel |

Figure5.61 [Breakpoint/Event Properties] Dialog Box ([Bug/Area] Page)

[Bus State]:

be satisfied with any bus status.

[Areal:

satisfied in any area.

Sets the bus status as the condition. When the [Don't care] check box is checked, the event will

Specifies the area for searching. When the [Don't care] check box is checked, the event will be

Note:  Items set for the bus state and memory access area vary according to the emulator in use. For details,

refer to section 5.15.4, Signalsto Indicate Bus States and Areas.
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(3) [Signals] page

Use this page to set external signals.

Breakpoint/Event Froperties 2 x|

General I Bus /dvea  Signals |.t’-‘n.cti0n|

— Probe 4 — Probe 3
" High " High
 Low
& Don't Care
— Probe 2 —Frobe 1
" High " High
 Low  Low
& Don't Care & Don't Care

Ok, I Cancel |

Figure5.62 [Breakpoint/Event Properties] Dialog Box ([Signals] Page)

[Probed]: Detects the status of the input probe signal 4
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don’t care]: The status of the input probe signal is not detected

[Probe3]: Detects the status of the input probe signal 3
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe2]: Detects the status of the input probe signal 2
[High): Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected
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[Probel]: Detects the status of the input probe signal 1

[High):
[Low]:

[Don’t care]:

(4) [Action] page

Detectsthe high level of the input probe signal
Detectsthe low level of the input probe signal

The status of the input probe signal is not detected

Use this page to decide what action the emulator takes when the defined event occurs.

Breakpoint/Event Froperties 2 x|

General | Bus / &rea | Signals  Action

Actiong
~ &

[ élarlTimer
[~ Stop Tirmer

Delay after detection before break occurs
oo

bus cycles

Required number of event ocourences
|01

[~ Enable Sequencing |

Ok, | Cancel |

Figure5.63 [Breakpoint/Event Properties] Dialog Box ([Action] Page)

[Action]:

[Break]:

[Start Timer]:

[Stop Timer]:

Selects an action that occurs when the event is satisfied. This cannot be used for an
event point being used as the trace acquisition condition.

Causes a break (stop) in the user program when the event occurs. Thisis the
default action.

Starts the run timer (the run timer value is displayed in the [ Status] window).

Stops the run timer (the run timer value is displayed in the [ Status] window).

[Delay after detection before break occurs):

Sets a 16-bit delay (in bus cycles) after the event has occurred before the action is
taken. The delay is only applicable to break events and thereis only one delay counter
in hardware, therefore only one breakpoint can have a non-zero delay. The range of
vauesis D’0to D'65,535 (only available when [Break] has been selected). This
cannot be used for an event point being used as the trace acquisition condition.
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[Required number of event occurrences]:

[Enable Sequencing]:

[Configure Sequence...]:

Allows a 16-bit pass count to be set. The event must occur the specified number of
times before the action istaken. The range of valuesis D’0 to D’65,535.

Allows the event to take part in a sequence of events (setting this requires the event to
use an event detector).

Displays the [Event Sequencing] dialog box to allow the event sequencing to be
configured (only available when [Enable Sequencing] has been selected).

(5) [Event Sequencing] dialog box

Thisdialog box allows the user to define which events are triggered by other events. If thisdialog box is
accessed (directly or indirectly) from [Trace Acquisition...], only those events assigned to the trace subsystem
are displayed. If accessed from the [Eventpoint] window, only the breakpoint or timer events are shown.

Event Sequencing

Event

%' |3 Armed By [~ Mo occurence of

" |3 Beset By The fallowing events: Cahicel |

[T 1 [E]H1 038 address

[~ 2 [EJH105C address count D10
[~ 3[EJH10FE address count D'2
™ 4 [E]H10FC address

™| undefined arunavaiable

™| undefined arunavaiable

™| undefined arunavaiable

™| undefined or unayailatble

Cy e

[Event]:
[Is Armed By]:
[Is Reset By]:

[No occurrence of]:

Figure5.64 [Event Sequencing] Dialog Box

Selects an event point to be set.
Arms the selected event.
Resets the selected event.

Arms an event when the set of events being selected does not occur (only available
when [Is Armed By] has been selected).

Thetest of conditions on event pointsis started with the execution of the user program. The conditions on event
points have not been satisfied immediately after the execution of the user program is started.

Satisfaction of the condition on an event point allows a transition of the state to that where the conditionis

satisfied.
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The state where the condition is satisfied is retained until the user program is stopped or the event point is reset.

When the condition on the event point is satisfied, no action will be taken even if the condition is satisfied again.
If you want the action to be taken again, reset the event point so that the state transits to that where no condition
issatisfied.

When the user program is stopped, the states of al the event points transit to that where no condition is satisfied.

When an event point must be in the state where its condition is satisfied or not (when [No occurrence of] is
selected) as the satisfaction condition of another event point, this event point is called the arm event.

An event point can reset the tested states of conditions of other event points or itself by satisfying the condition.
Thisevent point is called areset event.

A reset event resets event points regardless of their states where the condition is satisfied or not (e.g., resetting
the pass count).

Select an event point from the [Event] combo box. To set an arm event on the selected event point, select [Is
Armed By] and check the box corresponding to each event. The [No occurrence of] check box is used to set a
condition that the arm event isin the state where its condition is not satisfied.

To set areset event on the selected event point, select [Is Reset By] and check the box corresponding to each
event.

At the bottom of the screen is a diagram showing the current sequencing of the events (figure 5.64). The Sinput
sets (arms) an event and the R input resetsit. The legend ~S indicates the event is set (armed) by the non-
occurrence of the input events.

Figure 5.64 is an example that Ch1 isthe arm event for Ch2, Ch3, and Ch4. Ch3 isthe arm event for Ch4. Ch2
and Ch4 are the reset events for Chl and Ch2, respectively.

To satisfy the condition of the event point having an arm event, the arm event must be in the state where the
condition is satisfied or not (when [No occurrence of] is selected). When multiple arm events exist on one event
point, one of the arm events must be in the state where the condition is satisfied or not (when [No occurrence of]
selected) to satisfy the condition of the event point.

As the condition of the arm event on one event point, either of the states where the condition is satisfied or not
should be set.

To reset an event point with areset event, the condition of the reset event must be satisfied. While the condition
of thereset point is satisfied, no event point is reset even if the condition of the reset event is satisfied again.

When multiple reset events exist on one event point, the event point is reset when the condition of one of reset
eventsis satisfied.
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5.15.8  Setting Trigger Points

Thetrigger point is an event to output a trigger when the specified address has been accessed. Up to four trigger
points can be set by using the trigger outputs (four channels) on the bus monitoring circuit of the emulator.

The settings of the trigger point are displayed and modified on the [Trigger] sheet.

=k
Type State Condition | Aotion

[EXT.2-1 Enahle Address=H'00FFDEEQ Trigger output

ExT.2-2 Enahle Address=H'O0FFD404 Trigger ocutput

[ExT.2-3 Enahle Address=H'00001140 Trigger output

[EXT.2-4 Enahle Address=H'00FFEFSC Trigger output

« | I
4| » [\, Breakpoint A Event A Trigger

Figure5.65 [Event] Window ([Trigger] Sheet)

Selecting [Add...] or the event point and [Edit...] from the popup menu in this window displays the [Set Address
For Trigger] dialog box.

or Trigger

Address

¥ Triggerl: IH'DDFFDEED Carcel |

¥ Trigger: IH'DDFFD4D4

v TriggerZ: IH'DDDD‘I 140

¥ Triggers: [Ho0FFEFaC

Figure5.66 [Set AddressFor Trigger] Dialog Box

Thisdialog box allows the user to specify the address to be accessed as the trigger output condition during the
user program execution. Enable or disable the trigger output point by checking the check box on theleft in the
screen.

[Triggerl]: Enables the output of trigger channel 1.
[Trigger2]: Enables the output of trigger channel 2.
[Trigger3]: Enables the output of trigger channel 3.
[Trigger4]: Enables the output of trigger channel 4.
[Address]: Sets the address condition of the channel.
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Notes: 1. When the condition set for the trigger output (1 to 4) is satisfied, the high-level signal will be output
from the corresponding pin (1 to 4) of the external probe 2 (EXT2) during reading or writing.
2. Some emulators may not support the trigger point. For details, refer to section 8, Software
Specifications Specific to This Product, or the online help.

5.159 Editing Event Points

Handlings for settings other than PC breakpoints, event points, and trigger points are common. The following
describes examples of such handling.

5.15.10 Madifying Event Points

Select an event point to be modified, and choose [Edit...] from the popup menu to open the dialog box that
corresponds the event, which allows the user to modify the event conditions. The [Edit...] menuisonly available
when one event point is selected.

5.15.11 Enabling an Event Point

Select an event point and choose [Enable] from the popup menu to enable the selected event point.

5.15.12 Disabling an Event Point

Select an event point and choose [Disable] from the popup menu to disable the selected event point. When an
event point is disabled, the event point will remain in the list, but an event will not occur when the specified
conditions have been satisfied.

5.15.13 Deleting an Event Point

Select an event point and choose [Delete] from the popup menu to remove the selected event point. To retain the
event point but not have it cause an event when its conditions are met, use the [Disabl€] option (see section
5.15.12, Disabling an Event Point).

Note: No trigger point can be deleted. Use the [Disable] option to clear the settings.

5.15.14 Deleting All Event Points
Choose [Delete All] from the popup menu to remove all event points.

Note:  No trigger point can be deleted. If [Delete All] is selected, the settings of all channels become disabled.

5.15.15 Viewing the SourceLinefor an Event Point

Select an event point and choose [Go to Source] from the popup menu to open the [Source] or [Disassembly]
window at address of event point. The [Go to Source] menu is only available when one event point that has the
corresponding source file is selected.
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516 Viewingthe Trace Information

The emulator acquires the results of each instruction execution into the trace buffer as trace information and
displaysit in the [Trace] window. The conditions for the trace information acquisition can be specified in the
[Trace Acquisition] dialog box.

Since trace information in bus-cyclesis acquired by the hardware circuit and stored in the trace buffer, the
realtime operation is retained. The [Trace] window displays the content of the trace buffer, which records up to
32,768 bus cycles from the last program run and is aways updated.

5.16.1 Opening the[Trace] Window

To open the [ Trace] window, choose [View -> Code -> Trace] or click the [Trace] toolbar button (&]).

5.16.2 Acquiring Trace Information

When the emulator does not set the acquisition condition of the trace information, all bus cycles are acquired by
default without any condition (free trace mode).

In the free trace mode, trace acquisition is started with the execution of the user program and stopped by halting
the user program. The acquired trace information is displayed in the [ Trace] window.

= =10/ %
Address | Instruction Data | R/UW | drea Status | Clock  Probes NMI| IRQ7-0 @ Time... Source Label i‘
4H'00FFEFCO ER7  7a07 D 1 1 11111111 ct= PowerON
-05563 000402 00£f RD RO PROG 1 1111 1 11111111
-05567 000404 efcd RD ROM PROG 1 1111 1 11111111
-05566 000406 MOV. L ERG,B-ERT 0l00 ED ROM PROG 1 1111 1 11111111
-05565 000408 6dft  ED RO PROG 1 1111 1 11111111
-05564 00040a  MOV.L ER7,ERE 0ff& RD RO PROG 1 1111 1 11111111
-05563 ffefbe 00ff WR  RAM/DTC DATA 1 1111 1 11111111
-05562 ffefhe efhd TR RAM/DTC DATA 1 1111 1 11111111
-05561 00040¢ ORC.EB #H'80,CCR 0480 ED RO PROG 1 1111 1 11111111 set_imas.
-05560 00040 J3R B__INITSCT:24 5e00 ERD RO PROG 1 1111 1 11111111 _INITSCT(
-05559 000410 1llc2 RD ROM PROG 1 1111 1 11111111
-055558 0011c2 MOv. 1w RZ,B-ER7 6dfZ  RD ROM PROG 1 1111 1 11111111 __ _INITSCT
-05557 £fefbi 0000 WE  RAM/DTC DATA 1 1111 1 11111111
-05556 £fefba 04lz WR  FAM/DTC DATA 1 1111 1 11111111
-05555 0011c4 STM.L (ER4-ERE) ,E-5F 0120 ERD ROM PROG 1 1111 1 11111111
-05554 ffefba 0000 WR - RAM/DTC DATA 1 1111 1 11111111 ﬂ
Figure5.67 [Trace] Window
Thiswindow displays the following trace information items:
[PTR]: Cycle number in the trace buffer. When the most recent record is record 0, earlier record

numbers go backwards (-1, -2, ...). If adelay count has been set, the cycle number where the
trace stop condition has been satisfied is record 0. For the cycle (during delay) executed until
the trace has stopped, earlier record numbers go forward (+1, +2, ...) the most recent record.

[Address]: Address (6-digit hexadecimal)

[Instruction]: Disassembled code of the executed instruction

[Datal: Data bus value, displayed as 2-digit or 4-digit hexadecimal

[RIW]: Whether access was read (RD) or write (WR)

[Areal: Memory area being accessed; ROM, RAM, 8- or 16-hit 1/0, 8- or 16-bit EXT (external), or

DTC RAM (not available when atime stamp is acquired)
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[Status):

[Clock]:

[Probes]:

[NMI]:
[IRQ7-0]:

[Timestamp]:

[Source]:

[Label]:

Bus status during this cycle; DTC operation, PROG (prefetch), Data (CPU data access cycle),
Refresh (refresh cycle), or DMAC (DMAC cycle) (not available when atime stamp is
acquired)

Number of clock cyclesin buscycleas 1 to 8. To indicate more clock cycles, “OVR” is
displayed (not available when atime stamp is acquired).

A 4-bit binary number showing the four probe pinsin the order of Probe 4, Probe 3, Probe 2,
and Probe 1 from the left (not available when atime stamp is acquired).

Status of the NMI input (not available when atime stamp is acquired)
Status of eight IRQ inputs (not available when atime stamp is acquired)

Time stamp of the record. Time stamps start from zero each time the user program is executed.
The timer resolution depends on the time stamp clock rate selected in the trace acquisition
(only available when a time stamp is acquired).

Source program

Label information that corresponds to the address (if defined)

Note: Itemsother than [PTR], [Address], [Instruction], [Data], [R/W], [Area], [Status], [Probes], [Timestamp],
[Source], and [Label] vary according to the emulator in use. For details, refer to section 8, Software
Specifications Specific to This Product, or the online help.

It is possible to hide any column not necessary in the [Trace] window. Selecting a column you want to hide from
the popup menu displayed by clicking the right-hand mouse button on the header column hides that column. To
display the hidden column, select the column from the said popup menu again.
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5.16.3  Specifying Trace Acquisition Conditions

The capacity of the trace buffer islimited. When the buffer becomes full, the oldest trace information is
overwritten. Setting the trace acquisition condition allows acquisition of useful trace information and effective
use of the trace buffer. The condition is enabled by the event point to control starting, stopping, and ending the
trace acquisition. For event points, refer to section 5.15, Using the Event Points.

The trace acquisition condition is set in the [Trace Acquisition] dialog box that is displayed by selecting
[Acquisition...] from the popup menu.

The [Trace Acquisition] dialog box has the following pages:

Table5.4 [TraceAcquisition] Dialog Box Pages

Page Item

[General] Sets trace acquisition conditions.

[Stop] Sets trace stop conditions (without a delay).

[Delayed Stop] Sets trace stop conditions (with a delay).

[1] to [4] Sets the range trace (only available when the free trace mode is
disabled).

(1) [General] page

Sets trace acquisition conditions.

Trace Acquisition ﬂll
Geneal |Stop | DelayedStop] 1 |2 |3 4 ]
~Suppresz————— Time Stamp
™ Free Trace

Cliock:

[ DIC Cycles IDisabIed vI

[ Eefresh Cpcles

— Trace Events
Event:
[10(R)H1092 address |
add. | Ed. Sequence.. Delete | Delan |

ak. I Cancel |

Figure5.68 [Trace Acquisition] Dialog Box ([General] Page)
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[Suppress): Acquires no trace information of the specified types of bus cycle.

[Time Stamp]:  Setsacondition for time stamping.

[Clock]:

Select either from Disabled, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, 16 us, or
100 us as the resolution for time stamping. A time stamp has a 32-bit counter. At 125
ns the maximum time that can be measured is about 9 minutes, and at 100 ps the
maximum time is about 5 days.

When the counter overflows, its content will be cleared to continue counting. No time
stamp information will be acquired when Disabled is selected.

[Free Trace]: Checking this box enables the free trace mode.

When the free trace mode is enabled: Starts acquiring the dataimmediately after program
execution has been started. Only the trace halt condition is available. The rangetraceis
unavailable and four range-trace pages (1 to 4) become disabled.

When the free trace mode is disabled: Setsthe start and halt conditions of trace acquisition.

[Trace Events]: Setsevent pointsto be used as trace acquisition conditions.

[Event]:
[Add...]:
[Edit...]:

[Sequence...]:

[Delete]:

[Del All]:

Liststhe event points to be used as trace acquisition conditions.
Adds anew event point.
Changes the setting for the selected event point.

Configures an event sequence for the event point being used as a trace acquisition
condition. To set up the sequence, an event must have been set.

Deletes the selected event point.

Deletes dll event points.

Notes: 1. The bus cyclesthat can be specified by the [ Suppress] option vary according to the emulator in use.
For details, refer to section 5.15.4, Signalsto Indicate Bus States and Areas.
2. Thetrace buffer isused for the time stamp information and some of the trace information. Therefore,
when the time stamp is acquired, it isimpossible to acquire the trace information other than PTR,
Address, Instruction, Data, R/'W, Source, Label, and Timestamp.
3. If an event that is used for the range trace or trace stop function is deleted, that function becomes

disabled.
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(2) [Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed
simultaneoudly.

Trace Acquisition ﬂﬂ

General Stop | Delayed Stopl 1 I 2 I 3 I 4 I

— Stop Without Delay

— Events
[T undefined ar unavailable

[T undefined ar unavailable
[T undefined ar unavailable
[T undefined ar unavailable
[T undefined or unavailable
[T undefined or unavailable
[~ 7[EJH107E address
[ 8(E]H1084 address
[T undefined or unavailable
¥ 10[R]H'1092 address
[T undefined or unavailable
[T undefined or unavailable

ak. I Cahicel |

Figure5.69 [Trace Acquisition] Dialog Box ([Stop] Page)

[Stop Without Delay]: Defines a trace stop condition.
[Enable]: Checking this box enables a trace stop.

[Events): Lists the event points where trace acquisition conditions have been set. If the
box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(3) [Delayed Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed

simultaneoudly.

Trace Acquisition

Gerneral I Stop

Drelayed Stop |1 | 2 | 3 | 4 |

— Stop with Delay

Delay Count ID"I

— Events
I 1 [E]H'D address

= 2(E]HDaddress

I= 3 (E]HD address

™ 4E] Hill address

[ B(E]HD address

[ EB(E]HD address

[ 7 [EJH107E address
[ 8(E]H"1 084 address
[T undefined or unavailable
[T undefined or unavailable
[T undefined or unavailable
[T undefined or unavailable

ak. I Cahicel |

Figure5.70 [Trace Acquisition] Dialog Box ([Delayed Stop] Page)

[Stop With Delay]:
[Enable]:

[Delay Count]:

[Events]:

Defines a trace stop condition.

Checking this box enables a trace stop.

Setsthe delay count (in bus cycles, range 1 to 65535). This function allows
you to acquire anumber of trace records after any of the specified events
occur.

Lists the event points where trace acquisition conditions have been set. If the
box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(4) [1] to[4] pages

Setsarange trace. Thisisonly available when the free trace mode is disabled. Select either of the following four
modes: [Disabled], [Point to Point], [Range], and [Event].

» Disabled

Disables arange trace.

Trace Acquisition e

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditions

* Dizahled € Paint to Point " Range " Ewent

: Cancel |

Figure5.71 Range Trace Setting (Disabled)
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*  Point to Point

Acquires trace information in the specified range.

Trace Acquisition ﬂﬂ

Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled & Puint to Point " Range " Ewent

Start Addrezs

H'0000107E

Stop Address

|H'DDDD‘I 084,

¥ Cyclic

Cahicel
Figure5.72 Range Trace Setting (Point to Point)
[Start Address]:  Address where trace acquisition starts
[Stop Address]:  Address where trace acquisition stops
[Cydic]: When this box is checked, the event sequencing is configured so that the events reset

themselves which causes tracing to be restarted when the start event occurs after the stop event.

Sets the event points that are required to start or stop trace acquisition when the start or end addressis accessed,
respectively.

Point to Point mode is an easy method to set up the event mode. The event to start or sop trace acquisition isan
access to asingle address.

Select [Cyclic] to continue acquisition of the trace information only in the specified address range.

Note: Thisfunction automatically configures a sequence of event points. Note, however, that an unexpected
result may arise. In such cases, modify the setting of the sequence in the [Event Sequencing] dialog box.
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* Range

Only acquires the trace information that satisfies the specified condition.

Trace Acquisition 71 x|
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled " Puint to Point & Range " Ewent

Range Event Edi... |

|7 [EYH"107E address =l

Cahicel

Figure5.73 Range Trace Setting (Range)

[Range Event]:  Selectsan event point for which atrace acquisition condition has been set.
[Edit...]: Changes the setting for the selected event point.

Only acquires trace information from all bus cycles that matches the condition set in the selected event. This
mode uses one event channel or range channel.
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e Event

Acquirestrace information, controlling the start and end of trace acquisition with the specified condition.

Trace Acquisition 71 x|
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled " Puint to Point " Range & Event

[

|7 [EYH"107E address

Staop Event Edi...

Start Event Edit... |
_ e |

|2 [E)H'108& address =l

V¥ Cyclic:

Cahicel

Figure5.74 Range Trace Setting (Event)

[Start Event]: Selects the event point for which the condition to start trace acquisition has been set.
[Stop Event]: Selects the event point for which the condition to stop trace acquisition has been set.
[Edit...]: Changes the setting for the selected event point.

[Cydlic]: When this box is checked, the event sequencing is configured so that the events reset
themselves which causes tracing to be restarted when the start event occurs after the stop event.

Starts and stops trace acquisition when the conditions for starting and ending are satisfied, respectively. Selecting
[Cyclic] alows a continuous acquisition of trace information that can be acquired with the specified condition.
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5.16.4  Searching for a Trace Record

Use the [Trace Find] dialog box to search for atrace record. To open this dialog box, choose [Find...] from the
popup menu.

The [Trace Find] dialog box has the following options:

Table5.5 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the status of eight probe input signals (not available when a time

stamp is acquired).
[Timestamp] Specify the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary

according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Clicking the [OK] button after setting conditions in those pages stores the settings and starts searching. Clicking
the [Cancel] button closes this dialog box without setting of conditions.

When atrace record that matches the search conditionsis found, the line for the trace record will be highlighted.
When no matching trace record is found, a message dialog box will appear.

Only the trace information that satisfies all the conditions set in above pages will be searched.

If afind operation is successful, selecting [Find Next] from the popup menu will move to the next found item.
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(1) [General] page
Set the range for searching.

x
Status I Frobes I IRQ7-0
General | Addiess | Data | Rew | trea

Trace search range
(! ri [ Upward search
Start PTR : |-32767
EndFTR: ID
QK. I Cancel | Apply |

Figure5.75 [TraceFind] Dialog Box ([General] Page)

[Trace search range]: Sets the range for searching.
[Not designation]: Searches for information that does not match the conditions set in other
pages when this box is checked.
[Upward search]: Searches upwards when this box is checked.
[Start PTR]: Enters aPTR value to start a search.
[End PTR]: Enters a PTR value to end a search.

Note:  Along with setting the range for searching, PTR values to start and end searching can be set in the [Start

PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set an address condition.

x
Status | Prabes I IRGF-0

G.eneral . Address | Data I R I Area

Setting
’7Ealue 2 IH'FFEFBD

QK. I Cancel | Apply |

Figure5.76 [TraceFind] Dialog Box ([Address] Page)
[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.

[Value]: Enter the address vaue (not available when [Don’t care] has been checked).

256
RENESAS




(3) [Data] page

Set a data condition.
x
Status I Frobes I IRQ7-0
General I Address Data | R I Area
o :

Setting :
(Ealue : |H'DDDD

QK. I Cancel | Apply |

Figure5.77 [Trace Find] Dialog Box ([Data] Page)
[Don't care]: Detects no data when this box is checked.
[Setting]: Detects the specified data.

[Value]: Enter the data value (not available when [Don't care] has been checked).
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(4 [RIW] page
Select the type of access cycles.

x

Status I Prabes | IRGT-0
General I Address I Data R | Area
ri :
Setting
Strirg : IHD j

QK. I Cancel | Apply |

Figure5.78 [Trace Find] Dialog Box ([R/W] Page)

[Don't care]: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.
[String]: Select a read/write condition (not available when [Don't care] has been checked).
RD: Read cycle
WR: Write cycle
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(5) [Ares] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

x

Status I Prabes I IRGT-0 |
General I Address I Data I Rifws Area
I :
Setting
Skring : IHDM j

QK. I Cancel | Apply |

Figure5.79 [TraceFind] Dialog Box ([Area] Page)

[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition.
[String]: Select an area condition (not available when [Don't care] has been checked).

Note:  Available areas vary according to the emulator in use. For details, refer to section 5.15.4, Signalsto
Indicate Bus States and Areas.
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(6) [Status] page
Select the status of abus. The selection is not available when atime stamp is acquired.

x

Gerneral | Address I Data I R M I Area
Status _ | Prabes I IRGF-0

r:

5 ;attlng
Skring : IF'F!DG j

QK. I Cancel | Apply |

Figure5.80 [TraceFind] Dialog Box ([Status] Page)

[Don't care]: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition.
[String]: Select abus condition (not available when [Don't care] has been checked).

Note:  Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(7) [Probes] page

Select the status of four probe signals. The selection is not available when atime stamp is acquired.

x

Gerneral I Addressz | Data | R M I Area
Status Probes | IRGF-0

— Setting

Probed IDnn'l care'l Probe3 IDon'l care'l
Probe2 IDon'l care 'I Prabel IDnn't cale'l

QK. I Cancel | Apply |

Figure5.81 [TraceFind] Dialog Box ([Probes] Page)
[Don't care]: Detects no probe signal condition when this box is checked.

[Setting]: Detects the specified probe signal condition.

[Probed] to [Probel]: Select probe conditions (not available when [Don’t care] has been checked).

Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signd islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz I Data R M | Area |
Status I Frobes IRQ7-0
i ;
— Setting
IRG7 IW IRGE Daon't care ™
IRA5  [Dontcaex] 1RG4  |Dontcaer]
fas  [omemes] g2 [oornewes]
IR IW [=Twli] IW
ITI Cancel | Apply |

Figure5.82 [TraceFind] Dialog Box ([|RQ7-0] Page)

[Don't care]: Detects no IRQ input condition when this box is checked.
[Setting]: Detects the specified IRQ input condition.
[IRQ7] to [IRQOQ]: Select IRQ input conditions (not available when [Don’t care] has been
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checked).
Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input is low.

RENESAS




(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

x
Generall .t’-‘n.ddlessl Data I Ry Timestamp |

¥
Setting

Walue: h I_ mir I_s I_ms I_ s I_ ris

QK. I Cancel | Apply |

Figure5.83 [TraceFind] Dialog Box ([Timestamp] Page)

[Don't care]: Detects no time stamp va ue when this box is checked.
[Setting]: Detects the specified time stamp value.
[Value]: Enter the time stamp value.

Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns

(Not available when [Don’t care] has been checked.)

5.16.5 Clearingthe Tracelnformation

Select [Clear] from the popup menu to empty the trace buffer that stores the trace information. If several [Trace]
windows are open, all [Trace] windows will be cleared as they all access the same buffer.

5.16.6 Savingthe Trace Informationin aFile

Select [Save...] from the popup menu to open the [Save Ag] file dialog box, which allows the user to save the
information displayed in the [Trace] window as atext file. A range can be specified based on the [PTR] number
(saving the complete buffer may take several minutes). Note that this file cannot be reloaded into the [Trace]
window.

Note: In filtering of trace information, the range to be saved cannot be selected. All the trace information
displayed in the [Trace] window after filtering will be saved. Select afiltering range on the [General]
pagein the [Trace Filter] dialog box if you want to save the selected range. For details on the filtering
function, refer to section 5.16.12, Extracting Records from the Acquired Information.
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5.16.7 Viewing the[Source] Window
The [Source] window corresponding to the selected trace record can be displayed in the following two ways:

» Select atrace record and choose [View Source] from the popup menu.
» Double-click atrace record

The [Source] or [Disassembly] window opens and the selected line is marked with a cursor.

5.16.8 Trimming the Source
Choose [Trim Source] from the popup menu to remove the white space from the left side of the source.

When the white space is removed, a check mark is shown to the left of the [Trim Source] menu. To restore the
white space, choose [Trim Source] while the check mark is shown.

5.16.9  Acquiring a Snapshot of the Trace Information

A snapshot can be acquired when you need to check the trace information during execution of the user program.
Thisisuseful for checking time stamping or probe input signals. To acquire a snapshot of trace information,
select [Snapshot] from the popup menu. Trace acquisition istemporarily stopped to display arecord of the latest
trace information, and then restarted. A snapshot of trace information is only acquired during execution of the
user program.

5.16.10 Temporarily Stopping Trace Acquisition

To temporarily stop trace acquisition during execution of the user program, select [Halt] from the popup menu.
This stops trace acquisition and updates the trace display. Use this method to check the trace information without
stopping execution of the user program.

5.16.11 Restarting Trace Acquisition

To restart trace acquisition being stopped during execution of the user program, select [Restart] from the popup
menu.
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5.16.12 Extracting Recordsfrom the Acquired I nfor mation

Use the filtering function to extract the records you need from the acquired trace information. The filtering
function allows the trace information acquired by hardware to be filtered by software. Unlike the settings made
in the [Trace Acquisition] dialog box for acquiring trace information by conditions, changing the settings for
filtering several times to filter the acquired trace information allows easy extraction of necessary information,
which isuseful for analysis of data. The content of the trace buffer will not be changed even when the filtering
function isused. Acquiring useful information as much as possible by the [Trace Acquisition] settingsimproves
the efficiency in analysis of data because the capacity of the trace buffer islimited.

Use the filtering function in the [Trace Filter] dialog box. To open the [Trace Filter] dialog box, select [Filter...]
from the popup menu.

The [Trace Filter] dialog box has the following pages:

Table5.6 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Sets the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the states of eight IRQ input signals (not available when a time

stamp is acquired).

[Timestamp] Specifies the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Set filtering conditions and then press the [OK] button. This starts filtering according to the conditions. Clicking
the [Cancel] button closes the [Trace Filter] dialog box, which holds the settings at the time when the dialog box
was opened.

In filtering, only the trace information that setisfies one or more filtering conditions set in the above pages will
be displayed in the [ Trace] window.

Filtering conditions can be changed several times to analyze data because the content of the trace buffer is not
changed by filtering.
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(1) [General] page
Set the range for filtering.

Trace Filter x|
Status I Frobes I IRQ7-0

General | Addiess | Data | Rew | trea

I i [ Enabls Filter

™ Mot designation
Trace display range
Start PTH: I

End FTR :

QK I Cancel | Apply |

Figure5.84 [TraceFilter] Dialog Box ([General] Page)

[Don't care other pages]: Only selects the cycle number when this box is checked. Other options become

invalid.

[Enable Filter]: Enables the filter when this box is checked.

[No]: Filters information that does not match the conditions set in those pages when this
box is checked.

[Trace display range]: Sets the range for filtering.
[Start PTR]: Enters a PTR value to start filtering.
[End PTR]: Enters a PTR value to end filtering.

Note:  Along with setting the range for filtering, PTR valuesto start and end filtering can be set in the [Start
PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set address conditions.

Trace Filter x|

Status | Prabes I IRGF-0
General Address | Data I R I Area
[ Don't care

Setting
& Point © Bange

From ; IH'

To: I

QK I Cancel | Apply

Figure5.85 [TraceFilter] Dialog Box ([Address] Page)

[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.
[Point]: Specifies a single address (not available when [Don't care] has been checked).
[Range]: Specifies an address range (not available when [Don’t care] has been checked).
[From]: Enter a single address or the start of the address range (not available when [Don'’t
care] has been checked).
[To]: Enter asingle address or the end of the address range (only available when [Range]

has been selected).

Note:  Along with setting the address range, the start and end of the address range can be set in the [From] and

[To] options, respectively.
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(3) [Data] page
Set adata condition.

Trace Filker
Status I Frobes I IRQ7-0

General I Address Data | R I Area

Setting
& Point © Bange

From ; IH'

To: I

QK I Cancel | Apply

Figure5.86 [TraceFilter] Dialog Box ([Data] Page)

[Don't care]: Detects no data when this box is checked.

[Setting]: Detects the specified data.
[Point]: Specifies single data (not available when [Don'’t care] has been checked).
[Range]: Specifies adata range (not available when [Don't care] has been checked).
[From]: Enter single data or the minimum value of the data range (not available when [Don’'t

care] has been checked).

[To]: Enter the maximum value of the datarange (only available when [Range] has been

selected).

Note:  Along with setting the data range, the minimum and maximum vaues can be set in the [From] and [To]

options, respectively.
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(4 [RIW] page
Select the type of access cycles.

Trace Filter x|

Status I Prabes | IRGT-0
General I Address I Data R | Area

— Setting

[IRD
[TwhR

QK I Cancel | Apply |

Figure5.87 [TraceFilter] Dialog Box ([R/W] Page)
[Don't care]: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.

RD: Detects read cycles when this box is checked (not available when [Don’t care] has
been checked).

WR:  Detects write cycles when this box is checked (not available when [Don’t care] has
been checked).
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(5) [Ares] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

Status I Prabes I IRGT-0 |
General I Address I Data I Rifws Area

[CIRaM
14016

/08

[C]EXT-15

[CJEXT-8

[IRAM/DTC hd

QK I Cancel | Apply |

Figure5.88 [TraceFilter] Dialog Box ([Area] Page)
[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition (not available when [Don’t care] has been checked).

Note:  Available area conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(6) [Status] page
Select the status of abus. The selection is not available when atime stamp is acquired.

Gerneral | Address I Data I R M I Area
Status | Prabes I IRGF-0

[ IDATA

[ JREFRESH
[ ]DMAC
[]DTC
[JOTHER

QK I Cancel | Apply |

Figure5.89 [TraceFilter] Dialog Box ([Status] Page)
[Don't carel: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition (not available when [Don’t care] has been checked).

Note:  Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz | Data | R M I Area
Status Probes | IRGF-0

— Setting

Probed IDnn'l care'l Probe3 IDon'l care'l
Probe2 IDon'l care 'I Prabel IDnn't cale'l

QK I Cancel | Apply |

Figure5.90 [TraceFilter] Dialog Box ([Probes] Page)
[Don't care]: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don’t care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signd islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz I Data R M | Area |
Status I Frobes IRQ7-0
i ;
— Setting
IRG7 IW IRGE Daon't care ™
IRA5  [Dontcaex] 1RG4  |Dontcaer]
fas  [omemes] g2 [oornewes]
IR IW [=Twli] IW
ITI Cancel | Apply |

Figure5.91 [TraceFilter] Dialog Box ([IRQ7-0] Page)

[Don't care]: Detects no IRQ input condition when this box is checked.
[Setting]: Detects the specified IRQ input condition.
[IRQ7] to [IRQO]: Select IRQ input conditions (not available when [Don’t care] has been

checked).
Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

Trace Filker ﬂ
Generall .-’-‘«ddressl Data I FAw  Timestamp
r '
Setting
& Point ¢ Range

min =

s rg

o] b [ win] o[ me [ w[ ne
ID;I_h I_minl_sl_msl_ |_

o |

Cancel | Apply |

Figure5.92 [TraceFilter] Dialog Box ([Timestamp] Page)

[Don't care]: Detects no time stamp va ue when this box is checked.
[Setting]: Detects the specified time stamp value.
[Point]: Specifies asingle time stamp (not available when [Don't care] has been checked).
[Range]: Specifies atime stamp range (not available when [Don’t care] has been checked).
[From]: Enter a single time stamp value or the minimum value of the time stamp range.
Theformat isasfollows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Not available when [Don’t care] has been checked.)
[To]: Enter the maximum value of the time stamp range.

Note:  Along with setting the time stamp range, the minimum and maximum time stamp values can be set in the

Theformat is asfollows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Only available when [Range] has been selected.)

[From] and [To] options, respectively.
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5.16.13 Calculating the Differencein Time Stamping

Select [Timestamp Difference...] from the popup menu to cal cul ate the time difference between the two points
selected by the result of tracing in acquisition of time stamp information.

Timestarmp Difference 2 x|

— Select 2 line

Firzt PTR - |'32?54 Second PTR : ID

[Timestamp difference information :

Timeztamp Difference

0000k 000rmin 000z 003ms 897us B75ns Get Difference
Clear |

( | ] o |

Figure5.93 [Timestamp Difference] Dialog Box
[Select 2 lin€]: Select trace records to calculate the time stamp difference.

[First PTRY]: Specifies the first pointer to measure the difference. The pointer of theline
selected on the Trace window is displayed by default.

[Second PTRY: Specifies the second pointer to measure the difference.

[Timestamp Difference]: Displays the results of calculation.

[Get Difference]: Calculates the difference between the specified two points and display itsresult in the
[Timestamp Difference] list.

[Clear]: Clears all the resultsin the [Timestamp Difference] list.

[OK]: Closesthe dialog box. All the resultsin the [Timestamp Difference] list are cleared.
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5.16.14 Analyzing Statistical I nformation

Choose [Statistic] from the popup menu to open the [Statistic] dialog box and analyze statistical information
under the specified conditions.

1= |
x

Eesult
Clear
Result :
Condition | Amount | FTR
KN I

L,

Close

[Statistic Analysis]:
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[Default]:
[Range]:
[Item]:

[Start]:

[End]:

[Set]:
[New]:
[Result]:
[Clear]:

[Close]:

Figure5.94 [Statistic] Dialog Box
Setting required for analysis of statistical information.
Setsasingle input value or character string.
Sets the input value or character string as arange.
Setstheitem for analysis.

Setsthe input value or character string. To set arange, the start value must be
specified here.

Specify the end value if arange has been set (only available when [Range] has been
selected).

Adds anew condition to the current one.

Creates anew condition.

Obtains the result of statistical information analysis.

Clears all conditions and results of statistical information analysis.

Closes this dialog box. All the results displayed in the [Result] list will be cleared.
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Thisdiaog box allows the user to analyze statistical information concerning the trace information. Set the target
of analysisin [Item] and the input value or character string by [Start] and [End]. Click the [Result] button after
setting a condition by pressing the [New] or [Add] button to analyze the statistical information and display its
result in the [Result] list.

Note: In thisemulator, only [PTR] can be set as arange. Each of other items must be specified as a character
string. In analysis of statistical information, character strings are compared with those displayed in the
[Trace] window. Only those that completely match are counted. Note, however, that thistest is not case
sengitive. The number of blankswill not be cared either.

5.16.15 Extracting Function Calls from the Acquired Trace I nformation

To extract function calls from the acquired trace information, select [Function Call...] from the popup menu.
The [Function Call Display] dialog box will be displayed.

Furiction Call Display x|
Setting
Enable to dizplay trace information with function
call only 7
(O o i " Dizable
0K | LCancel |

Figure5.95 [Function Call Display] Dialog Box

[Setting]: Selects whether or not to extract function calls.
[Enable]: Extracts function calls.
[Disable]: Does not extract function calls.

When [Enable] is selected, only the cyclesthat include function calls are extracted for display from the acquired
trace information. The content of the trace buffer is not changed by extraction of function calls. Using this
function for the result of the free trace or the trace information that includes function calls allows the user to
know the order of function calls.
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5.17  Viewingthe Function Call History

The [Stack Trace] window shows the function call history.

5.17.1 Openingthe[Stack Trace] Window

To open the [Stack Trace] window, choose [View -> Code -> Stack Trace] or click the [Stack Trace] toolbar

button ().

Eind| Name value

F func3 {short *) { 000000024 }

=] param 3 000003 ffa { 0x00003£d8 } (short*)
L local 3 D'3 { 0x00003fd4 } (unsigned long)
F funcz (short *) { Ox0O0000072

=] param Z 000003 ffa { O0x00003fed } (short*)
L local 2 D'Z { O0x00003fe0 } {unsigned long)
F funcl{short *) { Ox0D000003e }

=] param_ 1 Ox00003ffa { Ox00003ff0 } (short*)
L local 1 D1 { 0x00003fec } {(unsigned long)
F maini) { O0x0000001Z }

L start D103 | 0x00003ffa } {=zhort)

Figure5.96 [Stack Trace] Window

The following items are displayed.

[Kind]: Indicates the type of the symbol.
F: Function
P: Function parameter
L: Local variable
[Name]: Indicates the symbol name.
[Valug]: Indicates the value, address, and type of the symbol.

5.17.2  Viewing the Source Program

Select a function and choose [Go to Source] from the popup menu to display, in the [Source] window, the source
program corresponding to the selected function.
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5.17.3  Specifying the View

Choose [View Setting...] from the popup menu to open the [Stack Trace Setting] dialog box, which alows the
user to specify the [Stack Trace] window settings.

Mest level (-64) Iiﬂ] =]

— Dizplay gvmbol
[~ Parameter
[~ Local Variable

— Diaplay Radix
* Hexadecimal
" Decimal
" Octal QK
" Binary

Cancel |

Figure5.97 [Stack Trace Setting] Dialog Box
[Nest level]: Specifies the level of function call nesting to be displayed in the [Stack Trace] window.
[Display symbol]:  Specifies the symbol typesto be displayed in addition to functions.

[Display Radix]: Specifies the radix for displaysin the [Stack Trace] window.
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518 Displaying Memory Contentsas an | mage

The memory contents can be displayed as an image in the [Image View] window.

5181 Opening the[Image View] Window

Choose [View -> Graphic -> Image...] or click the [Image] toolbar button (EI) to open the [Image Properties]
dialog box shown in figure 5.98.

2%

Bit/Fiuel! IBbil[|nde:-: Color’ 'I
Sarmpliti: I‘Hi‘1r 'I
Format: I chunky e I

r— Buffer Infomation:

Data Address: IH'UUUUUDDD

PBalette sddiess; IH'DDDDDDDD j
wWidth/Height Size[Fixel]:

. I— EBuffer Size:
Width: | H'O0000000  Byte
Height: I

—Wiew [nformation;
—Yiew Mode:—— — Fosition;

* Full Size 2 Position: I 0
" Part Size ' Positior: I 0

— Start Pozition: - width/HEght Size(Fizell—————

& Top Wi |
" Bottom Height: I

OF. I LCancel |

Figure5.98 [Image Properties| Dialog Box

The [Image Properties] dialog box is used to specify the display method of the [Image View] window.
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The following items are to be specified:

[Color Information]:

[Mode]:

[Bit/Pixel]:

[Sampling]:
[Format]:
[Buffer Information]:

[Data Address]:

[Palette Address]:

Specifies the color information of the image to be displayed.

Specifies the format.

[MONOCHROME]: Displaysin black and white.

[RGB]: Displayed in R (red), G (green), and B
(blue)

[BGR]: Displayed in B (blue), G (green), and R
(red)

[YCbCr]: Displayed by Y (brightness), Cb (color
differencein blue), and Cr (color difference
in red)

Specifies Bit/Pixel according to the selected [Mode]. (Valid when
RGB or BGR is selected)

Specifies the format of sampling. (Valid when Y ChCr is selected)
Specifies Chunky/planar. (Valid when Y CbCr is selected)
Specifies the area to store data, size, and the address of the palette.

Specifies the start address of the memory where image dataisto
be displayed. (Displayed in hexadecimal)

Specifies the start address of the memory of color palette data.
(Displayed in hexadecimal) (Valid when 8Bit is selected for RGB or BGR)

[Width/Height Size]: Specifies the width and height of the image.

[View Information]:

[View Mode]:

[Start Position]:

[Width (Pixel)]: Specifies the width of the image.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Height (Pixel)]: Specifies the height of the image.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Buffer Size]: Displays the buffer size of the image
from the width and height
(Displayed in hexadecimal)

Specifies the location, size, and data start location of the part to be
displayed among the entireimage.

Specifies the entire/part to be displayed in the image.

[Full Size]: Displays the entireimage.

[Part Size]: Displays part of theimage.
[Top]: Displays data from the upper left.
[Bottom]: Displays data from the lower left.
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[Position]: Specifies the start position of the image where part of theimageis
to be displayed. (Valid when [Part Size] is selected)

[X Position]: Specifiesthe X axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Y Position]: Specifiesthe Y axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Width/Height Size]: Specifies the height and width of the image to be displayed partly.
[Width (Pixel)]: Displays the width of display.
(When aprefix is omitted, the values are
input and displayed in decimal.)
[Height (Pixel)]: Displaysthe height of display.
(When aprefix is omitted, the values are
input and displayed in decimal.)

After the settings have been made in the [Image Properties] dialog box, clicking the [OK] button opens the
[Image View] window.

Even after the [Image View] window is displayed, the display contents can be modified by opening this dialog
box by choosing [Properties...] from the popup menu.

Figure5.99 [Image View] Window

The memory content is displayed as an image.

5.182 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will allow the window contents to be automatically updated when
user program execution stops.
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5.18.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.
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5.184 Displaying the Pixel Infor mation

Double-clicking within the window displays information on the pixel on which the mouse pointer islocated in
the [Pixel Information] dialog box.

Pixel InFarmation i' ﬂ

Color mode: I Index Calor
Fixel: I Ihdes Mo.195
Pazition

Buffer Size ‘width: I Height: I

Image Size ‘width: Height:

Figure5.100 [Pixel Information] Dialog Box
Thisdialog box displays pixel information on the cursor location.

[Color Mode]:  Displays the format of theimage.

[Pixel]: Displays color information of the cursor location. (Displayed in decimal)
[Position]: Displays the cursor locationin X and Y axis. (Displayed in decimal)
[X]: Displays the X axis of the cursor location.
[Y]: Displaysthe Y axis of the cursor location.

[Buffer Size]:  Displaysthe buffer size. (Displayed in decimal)
[Width]: Displays the buffer width.
[Height]: Displays the buffer height.

[Image Size]: Displays the width and height of the display. (Displayed in decimal)
[Width]: Displays the width.
[Height]: Displays the height.
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519 Displaying Memory Contents as Waveforms

Memory contents can be displayed as waveformsin the [Waveform View] window.

5.19.1 Opening the Waveform View Window

Choose [View -> Graphic -> Waveform...] or click the [Waveform] toolbar button to open the [Waveform
Properties] dialog box shown in figure 5.101.

Wavefarm Properties
Data Address:  [H'0000000D =]
DataSize:  fahit ] Cancel |
LChannel:
’7 £ Mono " Stereo
Buffer Size:  [H'D0000000 4

Figure5.101 [Waveform Properties] Dialog Box
Specifies the waveform format. The following items can be specified.
[Data Address]: Specifies the start address of data in memory (displayed in hexadecimal).
[Data Size]: Selects 8Bit or 16Bit.
[Channd]: Selects Mono or Stereo.
[Buffer Size]:  Specifies the buffer size of data (displayed in hexadecimal).

After the settings have been made in the [Waveform Properties] dialog box, clicking the [OK] button opensthe
[Waveform View] window.

Even after the [Waveform View] window is displayed, the display contents can be modified by opening this
dialog box by choosing [Properties...] from the popup menu.
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Figure5.102 [Waveform View] Window

Displays the memory contents as waveforms. The X axis shows the number of sampling dataand the Y axis
shows the sampling value.

5.19.2 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will alow the window contents to be automatically updated when
user program execution stops.

5.19.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.19.4  Zoom-In Display

Selecting [Zoom In] from the popup menu displays the waveforms with the horizontal axis enlarged.

5.195 Zoom-Out Display

Selecting [Zoom Out] from the popup menu displays the waveforms with the horizontal axis reduced.

5.19.6 Resetting the Zoom Display

Selecting [Reset Zoom] from the popup menu displays the waveformsin its original size.

5.19.7  Setting the Zoom M agnification

In the [Zoom Magpnification] submenu of the popup menu, the zoom magnification can be selected from 2, 4, or
8.

5.19.8 Setting the Horizontal Scale

In the [X Scale] submenu of the popup menu, the size of the X axis can be selected from 128, 256, or 512 pixels.
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5.19.9 Non-Display of Cursor

Selecting [Clear Cursor] from the popup menu hides the cursor display.

5.19.10 Displaying the Sampling I nformation

Selecting [Sample Information...] from the popup menu displays the [Sample Information] dialog box.

Sample Information 2 x]

Data Size: I Bhit
Channel: I fono

¥ | H'0000310
Walue

v | H'23

Figure5.103 [Samplelnformation] Dialog Box

Displays the sampling information of the cursor location in the [Waveform View] window. The following
information is displayed.

[Data Size]: Displays 8hit or 16hit.
[Channd]: Displays the data channel.

[Valug]: [X] Displaysthe X axis of cursor location.

[Y] Displaysthe Y axis of cursor location (displays Y axes for both the upper and
lower plots when Stereo is selected).
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5.20

Analyzing Performance

Use the performance analysis function to measure the rate of execution time. The performance analysis function
does not affect the realtime operation because it measures the rate of execution time in the specified range by
using the circuit for measurement of hardware performance included in the emul ator.

Select either of the following five modes according to the purpose of measurement.

Table5.7

Mode

Available M easurement Modes

Description

Purpose

Time Of Specified Range
Measurement

Measures the execution time and
execution count in the specified
range.

Measurement of time taken for
processing of functions except for
that required for child functions
called from the functions.

Start Point To End Point
Measurement

Measures the execution time and
execution count between the
specified addresses.

Measurement of time taken for
processing of functions.

Start Range To End
Range Measurement

Measures the execution time
from a specified range to another
specified range.

Measurement of execution time
spent from calling of any of
sequential subroutines to calling of
any of another sequential
subroutines in a program that
includes subroutines in sequence,
such as an assembly program.

Access Count Of
Specified Range
Measurement

Measures the number of times a
specified range is accessed from
another specified range.

Measurement of the number of
times a global variable is accessed
from a specific function.

Called Count Of
Specified Range
Measurement

Measures the number of times a
specified range has called
another specified range.

Measurement of the number of
times a function is called from a
specific function.

Use eight performance channelsinstalled on the circuit for measurement of hardware performance in the
emulator for setting of conditions for measurement. Up to eight points can be set.

Note, however, that up to four points can be set in Start Range To End Range Measurement, Access Count Of
Specified Range Measurement, or Called Count Of Specified Range M easurement because two sequentia points
are used for setting a condition in these modes.
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Table5.8 Mode Settingsfor Measurement

Point
Page
Time Of Specified Range 0 o) 0 (0] (0] (0] (0] (0]
Measurement
Start Point To End Point o) 0 (e} e} (e} (e} (e} (e}
Measurement
Start Range To End 0 0O o) 0O (e} 0O (e} 0O
Range Measurement
Access Count Of [e) 0 (o] 0O (0] 0O (0] O
Specified Range
Measurement
Called Count Of [e) 0O (e} 0O (e} 0O (e} O

Specified Range
Measurement

Note: O: Available
O : Not available

Note:  Only one point isused in Time Of Specified Range Measurement and Start Point To End Point
M easurement, while two sequential points are used in Start Range To End Range M easurement, Access
Count Of Specified Range Measurement, and Called Count Of Specified Range Measurement. The
conditions that have been set will be canceled when switching these modes of different types.
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5.20.1 Opening the [Performance Analysis] Window

Choose [View -> Performance -> Performance Analysis] or click the [PA] toolbar button ) to open the
[Select Performance Analysis Type] dialog box.

erformance An VpE ﬂﬂ

Performance dnalysiz EE000 Perfarmanc

i

LCancel

Figure5.104 [Select Performance Analysis Type] Window

Select [E6000 Performance Analysis] and then click the [OK] button to open the [Performance Analysis)
window.

«#-Performance & =10 x|
No Name | Condition | Rate | RUN-TIME MAX-MIN-TIME | Count |
1 PAl  Range H'0000103% H'00001108 9% OOk O0win 005 055ms 764us l60ns 1234
z PAZ  PtoP H'0D00Z063 H'000020D4 25% 0Ok OOmin 00s 147ms 68Zus 580ns OOh OOmin... 1234
3 PA3  RtoR H'0000103% H'00001108 65% OOk ODmin 005 38lws 580us 480ns 2458
4 + H'00002068 H'00002136

5

6

7

g

Figure5.105 [Performance Analysis] Window

Thiswindow displays the rate of execution time in the area selected by the user during the last program run in
percentages, histogram, or numerical values.

It is possible to hide any column not necessary in the [Performance Analysis| window. Selecting a column you
want to hide from the popup menu displayed by clicking the right-hand mouse button on the header column
hides that column. To display the hidden column, select the column from the said popup menu again.
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5.20.2  Setting Conditionsfor Measurement

Conditions for measurement can be displayed and changed in the [Performance Analysis] window. Select a point
where a condition isto be set, and then select [Set...] from the popup menu to display the [Performance Analysis
Properties] dialog box.

Select either from the following five modes as the condition by the [M easurement Method] option:

Table5.9 Conditionsfor Measurement (Measurement Method)

[Measurement Method] Option

Time Of Specified Range Measurement

Start Point To End Point Measurement
Start Range To End Range Measurement
Access Count Of Specified Range Measurement

Called Count Of Specified Range Measurement

Set a condition for measurement according to the mode being selected. The parameters to be set depend on the
modes.

The [Performance Analysis] window has a support function to enter the address range of afunction
automatically if the name of the function is entered to set an address range. Entering a function namein the
[Input Function Range] dialog box displayed by clicking the[...] button on the [Performance Analysis
Properties] dialog box automatically enters the address range of the function.

Inpuk Function Range

2l
Function

Sample:: Cancel

Figure5.106 [Input Function Range] Window

Notes: 1. Entering the name of an overload function or aclass opens the [Select Function] dialog box. Select a
function in this dialog box. For details on the dialog box, refer to section 5.13.3, Supporting
Duplicate Labels.

2. The addresses figured out are just for reference. In some cases, the end address of a function may be
different. Check the last instruction of the function in the [Disassembly] window to correct the value
set in [End Address] so that it will be the address of the last instruction (in general, the last instruction
of afunction isaRTS instruction). A label name or an expression can be entered instead of an
address value in boxes where an address should be entered.
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(1) Time Of Specified Range M easurement

Performance Anal operties 2=l

teazurement bethod PAT:

Time Of 5 ed R ange Measurement

Fange Hame IF'M
Range

Start Address IH'DDDDDDDD _I
End Address : IH'DDDDDDDD

— Common Settings of Pelformance(Pa1-8)

Address Caontral Mode: PC Settings... |
Time Measurement Unit: 160ns
Cancel |

Figure5.107 Time Of Specified Range Settings

[Range Name]: The name of the range to be measured

[Range]: The range for the Time Of Specified Range M easurement
[Start Address)]: Address to start measurement
[End Address): Address to end measurement

Measures the execution time and the execution count in the range between the start address and end address.
Starts measurement with a detected program prefetch in the range specified between the start and end addresses,
and then stops with a detected program prefetch out of the specified range. M easurement can be restarted with a
detected program prefetch in the specified range. The execution count isincremented every time the program is
prefetched at the end address of the specified range. The execution time measured does not include the time
spent while being called from the specified range.
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(2) Start Point To End Point Measurement

Performance Anal operties 2=l

teazurement bethod PAT:

Start Point To End Paint b

Fange Hame IF'M
Fairt

Start Address IH'DDDDDDDD _I
End Address : IH'DDDDDDDD

Time Out : IIJIJh 00rmir 00z 000rn: 000us 000ns
Count ID'1

— Common Settings of Pelformance(Pa1-8)

Address Caontral Mode: PC Settings... |
Time Measurement Unit: 160ns
Cancel |

Figure5.108 Start Point To End Point Measurement Settings

[Range Name]: The name of the range to be measured
[Point]: Therange for the Start Point To End Point Measurement
[Start Address)]: Address to start measurement
[End Address): Address to end measurement
[Time Out]: The timeout value to finish measurement. When the minimum time for measurement

is160 ns, 40 ns, or 20 ns, enter the value as follows.
Example: 1h 2min 3s 123ms 456us 789ns

If the CPU operating mode is target, enter a hexadecimal number in 10 digits.
Example: 123456789A

A break occurs every time avalue measured in the specified range exceeds the
timeout value (not the totd time). Thisisonly available for channel 1.

[Count]: The count-up value used in measurement of the execution count. A break occurs
every time the execution count exceeds the count-up vaue. Thisisonly available for
channd 1.

Measures the execution time and the execution count in the range between start address and end address. Starts
measurement with a detected program prefetch at the start address, and then stops with a detected program
prefetch at the end address. The execution count isincremented every time the program is prefetched at the end
address of the specified range. The execution time measured includes the time spent while being called from the
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specified range. When either from one to four pointsis selected, the maximum and minimum time in the
specified range can be measured.

Notes: 1. When [Time Out] is selected in the Start Point To End Point M easurement mode, the execution time
will not be measured correctly.
2. When [Time Out] and [Count] are selected, satisfaction of either of these options stops execution of
the user program (performance break).
3. Only channd 1 can be used for [Time Out] and [Count]. Use other channelsif you do not want to
select [Time Out] or [Count] in the Start Point To End Point M easurement mode.
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(3) Start Range To End Range Measurement

Perfarmance Anal ‘opetties

Measurement Method PAT: Start Fange To End Hange b4

Fange Hame IF'M
Start Range End Range

Start Address IH'DDDDDDDD _I Start Address IH'DDDDDDDD _I
End Address : IH'DDDDDDDD End Address : IH'DDDDDDDD

— Common Settings of Pelformance(Pa1-8)

Time Measurement Unit: 160ns

Address Caontral Mode: PC Settings... |

Cancel |

Figure5.109 Start Range To End Range M easurement Settings

[Range Name]: The name of the range to be measured

[Start Range]: The start range for the Start Range To End Range M easurement
[Start Address)]: Start address
[End Address): End address

[End Range]: The end range for the Start Range To End Range M easurement
[Start Address]: Start address
[End Address]: End address

Starts measurement with a detected prefetch cyclein the specified start address range, and then stops with a

detected prefetch cycle in the specified end address range. The execution count is incremented every time the

program passes the end address range.
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(4) Access Count Of Specified Range Measurement

Perfarmance Anal ‘opetties

teazurement bethod PAT: ified Range b

Fange Hame |F'A1

Range Arcess Area Fange

Start Address . |H'00000000 J Start Address H'00000000 J
End Address:  [H'00000000 End Address : H'00000000

Accesz Tupe
[¥ Don't Care

M - M - r

Common Settings of Performance(Pd1-8)

Addresz Caontrol tMode: Prefetch Settings...
Time Measurement Unit: 160ns
Cancel

Figure5.110 Access Count Of Specified Range M easurement Settings

[Range Name]: The name of the range to be measured
[Range]: The range for the Access Count Of Specified Range Measurement
[Start Address]: Start address
[End Address): End address
[Access Area Rangel: The access range for the Access Count Of Specified Range Measurement
[Start Address]: Start address
[End Address): End address
[Access Typel: The bus cycle on the access range to be measured

Measures the number of times the range specified as the access range is accessed from the range specified by the

start and end addresses. The execution count in the range is measured with Time Of Specified Range
Measurement mode.

Note: Available bus cycle conditions vary according to the emulator in use. For details, refer to section 5.15.4,

Signals to Indicate Bus States and Areas.
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(5) Called Count Of Specified Range M easurement

Perfarmance Analysis Properties ﬂll

teasurement Method PAT: Called Count Of Specified B ange
Fange Hame IF'M
Range Call Fange

Start Address IH'DDDDDDDD _I Start Address IH'DDDDDDDD _I
End Address : IH'DDDDDDDD End Address : IH'DDDDDDDD

— Common Settings of Pelformance(Pa1-8)

Address Caontral Mode: PC Settings... |
Time Measurement Unit: 160ns
Cancel |

Figure5.111 Called Count Of Specified Range M easurement Settings

[Range Name]: The name of the range to be measured
[Range]: The range for the Called Count Of Specified Range Measurement
[Start Address]: Start address
[End Address): End address
[Call Range]: The range for the Called Count Of Specified Range Measurement. Asthe call range,
specify the start and end addresses of the selected subroutine.
[Start Address]: Start address
[End Address): End address

Measures the number of times the range specified as the call rangeis called from the range specified by the start
and end addresses. The execution time in the specified range can be measured with Time Of Specified Range
Measurement mode. Asthe call range, specify the start and end addresses of the selected subroutine.
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5.20.3 Selecting the Address Detection Mode and Resolution

In measurement of hardware performance, there are two types of address detection modes: prefetch address
detection mode and PC address detection mode. Select the appropriate address detection mode according to the
measurement mode in use. The resolution can also be selected here.

To select an address detection mode and resolution, click the [Settings...] button on the [Performance Analysis
Properties] dialog box. The [Common Settings of Performance(PA1-8)] dialog box will be displayed.

Comman Settings of Performance(PAl-8)

Address Contral Mode Prefetch

Time Measurement Unit 160ns j Caricel |

Figure5.112 [Common Settings of Performance(PA1-8)] Dialog Box
[Address Control Mode]: Select the method to detect addresses for the rate of execution time.

PC: PC address detection mode
Prefetch: Prefetch address detection mode

[Time Measurement Unit]: Select the timer resolution to be used for measurement from 160ns, 40ns,
20ns, or Target. The timer for execution time measurement has a 40-bit
counter. At 20 ns the maximum time that can be measured is about six hours,
and at 160 ps the maximum time is about two days. When the counter
overflows, “Timer Overflow” is displayed as the result of measurement.
When Target is selected, the counter isincremented by an input clock. The
result of measurement is displayed as 10 digitsin hexadecimal.

Select the prefetch address detection mode in Access Count Of Specified Range Measurement, and PC address
detection mode in other measurement modes. Otherwise, the result of the measurement will be incorrect.

5204  Starting Performance Data Acquisition

Executing the user program clears the result of previous measurement and automatically starts measuring the rate
of execution time according to the conditions that have been set. Stopping the user program displays the result of
measurement in the [Performance Analysis] window.

5205 Deleting a Measurement Condition

Select [Reset] from the popup menu with a measurement condition selected to del ete the condition.

5.20.6  Deleting All Measurement Conditions

Choose [Reset All] from the popup menu to delete all the conditions that have been set.
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Section 6 Tutorial

6.1 Introduction
The following describes the main functions of the emulator by using atutorial program.

Thetutorial program is based on the C++ program that sorts ten random dataitemsin ascending or descending
order. Thetutorial program performs the following actions:

* Thenui n function repeatedly callsthet ut ori al function to repeat sorting.

e Thetutorial function generatesrandom datato be sorted and callsthesort andt ut ori al functions
in order.

e Thesort function entersthe array where the random data generated by thet ut ori al function are stored,
and sorts them in ascending order.

» Thechange function then sorts the array, which was sorted in ascending order by the sor t function, in
descending order.

Thefilet ut ori al . cpp contains source code for the tutorial program. ThefileTut ori al . abs isa
compiled load module in the Dwarf2 format.

Notes: 1. After recompilation, the addresses may differ from those given in this section.

2. Thissection describes general usage examples for the emulator. For the specifications of particular
products, refer to section 8, Software Specifications Specific to This Product, or the online help.

3. Theoperation address of Tut ori al . abs attached to each product differs according to products.
Replace the address used in this section with the relevant address in each product after checking that
it is placed on the corresponding line of the source program.

4. Inthistutorial, the H8S/2633 E6000 emulator is taken as an example. File paths or the appearance of
figures differs according to products.
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6.2 Runningthe HEW

Open aworkspace by following the procedure listed in section 4.2.3, Selecting an Existing Workspace.

Select the following directory:
HEW installation destination directory\Tool s\Renesas\DebugComp\Platform\E6000\2633\ T utorial

Note: Thefile path differs according to products. If necessary, replace \2633 with another name.

Then select the file indicated below.

2%

Lok, jr: I@ Tutarial j - IC:F -

Debug_H&5_2237_EA000_Emulator _CP
SoUrce

File name: |Tutorial.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure6.1 [Open Workspace] Dialog Box

Opening this workspace automatically connects the emulator.
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6.3 Downloading the Tutorial Program

6.3.1 Downloading the Tutorial Program

Download the object program to be debugged.

Select [Download modul€] from [Tutoria.abs] of [Download modules].

EI@ Tutorial

E-[E Tutorial

L&) shrkeo

+

Diepender

E] shik.h
=] sorth

El'a C zaurce file
i ie[H dbscte

C+ gource file
- Q resetprg. cpE
-|Z] zort.cpp

Q Tutorial.cpp
Download modu

load rodule

Unlead module

Configure Wiew, ..

’T Al Docking

Hide:

Figure6.2 Downloading the Tutorial Program
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6.3.2 Displaying the Sour ce Program
The HEW allows the user to debug a user program at the source level.

» Double-click [Tutorial.cpp] under [C++ sourcefilg].

e | void main{woid)
- {
=G Tutorial 0200001036 while (119
E-[F Tutorial 0=00001034 tutorial ();
=23 C source file T
i e 3] dbsctc ¥
0=z00001038 wolid tutorial{wvoid)
O=z00001044 {
long a[l07]:
long 3
P int 1i;
Ela Download modules class Sample *p_san.
= 0=00001046 p_san= Sample;
0=z0000104e for{ i=0; 1<10; i++ 3{
0=z00001050 i = rand({):
0=z00001058 iff{j < 0y
0=z0000105a i o= —=3:
1
0=z0000105c ali] = 3:
¥
O0=00001070 p_sam—-r=ortia):
0=0000107%a p_=sam->rchangs(a):
O0=00001082 p_=sam—-:=0=a[0]:
0x0000108a p_=s=am—-r:=l=a[l]:
000001096 p_samn—r:=2=a[2]:
0=000010a2 p_sam—»=3=a[3]:
0x000010as p_samn—»=d=a[4]:
0=000010ba p_sam—>»=5=a[5]:
0=000010ch P_samn—:=b=al6];
O0x000010d2 P_samn—:=7=a[7]:
0x000010de P_samn—:=8=a[8]:
0=z000010ea p_=an—r=9=a[9]:
0=z000010f6 p_sam;
0=z000010fc 1

Figure6.3 [Source] Window (Displaying the Sour ce Program)

» Select afont and size that arelegible if necessary. For details, refer to section 4, Using the Editor in the HEW
part.

Initialy the [Source] window shows the start of the user program, but the user can use the scroll bar to scroll
through the user program and look at the other statements.
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6.4 Setting a PC Breakpoint

A PC breakpoint is a simple debugging function.

The [Source] window provides a very simple way of setting a PC breakpoint at any point in a program. For

example, to set a PC breakpoint at thesor t function call:

» Select by double-clicking the [Editor] column on the line containing the sor t function call.

Emﬁ? Tutarial
=-[E Tutorial

=53 € source file
dbsct.c
shrk.c
423 Ca+ zource file
resetprg, cpp
sork.cpp
Tutorial.cpp
=53 Download modules

0=00001038
0=00001044

0=00001046
0=0000104es
0=00001050
0=00001058
0=0000105a

0=0000105c

0=00001070 L
0=0000107a

O=00001082
0=0000108a
0=00001096
0=00001082
0z000010as
0=000010ba
0=000010ck
0=000010d2
0=000010de
0z000010=a
O0=000010f6
O=000010fc

wold tutorial (woid)

long a[10];

long 3:

int i

clazs Sanple *p_=am;

p_=am= Sample;
for({ i=0: 1i<10: i++ ){
7 = rand():
if{3 ¢ 03{
T B
Yo .
ali] = 3:

p_=am—»zort{al;
p_=sam-:change{a) ;

p_=san—->=0=a[0]
p_=am—rzl=all]
p_=am—r=2=al2]
p_=am—->=3=al[3];
p_=amn—:>=4=al[4]:
p_=am—>z5=a[5]:
P sam—r=6=al[b]
p_=am—:=7=al[7]
p_=s=am—:=8=a[8]
p_=amn—->=9=a[9]
p_sam;

}

Figure6.4 [Source] Window (Setting a PC Breakpoint)

The symbol « will appear on the line containing the sor t function. This shows that a PC breakpoint has

been set.
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6.5 Setting Registers
Set avalue of the program counter before executing the program.

» Select [Registers] from the [CPU] submenu of the [View] menu. The [Register] window is displayed.

- Register =101 x|
|Register Hamel Register Valuel
RO H'oooooooo
Rl H'0ooooooo
RZ H'oooooooo
R3 H'0ooooooo
R4 H'oooooooo
RS H'0ooooooo
RE H'oooooooo
R7 H'0ooooolo
PC H'ooo40o
CCR I0--=---
b 111

Figure6.5 [Register] Window

» To change the value of the program counter (PC), double-click the value areain the [Register] window with
the mouse. The following dialog box is then displayed, and the value can be changed. Set the program
counter to H’00000400 in thistutorial program, and click the [OK] button.

Reqgister - [PC] e |

Walue

|H'uuu4uu
Setda: Cancel |

IWhnIe Regizter j

Figure6.6 [Register] Dialog Box (PC)
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6.6 Executing the Program

Execute the program as described in the following:

» To execute the program, select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

Figure6.7 [Go] Button

While the program is executing, the current address bus value and the operating state of the MCU are displayed

on the status bar.

The program will be executed up to the breakpoint that has been inserted, and an arrow will appear on the
[Editor] column in the [Source] window to show the position that the program has halted, with the message

[ Break = PCBr eak] in the status bar.

Note:  When the source file is displayed after a break, a path of the source file may be inquired. The location of

the sourcefileis as follows:

HEW installation destination directory\Tool s\Renesas\DebugComp\Platform

\E6000\2633\Tutorial\source

Thefile path differs according to products. If necessary, replace \2633 with another name.

0x00001038
O=00001044

0=00001046
0=0000104=
0=00001050
0=00001058
0=0000105=

0=0000105<

O0=00001070 L=
0x0000107=a

0=z00001082
0=z0000108a
0=z00001096
O=z000010=2
0=z000010a=
0=z000010ba
0=z000010c6
O=z00001042
0=z000010de
0=z000010=a
0=z000010f6
0=z000010fc }

wold tutorial (woid)

long a[10]:

long 3

int 1

cla=s Sanple *p =an:

po=am= Sanple;
for({ 1=0; 1<10; i++ )9
i = randi):
1f03 <« 0){
1 = 1.
ali] = 3:

p_=an—=zort(a):
p_=amn—rchangel(al;

p =am—r=0=a[0]
p o=am—r=l=a[l]
p =am—r=2=al2]
p o=amn—r=3=al 3]
p =am—r=4=a[4];
p_=an—>=5=a[5]:
p =am—r=h=al[6];
p o=amn—r=7=al[7]
p =am—r=d=a[8]
p o=amn—r=9=a[9]
p_=amn;

Figure6.8 [Source] Window (Break Status)
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The user can see the cause of the break that occurred last time in the [Status] window.

Select [Status] from the [CPU] submenu of the [View] menu. After the [Status] window is displayed, open
the [Platform] sheet, and check the St at us of Cause of | ast break.

_ (O] x|
Item I Status I
Connected To: H2S5/2EZ37 ES000 Ewmulator CPU Z000 (Ewulator PCI Card Driver)
CPUT Ha5/ 2237

Mode 7

Clock =zource Main: 10MH=, Subk:3ZkHz

Dun status Ereak

Cause of last break PC EBreak

Event Time Count 00k O0min 00s 000ms 000us 000ns

Purn Time Count 00k O0min 00s 000ms 9EZ5us £Zfns

4] :IH Wemary j Platform £ Events J

Figure6.9 [Status] Window

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.7 Reviewing Breakpoints
The user can see dl the breakpoints set in the program in the [Event] window.

» Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed. Select
the [Breakpoint] sheet.

1ol
Type State | Condition I Action I

Program Enahle PC=H'O0001070iTutorial.cpp/44d)] Break

| 4]+ T Breakpoint £ Event }i Trioger /

Figure6.10 [Event] Window

The popup menu, opened by clicking the [Event] window with the right-hand mouse button, allows the user
to set or change breakpoints, define new breakpoints, and del ete, enable, or disable breakpoints.
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6.8 Referringto Symbols
The [Label] window can be used to display the information on symbols in modules.

Select [Label] from the [Symbol] submenu of the [View] menu. The [Label] window is displayed so that the user
can refer to the addresses of symbolsin modules.

=lolx|
EP Ija.ddress IName I -

H'ooooog00 PowerON_Reset i)

H'Oooolooo _sbrk

H'O0O001034 _main

H'O0O001038 tutorial )

H'O0OO001104 _abort

H'Oooolloc _ INITECT

H'OOO011Ez loopl

H'O0OO011ZC loopz

H'OOO0O11ZE next_loopZ

H'0000113z next_loopl oo

H'O0O001144 loop3

H'OO0O0l1&z loopd

H'O00o0llss next_loopd

H'Oooollsc next_loop3

H'Oo00lles operator new{unsigned lorng)

H'O0OO011EBE _ CALL_TNIT

H'OOOO11EO _ CALL_END

H'OOOOl1E4 operator delete{woid *)

H'O0OO011EE _rand

H'OOO0lzZ& _srand

H'O00O0lz3z $DIVLES

H'Ooooolz3c not_negk

H'oooolz44 not_neg¥

H'00O0124E not_negs LI

Figure6.11 [Label] Window
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6.9 Viewing Memory

When the label name is specified, the user can view the memory contents that the label has been registered in the

[Memory] window. For example, to view the memory contents corresponding to _nai n in byte size:

e Select [Memory ...] from the [CPU] submenu of the [View] menu to enter _nai n in the [Start address] edit
box and # f inthe [End address] edit box, respectively, and to select Byt e in the [Format] combo box.

et add

Begin:

2|

men

End:

LCancel

i

|+

FEormat;

[Byte [41)

=

Figure6.12 [Set Address] Dialog Box

e Click the [OK] button. The [Memory] window showing the selected area of memory is displayed.

O -lolx
Address Data YValue =
0x00001034 5hH 02 40 FC 01 00 6D F3 V.8...m
0x0000103C 01 20 6D F4 79 37 00 2B myT .
0x00001044 OF F3 1a 80 KE 00 20 00 e T
0x0000104C OF 86 19 44 LsKE 00 11 EE A + LA
0x00001054 17 FO OF 85 4C 02 17 BS AB0aiban s
0x000010c 17 F4 OF CO 10 70 0A BO @ ..... p..
0x00001064 01 00 69 85 OB 5H4 72 24 LAl TS
0x0000106C 00 OA 4D EO OF EBS OF D1 A (R
0x00001074 OF EO bHE 00 20 68 OF D1 M he .
0x0000107C OF EO bHE 00 220 D& 01 00 P
0x00001084 62 K0 01 00 &2 EO 01 00 iP..i...
0x0000108C 6F 5H0 00 04 01 00 6F EO oP....0.
0x00001024 00 04 01 00 &F 50 00 08 .. 0P,
0x0000109C 01 00 6F EO 00 08B 01 00 PR - T =
0x00001084 6F K0 00 OC 01 00 &F EO oP....0.
0x000010C 00 0O0C 01 00 6F 5HO 00 10 PR 1 LI
0x000010B4 01 00 &F EO 00 10 01 00 saltaaan s :J
Figure6.13 [Memory] Window
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6.10 Watching Variables

Asthe user steps through a program, it is possible to watch that the values of variables used in the user program
are changed. For example, set awatch on the long-type array a declared at the beginning of the program, by
using the following procedure:

» Click the left of displayed array a in the [Source] window to position the cursor.

e Select [Instant Watch...] with the right-hand mouse button.

The following dialog box will be displayed.

Instant Wakeh ﬂ ﬂ
- a { 0=00ffef80 } (long(10]) Cloze I
Add

Figure6.14 [Instant Watch] Dialog Box

» Click the [Add] button to add a variable to the [Watch] window.

Figure6.15 [Watch] Window (Displaying the Array)
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The user can aso add a variable to the [Watch] window by specifying its name.

e Click the [Watch] window with the right-hand mouse button and select [Add Watch...] from the popup menu.

The following dialog box will be displayed.

Add Wiatch 2%

Wariable or expression;

I

i Cancel

Figure6.16 [Add Watch] Dialog Box

* Inputvariablei to[Variable or expression] edit box and click the [OK] button.

The [Watch] window will now also show theint-type variablei .

HUUUa{FM

Figure6.17 [Watch] Window (Displaying the Variable)
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The user can click mark ‘+' at the left side of array a in the [Watch] window to watch al the elements.

- H'000041c6 { Dw00ffefB0 }

B 1] H'O000167e { 0w00fefad } (long]
SR [ H'O0002781 { 0x00ffefas } lang]
B[ HIDDO044Bb { D400HfefSe ) flong)
B[4 H'0000734b { 0=00¢fef30 } flong]
B [ HO0001 5t { 0+00ffefd4 } (long)
B [E] H'000059e2 { 0w00fef98 } (long]
R [T H'00007 cfb { 0x00fef3c ¥ lang]
B HIDDO0354 { 0x001efal flong)
B H{O0000f6 { Dx00ffefad } flang]

i H'000a { R4 } [int]

Figure6.18 [Watch] Window (Displaying Array Elements)
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6.11 Displaying Local Variables

The user can display loca variables in a function using the [Locals] window. For example, we will examine the
local variablesinthet ut ori al function, which declaresfour local variables: a,j ,i ,and p_sam

e Select [Locals] from the [Symbol] submenu of the [View] menu. The [Locals] window is displayed.
The [Locas] window shows the local variablesin the function currently pointed to by the program counter,

along with their values. Note, however, that the [Locas] window isinitialy empty because local variables are
yet to be declared.

I':-n]

i H'00fefa0 { ERS }
-------- i H'O00a { R4} (irt)
- p_zam 0=00ffb0dE { ERE } [class Sample”)

Figure6.19 [Locals] Window

e Click mark ‘+' at the left side of array a in the [Locals] window to display the elements.
» Refer to the elements of array a before and after the execution of thesor t function, and confirm that
random data is sorted in descending order.
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6.12 Stepping Through a Program
The HEW provides arange of step menu commands that allow efficient program debugging.

Table6.1 Step Option

Menu

Command Description

Step In Executes each statement, including statements within functions.

Step Over Executes a function call in a single step.

Step Out Steps out of a function, and stops at the statement following the statement in the
program that called the function.

Step... Steps the specified times repeatedly at a specified rate.

6.12.1 Executingthe [Step In] Command
The [Step In] command steps into the called function and stops at the first statement of the called function.

» To step throughthe sor t function, select [Step In] from the [Debug] menu, or click the [Step In] button in
the toolbar.

®

Figure6.20 [Step In] Button
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Qx00002000 Sample: :Sample()
i

0=00002006
0x0000201c =0=0;
0=00002026 =s1=0;
0x0000202c =2=0;
0=00002032 s3=0;
0x00002038 =4=0;
0=z0000203e =5=0;
0x00002044 =h=0;
0=z0000204a =7=0;
O0x00002050 =8=0;
0=00002056 =9=0;
0x00002060 1
0x000020643 orvold Sample: i=ortilong *a)
0=00002070 i
long t:
int 1. 3. k. gap:
0=z00002072 gap = §:
0x00002078 while{ gap » 0 }{
0=00002078 for{ k=0; k<gap: k++)q
0x0000207c for{ i=k+gap: 1<10; i=i+gap }{
0=00002080 for{j=i-gap: jr=k; j=j—gap)q
Ox00002084 if{aljlsalj+gapl i
t =al1]:
0x000020=4 alj]l = alj+gap]:
0=000020a8 al[j+gap] = t:
b
=l==
break;
¥
b
¥
0=000020=0 gap = gap-2;
0x000020cc 1

Figure6.21 [Source] Window (Step In)

» Thehighlighted line moves to the first statement of the sor t function in the [Source] window.
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6.12.2 Executing the [Step Out] Command

The [Step Out] command steps out of the called function and stops at the next statement of the calling statement
inthe mai n function.

» Tostepout of thesort function, select [Step Out] from the [Debug] menu, or click the [Step Out] button in
the toolbar.

19

Figure6.22 [Step Out] Button

N erfo ce Embe: E .cpp] =10 x|
2+ Elle Edit W¥iew Project Options Buld Debug Memory Tools Window Help - |E' 5[
DeHd|e|s |0 Tal|ow|@sc e 2z |0|En 6w =1 &
o EE® |“| Debug,_ HB5_2237_£6000 =] |[Sessontizs_zzs7_Eenon =] | 74 4 | [ 381 | o 9 18 5 m s E 2@ |
BEessh BRalg a7a|ees |mes|Ffeaneed:.
=] = int 1i; j
W class Sanple *p_sam:
E-@ Tutorial 0=00001046 p_san= Sanple:
B3 C source file Ox0000104s for{ i=0: 1<10: i++ ){
dbsct.c 0x00001050 ] = randij}:
H shik.c Ox00001058 1f03 « 0
- Ox0000105 Sch) s
23 C+ source file * = 1 2 :
i tesetprg cpp 0=0000105c alil = 3:
soit.cpp T
oy 0=00001070 [ ] p_sam—:sort{a);
0=0000107& [ p_san—>changeia):
e Tutorial abs 0=00001082 p_sam—:s0=a[0]
0=z0000108a p_=zamn—:sl=all]
0x00001096 p_sam—:sZ2=al2]
0=z000010a2 p_=zan—:s3=al3]
O=000010a= p_san—>=d=al[4]:
0=z000010ba p_samn—»=5=a[58]:
0x000010ckE p_san—:sb=alb]
O=z000010d2 p_=san—:s7=al?]
0=000010de p_=an—:=8=a[8]
0=000010ea p_sam—3>=9=a[9]:
= 0=000010f6 p_sam; -
@ijectsl@l\laviga 4 »
I Walue | Type I
E-B e 1 Dx00fFef80 } [long[10])
=N H'00000fG { 0x00ffef80 [larvg]
‘R[] HD0001 5fb { 0x00ffefd | [latg)
‘B2 H'00001E7e { Dx00ffel38 [long]
R [ H'00001 fb { 0x00ffefds [larvg]
‘B’ [ H'00002781 { 0x00fFef30 | [lang]
~R A H'0000354 { 0x00ffef34 } [long]
R E H'000041 6 { 0x00ffef35 [larvg]
‘B [ H'0000446k { Dx00ffef3e [long)
‘BB H'000053e2 { 0x00ffefal } [long]
R E H'0000734b { 0x00ffefad [larvg]
i H'000a { R4} [int]
Break = Stepping Completed Read-write  [45/64 1 s WM 2

Figure6.23 [HEW] Window (Step Out)

The data of variable a displayed in the [Watch] window is sorted in ascending order.
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6.12.3 Executing the [Step Over] Command
The [Step Over] executes afunction call asa single step and stops at the next statement of the main program.

» To step through all statementsin the change function at asingle step, select [Step Over] from the [Debug]
menu, or click the [Step Over] button in the toolbar.

[0

Figure6.24 [Step Over] Button

£33 Tuikarial - High-p nance Embe _lof x|
<+ File Edit “iew Project Options Euild Debug Memory Tools Window Help _|5|1|
Dedd g em|oTal|lorascn: 2 |D|E*|H||n L
fam A A ”J|Debug_Hss_zzw_Esuuu_j |[essionties_zz37_eeom =] | 74 4 | [ B | &8 4 £ HJ@, G & & B @ |
B Re+4BEAF @Fa|8e 6 |mE 0 |fealsrddn.
= zl
=& Totaral O=00001046 D_san= Sanple;
@ Tutoial 0x0000104e for{ i=0: i<10: i++ ){
- Tutorial 000001050 j = rand():
B3 C source file 0x00001058 1f(3 < 0){
dbect.c O0x0000105a g = =hf8
] ke 0x0000105= AT
B3 T source file :
tesetpig.cpp O0=00001070 p_sam—:sort(a):
soit.cpp 0=0000107a p_=zan—:change{a);
utarial cpp
O=z00001082 p_=an—:s0=a[0]
{3 Downioad modules 0x0000108a P_sam—ssl=al1]
Tutarial abs Ox00001096 p_=zan—:s2=al]
0=000010&a2 p_sam—>=z3=a[3]:
O0x000010as p_sam—»sd=a[4]:
0x000010ba p_sam—:>s5=a[5]:
0=z000010c6 p_=san—:sh=alf]
0x000010d42 p_sam—:s7=al[7]
0=z000010de p_=san—:s8=al8]
0x000010ea p_san—:s9=a[9]
0=z000010f6 D_Sam:
0=000010fc
N FHProjects I o] Naviga... 4 _.lJ
ﬂ' Name I Walue | Type I
T E-R A { 0w00ifef80 [long[10])
RO H'0000794k { Dx00ffef80 } [long)
=R H'000059e2 { 0:00ffefS4 } [long)
B 2 H'0000446b { 0x00ffef35 [long)
‘R 3] H'000047 6 { Dx00ffefBe [long)
‘B H'00003¢54 { 0x00ffef30 } [lonag)
R [ HO0002751 { Dx00fef54 } {lomg)
‘B [E] H'00001cfb { Dx00ifef38 } [long)
‘B [A H'0000167e { 0x00ffef3c [long)
-l H'000015fb { Dx00ffefall } {long)
RO H'00000f6 { 0x00ffefad } [long)
i H'000a{R4} [int]
Ready Read-write (4764 [ [Is WMz
Figure6.25 [HEW] Window (Step Over)
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6.13 Forced Breaking of Program Executions
The HEW can force a break in the execution of a program.
» Cancd al the breaks.

» To execute the remaining sections of thet ut ori al function, select [Go] from the [Debug] menu or the
[Go] button on the tool bar.

=l

Figure6.26 [Go] Button

» The program goesinto an endlessloop. To force abreak in execution, select [Halt] from the [Debug] menu
or the [Halt] button on the toolbar.

Figure6.27 [Halt] Button

6.14 Resettingthe MCU

Resetting the MCU initializes the internal /O registers and makes the program counter jump to the address set in
the reset vector.

To reset the MCU, select [Reset CPU] from the [Debug] menu or the [Reset CPU] button on the toolbar.

=

Figure6.28 [Reset CPU] Button

To execute the program from the reset vector, select [Reset Go] from the [Debug] menu or the [Reset Go] button
on the toolbar.

=l

Figure6.29 [Reset Go] Button

Note: Thistutorial program is executable from the reset vector.
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6.15 Break Function

The emulator’ s break functions are of two types: PC breaks and breaks at event points. PC breakpoints and
event points are set in the HEW' s [Event] window.

An overview and setting of the break function are described below.

6.15.1 PC Break Function
The emulator can set up to 256 PC breakpoints.

»  Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.
» Select the [Breakpoint] sheet.

-Ioix

Tvpe dtate | Condition I Action I

[ 4% ] Breakpoint £ Eveni }, Trigger /

Figure6.30 [Event] Window (Before Setting a PC Breakpoint)

* Click the [Event] window with the right-hand mouse button and select [Add...] from the popup menu.
* The[Breakpoint/Event Properties] diaog box is displayed.

RENESAS
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Breakpoint/Event Properties

General

— Tupe
(¢ PC Break

" Evert

2]

Address
 Don'tCare ) Addess ) Bange

Address Lo [H'00001082
Address Hi JH00000000

I~ Dutside B ange

— [ata Compare [irection—;
" Compare = Wsetdask | Bead
Walue [

- IHD ) wfite
= Byte. £ wod
Hask IH'D ¥ Either

o |

Cancel

Figure6.31 [Breakpoint/Event Properties] Dialog Box

» Check the [PC Break] radio button in the [ Type] group box.

» Usethe[Source] window to refer to the address on the line that has ‘' p_sam->s0=g[0];’ within the
tutorial functionand enter this addressin the [Address Lo] edit box of the [Address] group box. In this

example, enter H 00001082.

Note: Thisdiaog box differs according to the product. For theitems of each product, refer to section 8,

Software Specifications Specific to This Product, or the online help.

e Click the [OK] button.

The PC breakpoint that has been set is displayed in the [Event] window.

Type State Condition

Program Enable

PC=H'00001082 (Tutorial.cpp/47)

| 4] =T Breakpoint £ Event ) Trigoer J

Figure6.32 [Event] Window (PC Breakpoint Setting)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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» Close the [Event] window.

» To stop thetutorial program at the breakpoint, select [Reset Go] from the [Debug] menu.

The program runs until it stops at the breakpoint that has been set.

Qx00001038 wolid tutorial{void)
0=00001044 i

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;
0=00001046 p_=amn= Sample:;
0x0000104e for{ i=0; 1<10; i++ }{
0=00001050 7 = rand{):
Ox00001058 if{j < 03
0=0000105&a i o= -3:

b

0=0000105c ali] = 7:

b
0=00001070 p_sam—r=ort(a):
0=0000107a p_samn—>change{a);
0=z00001082 [ =3 p_san—:=0=a[0];
0=0000108a p_=samn—r=l=a[l]:;
0=00001096 p_samn—:=z=2=al[2];
0=000010a2 p_samn—r=3=al[3]:
0=000010ae p_san—>=z=d=ald];
0=000010ba p_=sam—:r=5=a[5]:
0=000010cE p_samn—:zb=al[b];
0=00001042 p_samn—:=7=a[7]:
0=z000010de p_san—:=z=8=a[8];
0=000010ea p_samn—:=9=a[9]:
0x000010fe E_=am;
0=000010f= ¥

Figure6.33 [Source] Window at Execution Stop (PC Break)

The [Status] window displays the following contents:

- Status

Ttem IStatus

=0l x|

Conmnected To:

CPTT

Mode

Clock source

Dun status

Cause of last break
Event Time Count
Dun Time Count

H22/2237 E&E000 Emulator CPU 2000 (Emulator PCI Card Driver)

HES/ 2237

7

Main: 10MH=, Sub:3fkHz

Break

PC Break

00k O0min O00s O00Oms O0COus O000ns
00k O0min O0s O0lms O02Zus S00ns

4] ' Memary }, Platform # Events f

Figure6.34 Displayed Contents of the [Status] Window (PC Break)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.15.2 Breaking Execution at Event Points

Setting up of an event point on event channel 1 (Ch1) such that a break is triggered when the event point’s
conditions have been satisfied five timesis explained as an example of the use of event points.

» Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.

» Thebreakpoint that has been previously set must be deleted. Click the [Breakpoints] window with the right-
hand mouse button and select [Delete All] from the popup menu to delete all the breakpoints that have been
Set

» Click the [Event] tab.

Up to 12 event points (eight event channels and four range channels) can be set up as independent conditions. In
this example, we are setting the condition for event channel 1.

-l
Chz (E) Enpty

Ch3 (E) Eupty

Cha (E) Enpty

Ch5 (E) Eupty

Che (E) Enpty

Ch7? (E) Eupty

Cha (E) Enpty

Ch% (R) Eupty

Chll(R) Ewpty

Chll (R} Eupty

Chlz (R) Ewpty

4T, Breakpoint ), Event /£ Trigoer f

Figure6.35 [Event] Window (Event Channel 1 [Ch1])

» Select thelinefor Chl in the [Event] window. Double-click on thislinethat is highlighted.

* The[Breakpoint/Event Properties] dialog box is displayed.

» Make the following settings in the boxes on the [General] page:
Select the [Event] radio button in the [Type] group box.
Select the [Address] radio button in the [Address] group box. Then use the [Source] window to refer to the
address on the line that has ‘&[i]=j;" withinthet ut ori al function and enter this address in the [Address
Lo] edit box. In this example, enter H 0000105c.

» Enter D' 5 asthe number of times the event condition isto be satisfied in the [Required number of event
occurrences| edit box on the [Action] page.
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oint/Event Propetties ﬂ ﬂ

General |Bus ! twea | Signals | Action |

— Type Address
" PC Break " Don't Care @ Address ¢ Range

Address Lo [
& Evert & . | H'00001 05

Address i |H00000000

[T Outside Fange

— Data Compare Direction——
[ Compare 7 Wse Mask " Read
Walue [
- IHD £ Wdrite
¢ Bute € Word
Mask IH'D * Either

Ok, I Cancel |

Figure6.36 [General] Page ([Breakpoint/Event Properties| Dialog Box)
» Click the [OK] button. The [Event] window is displayed, as shown below.

_lo/x
Type Jdtate Condition I Action I
Chl (E) Enable Address=H'0000105C (Tutorial.cpp/d2) address count 'S Break

Chz (E) Empty

Chi (E) Enpry

Chd (E) Enpty

Chh (E) Empty

Cht (E) Enpry

Ch7? (E) Enpry

Chi (E) Empty

ChY (R] Enpry

Chld(E) Eupty

Chll(E) Eupty

ChlZ (R} Eupty

A>T Breakpaint b Event £ Trigger f

Figure6.37 [Event] Window (Setting Completed)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Select [Reset Go] from the [Debug] menu to stop the tutorial program at breakpoints.

The program runs then stops at the condition specified under Ch1.
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Oxz00001038 wold tutorial{void)
0=z00001044 {

long a[107]:

long 3@

int 1

claz=z Sanple *p _=am;
0=00001046 D_=am= Sample;
0=z0000104e for{ i=0; 1<10; i++ ){
0=z00001050 i = randi):
O=z00001058 if{3 < 03
0=z0000105& i = =3

1

0xz0000105c | d o> al[i] = 3:

1
0=00001070 p =am—r=ortia);
0=0000107a p_=zan—:>change(a);
O=z00001082 p_=zan—:=0=a[0];
0=0000108a p =am—r=l1=a[l]:
0=z00001096 p_=zan—:=2=al[2];
0=000010a2 p =am—r=3=al[3];
0=z000010as p_=zan—>sd=ald];
0=000010ba p =am—r=5=a[5];
0=z000010ck p_=zan—:s=6=al&];
O0=000010d2 p =am—r=7=al[7].
0=z000010de p_=zan—:>=8=a[8]:
0=0000102a p =am—r=9=a[9];
0=z000010f6 [_Sam;
0=z000010fc ¥

Figure6.38 [Source] Window at Execution Stop

The [Status] window displays the following contents.

E— N (=
Ttem I Status I
Connected To: H22,72227 E6000 Emulator CPU 2000 (Emulator PCI Card Driwver)
CPUT H35/ 2237

Mode 7

Clock source Main:10MH=, Sub:3ZkH=

Lun status Ereak

Canse of last break Complex Ewent Svystem

Event Time Count O0h O0min 00s 000ms O000us O000ns

Lun Time Count O0h O0min 00s 000ms 738us 750ns

AT Memaory b Platform f Events /

Figure6.39 Displayed Contents of the [Status] Window

Refer to the [Watch] window for the value of variablei . The valueis4, indicating that the break occurred after
the condition had been satisfied five times.

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Remove the event point. Clicking the right-hand mouse button on the [Event] window displays a popup menu.
Select [Remove All] from this menu to remove all event points.
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6.16 Trace Functions

The trace functions of the emulator use the realtime trace buffer, which is able to store the information on up to
32,768 bus cycles. The content of this buffer, which is constantly updated during execution, is displayed in the
[Trace] window.

Select [Trace] from the [Code] submenu of the [View] menu to display the [Trace] window.

W Generic Trace =1O1x]

PTR Address | Tnatruction |Data |R/U |Area ‘Status Clock | Probes ‘N]{I |IRO?*D Tinestaup | Source |Lahel |

Figure6.40 [Trace] Window

When trace information is displayed in the [Trace] window, clicking the right-hand mouse button on the [Trace]
window displays apopup menu. Select [Clear] from this menu to clear the trace information.

The following sections give an overview of the trace functions and methods for setting them.
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6.16.1 Displaying a Trace (when Time Stamping isnot Available)

The method used to specify an address as an event condition for the tracing of read/write cycles and display the
trace is described below.

(1) Clicking the right-hand mouse button on the [Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box.

Trace Acquisition il il

General IStop I Delayed Stopl

—Suppress——————— Time Stamp
¥ Free Trace

Clock:

[~ DIC Cycles I Dizabled - l

[~ Befrash Cycles

r Trace Ewent:

Exwent:

~

add.. | Edi. Semuence.. Deiee | | bl |

QK. I Cancel

Figure6.41 [Trace Acquisition] Dialog Box
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(2) Register an address as an event condition for trace acquisition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Froperties 2=

General |Bus ! twea | Signals | Action |

~ Twpe Address
) EC Break " Don't Care @ Address ¢ Range

AddressLe |H 00000000
Address i |H00000000

[T Outside Fange

— Data Compare Direction——
[ Compare 7 Wse Mask " Read
Walue [

- IH L £ Wdrite

¢ Bute € Word
baskHD

* Either

Ok, I Cancel

Figure6.42 [Breakpoint/Event Properties] Dialog Box

(3) Use the [Source] window to refer to the address on the line that has‘g[i]=j;’ withinthet ut ori al function
and enter this addressin the [Address L o] edit box of the [Address] group box on the [General] page of the
[Breakpoint/Event Properties] dialog box. In this example, enter H 0000105c. This address has thus been
set. Click the [OK] button to close the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Froperties 2=

General |Bus ! twea | Signals | Action |

~ Twpe Address
) EC Break " Don't Care @ Address ¢ Range

AddressLa |H'000M 05C

{* Ewent .
Address i |H00000000
[T Outside Fange
— Data Compare Direction——
[ Compare 7 Wse Mask " Read
Walue IH'D

£ Wdrite

¢ Bute € Word
baskHD

Ok, I Cancel |

Figure6.43 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(4) The event that has been set is now displayed in the [Event] combo box of the [Trace Events] group box on
the [General] page of the [Trace Acquisition] dialog box.

Trace Acquisition ﬂﬂ
General | Stop | Delayed Stap |
—Suppress Time Stamp
¥ Eree Trace
[T DMAL Cycles Clack:
[ DIC Cycles IDisabIed |
[ Eefresh Cycles
— Trace Events
Ewent:
{3 (R] H105C address |
Edit... Sequence,.. Delete | Del &l |
ak. | Cahicel |

Figure6.44 [Trace Acquisition] Dialog Box (Adding an Event)
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(5) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages [1] to [4] to the [Trace Acquisition] dialog box.

Trace Acquisition ﬂil
General |Stop | DelapedStop| 1 |2 |3 |4 |
—Suppress—————— Time Stamp

[~ DMAC Cycles Clack:

[~ DIC Cycles IDisabIed ’l

[T Befresh Cycles

— Trace Everts

Exvent:
|9 (R)H105C address =l
bgd.. | Ed. Sequence. . Dekte | Delal |

Ok I Cancel |

Figure6.45 [Trace Acquisition] Dialog Box (Pages Added)
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(6) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button.

Trace Acquisition ﬂil
General | Stop | Delayed Stop 1 |2 | 3 | 4 |

r— Conditions

" Disabled " Paint to Point

Range Event

Ok I Cancel |

Figure6.46 [TraceAcquisition] Dialog Box (Displaying Page [1])
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(7) Select the event you have registered from the [Range Event] combo box. The event is now enabled. Click the
[OK] button to complete the trace setting.

Trace Acquisition e |
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I

r— Conditions

" Disabled " Puoint to Point ' Range " Exent

Range Event Edi... |

ak. I Cahicel |

Figure6.47 [Trace Acquisition] Dialog Box (Setting Completed)

(8) Make the setting such that the break occurs after the instruction at the address on the line that has ‘ d[i]=j;’
withinthet ut ori al function (H 0000105C in this example) has been executed five times (for details on
this, refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

o Generic Trace -0l x|

FTR ‘ Address | Instruction | Data | R ‘ Area ‘ status | Clock Probes | NMI | IRQ7-0 Tinestauwp | Source ‘ Label ‘

-00004 00105c EXTS.L ER4 17f4 ERD ROM FROG 1 1111 1 11111111 a[i] = 37
-00003 00105c  EXTE.L ER4 17f4 RD ROM FROG 1 1111 1 11111111 a[i] = 3;
-00002 00105c EXT5.L ER4 17f4 ERD ROM PROG 1 1111 1 11111111 a[i] = 3:
-00001 00105c EXTS.L ER4 17f4 ERD ROM FROG 1 1111 1 11111111 a[i] = 37
+00000 00105c  EXTS.L ER4 17f4 RD ROM FROG 1 1111 1 11111111 a[i] = 3;

Figure6.48 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertica) bars below the title bar to adjust the width
of the column.

(10) Remove the event points that have been set and clear the trace information. Click the right-hand mouse
button on the [Event] window to display a popup menu. Select [Delete All] from this menu to remove all of
the event points that have been set. Click the right-hand mouse button on the [Trace] window to display a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.2 Displaying a Trace (when Time Stamping is Available)

The following procedure is for obtaining and displaying, with time stamps, trace information on cycles of
writing to memory locations in the specified address range.

(2) Clicking the right-hand mouse button on the [Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box (see figure 6.41, [Trace Acquisition] dialog
box).

(2) Register the address range for trace acquisition as an event condition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box (see figure
6.42, [Breakpoint/Event Properties] dialog box).

(3) Click the [Range] radio button in the [Address] group box on the [General] page of the [Breakpoint/Event
Properties] dialog box. Use the [Locals] window to refer to the address on the line where variable a, which is
defined withinthet ut or i al function, isalocated (H 00FFEF80 in this example) and enter this address
in the [Address Lo] edit box. Then enter an address, which is H’ 27 added to that entered in the [Address L o]
edit box (H O0FFEFAY in thisexample), in the [Address Hi] edit box. This procedure sets the memory
range for variable a of thet ut ori al function.

(4) Click the [Write] radio button in the [Direction] group box to set awrite cycle for the specified range. This
completes the setting of a memory range. Click the [OK] button to close the [Breakpoint/Event Properties]
dialog box.

Breakpoint/Event Froperties 2=

General |Bus ! twea | Signals | Action |

~ Twpe Address
) EC Break " Don'tCare ¢ Address © Range

Address L |H'0OFFEFAD

{* Ewent .
AddiessHi  [H'ODFFEF&7
[ Outside Fange
— Data Compare Direction——
[ Compare 7 Wse Mask " Read
Walue IH'D

¢ Bute € Word
baskHD

€~ Either

Ok, I Cancel |

Figure6.49 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(5) The event that has been set in the [Event] combo box of the [Trace Events] group box on the [General] page

of the [Trace Acquisition] dialog box is displayed.

Trace Acquisition

General I Stop I Delayed Stopl
— Suppress Time Stamp
[~ DMAC Cycles
[~ DIC Cycles

[~ Befrash Cycles

Clock:

IDisabIed 'l

¥ Free Trace

2|

r Trace Ewent:

Exwent:

IS [R) H'FFEF20 range to H'FFEFAT write

Edit... Seguence,..

Delete |

pelal |

~

ok |

Cancel |

Figure6.50 [Trace Acquisition] Dialog Box (Adding an Event)

(6) To enable time stamping, select 125ns from the [Clock] combo box of the [Time Stamp] group box.

Trace Acq

General I Stop I Delayed Stopl
— Suppress Time Stamp
[~ DMAC Cycles
[~ DIC Cycles

[~ Befrash Cycles

Clock:

¥ Free Trace

2|

r Trace Ewent:

Exwent:

IS [R) H'FFEF20 range to H'FFEFAT write

~

sdd.. | Ed. Semuence.. Delte | Delal |
Ok I Cancel |

Figure6.51 [Trace Acquisition] Dialog Box (Time Stamping is Available)
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(7) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages [1] to [4] (seefigure 6.45, [Trace Acquisition] dialog box).

(8) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button (see figure 6.46, [Trace Acquisition] dialog box).

(9) Click the [Range Event] combo box to select the event you have registered. The event is now enabled. Click
the [OK] button to complete the trace setting.

Trace Acquisition i 3

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditions

" Dizabled £ Paint to Point {* Hange " Ewent

Fange Ewvent Edit... |

ak. I Cancel |

Figure6.52 [Trace Acquisition] Dialog Box (Setting Completed)

(10) Make the setting such that the break occurs after the instruction at the address on the line that has ‘p_sam-
>s0=g[0];" withinthet ut ori al function (H 00001082 in this example) (for details on this, refer to
section 6.15.1, PC Break Function).

(11) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

o Generic Trace = [ 3]

TR | Address | Instruction | Data ‘ R | Area | Status | Clock | Probes ‘ HMI | IRQ7-0 | Timestamp | Sour 4~

-00087 ffefan aoog R 0000h000nin00050000ns733u3575ns

-00086 ffefsz dlce  WR 0000k000Rin00050000s735us000ns

-00085 ffefdd oooo WR 0000h000Rin000s000ns759ua375ns

-00084 ffefas 167e TR 0000h000nin000s0000ns755u3500ns

-00083 ffefss aooo WR 0000k000Rin000s0000s775us87 508

-00082 ffefda 278l WR 0000h000Rin000s000ns760us000ns

-00081 ffefac aoog R 0000h000nin0005000ns800U3375ns

-00080 ffefie 4d6b  WR 0000k000Rin00050000s800us500ns

-00079 f£fefsn aoog R 0000h000nin000s000ns820us57 5ns

-00076 ffefsz 734b R 0000k000Rin000s000Rs821us000ns

-00077 f£Lfefsd aooo WR 0000h000Rin000s0000s841lus375ns

-00076 ffef9s 15fh TR 0000h000nin0005000ns841u3375ns

-00075 ££ef98 aooo WR 0000k000Rin000s000Rs861us875ns

—PIDD'M ffeffa 5%z TR UDUDhDUDminDUDSﬂUDmSSSluSB?SnS = i
4

Figure6.53 [Trace] Window (Displaying the Result)
If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width
of the column.
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(12) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
all the event points that have been set. Clicking the right-hand mouse button on the [Trace] window
displays a further popup menu. Select [Clear] from this menu to clear the trace information. To disable time
stamping, select Disabled in the [Clock] combo box of the [Time Stamp] group box on the [General] page
of the [Trace Acquisition] dialog box.

6.16.3 Statistics
The number of times the internal RAM has been written to can be included in the acquired trace information.

(1) Moake the setting such that a break occurs at the address on the line that has ‘p_sam->s0=4[0];" within the
tutorial function (H 00001082 in thisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

(2) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays trace information.

(3) Select [Statigtic...] from the popup menu that is displayed when you click the right-hand mouse button on
the [Trace] window. A message box appears, indicating that the trace datais being loaded, and the
[Statistic] dialog box will be displayed.

: 21
r— Statistic: Analysis
‘] Sef |
ltem |<Nnne> j
B [
Start : I
Eiesult |
End :I
[Clear |
Result :
Caondition | ArnoLint | FTR
KN I i
Cloze |

Figure6.54 [Statistic] Dialog Box
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(4) Select R/W in the [Item] combo box and enter WR in the [Start] edit box. After that, click the [New] button.
“R/W=WR”" is now displayed in the [Condition] column of the [Result] list box.

: 21x
— Statiztic Analysis
{* Default © Hanoe Set
ltem IF!N\-" ﬂ
Start : IWH
Bezult |
End :I
Clear |
Result :
Condition | Amount | FTR
R =R
KN I i
Close |

Figure6.55 [Statistic] Dialog Box (New Condition)
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(5) Then, select Areafrom the [Item] combo box and enter RAM in the [Start] edit box. After that, click the
[Add] button; the new condition is now added to the “R/W=WR" display in the [Condition] column of the
[Result] list box, so that it now shows“R/W=WR & Area=RAM". This completes setting of the condition.

— Statiztic Analysis

{* Default © Hanoe

ltem : farea |
Start : IHAM

End |

Result :

Candition | Amount | PTR

RAw'=wR & Area=RaM

KN i
Close |

Figure6.56 [Statistic] Dialog Box (Condition Added)
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(6) To start statistical analysis of the specified condition, press the [Result] button. The number of write
operations that satisfy the condition and the PTR values will be displayed.

: 21x]
— Statiztic Analysis
¢ Default © Hange Set
ltem I.&rea ﬂ
Start : IHﬂM
End : | d
Clear |
Result :
Condition | Amount | FTR
RAw'=w R Area=RAM 1114 -09063,-09058,-0905:
N I i
Close |

Figure6.57 [Statistic] Dialog Box (Result of Analysis)

(7) Click the[Close] button to close the [Statistic] dialog box.

(8) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Event] window displays a popup menu. Select [Delete All] from this menu to remove all the
event points that have been set. Clicking the right-hand mouse button on the [Trace] window displays a
further popup menu. Select [Clear] from this menu to clear the trace information.

338
RENESAS




6.16.4 Function Calls
This mechanism is used to only collect trace information on the function calls.

(1) Makethe setting such that a break occurs at the address on the line that has ‘p_sam->s0=g[0];" within the
tutorial function (H 00001082 in thisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

(2) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the

[Trace] window then displays trace information.
(3) Select [Function Call...] from the popup menu displayed by clicking the right-hand mouse button on the
[Trace] window. The [Function Call Display] diaog box will be displayed.

Function Call Display ﬂﬂ

Setting

Enable to dizplay trace information with function
call only 7

{~ Enable

0K | LCancel |

Figure6.58 [Function Call Display] Dialog Box

(4) Click the [Enable] radio button and then the [OK] button. Only the information on function callsis now
displayed in the [Trace] window (the [Label] column’s right-side boundary has been moved to the left in the
[Trace] window to show the function calls).

- Generic Trace _I— _ID 5'
Lakhel | PR | add...| Instruction | pata| /| Area| Status | clock | Probes | mmr | IRo7-o |-
PowerOl_Reseti) -09108 000400 MOV.L #H'00FFEFCO,ER? 7a07 RD EROM  PROG 1 1111 1 11111111
_main -03582 001034 BSR Btutorialij:s 5502 RD EROM  PROG 1 1111 1 11111111
tutorial|) -03578 001038 MOV.L ER3, B-ER7 0l00 D ROM  PROG 1 1111 1 11111111
Sample: :Sample() -03558 002000 MOY.L ERZ,B-ER7 0lo0 RD ROM PROG 1 1111 1 11111111
_shrk -03369 001000 STM.L (ERZ-ER3) ,@-5P 0110 ED ROM PROG 1 1111 1 11111111
Sawple::sortilong *) -01667 002068 STM.L ({ERZ-ER3) ,@-5F 0110 ED ROM FROG 1 1111 1 11111111
Semple: :change (Long *)  -00459 0020d5 MOV.L FR3,B-FR7 0100 RD ROM  PROG 1 1111 1 11111111
4 I

Figure6.59 [Trace] Window (Function Calls)

(5) Toreturnthedisplay in the [Trace] window to its previous state, follow the procedurein (3) to display the
[Function Call Display] dialog box. Click the [Disable] button and then the [OK] button.

(6) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
all the event points that have been set. Clicking the right-hand mouse button on the [ Trace] window displays
afurther popup menu. Select [Clear] from this menu to clear the trace information.
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6.17 Stack Trace Function
The emulator uses the stack’ sinformation to display the function call history.

Notes: 1. Thisfunction can be used only when the load module that has the Dwarf2-type debugging
information isloaded. Such load module is supported in H8S, H8/300 C/C++ compiler V4.0 or later.

2. For details on the stack trace function, refer to the online help.

* Double-click the [Editor] columninthesort function and set a PC breakpoint.

0=00002068 wold Sample: j=ort{long *a)
O=x00002070 i
long t:
int 1., j. k. gap:
0x00002072 gap = 5
0=00002074 while{ gap » 0 3{
0=00002078 for{ k=0; k<gap: k++){
0=0000207c for{ i=k+gap; 1<10; i=i+gap )
0=z00002080 for{j=i—gap; j:=k. j=j-gap){
O0x00002084 » if{aljlrali+gapli{

t = alil:
0x00002024 ali]l = ali+gapl:
0=000020a8 alj+gap] = t:

h

else

brealk
H
b
H

0=000020c0 gap = gap-s2;
0=z000020cc T

Figure6.60 [Source] Window (PC Breakpoint Setting)

» Select [Reset Go] from the [Debug] menu.
» After the break in program execution, select [Stack Trace] from the [Code] submenu of the [View] menu to
open the [Stack Trace] window.

Kind |Name |Walue |
F Sanple: izort(long *) { 0=x00002084 3
F tutorial() { 0=x0000107%7a 7}
F mnaini) { 0=0000103&
F PowerON_Re=et () { 0=0000041e 3}

Figure6.61 [Stack Trace] Window

Figure 6.61 shows that the position of the program counter is currently at the selected line of thesor t ()
function, and that thesort () functioniscaled fromthet ut ori al () function.

To remove the PC breakpoint, double-click the [Editor] columninthesort function again.
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6.18 Performance Measurement Function
Performance measurement by the emulator isin the following modes:

»  Time Of Specified Range Measurement

e Start Point To End Point Measurement

. Start Range To End Range Measurement

e Access Count Of Specified Range Measurement
e Called Count Of Specified Range M easurement

In thistutorial, we describe the Time Of Specified Range Measurement.

6.18.1 Time Of Specified Range M easurement

(1) Select [Performance Analysis] from the [Performance] submenu of the [View] menu to display the [Select
Performance Analysis Type] dialog box.

ct Performance Ana

Performance Analysis: EE000 Performance Anal

LCancel

Figure6.62 [Select Performance Analysis Type] Dialog Box

(2) Select “E6000 Performance Analysis’ from the [Performance Analysis] combo box in the [Select
Performance Analysis Type] dialog box and click the [OK] button. The [Performance Analysis| window will
be displayed.

- Performance Analysis = |EI|5|
No Name | Condition |pate | mm-TimE | ma-nIN-TINE Count | 0---10---20---
1
2
3
1
5
6
7
8
4 | |

Figure6.63 [Performance Analysis| Window
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(3) Select theline of the [Performance Anaysis] window that has 1 in its [No] column and click the right-hand
mouse button to display a popup menu. Select [Set...] from this popup menu to display the [Performance
Analysis Properties] dialog box.

Performance Analvsis Properties

Measurement Method PA1: Specified Hange

Range Mame : |PA1
Range

Start Address : IH'DDDDDDDD _I
End Address : |H'DDDDDDDD

— Carmmon Settings of Performance[Pad-8)

Address Contral Mode: Prefetch Settings... |
Time Meazurament Unit: 160ns
Cancel |

Figure6.64 [Performance AnalysisProperties| Dialog Box

(4) Select Time Of Specified Range Measurement from the [M easurement Method PA1] combo box.
(5) The parameter settings are as follows.

Enter “sort” in the [Range Name] edit box.

Click the[...] button to the right of the [Start Address] edit box to display the [Input Function Range]
dialog box. Enter the function name “sort” in the [Function] edit box of this dialog box and then click
the [OK] button. The corresponding addresses for the function “sort” will now be set in the [Start
Address] and [End Address] edit boxes.

Inpuk Function Range

2l
Function

zart Cancel

Note:

342

Figure6.65 [Input Function Range] Dialog Box

The addresses figured out in the [Input Function Range] dialog box are just for reference. In some cases,
the end address of a function may be different. Check the last instruction of the function in the
[Disassembly] window to correct the value set in [End Address] so that it will be the address of the last
ingtruction (in general, the last instruction of afunction isa RTS instruction). A label name or an
expression can be entered instead of an address value in boxes where an address should be entered.
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(6) Click the [Settings...] button in the [Common Settings of Performance(PA1-8)] group box to display the
[Common Settings of Performance(PA1-8)] dialog box. Select [PC] from the [Address Control Mode] combo
box and then click the [OK] button. PC is now displayed in the [Address Control Mode] text field of the
[Common Setting of Performance(PA1-8)] dialog box.

Common Settings of PerformanceiPal-g) ﬂ il

Address Control Mode PC -
Time Measurement Unit |1BDns j Eamel |

Figure6.66 [Common Setting of Perfor mance(PA1-8)] Dialog Box

(7) Click the [OK] button to display the content that has been set for line 1 of the [No] column in the
[Performance Analysis] window. This completes the settings for a Time Of Specified Range Measurement.

«# Performance Analysis [ =] 7]
Ho Mame | Condition I Rate I RUN-TIME I MAX-MIN-TIME | Count I 0---10---20---30-—-
1 sort Range H'00002068 H'0000Z0D4 0% 00h OOmin 00s 000ws 000us 000ns

2

3

4

5

6

7

8

4 | ol

Figure6.67 [Performance Analysis] Dialog Box (Setting Completed)

(8) Set an event point at the address on the line that has ‘ p_sam->change(a);” withinthet ut ori al function
(H 0000107 inthisexample) so that a break occurs when the specified sor t function has been executed
three times (refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Performance Analysis] window then displays the information shown below. The vaue shown in the [Count]
column is 3, which indicates that the sor t function has been executed three times and the execution time.

_lolx|
| pace RUN-TIME | mac-man-TInE | count | 0---10---z0---30---

1 gort  Range H'00002068 H'0000Z0D4  18% 00k O0min 00z O0Oms 352us 430ns 3 #REEEEEER
z

A @ m e

| &

Figure6.68 [Performance Analysis| Dialog Box (Displaying the Result)

(10) Delete the setting for performance analysis and remove the event point. Click the right-hand mouse button
on the [Performance Analysis] window to display a popup menu. Select [Reset All] from this popup menu to
delete all of the settings. Clicking the right-hand mouse button on the [Event] window also displays a popup
menu. Select [Delete All] from this popup menu to remove all the event points that have been set.
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6.19 Monitor Function

The emulator allows monitoring of the content of specified addresses in memory during execution of the user
program. In this example, we monitor the content of the address range where variable a of thet ut ori al
function is stored.

(1) Select the [CPU] submenu from the [View] menu. Then selecting [Monitor Setting...] from the [Monitor]
submenu displays the [Monitor Setting] dialog box.

21|
Manitar Setting I
Mame: |monitor1
— Optiars
Address: |H'DDDDDDDD
Size [bytel |Hzn |
Access [Format); |BYTE (25T j

¥ &uto-Refresh at rate [ms] : ID'DDEDD

[V Reading the Initial alue

r— Colar
Change Indicator; I Change j
Foreground: [N |~ Backgound: [ ] IvI
[V tayfly
r— Detail
IDETNL MOT SUPPORTED! Detail |
— Higtom

oK Cancel
| I

Figure6.69 [Monitor Setting] Dialog Box
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(2) Set theitemsin the [Monitor Setting] dialog box as follows:
e Enter monitorl in the [Name] edit box.
e Set the parametersin the [Options] group box as follows:
(a) Usethe[Locals] window to refer to the address on the line where variable a, which is defined within

thet ut ori al function, isallocated and enter this address in the [Address] edit box. In this example,
enter H OOFFEF80.

(b) Enter H 50 inthe [Size] edit box.
(c) Select BYTE (HEX) from the [Access] combo box.
(d) Check the [Auto-refresh at rate] check box and enter D' 00500.
(e) Check the [Reading the Initial Vaue] check box.
*  Set the parametersin the [Color] group box as follows:
(a) Select Change from the [Change Indicator] combo box.
(b) Select red and white in the [Foreground] and [Background] combo boxes, respectively.
(c) Check the [Mayfly] check box.

Note: Depending on the operating system in use, the foreground and background colors may not be selectable.

Monitor Setking 2x|
M anitar Setting |
Hame: Imonitnr'l
— Optionz
Address: |H'DDFFEF8IZI
Size (byte]: [H'50 =]
Aecess [Fomat): IBYTE HEX] j

¥ Auto-Refresh at rate [ms) : ID'DDEDD

¥ Reading the Initial Yalue

— Colar
Change Indicator: IEhange ﬂ
Foreground: _Ivl B ackground: |:||v|
v Maply
— Detail
lDETﬁIL MOT SUPPORTELD! [Deta |
— Histary

| |
ak I Cancel |

Figure6.70 [Monitor Setting] Dialog Box (Setting Completed)
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(3) Click the [OK] button to open the [Monitor] window.

«# monitar; monitarl - H'OOFFEFS0

Addre=ss

0x00FFEFB0
0x00FFEF &8
0x00FFEFS0
0x00FFEF 38
Ox00FFEFAQ
0xQ00FFEFAB
Ox00FFEFBO
0xQ00FFEFEB
Ox00FFEFCO
0xQ00FFEFCSB

Data

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
FF
00
00
18
18

19
44
3F
ic
15
BO
Q0
10
ah
6h

4B
aB
54
FB
FB
D8
oa
34
18
18

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
FF
FF
00
18
18

=101 %]

59
41
27
14
oF
EF
EF
04
ah
6h

E2
Ccé
81
7E
Fa
80
80

18
18

| v

Ll
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Figure6.71 [Monitor] Window
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(4) Select [Reset Go] from the [Debug] menu. When the content of the address range changes with execution,

the updated values are red (i.e. the color that was selected in the [Foreground] and [Background] combo
boxes). Values will be displayed in black if they have not been updated or a certain period of time has

elapsed since the last update.

«# monitar; monitarl - H'OOFFEFS0

Addre=ss

0x00FFEFB0
0x00FFEF &8
0x00FFEFS0
0x00FFEF 38
Ox00FFEFAQ
0xQ00FFEFAB
Ox00FFEFBO
0xQ00FFEFEB
Ox00FFEFCO
0xQ00FFEFCSB

Data

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
FF
00
00
18
18

08
27
38
49
a8
BO
Q0
10
ah
6h

39
4D
cl
EE
70
D8
00
34
18
18

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
00
FF
00
18
18

16

4E
a7
10
41
EF
04
ah
6h

=101 %]

54
08
3F
5C
iF
Ccé
80

18
18

| v

=

Figure6.72 [Monitor] Window (during Execution)

(5) After you have finished checking the statesin the [Monitor] window, select [Halt Program] from the [Debug]

menu to halt the program’ s execution.
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6.20 What Next?
Thistutorial has described the major features of the emulator and the use of the HEW.

Sophisticated debugging can be carried out by using the emulation functions that the emulator offers. This
provides for effective investigation of hardware and software problems by accurately isolating and identifying
the conditions under which such problems arise.
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Section 7 Hardware Specifications Specific to This Product

This section describes the hardware specifications on the H8/3664 E6000 emulator.

7.1 H8/3664 E6000 Emulator Specifications

The H8/3664 E6000 emulator supports the system development using the following microcomputers:

» H8/3664 group
» HB8/3664N

» HB8/3672 group
» H8/3687 group
* HB8/3694 group
» H8/36014 group
» H8/36057 group
» H8/36037 group
» H8/36024 group
» H8/36049 group

7.11 Supported Items

For emulation of the H8/36057 group or the H8/36037 group, an expansion 1/O board (HS36037EIO061H) is
required.

For emulation of the H8/36024 group or the H8/36049 group, an expansion 1/O board (HS36024EI061H) is
required.

For notes on the user cable and the expansion /O board, refer to the user’s manual provided for each of them.

Contact Renesas’ sales office for the MCU type names and packages supported by the EG000 emulator and for

the combination of the E6000 user system interface cables and optional boards.
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712 Operating Voltage and Frequency Specifications

Table 7.1 shows the MCU operating voltage and frequency specifications supported by the E6000 emulator. If
the emulator is used in an environment that exceeds the operating voltage range and operating frequency range
guaranteed for the MCU operation, normal emulator operation is not guaranteed. Note that the operation with
low voltage or high frequency is not supported in some MCUSs.

Table7.1 Operating Voltage and Frequency Specifications

Operating Frequency

No. MCU Types Operating Voltage (V) (@ (MHz)
1 H8/3664 group (except for H8/3664F)  2.7-5.5 1-10
4.0-5.5 1-16
2 H8/3664F 3.0-5.5 1-10
H8/3664N 4.0-5.5 1-16
3 H8/3672 group 3.0-5.5 1-10
4.0-5.5 1-16
4 H8/3687 group 2.7-5.5 1-10
H8/3694 group 4.0-5.5 1-20
5 H8/3684F 3.0-5.5 1-10
H8/3687F 4.0-5.5 1-20
H8/3694F
6 H8/36014 group 3.0-5.5 1-10
4.0-5.5 1-20
7 H8/36024 group 3.0-5.5 1-10
H8/36049 group 4.0-5.5 1-20
8 H8/36037 group 3.0-5.5 1-10
H8/36057 group 4.0-5.5 1-20

NOTE

For details on the operating voltage and frequency specifications,
refer to the MCU hardware manual.
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7.2 User System Interface

All user system interface signals are directly connected to the MCU in the emulator with no buffering except for
those listed below which are connected to the MCU through control circuits:

« NMI
- IRES
.+ 0OsC1
« X1

« TEST
* VCL

721 Signal Protection

All user system interface signals are protected from over- or under-voltage by use of diode arrays except for the
AVcc.

Pull-up resistors are connected to the port signals except for the analog port signals.

The Vcc pins (except for the AVcc pin) at the head of the user system interface cable are connected together.
The emulator monitors the voltage level of the Vcc pins and displays the power-supply status in the [Extended
Monitor] window.

If the user system interface cable is not connected to the user system, the Uvce of the MCU is5 V.

722 User System Interface Circuits

The interface circuit between the MCU in the emulator and the user system has a signal delay of about 8 nsdue
to the user system interface cable and it includes pull-up resistors. Therefore, high-impedance signalswill be
pulled up to the high level. When connecting the EG000 emulator to auser system, adjust the user system
hardware to compensate for propagation delays.

Default:

UVce
47 kQ

47 Q User system
MCU A

w —————oO0 .
@ é interface cable

Figure7.1 Default User System Interface Circuit

/RESand NMI: The NMI signal isinput to the MCU through the emulator control circuit. The rising/falling
time of the signal must be 8 ng/V or less.

UVce

HC14 HC14 47kQ

Emulator User system
c_ontrlol interface cable
circuit

Figure7.2 User System Interface Circuit for /RESand NM|I
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PBO to PB7 (pinsused for ANOto AN7), AVcc and AVss:

AVcc
470
MCU PBO/ANO to PB7/AN7 USer system
interface cable
AVss
AVce
MCU User system
interface cable
O AVss
0.022 uF

Figure7.3 User System Interface Circuit for PBOto PB7, AVcc and AVss Signals

V. and TEST: WhenV_ isconnected to GND or the TEST pin is connected to the Vcc level, awarning
message to indicate that the pin connections are incorrect will be displayed when the HEW isinitiated. Recheck

these pins on the user system.

Vcu
MCU
TEST

It

Vel
TEST

——-oO VcL
——->=O TEST

j/v J”_0.1 uF

Pin monitor
circuit
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Figure7.4 V_ and TEST System Interface Cir cuit
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7.3 Differ ences between M CU and Emulator

When the emulator isturned on or initialized, or the system is reset, there are some differencesin theinitial

valuesin some of the general registers between the MCU and the emulator as shown in table 7.2.

Table7.2 Initial Value Differences between MCU and Emulator

Status Register E6000 Emulator MCU
Power-on/ PC Reset vector value Reset vector value
initialized EROto ER6  Undefined Undefined
ER7 (SP) H'10 Undefined
CCR The | mask is set to 1 and the The | mask is set to 1 and the

other bits are undefined

other bits are undefined

Reset command PC Reset vector value

Reset vector value

EROto ER6  Undefined
ER7 (SP) H'10

CCR The I mask is set to 1 and the
other bits are undefined

Undefined
Undefined

The I mask is set to 1 and the
other bits are undefined

731 A/D Converter and D/A Converter

Due to the use of auser system interface cable, thereis a slight degradation in the A/D and D/A conversion than

that quoted in the Hardware Manual for the MCU being emul ated.
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7.4 Handling Serial EEPROM Board

AWARNING

Always switch OFF the emulator and user system before
connecting or disconnecting the serial EEPROM board and make sure
that the pin 1 on both sides are correctly aligned. Failure to do so will
result in a FIRE HAZARD and will damage the user system and the
emulator product or will result in PERSONAL INJURY. The USER
PROGRAM will be LOST.

To remove and fasten the emulator cover, take the following steps.

Remove four screws from the sides of the emulator station.

Pull the emulator cover upward and removeit.

Install the serial EEPROM board in the serial EEPROM socket (M1) of the emulator.
Close the emulator cover and fasten it with the four screws.

A w DN

Figure7.5 Removing and Fastening the Emulator Cover

This emulator includes a serial EEPROM board (HS3664EM S61H) for evauation of the H8/3664N (on-chip
EEPROM). Figure 7.6 shows the installed of this serial EEPROM board. Align pin 1 with pin 1 of serial
EEPROM socket (M 1) on the emulator. The seriadl EEPROM board must be installed to evaluate the H8/3664N.
When evaluating any other MCU, remove the serid EEPROM board. The slave address code of the seria
EEPROM board is always H’ 00. Note that the slave address code can be rewritten to H’ 00 to H’ 07; however, the
slave address of this serial EEPROM board must always be H’00 (initial value of H8/3664N on-chip EEPROM).
The EEPROM can be programmed up to 100,000 times. If programming exceeds 100,000 times, purchase a new
serial EEPROM board (HS3664EM S61H) and change it with the old one.

354
RENESAS




Serial EEPROM
board

Serial EEPROM
socket

Figure7.6 Installing Serial EEPROM Board
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Section 8 Software Specifications Specific to This Product

This section describes the software specifications of the H8/3664 E6000 emulator.

8.1 Softwar e Specifications of the H8/3664 E6000 Emulator

Information specific to this emulator is given below.

811 Target Hardware

This emulator software conforms to the H8/3664 E6000 (HS3664EPI61H) emulator.

8.1.2 Selectable Platforms
The debugging platforms selectable in this emulator are listed below.

Table8.1 Selectable Target Platforms

Debugging Platform Remark

H8/3664 E6000 Emulator CPU 300H For emulation of the MCUs that have the H8/300H CPU as the
core without any expansion 1/0 board in use.

H8/36037 E6000 Emulator CPU 300H  For emulation of the MCUs that have the H8/300H CPU as the
core with the expansion 1/0 board (HS36037EIO61H) in use.

H8/36024 E6000 Emulator CPU 300H  For emulation of the MCUs that have the H8/300H CPU as the
core with the expansion 1/0 board (HS36024EI061H) in use.

RENESAS

357



8.1.3

[Configuration Properties| Dialog Box ([General] Page)

Itemsthat can be set in this dialog box are listed below.

&4 EAO00 Configuration Properties ﬂil
General |
Davioe: Uger Signals
Device: Iw User Peset enable
. [w User NMI enable
Clock: f1hHz [¥ | Uzer Standby enable
[ lser Bus Request ensble

SubGlock:  [32.760kHz

Ll Lef Lol

Timer Resalution: |1 25nz

[# Enable read and write on the fly
[+ Break on access errar

[~ Enable internal ROM area write
[¥ Tramsit to active mode at break

User YOG Threshold = 270V 4] [ i

Diriver: |Emu|atc-r PCI Gard Driver
[~ Chanee driver in start up

oK I Cancel
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Figure8.1 [Configuration Properties] Dialog Box ([General] Page)
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[General] page

[Device]

[Clock]
[SubClock]

[Timer Resolution]

[Enable read and write on the
fly]

Selects the MCU to be emulated. To use an MCU not included in the list,
select [Custom] to specify the functions required for this MCU. See the
hardware manual for details.

Selects the speed of the MCU'’s clock and sub-clock.

Selects the speed of the MCU'’s sub-clock. (Note that selection is not
available when emulating the H8/3672 group, H8/36014 group, H8/36024
group.)

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this box if you
require realtime emulation.

- When accessing the internal ROM or internal RAM

HEW accesses the memory directly as the bus mastership is released to
the emulator without breaking the user program. The MCU waits for eight
clock cycles in each access.

- When accessing the internal I/O

Memory is accessed with breaking the user program. This pause is
approximately 378 ps while operating at 16 MHz.

When the internal RAM is disabled, an access to this area is not available
during the user program execution.

Note:

When the content of the memory is modified during the user program
execution (e.g. modification in the [Memory] window or by the
MEMORY_EDIT command), HEW reads the content to update the value.

HEW also reads the memory content when the content has been updated
by operations such as selecting [Memory -> Refresh]. In this case, the
content of memory is read and then updated in each of the windows.

To prevent unnecessary reading of the memory content, close the
window displaying the memory content (such as the [Memory] or
[Disassembly] window) or make the settings so that the content will not
be updated.

The [Monitor] window, or the [Watch] window that satisfies the conditions
listed below displays the memory content. Note that, however, opening
these windows does not prevent realtime operation because the method
of updating the memory content in these windows is different.

Conditions:
1. Registered symbols are only allocated to general-purpose registers.

2. Registered symbols are only allocated to the monitor range set by the
[Monitor] function (the mark R is colored in blue).

3. Registered symbols are comprised of those with the conditions 1 and 2
listed above.
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[General] page (cont)

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses an access-prohibited area or writes to a write-
protected area.

[Enable internal ROM area write] ~ When this box is checked, writing to the internal ROM area is enabled.

For the result of writing, see the [Extended Monitor] window.

[Transit to active mode at break]  Checking this box causes the emulator to enter the active mode when a

break occurs if the emulator has been in the subactive mode immediately
before the occurrence of a break. This allows a break processing by the
system clock.

[User VCC Threshold] Sets the voltage level for the user system. [Down] will be displayed in
[User System Voltage] of the [Extended Monitor] window when the actual
user VCC of the target system is lower than the specified value.

[User Signals] When this box is checked, the reset and NMI signals from the user
system are enabled.

[Driver] Displays the E6000 driver that is currently installed.

[Change driver in start up] When this box is checked, selection of a driver will be available next time

the emulator is connected.

The MCUs selectable by the [Device] option and options that depend on the MCUs are listed below. To emulate
an MCU with adescription in the Expansion Hardware column, connect the correct expansion hardware.

Table8.2 Environment for the H8/3664 E6000 Emulator CPU 300H Debugging Platform

[Device] Option

[Clock] Option Expansion Hardware

Custom The MCU previously selected
H8/3664 Main: 1 MHz, Sub: 32.768 kHz None
H8/3663 Main: 10 MHz, Sub: 32.768 kHz
H8/3662 Main: 16 MHz, Sub: 32.768 kHz
H8/3661 Main: 1 MHz, Sub: Target
H8/3660 Main: 10 MHz, Sub: Target
H8/3664F Main: 16 MHz, Sub: Target
H8/3664N Main: Target, Sub: Target
H8/3687

H8/3686

H8/3685

H8/3684

H8/3683

H8/3682

H8/3687F

H8/3684F

H8/3694

H8/3693

H8/3692

H8/3691

H8/3690

H8/3694F

H8/36014F Main: 1 MHz

H8/36012F Main: 10 MHz

H8/3672F Ma?n: 16 MHz

H8/3670F Main: Target

Note: Target in [Clock] is only available when the target system is connected.
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Table8.3 Environment for the H8/36037 E6000 Emulator CPU 300H Debugging Platform

[Device] Option

[Clock] Option Expansion Hardware

Custom

H8/36037
H8/36036
H8/36035
H8/36034
H8/36033
H8/36032
H8/36037F
H8/36034F

H8/36057
H8/36054
H8/36057F
H8/36054F

The MCU previously selected

Main: 1 MHz, Sub: 32.768 kHz HS36037EI061H
Main: 10 MHz, Sub: 32.768 kHz

Main: 16 MHz, Sub: 32.768 kHz

Main: 1 MHz, Sub: Target

Main: 10 MHz, Sub: Target

Main: 16 MHz, Sub: Target

Main: Target, Sub: Target

Note: Target in [Clock] is only available when the target system is connected.

Table84  Environment for the H8/36024 E6000 Emulator CPU 300H Debugging Platform

[Device] Option

[Clock] Option Expansion Hardware

Custom The MCU previously selected
H8/36024 Main: 1 MHz HS36024EI1061H
H8/36022 Main: 10 MHz
Main: 16 MHz
Main: Target
H8/36049 Main: 1 MHz, Sub: 32.768 kHz
H8/36048 Main: 10 MHz, Sub: 32.768 kHz
H8/36047 Main: 16 MHz, Sub: 32.768 kHz
H8/36049F Main: 1 MHz, Sub: Target

Main: 10 MHz, Sub: Target
Main: 16 MHz, Sub: Target
Main: Target, Sub: Target

Note: Target in [Clock] is only available when the target system is connected.
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8.14

[Configuration Properties] Dialog Box ([Custom] Page)

Itemsthat can be set in this dialog box are listed below.

2=l
Gereral  Custom Device
ROME:
FLa bt |2048E} j [~ Enable Flash memary
— Modules
[~ Enable TimerE1 [¥ Enable WatchDogTimer ‘H('E S[?_"Ecgl
[~ Enable TimerB2 [+ Enable &/D Converter e H(I;a_e
[~ Enable TimerB2 [¥ Enable SCI3 ~ ]IOé
[+ Enable Timery [~ Enable SCI3-2
W Enable Timeril I” Enable SCH-1 —T(i_me[;ﬁ fh lRTO—
[~ Ensble Timerx I~ Enable SCI4-2 - n'fer':
[~ Enable TimerZ0 [~ Enable 14Bit Pyt Timer  RIC
[~ Enable TimerZ1
’TI Cancel |

Figure8.2 [Configuration Properties] Dialog Box ([Custom Device] Page)
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[Custom Device] page

[ROM]

Specify the internal ROM area size.

8KkB: Sets the internal ROM area to be 8 kbytes (H'000000 to H'001FFF).

12kB: Sets the internal ROM area to be 12 kbytes (H'000000 to
H'002FFF).

16kB: Sets the internal ROM area to be 16 kbytes (H'000000 to
H'003FFF).

24kB: Sets the internal ROM area to be 24 kbytes (H'000000 to
H'005FFF).
32kB: Sets the internal ROM area to be 32 kbytes (H'000000 to
H'007FFF).

40kB: Sets the internal ROM area to be 40 kbytes (H’'000000 to
H'009FFF).

48kB: Sets the internal ROM area to be 48 kbytes (H’'000000 to
H'00BFFF).

56kB: Sets the internal ROM area to be 56 kbytes (H'000000 to
H'00DFFF).

[RAM]

Specify the internal RAM area size.

512B: Sets the internal RAM area to be 512 bytes (H'FFFD80 to
H'FFFF7F).

1024B: Sets the internal RAM area to be 1024 bytes (H'FFFB80 to
H'FFFF7F).

1536B: Sets the internal RAM area to be 1536 bytes (H'FFF980 to
H'FFFF7F).

2048B: Sets the internal RAM area to be 2048 bytes (H'FFF780 to
H'FFFF7F).

3072B: Sets the internal RAM area to be 3072 bytes (H'FFECO0 to
H'FFEFFF and H'FFF780 to H'FFFF7F).

4096B: Sets the internal RAM area to be 4096 bytes (H'FFE800 to
H'FFEFFF and H'FFF780 to H'FFFF7F).

5120B: Sets the internal RAM area to be 5120 bytes (H'FFE400 to
H'FFEFFF and H'FFF780 to H'FFFF7F).

6144B: Sets the internal RAM area to be 6144 bytes (H'FFEO0O0O to
H'FFEFFF and H'FFF780 to H'FFFF7F).
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[Custom Device] page (cont)

[Modules]

Check this box to validate on-chip peripherals.

Enable TimerB1: Enables timer B1.

Enable TimerB2: Enables timer B2.

Enable TimerB3: Enables timer B3.

Enable TimerV: Enables timer V.

Enable TimerW: Enables timer W.

Enable TimerX: Enables timer X.

Enable TimerZ0: Enables timer Z0.

Enable TimerZ1: Enables timer Z1.

Enable WatchDog Timer: Enables the watchdog timer.
Enable A/D Converter: Enables the A/D converter.
Enable SCI3: Enables SCI3.

Enable SCI3-2: Enables SCI3_2.

Enable SCI4-1: Enables SCI4_1.

Enable SCI4-2: Enables SCI4_2.

Enable 14Bit PWM Timer: Enables the 14-bit pulse width modulator.
IIC Select: Selects whether or not to enable IIC1 or [IC2.

Disable: Disables IIC1 and IIC2.
1IC1: Enables IIC1.
11IC2: Enables IIC2.

TimerA/RTC: Selects whether or not to enable timer A or RTC.

Disable: Disables timer A and RTC.
TimerA: Enables timer A.
RTC: Enables RTC.
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8.15 Memory Mapping Function

The memory map cannot be changed with this emulator.

8.1.6 [Status] Window

Selecting [View -> CPU -> Status] or clicking the [Status Display] toolbar button displays the [Status] window.

The [Status] window has three sheets. This emulator displays the following items.
(1) [Memory] Sheet
Selecting the [Memory] tab on the [Status] window displays this sheet.

Table85 [Memory] Sheet Items

[Item] Column [Status] Column

Target Device Configuration Displays memory mapping.

System Memory Resources Displays the memory resource of the emulator hardware.
Program Name Displays the program file name.
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(2) [Platform] Sheet

Selecting the [Platform] tab on the [Status] window displays this sheet.

Table8.6 [Platform] Sheet Items

[Item] Column

[Status] Column

Connected To:
CPU

Clock source

Displays emulator name (driver used).
Displays the target MCU name.

Displays the selected clock.

Subclock source

Displays the selected sub-clock.

Run status

Displays the execution status.
Break: The user program breaks
Running: The user program is running

Cause of last break

Displays the cause of the emulator stopped at a break. If a program
breaks in the sub-active state, '(SubActive)' will be displayed after the
cause of the break.

Ready: User program not executed (immediately after starting the HEW)
User Break: Break by the user

PC Break: Break by program breakpoint

On Chip Break A: Break by hardware PC Break

Complex Event System: Break by complex event system

Stepping Completed: Break by stepping completed

Stepping Aborted: Break by stepping aborted

ROM Write Access Break: Break by writing to ROM

Unused Area Access Break: Break by accessing to a guarded memory
Performance Break: Break by Performance Analysis

Invalid breakpoint: Break by a break instruction without PC Break

Event Time Count

Displays the measured result of the timer between events.

Run Time Count

Displays the total execution time of the program.

(3) [Events] Sheet

Selecting the [Events] tab on the [Status] window displays this sheet.

Table8.7 [Events] Sheet Item

[Item] Column

[Status] Column

Resources

Displays the resource information and the information on events such as
the breakpoint.
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8.17 Extended Monitor Function

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button displays the
[Extended Monitor] window. This emulator displays the following items.

Table8.8 [Extended Monitor] Window Items

[Item] Column [Value] Column

User NMI Displays the status of the NMI pin.

User Reset Displays the status of the reset pin.

User System Voltage Displays whether or not the user VCC is equal to or exceeds the value set in
[User VCC Threshold] on the [General] page of the [Configuration Properties]
dialog box.

User Cable Displays whether or not the user cable is connected.

Running status Displays the address bus value in the MCU and the status of the CPU while
the user program is running, and the cause of a break while the user program
is halted.

Break = <Cause of break>: Displays the cause of a break.

Address = <Address bus value>:
Displays the address bus value during the user program execution. While in
subactive mode, ‘(SubActive)’ is displayed after the address bus value.

Status = <Status of the CPU>: Displays the status of the CPU.

PREFETCH: CPU instruction prefetch cycles
DATA: CPU data access cycles

SLEEP: Sleep mode

STANDBY: Standby mode

SUBSLEEP: Subsleep mode

ROM Write Displays whether or not the ROM has been written to during the user program
execution.

Once the ROM has been written to, the state is retained until the Configure
Platform is set again.

Target Clock Displays whether or not there is a clock signal to be input from the user
system.

Note: In this emulator, the update interval in the [Extended Monitor] window cannot be selected or changed.
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8.1.8 Signalsto Indicate Bus States and Ar eas

The following tables show examples of signalsto indicate the bus states and areas that can be acquired by the
emulator.

Table8.9 Bus State Signals Acquired by the Emulator

Bus State Trace Display (Status) Description
CPU Prefetch PROG CPU prefetch cycles
CPU Data DATA CPU data access cycles

Table8.10 Area Signals Acquired by the Emulator

Area Trace Display (Area) Description
On-chip ROM ROM ROM
On-chip RAM RAM RAM
On-chip 1/0O 16bit 1/0-16 16-bit 1/0
On-chip 1/0O 8bit 1/0-8 8-hit I/0

Note: The signalsto indicate bus states and areas are used to set the [Bus/Area] condition of the event point.
They can also be acquired as the trace information. The bus state signals are al so used to set the
condition not to acquire the trace ([Suppress] option) and in the Access Count Of Specified Range
M easurement mode for measuring the hardware performance ([Access Type] option).

8.1.9 Monitoring Function

This emulator incorporates the bus monitoring circuit as the standard, which thus allows a use of the monitoring
function to update the content of memory without affecting the realtime operation.

8.1.10 Trigger Points

This emulator incorporates the bus monitoring circuit as the standard, which thus allows a use of trigger points
that can be set on the [Trigger] sheet in the [Event] window.
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8.1.11 Tracelnformation

Selecting [View -> Code -> Trace] or clicking the [Trace] toolbar button displays the [Trace] window. Trace
information that can be acquired by the emulator and trace information items to be displayed are as listed below.

[PTR] Cycle number in the trace buffer. When the most recent record is record 0,
earlier record numbers go backwards (-1, -2, ...). If a delay count has been
set, the cycle number where the trace stop condition has been satisfied is
record 0. For the cycle (during delay) executed until the trace has stopped,
earlier record numbers go forward (+1, +2, ...) the most recent record.

[Address] Address (6-digit hexadecimal)

[Instruction] Disassembled code of the executed instruction

[Data] Data bus value, displayed as 2-digit or 4-digit hexadecimal

[R/W] Whether access was read (RD) or write (WR)

[Area] Memory area being accessed; ROM, RAM, or 8- or 16-bit I/O (not available
when a time stamp is acquired)

[Status] Bus status during this cycle; PROG (prefetch) or Data (CPU data access
cycle) (not available when a time stamp is acquired)

[Mode] Operating mode; ACT (active) or SUB (subactive) (not available when a
time stamp is acquired)

[Probes] A 4-bit binary number showing the four probe pins in the order of Probe 4,
Probe 3, Probe 2, and Probe 1 from the left (not available when a time
stamp is acquired).

[NMI] Status of the NMI input (not available when a time stamp is acquired)

[Timestamp]

Time stamp of the record. Time stamps start from zero each time the user
program is executed. The timer resolution depends on the time stamp
clock rate selected in the trace acquisition (only available when a time
stamp is acquired).

[Source]

Source program

[Label]

Label information that corresponds to the address (if defined)
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8.1.12  Searching for a Trace Record

While using the emulator, the [Trace Find] dialog box has the following pages:

Table8.11 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp

is acquired).

[Timestamp]

Specify the time stamp value for bus cycles (only available when a time
stamp is acquired).

8.1.13 TraceFiltering Function

While using the emulator, the [Trace Filter] dialog box has the following pages:

Table8.12 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is not
acquired).

[Status] Sets the status of a bus (not available when a time stamp is not
acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp

[Timestamp]

is not acquired).

Specifies the time stamp value for bus cycles (only available when a time
stamp is acquired).
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8.1.14 Reading from and Writing to the EEPROM

With this emulator, users can view and write to memory areasin the EEPROM. This section describes how to

look at memory areas and how to fill and move a memory block.

(2) Viewing aMemory Areain the EEPROM

Tolook a a memory areain the EEPROM, choose [View -> CPU ->EEPROM ...] or click the [EEPROM)]

toolbar button (&) to open the [EEPROM] window. Thiswill open the [Properties] dialog box shown in

figure 8.3.

I

alll -
ite mode:

IF‘age LI
Column count:

D =]
Display value as:

I AMNSI character j

Figure8.3 [Properties| Dialog Box

Select the range of dave addresses of the EEPROM you wish to display from the [ID] combo box. [All]
displays al memory areas in the EEPROM incorporated in the emulator. Select mode to write to memory
from the [Write mode] combo box. Then select the number of columnsto be displayed in arow from the

[Count column] combo box and the format for display of data from the [Display value as] combo box. Click
the [OK] button or press the [Enter] key, and the dialog box closes and the [EEPROM] window opens. The

display can be scrolled within the range of the selected slave addresses.
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ID | Address 1} g 10 18

00 0x00000000  0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000020 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000040 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000060 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000080  0000000000000000 0000000000000000 0000000000000000 0000000000000000
00 0x000000A0 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x000000CO  0000000000000000 0000000000000000 0000000000000000 0000000000000000
00 0x000000EQ 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000100 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000120 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000140 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x00000160 0000000000000000 0000000000000000 0000000000000000 0000000000000000
00 0x00000130 0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x000001A0 0000000000000000 0000000000000000 0000000000000000 0000000000000000
00 0x000001C0  0000000000000000 0000000000000000 0000000000000000  0000000000000000
00 0x000001EQ DDDDDDDDDDDDDDDD DDDDDDDDDDDILDDDD  DODDDDDDDDDDDDDD  DDDDDDDDDLDDDDDD
01 0x00000000 DDDDDDDDDDDDDDDD  DDDDDDDDDDDDDDDD  DDDDDDDDDDDDDDDD  DDDDDDDDDDDDDDDD
01 0x000000Z0 DDDDDDDDDDDDDDDD DDDDDDDDDDDDLDDDD  DODDDDDDDDDDDDDD  DDDDDDDDDLDDDDDD
01 0x00000040 DODDDDDDDDDDDDDD DDDDDDDDDDDDDDDD  DDDDDDDDDDDDDDDD  DDDDDDDDDDDDDDDD
01 0x00000060 DDDDDDDDDDDDDDDD DDDDDDDDDDDLDDDD  DDDDDDDDDDDDDDDD  DDDDDDDDDLDDDDDD
01 0x00000080 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000000A0 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000000C0O 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000000EQ 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x00000100 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000001Z20 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x00000140 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x00000160 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x00000130 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000001A0 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000001C0 0101010101010101 0101010101010101 0101010101010101 0101010101010101
01 0x000001EQ 0101010101010101 0101010101010101 0101010101010101 0101010101010101

Figure8.4 [EEPROM] Window

The [EEPROM] window has [ID], [Address], [Va ue], and data columns. The number of data columnsis that
selected in the [Column count] combo box. Each of the columnsis displayed in hexadecimal.

[ID]: Slave address of the EEPROM.

[Address]:  Addressof thefirst item in the data columns of this row.

Data: Datais read from the EEPROM, and then converted to the display width.
[Value]: Datadisplayed in an aternative format.

(2) Viewing a Different Memory Area
To change the memory area displayed in the [EEPROM] window, use the [Properties] dialog box. Thisbox
can be opened by choosing [Properties...] from the popup menu.
Select the new slave address value, and click the [OK] button or press the [Enter] key. The dialog box closes
and the [EEPROM] window display is updated with the data at the new address.
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(3) Modifying the Memory Contents
The memory contents can be modified via the [Edit] dialog box. The contents of the EEPROM are changed
in byte or page units, depending on the mode selected in the [Write mode] combo box of the [Properties]
dialog box. Move the cursor on the column that you wish to change and select [Edit...] from the popup menu.

Vil
IH'D1 23456730ABCGDEF Cancel |

Figure8.5 [Edit] Dialog Box

A number can be entered in the [Value] field. After you have entered the new number, click the [OK] button
or press the [Enter] key. Then the dialog box closes and the new value is written into memory.

The memory contents can a so be modified by moving the cursor on a data column and entering the new
value in hexadecimal through the keyboard.

(4) Selecting aMemory Range
You can select arange by clicking on the first data column and dragging the mouse to the last column. The
selected range is highlighted.

(5) Filling aMemory Areawith aValue
A value can be set as the content of amemory address range using the memory fill function.
To fill amemory range with the same value, choose [Fill...] from the popup menu of the [EEPROM]
window. The [Fill] dialog box is shown in figure 8.6.

2
Start I0: Start address: oK
fo =] H000001 A0 Gancel |
End IC: End address:
|-| LI |H'DDDDDDEF
Data size: Diata:
|Bvte G1) =l [HAA
Wik ite mode:
IPage LI
v Merify

Figure8.6 [Fill] Dialog Box

If an address range has been selected in the [EEPROM] window, the specified start and end dave addresses
and the start and end addresses will be displayed. Select a format from the [Data size] combo box and enter
the datavaluein the [Data)] field. Then select a mode for writing from the [Write mode] combo box.
Checking the [Verify] check box allows comparison of memory contents before setting these values. On
clicking the [OK] button or pressing the [Enter] key, the dialog box closes and the new value is written into
the memory range.
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(6) Copying aMemory Area
Y ou can copy a memory area using the memory copy function. The following three types are available:
. From EEPROM to EEPROM
. From EEPROM to normal memory
. From normal memory to EEPROM

(a) From EEPROM to EEPROM

Selecting a memory range and then [Copy...] from the popup menu opens the [Copy] dialog box (figure
8.7). Select the [EEPROM -> EEPROM] toggle button in the [Copy Direction] group box.

2lx|
—Copy Direction
(+ EEPROM -> EEPROM Cancel |
¢ EEPROM -> MEMORY
" MEMORY —> EEPRCIM
— SOUrCe
Start ID: Start address:
ID LI |H'EIEIEIEIEI1 ED
Erg IC: End address:
I.I LI |H'DDDDDD1 F
— Desztination
I Address:
3 j |H'EIEIEIEIEIEIEIEI
Wik ite mode:
IPage ;I
[ Merify

Figure8.7 [Copy] Dialog Box (EEPROM -> EEPROM)

The start dave address and end slave address as the source selected in the [EEPROM] window will be
displayed in the [Start ID] and [End ID] combo boxes. The source start address and end address will be
displayed in the [Start address] and [End address] fields. Checking the [V erify] check box enables
copying while comparing the copy source and copy destination. The copy unit can be selected in the
[Write mode] combo box. As the destination, select the start slave address from the [ID] combo box and
enter the start address value in the [Address] field of the [Destination] group box, respectively. Then click
the [OK] button or pressthe [Enter] key. Thiswill close the dialog box and copy the memory block to the
new address.
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(b) From EEPROM to normal memory

Selecting a memory range and then [Copy...] from the popup menu opens the [Copy] dialog box (figure
8.8). Select the [EEPROM -> MEMORY?] toggle button in the [Copy Direction] group box.

21x
—Copy Direction
(" EEPROM -> EEFROM Cancel |
f+ EEPROM -> MEMORY
= MEMORY - EEPRCIM
—Source
Start ID: Start address:
|D j |H'DDDDD1 EO
End ID: End address:
|1 j |H'EIEIEIEIEIEI1 F
— Destination
0 Address:
LI |H'DDDDDDDD
Wik ite mode:
|Page j
¥ Merify

Figure8.8 [Copy] Dialog Box (EEPROM -> MEMORY)

The start dave address and end slave address as the source selected in the [EEPROM] window will be
displayed in the [Start ID] and [End ID] combo boxes. The source start address and end address will be
displayed in the [Start address] and [End address] fields. Checking the [V erify] check box enables
copying while comparing the copy source and copy destination. The copy unit can be selected in the
[Write mode] combo box. Enter the start address value of the destination in normal memory in the
[Address] field of the [Destination] group box. Then click the [OK] button or pressthe [Enter] key. This
will close the diadog box and copy the memory block to the specified address in norma memory.
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(c) From normal memory to EEPROM
Selecting a memory range and then [Copy...] from the popup menu opens the [Copy] dialog box (figure
8.9). Select the [MEMORY -> EEPROM)] toggle button in the [Copy Direction] group box.

21x
—Copy Direction
(" EEPROM -> EEFROM Cancel |
" EEPROM -> MEMORY
f+ MEMORY - EEPRCIM
—Source
Start ID: Start address:
| j |H'DDDDDDDD
End ID: End address:
I j |H'EIEIEIEIEIEIFF
— Destination
0 Address:
0 LI |H'DDDDDDDD
Wik ite mode:
|Page j
¥ Merify

Figure8.9 [Copy] Dialog Box (MEMORY -> EEPROM)

Enter the source start address and end address in normal memory in the [Start address] and [End address]
fields. Checking the [Verify] check box enables copying while comparing the copy source and copy
destination. The copy unit can be selected in the [Write mode] combo box. As the destination, select the
start slave address from the [ID] combo box and enter the start address value in the [Address] field of the
[Destination] group box, respectively. Then click the [OK] button or press the [Enter] key. Thiswill close
the dialog box and copy the memory block to the new address.

(7) Disabling Update of the Window Contents
Automatic update of the [EEPROM] window contents, which is performed when user program execution
stops or in other cases, can be disabled. Thisis done by checking [Lock Refresh] in the popup menu.

(8) Updating the Window Contents
The [EEPROM] window contents can be forcibly updated. Thisis done by checking [Refresh] in the popup
menu.
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8.2 Noteson Usage of the H8/3664 E6000 Emulator

There are the following notes on usage of the emulator.

821 1/0 Register

In the E6000 emul ator, one evaluation chip emulates several types of MCU. Therefore, there are some
differencesin I/O registers between an actual MCU and the emulator. Note these differences when accessing the
1/0 registers.

1/0 port isin theinput state at default. The I/O register contents indicate the emulator port status. When the user
system interface cable is not connected, the read value is 1 due to pull-up resistors.

In the emulator, accesses to the following registers for controlling the flash memory areinvalid.

* Flash memory control register 1 (FLMCR1: H'FF90)

*  Flash memory control register 2 (FLMCR2: H'FF91)

» Flash memory power control register (FLPWCR: H'FF92)
* Block register 1 (EBR1: H'FF93)

» Flash memory enable register (FENR: H'FF9B)

Note: The addresses indicate the lower 16 bits.

(1) Warningsthat Apply to H8/3664 Group Programming
() The description given in the hardware manual is“Initial value: 1. Reserved. These bits are always read as
1". However, the description in the emulator manual is* Always specify 0. These bits are always read as
the specified values’.

Table8.13 Differences between the H8/3664 Group Products (1)

Target Address Register Name Bits

H'FFEO Port mode register 1 3and 2

(b) The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
0". However, the description in the emulator manual is “ Always specify 0. These bits are alwaysread as
the specified values’.

Table8.14 Differences between the H8/3664 Group Products (2)

Target Address Register Name Bits
H'FFE1 Port mode register 5 7 and 6
H'FFF9 Module standby control register 1 7

(c) The description given in the hardware manual is“ Reserved”. However, the description in the emulator
manual is*“Always specify 0. These bits are always read as the specified values’.
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Table8.15 Differences between the H8/3664 Group Products (3)

Target Address Register Name Bits
H'FFE2 Port mode register 3 7t03
H'FFF5 Interrupt enable register 2 7t05
H'FFFA Module standby control register 2 7t00
H'FFFB Module standby control register 3 0

(2) Warnings that Apply to H8/3672 Group Programming

() The description given in the hardware manual is“Initial value: 1. Reserved. These bits are always read as
1”. However, the description in the emulator manual is “ Always specify 0. These bits are always read as
the specified values’.

Table8.16 Differences between the H8/3672 Group Products (1)

Target Address Register Name Bits

H'FFEO Port mode register 1 3

(b) The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
0". However, the description in the emulator manual is“ Always specify 0. These bits are always read as

the specified values’.

Table8.17 Differences between the H8/3672 Group Products (2)

Target Address Register Name Bits
H'FFEO Port mode register 1 6 and 5
H'FFF1 System control register 2 6,1, and 0
H'FFF2 Interrupt edge select register 1 7,2and 1
H'FFF4 Interrupt enable register 1 6,2and 1
H'FFF9 Module standby control register 1 7

(c) The description given in the hardware manual is“Reserved”. However, the description in the emulator
manual is“Always specify 0. These bits are always read as the specified values’.

Table8.18 Differences between the H8/3672 Group Products (3)

Target Address Register Name Bits
H'FFE2 Port mode register 3 7t03
H'FFF5 Interrupt enable register 2 7t05
H'FFFA Module standby control register 2 7t00
H'FFFB Module standby control register 3 0
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Table8.19 Differences between the Evaluation Chip and the H8/3664, H8/3672 Group Products

Address |Register [Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HFFEO |PMRL1  [IRQ3 IRQ2 |IRQL |IRQD [TXD2 [PWM |TXD  |TMOW
HFFELl |PMRS [POF57 [POF56 [WKPS [WKP4 |WKP3 |WKP2 [WKPL1 [WKPO
H8/3660 |HFFE2 |PMR3  |POF27 [POF26 |POF25 |POF24 |POF23 |O 8] 8]
fii\;a:ﬁ;) HFFFL |SYSCR2 [SMSEL [LSON [DTON ([MA2  |MAl MAO  |SAL SAO
HFFF2 |IEGR1 [NMIEG |[O 0 0 IEG3 [IEG2 [IEGL |IEGO
HFFF4 |IENRL [IENDT  [IENTA [IENWP (O IEN3  |IEN2  [IEN1  [IENO
HFFF5 |IENR2 [IENTB3 [IENTB2 |IENTBL (O 0 0 0 0
HFFF9 |MSTCRL [MSTS4 [MSTIC [MSTS3 [MSTAD |MSTWD |[MSTTW [MSTTV [MSTTA
HFFFA |MSTCR2 [MSTS3_2 [MSTTB3 [MSTTB2 [MSTTBL|MSTTX |O MSTTZO0 |MSTPWM
HFFFB |MSTCR3 [0 0 0 0 0 0 0 MSTS4_2
Address |Register [Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HFFEO |PMRL1  [IRQ3 IRQ2 |IRQL [IRQD O 0 TXD  [TMOW
HFFEL |PMRS |0 0 WKP5  |WKP4 |WKP3 |WKP2 [WKP1 [WKPO
HFFE2 O 0 0 0 0 0 0 0 0
he/aceq |VFFFL [SYSCR2 |SMSEL |LSON |DTON |MA2  MAL MAO  |SAL SAO
HFFF2 |IEGR1 [NMIEG |[O 0 0 IEG3 [IEG2 [IEGL |IEGO
HFFF4 |IENRL [IENDT  [IENTA [IENWP (O IEN3  |IEN2  [IEN1  [IENO
HFFFs O 0 0 0 0 0 0 0 0
HFFF9 |MSTCRL |O IMSTIIC [MSTS3 [MSTAD |MSTWD |MSTTW [MSTTV [MSTTA
HFFFA O 0 0 0 0 0 0 0 0
HFFFB |0 0 0 0 0 0 0 0 0
Address |Register [Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HFFEO |PMRL1  [IRQ3 0 0 IRQ0 |0 0 TXD 0
HFFELl |PMRS [POF57 [POF56 [WKPS |WKP4 |WKP3 |WKP2 [WKP1 [WKPO
HFFE2 O 0 0 0 0 0 0 0 0
hg/ae7o |WFFFL [SYSCR2 [SMSEL |0 DTON |MA2 MAL MAO 0 0
HFFF2 |IEGR1 |O 0 0 0 EG3 O 8] IEGO
HFFF4 |IENRL [IENDT O IENWP |0 IEN3 |0 0 IENO
HFFFs O 0 0 0 0 0 0 0 0
HFFF9 |MSTCRL |O 0 IMSTS3 |MSTAD |MSTWD |MSTTW [MSTTV |0
HFFFA O 0 0 0 0 0 0 0 0
HFFFB |0 0 0 0 0 0 0 0 0
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?3) Warnings that Apply to H8/3687 Group Programming
() The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
1, and cannot be modified”. However, the description in the emulator manual is“ Always specify 0.
These bits are always read as the specified values’.

Table8.20 Differences between the H8/3687 Group Products (1)

Target Address Register Name Bits
H'FFE2 Port mode register 3 7t05
H'FFF5 Interrupt enable register 2 7 and 6
H'FFF9 Module standby control register 1 7 and 2
H'FFFA Module standby control register 2 6,5, and 3

(b) The description given in the hardware manual is “ Reserved”. However, the description in the emulator
manual is “Always specify 0. These bits are always read as the specified values'.

Table8.21 Differences between the H8/3687 Group Products (2)

Target Address Register Name Bits

H'FFFB Module standby control register 3 0

(c) The hardware manual shows registers at the addresses given below. For these locations, however, the
applicable description in the emulator manual is “Writing has no effect. These bits are always read as
undefined values’, because there are no registers at these locations of the emulator.

Table8.22 Differences between the H8/3687 Group Products (3)

Target Address Register Name Bits
H'F730 Low-voltage-detection control register 7t00
H'F731 Low-voltage-detection status register 7t00

(d) The H8/3687 group has power-on reset and optional |ow-voltage detection circuit functions. However, the
E6000 emulator does not support these functions.
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Table8.23 Differences between the Evaluation Chip and the H8/3687 Registers

Address |Register [Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 |O O O O O O O O O
HF731 |O 0 0 0 0 O 0 0 0
H8/3660 |H'FFEO [PMR1  |IRQ3 IRQ2 IRQ1 [IRQ0 [TxD2 |PWM |TXD TMOW
fii\;al:?r;) HFFE1 [PMR5 |POF57 |POF56 |WKP5 |WKP4 [WKP3 |WKP2 |WKP1 |WKPO
HFFE2 [PMR3 |POF27 |POF26 |POF25 |POF24 |POF23 |O O O
HFFF1 [SYSCR2 |SMSEL |LSON |DTON [MA2 MAL MAO SA1L SAO
HFFF2 [IEGR1 |NMIEG |O O O IEG3 [IEG2 |IEG1  |IEGO
HFFF4 [IENR1 |IENDT |IENTA [IENWP |O IEN3 [IEN2  |IEN1  |IENO
H'FFF5 [IENR2 |IENTB3 |IENTB2 |IENTB1 |0 O O O O
HFFF9 |[MSTCR1 |[MSTS4 |MSTIC |MSTS3 |[MSTAD [MSTWD [MSTTW [MSTTV |MSTTA
H'FFFA |[MSTCR2 |MSTS3_2|MSTTB3 |MSTTB2 |MSTTB1|MSTTX |O MSTTZ0 |MSTPWM
H'FFFB |[MSTCR3 |O 0 0 0 O 0 0 MSTS4_2
Address |Register [Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 JLvDCR |LvDE O O O LDVSEL JLVDRE [LVDDE |LvDUE
HF731 JLvDsr |o 0 0 0 O 0 LVDDF JLVDUF
HFFEO [PMR1  |IRQ3 IRQ2 IRQ1 [IRQD |TXD2 [PwWM |TXD TMOW
He/3687 HFFE1 [PMR5 |POF57 |POF56 |WKP5 |WKP4 [WKP3 |WKP2 |WKP1 |WKPO

HFFE2 |PMR3 O O O POF24 |POF23 |O O O

H'FFF1 [SYSCR2 |SMSEL |LSON DTON [MA2 MA1 MAO SAl SAO

HFFF2 [IEGR1 NMIEG O O O IEG3 IEG2 IEG1 IEGO
H'FFF4 [IENR1 IENDT IENTA [IENWP (O IEN3 IEN2 IEN1 IENO
HFFF5 [IENR2 O O IENTB1 (O O O O O

H'FFF9 [MSTCR1 jO JMSTIIC [MSTS3 |MSTAD (MSTWD O MSTTV [MSTTA
HFFFA |[MSTCR2 |MSTS3_2Q0 O MSTTB1}O O MSTTZ |MSTPWM
HFFFB O O O O O O O O O
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(4) Warnings that Apply to H8/3694 Group Programming
() The description given in the hardware manual is“Initial value: 1. Reserved. These bits are always read as
1, and cannot be modified”. However, the description in the emulator manual is“ Always specify 0.
These bits are always read as the specified values’.

Table8.24 Differences between the H8/3694 Group Products (1)

Target Address Register Name Bits

H'FFEO Port mode register 1 3and2

(b) The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
0, and cannot be modified”. However, the description in the emulator manual is“ Always specify 0. These
bits are always read as the specified values”.

Table8.25 Differences between the H8/3694 Group Products (2)

Target Address Register Name Bits
H'FFE1 Port mode register 5 7 and 6
H'FFF9 Module standby control register 1 7

(c) The description given in the hardware manual is“Reserved”. However, the description in the emulator
manual is“Always specify 0. These bits are always read as the specified values’.

Table8.26 Differences between the H8/3694 Group Products (3)

Target Address Register Name Bits
H'FFE2 Port mode register 3 7t03
H'FFF5 Interrupt enable register 2 7t05
H'FFFA Module standby control register 2 7t00
H'FFFB Module standby control register 3 0

(d) The hardware manual shows registers at the addresses given below. For these locations, however, the
applicable description in the emulator manual is “Writing has no effect. These bits are always read as
undefined values’, because there are no registers at these locations of the emulator.

Table8.27 Differences between the H8/3694 Group Products (4)

Target Address Register Name Bits
H'F730 Low-voltage-detection control register 7t00
H'F731 Low-voltage-detection control register 7t00

(e) The H8/3694 group has power-on reset and optional |ow-voltage detection circuit functions. However, the
E6000 emulator does not support these functions.
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Table8.28 Differences between the Evaluation Chip and the H8/3694 Registers

Address |Register |Bit7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 |0 o o o o o o o o
HF731 |0 o o o o o O O 0
HFFEO |PMRL  [IRQ3 RQ2 [IRQ1 |RQo [txp2 |Pwm |txp  |Tmow
HFFEL |PMR5  |POFS7 |POFS6 |WKPS |WKP4 |WKP3 [WKP2 |WKP1 |WKPO
H8’3|66° HFFE2 |PMR3  |POF27 |POF26 |POF25 |POF24 |POF23 |O O O
fii\;aci?y;) HFFFL |SYSCR2 [SMSEL |[LSON |DTON [mA2  [MAL  [mA0  [sAa1  [sao
HFFF2 |IEGRL  [NMIEG |0 o o IEG3 |IEG2 [IEGL |[IEGO
HFFF4 |IENRL  [IENDT  [IENTA [IENWP |O IEN3  [IEN2 [IEN1  [IENO
HFFF5 |IENR2  [IENTB3 [IENTB2 |IENTBL |0 o o o o
HFFF9 |MSTCRL [MSTS4 [MSTIC |MSTS3 [MSTAD |MSTWD [MSTTW [MSTTV [MSTTA
HFFFA |MSTCR2 [MSTS3 2 [MsTTB3|MSTTB2 |MSTTBL|MSTTX |0 MSTTZ0 [MSTPWM
HFFFB |MSTCR3 |O o o o o O O MSTS4_2
Address |Register |Bit7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 JLvbcr  JLvDE o o o LvpskeL JLvore |Lvope [Lvpue
HF731 Jvbsr o o o o o O LVDDF |LVDUF
HFFEO |PMRL  [IRQ3 RQ2 [IRQ1 |IrRQo o o T™xD  |[TMow
HFFEL |PMRs o o WKP5 |WKP4 [WKP3 |WKP2 |WKP1 |WKPO
HrFe2 o o o o o o o o al
He/3694 |HFFFL [SYScR2 [SMSEL |Lson [pToN [mAaz  [wa1  |mao  [sa1  |[sao
HFFF2 |IEGRL  [NMIEG |0 o o IEG3 |IEG2 [IEGL |[IEGO
HFFF4 |IENRL  [IENDT  [IENTA [IENWP |O IEN3  [IEN2 [IEN1  [IENO
HFFFs o o o o o o o o al
HFFFo [msTcr1 o JvsTic [MsTs3 |[MSTAD |MSTWD [MSTTW |MSTTV [MSTTA
HFFFA o o o o o o o o o
HFFFB O o o o o o 0 0 0
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(5) Warningsthat Apply to H8/36014, H8/36024 Group Programming

() The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
0". However, the description in the emulator manual is “ Always specify 0. These bits are alwaysread as

the specified values’.
Table8.29 Differences between the H8/36014, H8/36024 Group Products (1)

Target Address Register Name Bits

H'FFEO Port mode register 1 6,5,2,and 0
H'FFF1 System control register 2 6,1, and 0
H'FFF2 Interrupt edge select register 1 7,2,and 1
H'FFF4 Interrupt enable register 1 6,2,and 1
H'FFF9 Module standby control register 1 7and 0
H'FFFA Module standby control register 2 6to0

(b) The description given in the hardware manual is“Reserved”. However, the description in the emulator
manual is“Always specify 0. These bits are always read as the specified values’.

Table8.30 Differences between the H8/36014, H8/36024 Group Products (2)

Target Address Register Name Bits
H'FFE2 Port mode register 3 7t03
H'FFF5 Interrupt enable register 2 7t05
H'FFFB Module standby control register 3 0

(c) The hardware manual shows registers at the addresses given below. For these locations, however, the
applicable description in the emulator manual is “Writing has no effect. These bits are always read as
undefined values’, because there are no registers at these locations of the emulator.

Table8.31 Differences between the H8/36014, H8/36024 Group Products (3)

Target Address Register Name Bits
H'F730 Low-voltage-detection control register 7t00
H'F731 Low-voltage-detection status register 7t00

(d) The H8/36014, H8/36024 group has power-on reset and optional low-voltage detection circuit functions.
However, the E6000 emulator does not support these functions.

(e) While emulating the H8/36024 group, set PCR1 and PCR5to ‘0’ if you want to use SCI3_3.
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(f) While emulating the H8/36024 group, note that the register specifications at address H’ F608 in the actual
device and expansion 1/0 board (HS36024EI061H) are different. Table 8.32 lists the specifications and
note on them.

Table8.32 Register Specificationsand Note

Item

Register Specifications Note

HS36024E1061H

Bits 4 to 7 (1111): Reserved None
Bit 3 (0): Selects the device (0: H8/36024)

Bit 2 (0): Selects whether or not to delete
noise (0: no, 1: yes)

Bit 1 (0): Selects the TXD3 output (0: port, 1:
TXD_3)

Bit 0 (0): Selects whether or not to stop
modules (0: operate, 1: stop)

H8/36024

Bits 4 to 7 (1111): Reserved For emulation with the
expansion |/O board
(HS36024EI061H), set
bits 2 and 3 to ‘0"

Bit 3 (1):Reserved (always read as 1 and
writing has no effect)

Bit 2 (1): Reserved (always read as 1 and
writing has no effect)

Bit 1 (0): Selects the TXD3 output (0: port, 1:
TXD_3)

Bit 0 (0): Selects whether or not to stop
modules (0: operate, 1: stop)

Note: The value in parentheses indicates the initial value after a reset.

Table8.33 Differences between the Evaluation Chip and the H8/36014, H8/36024 Registers

H8/3660
(Evalua-
tion chip)

Address |Register |Bit7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
H'F730 |O O O O O O ] ] O

HF731 (O 0 0 0 0 0 0 0 O
H'FFEO |PMR1 IRQ3 IRQ2 IRQ1 IRQO TXD2 PWM TXD TMOW
H'FFE1 [PMR5 POF57 POF56 [WKP5 |WKP4 [WKP3 [WKP2 |WKP1 [WKPO
HFFE2 |PMR3 POF27 POF26 |POF25 |POF24 |POF23 |O O O
H'FFF1 [SYSCR2 [SMSEL LSON [DTON [MA2 MA1 MAO SAl SAO
HFFF2 [IEGR1 NMIEG O O O IEG3 IEG2 IEG1 IEGO
H'FFF4 [IENR1 IENDT IENTA [IENWP |O IEN3 IEN2 IEN1 IENO
H'FFF5 [IENR2 IENTB3 IENTB2 [IENTB1 |0 O ] ] ]
H'FFF9 [MSTCR1 [MSTS4 MSTIIC |[MSTS3 [MSTAD |MSTWD [MSTTW [MSTTV |MSTTA
HFFFA |[MSTCR2 |MSTS3_2 |MSTTB3|MSTTB2|MSTTB1|MSTTX |O MSTTZ0 [MSTPWM
H'FFFB [MSTCR3 (O 0 0 0 0 ] 0 MSTS4 2
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Address |Register |Bit 7 Bit 6 Bit5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

HF730 JLVDCR LVDE O O O LVDSEL JLVDRE |JLVDDE [JLVDUE
H'F731 JLVDSR O O O O O O LVDDF JLVDUF
HFFEO |[PMR1 IRQ3 O O IRQO TXD2 O TXD O

HFFE1l |[PMR5 POF57 POF56 [(WKP5 |WKP4 |WKP3 (WKP2 |WKP1 |WKPO

He/seo1a |HFFE2 O a] a] a] a] 0 0 0 0

H8/36024 |HFFF1 [SYSCR2 |SMSEL o DTON [MA2 MAL MAO 0 0
HFFF2 [IEGR1 |o a] a] a] EG3 o 0 IEGO
HFFF4 [IENR1 IENDT O IENWP |0 EN3 o 0 IENO
HFFF5 O a] a] a] a] 0 0 0 0
HFFF9 [MSTCR1 |O a] MSTS3 [MSTAD [MSTWD |MSTTW [MSTTV |0
HFFFA [MSTCR2 |MSTS3 2 o a] a] 0 0 0 0
HFFFB O a] a] a] a] 0 0 0 0

(6) Warnings that Apply to H8/36037, H8/36057 Group Programming
() The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
0". However, the description in the emulator manual is “ Always specify 0. These bits are alwaysread as
the specified values’.

Table8.34 Differences between the H8/36037, H8/36057 Group Products (1)

Target Address Register Name Bits

H'FFEO Port mode register 1 2and 0
H'FFF4 Interrupt enable register 1 6

H'FFF5 Interrupt enable register 2 7 and 6
H'FFF9 Module standby control register 1 7,6,2,and 0
H'FFFA Module standby control register 2 6,5, and 3

(b) The description given in the hardware manual is“Reserved”. However, the description in the emulator
manual is“Always specify 0. These bits are always read as the specified values’.

Table8.35 Differences between the H8/36037, H8/36057 Group Products (2)

Target Address Register Name Bits
H'FFE2 Port mode register 3 7t05
H'FFFB Module standby control register 3 0

(¢) The hardware manua shows registers at the addresses given below. For these locations, however, the
applicable description in the emulator manual is “Writing has no effect. These bits are always read as
undefined values’, because there are no registers at these locations of the emulator.

Table8.36 Differences between the H8/36037, H8/36057 Group Products (3)

Target Address Register Name Bits
H'F730 Low-voltage-detection control register 7t00
H'F731 Low-voltage-detection status register 7t00
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(d) The H8/36037, H8/36057 group has power-on reset and optional low-voltage detection circuit functions.
However, the E6000 emulator does not support these functions.

(e) While emulating the H8/36037, H8/36057 group, set PCRIto ‘0’ if you want to use TinyHCAN or SSU.

Table8.37 Differences between the Evaluation Chip and the H8/36037, H8/36057 Register s

Address |Register |Bit7 Bit 6 Bit5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 |0 o o o o o O O 0
HF731 |D o o o o o o o o
HFFEO |PMR1  [IRQ3 IRQ2 [IRQL |RQ0 [TxD2 |Pwm |TxD  |Tmow
HFFEL |PMR5  |POF57  |POFS6 |WKP5 [WkP4 |WKP3 |wkP2 |wkPi |wkPo
H8/3660 |\ vrrE [PMR3  |POF27  |POF26 |POF2s |PoF24 |PoF23 o O O
:ii\éal:?r;) HFFFL |SYSCR2 [SMSEL |[LSON |DTON [MA2  |[MAL  [MAO  |SA1  [SAO
HFFF2 [IEGRL [NMIEG |O o o IEG3 |IEG2 [IEGL |[IEGO
HFFF4 |IENRL  [IENDT  [IENTA [IENWP |O IEN3  [IEN2  [IENL  [IENO
HFFF5 |IENR2  [IENTB3 |IENTB2 |IENTB1 |O o O O O
HFFF9 |MSTCRL [MSTS4 [MSTIC |MSTS3 [MSTAD |MSTWD [MSTTW |MSTTV [MSTTA
HFFFA |MSTCR2 [MSTS3 2 [MSTTB3|MSTTB2|MSTTBL|MSTTX |O MSTTZ0 [MSTPWM
HFFFB |MSTCR3 |0 0 0 0 o 0 0 MSTS4_2
Address |Register |Bit7 Bit 6 Bit5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 JLvbcr  JLvDE o o o LvDsEL JLvDRE |LvppE [LvDUE
Hr73L |uvosr o 0 0 0 o o LVDDF |LVDUF
HFFEO |PMR1  [IRQ3 IRQ2 [IRQ1 |IRQo [txp2 |o ™0 |o
HFFEL |PMR5  |POF57  |POFS6 |WKP5 [WKP4 |WKP3 |wkP2 |wkP1 |wkPo
neiacos7 |HFFE2 [PMR3 o o o POF24 |POF23 |O o o
He/a6057 |HFFFL |SYSCR2 [sMSEL [Lson [pToN [wma2  |mMA1  [mA0  |sAa1  |sAo
HFFF2 [IEGRL [NMIEG |O o o IEG3 |IEG2 [IEGL |[IEGO
HFFF4 [IENRL  [IENDT o IENWP |0 IEN3  |IEN2 |IENL  [IENO
HFFFs [IENR2 o o IENTBL |0 o o o o
HFFF9 |MsTcr1l o o Jvstss |msTaD |MsTwD |O MsTTV [o
HFFFA |MSTCR2 [msTsz 2 |o o msTTB1|D O MSTTZ [MSTPWM
HFFFB o o o o o o o o o
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(7) Warnings that Apply to H8/36049 Group Programming

() The description given in the hardware manual is“Initial value: 0. Reserved. These bits are always read as
0". However, the description in the emulator manual is “ Always specify 0. These bits are alwaysread as
the specified values’.

Table8.38 Differences between the H8/36049 Group Products (1)

Target Address Register Name Bits
H'FFF2 Port mode register 3 7,6, and 5
H'FFF5 Interrupt enable register 2 7 and 6
H'FFF9 Module standby control register 1 7

H'FFFA Module standby control register 2 6,5, and 3

(b) The description given in the hardware manual is “ Reserved”. However, the description in the emulator
manual is “Always specify 0. These bits are always read as the specified values'.

Table8.39 Differences between the H8/36049 Group Products (2)

Target Address Register Name Bits

H'FFFB Module standby control register 3 0

(c) The hardware manual shows registers at the addresses given below. For these locations, however, the
applicable description in the emulator manual is “Writing has no effect. These bits are always read as
undefined values’, because there are no registers at these locations of the emulator.

Table8.40 Differences between the H8/36049 Group Products (3)

Target Address Register Name Bits
H'F730 Low-voltage-detection control register 7t00
H'F731 Low-voltage-detection status register 7t00

(d) The H8/36049 group has power-on reset and optiona low-voltage detection circuit functions. However,
the E6000 emulator does not support these functions.

(e) While emulating the H8/36049 group, set PCR1 and PCR5to ‘0’ if you want to use SCI3_3.
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(f) While emulating the H8/36049 group, note that the register specifications at address H’ F608 in the actual
device and expansion /O board (HS36024E1061H) are different. Table 8.41 lists the specifications and

note on them.

Table8.41 Register Specificationsand Note

Iltem Register Specifications Note

HS36024E1061H Bits 4 to 7 (1111): Reserved None
Bit 3 (0): Selects the device (1: H8/36049)

Bit 2 (0): Selects whether or not to delete
noise (0: no, 1: yes)

Bit 1 (0): Selects the TXD3 output (0: port, 1:
TXD_3)

Bit 0 (0): Selects whether or not to stop
modules (0: operate, 1: stop)

H8/36049 Bits 4 to 7 (1111): Reserved For emulation with the
Bit 3 (1):Reserved (always read as 1 and expansion I/0 board
writing has no effect) (H836024E|061H)' set

bits 3 to ‘1'.
Bit 2 (0): Selects whether or not to delete
noise (0: no, 1: yes)
Bit 1 (0): Selects the TXD3 output (0: port, 1:
TXD_3)
Bit 0 (0): Selects whether or not to stop
modules (0: operate, 1: stop)
Note: The value in parentheses indicates the initial value after a reset.
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Table8.42 Differences between the Evaluation Chip and the H8/36049 Registers

Address |Register |Bit7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 |0 o o o o o o o o
HF731 |0 o o o o o O O 0
HFFEO |PMRL  [IRQ3 RQ2 [IRQ1 |RQo [txp2 |Pwm |txp  |Tmow
HFFEL |PMR5  |POFS7 |POFS6 |WKPS |WKP4 |WKP3 [WKP2 |WKP1 |WKPO
H8’3|66° HFFE2 |PMR3  |POF27 |POF26 |POF25 |POF24 |POF23 |O O O
fii\;acﬁ;) HFFFL |SYSCR2 [SMSEL |[LSON |DTON [mA2  [MAL  [mA0  [sAa1  [sao
HFFF2 |IEGRL  [NMIEG |0 o o IEG3 |IEG2 [IEGL |[IEGO
HFFF4 |IENRL  [IENDT  [IENTA [IENWP |O IEN3  [IEN2 [IEN1  [IENO
HFFF5 |IENR2  [IENTB3 [IENTB2 |IENTBL |0 o o o o
HFFF9 |MSTCRL [MSTS4 [MSTIC |MSTS3 [MSTAD |MSTWD [MSTTW [MSTTV [MSTTA
HFFFA |MSTCR2 [MSTS3 2 [MsTTB3|MSTTB2 |MSTTBL|MSTTX |0 MSTTZ0 [MSTPWM
HFFFB |MSTCR3 |O o o o o O O MSTS4_2
Address |Register |Bit 7 Bit 6 Bit5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
HF730 Juvbcr  JLvpe o o o LvpseL Juvore Juvope JLvoue
HF731 Juvbsr o o o o o o LVDDF JLVDUF
HFFEO [PMRL  |IRQ3 IRQ2 |IRQ1 |IRQ0 |TxD2 |PwMm [TxD  |T™Mow
HFFEL [PMR5  |POFS7 |POF56 |WKP5 |WKP4 |WKP3 |WKP2 [WKP1 |WKPO
HFFE2 |PMR3 o o o POF24 |POF23 |0 o o
He/acoag |HFFFL |SYSCR2 [SMSEL [LSON [DTON [MA2  [MA1  |MAO  [sAl  [sAo
HFFF2 [IEGR1  [NMIEG  |O o o IEG3 |IEG2 |IEGL [IEGO
HFFF4 [IENRL  |IENDT  [IENTA [IENWP |O IEN3  [IEN2 [IEN1  [IENO
HFFFs [IENR2 |0 o IENTBL |0 o o o o
HFFFo |MsTcR1 |o MSTIIC |MSTS3 |MSTAD |MSTWD |MSTTW |MSTTV |MSTTA
HFFFA [MsTcr2 |msTs3 2 |o o mstTBL|O0 o MSTTZ |MSTPWM
HFFFB o o O O o o o o o
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8.2.2 Noteson Mode Transitions

The MCU makes a transition to some other mode when interrupts occur. In the E6000 emulator, a break interrupt
occurs with any of the following operations or actions. Therefore, break interrupts will occur even when no
interrupt has been set up in the user program. Thiswill lead to unexpected mode transition.

» Forcible breaks (When the Esc key is pressed or the STOP tool bar button is clicked)
* PCbreaks

» Breaks specified by the event detection system

e STEP (Step In, Step Over, Step Out) execution

*  When aprogram is executed by a Go command from the address of a PC break.

When emulation breaksin the emulator, the operating mode immediately before the break (Active mode or
Subactive mode) and the cause of the break are displayed in the status bar and status window. The operating
mode can be referred to by looking at the status bar.

Examples: ROM Write-Access Break (Active)
User Break (Subactive)

823 Accessto the Reserved Area
When accessing the reserved area, note the following:

If the reserved areais used, the operation in the actual MCU cannot be guaranteed. |If the user program extends
to the reserved area during debugging, select the MCU having the largest ROM capacity (for example, debug the
H8/3663 program in the H8/3664 mode).

In the E6000 emul ator, one evaluation chip emulates several types of MCU. Therefore the emulator has I/0
registers other than those of the target MCU. Therefore, do not access unused addressesin the 1/0 register area.
The values when such unused address areas are read from and written to cannot be guaranteed. Note that the
address range H'FO00 to H' F77F is used by the emulator system so do not access this area. Values are not
guaranteed when addresses in this range are read or written to. An access error break will not occur.

8.24 Environment for Execution of the Tutorial Program

Thistutorial program runs on the debugging platform H8/3664 E6000 emulator CPU 300H. Be sure to remove
the expansion |/O board from the H8/3664 E6000 emulator before running the tutorial program.
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Appendix A Troubleshooting

| have a text file in the editor but it does not show any syntax coloring.

Ensure that you have named the file (i.e. saved it) and that the [Enable syntax coloring] check box is set on
the [Editor] tab of the [Options] dialog, which is launched via[Tools->Options...]. HEW checks afile group
to which thefile's extension belongs and decides whether the file is colored. To view the current defined
extensions and their file groups, use the [File Extensions] dialog which islaunched via[Project->File
Extensions...]. To view coloring information, select [ Tools->Format] to display the [Format] dialog, click the
item to view its color under iconsin the tree, and see the [Color] tab. (See the “ Syntax Coloring” sectionin
chapter 4, Using the Editor of the HEW Part for details.)

| opened a workspace from my PC, and one of my colleagues opened the same workspace smultaneousy
from another PC. | changed the settings of the workspace and saved it. He or she saved the workspace
after me. | opened the workspace again and found that the settings of the workspace differed from what |
had set before.

The settings saved last are enforced. Once HEW opens aworkspace, it is updated inside the memory. HEW
does not save the settingsinto afile until auser saves the workspace intentionally.
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Appendix B Regular Expressions

The HEW editor allows you to include special charactersin search strings when performing afind or replace
operation. These characters arelisted in table B.1 and are detailed in the following pages.

TableB.1 Regular Expression Characters

Character Function

? Matches any single character (except a newline)

* Matches any number of occurrences (0 or more) of any character except a

newline

\n Matches a new line character

\t Matches a tab character

[] Matches any one character or range listed within the brackets

\ Overrides any following regular expression character

e Symbol: ?
Meaning:  This character matches any single character, except the newline character.
Example:  t?p matches “top”, “tip” but not “trap”.

e Symbol: *

Meaning:  This character matches any number of occurrences (0 or more) of any character except a
newline. Thus, this character will not match across new lines. The* character will match as few
occurrences as are necessary to make the rest of the pattern match.

Example 1: t*o matchesthe “to” of “too”, the “tro” of “trowel” and the “ty 0" of “sporty orange”
but not “smart orange” because the * character does not match across anew line.

e Symbol: \n

Meaning:  This character matches the newline character.

\n would be used to search for line endings or in patterns that cross line boundaries.

Example1: ;\n
matches every occurrence of a newline following a semicolon

Example 2: ;\nif

searches for a semicolon, anew line and aline beginning with “if”.
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* Symbol: \t
Meaning:  This character matches the tab character.
Example 1: \t8
Finds every occurrence of atab character followed by an 8.
Example 2: initt
Finds every occurrence of atab character following “init”.

* Symbol: [1

Meaning:  Thismatches any one character or arange of single characters listed within the brackets.
Brackets cannot be nested.

[-] specifies arange of characters e.g. [a-z] or [0-9]. The beginning character in the range must
have alower ASCII value than the ending character of the range.

[~] matches asingle character if it isnot any one of the characters between
[~and]. This pattern also matches newline characters, unless the newline character isincluded
within the brackets.
Example 1: [AEIOU]
Finds every uppercase vowel.
Example2: [<>7]
Findsaliteral <, >or ?.
Example 3: [A-Za-z0-9 ]
Matches an upper or lowercase letter, a digit or an underscore.
Example4: [~0-9]
Matches any character except a digit.
Example 5: [ \t\n]
Matches a space, atab or newline.
Example6: [\]]
Matchesalitera ] if ] isplaced after \.

e Symbol: \

Meaning:  Thisisthe regular expression override character. If the character following the backdashisa
regular expression character, it istreated asanormal character. The backslash isignored if it is
followed by anormal (non-regular expression) character.

Example 1: \*

Searches for every occurrence of an asterisk.

Example2: \\

Searches for every occurrence of a backdash.
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Appendix C Placeholders
This appendix describes how to use the placeholders, a feature provided by several of the HEW components.

ci1 What is a Placeholder ?

A placeholder isa specia string, inserted into text, which is replaced at some subsequent time for the actual
value. For example, one of the HEW placeholdersis $(FULLFILE) which represents a file with afull path.
Suppose that you have an editor in c:\myedit\myeditor.exe, which can take the file to edit as a parameter. When
invoking the editor the following shortcut could be made, e.g.:

c:\myedit\myeditor.exe c:\files\filel.c

if you wanted to open FILEL.C from the directory c:\files. However, what happensif you want the HEW to open
any file through this editor? The problem is that the command above is specific to “c:\files\filel.c”. What we
want to be able to do isto tell the HEW to use the editor specified but to open the file that | have chosen at that
time. To do this, you can replace the specific name of thefile for ageneral placeholder, i.e.:

c:\myedit\myeditor.exe $(FULL FILE)

Now whenever the HEW launches the editor with afile, it knowsthat it has to replace $(FULLFILE) with the
fileyou have selected.

Cc.2 Inserting a Placeholder

Placeholders can only be entered into three specific edit fields within the HEW (figures C.1, C.2 and C.3). There
are four ways a placeholder can be entered:

In thefirst example, place the insertion cursor at the point you would like to insert the placeholder and then
select the required placeholder from the popup menu to the right of the edit field.

File:
o projectymyprojecthouputhfile 7 out [ 3 |

FigureC.1 Placeholder Popup Menu

In the second example, select the required placeholder other than [Custom directory] from the combo box and
specify a sub-directory relative to the directory shown by the placeholder. If you select [Custom directory],
specify an absolute directory path in the [Sub-Directory] field.

Relative to :

ICnnfiguralion directary ﬂ

Sub-Directorny :

Figure C.2 Placeholder Combo Box and Sub-Directory Field

Note: The[Sub-Directory] field may be written as the [File path] field.
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In the third example, place the insertion cursor at the point you would like to insert the placeholder, select the
required placeholder from the combo box and then click the [Insert] button.

Placehalder:

Canfiguration directary j Inzert |

Figure C.3 Placeholder Combo Box

In the fourth example, type the placeholder into the field directly. Ensure that you type the placeholder namein
uppercase and that it is preceded by $( and followed by ), i.e.

Thisis correct:
$(FILEDIR)

These areincorrect:
$(Filedir)

$( FILEDIR )
$FILEDIR
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Cc3 Available Placeholders

Table C.1 lists the placeholders and their meanings.

TableC.1 Placeholders

Placeholder Meaning
$(FULLFILE) Filename (including full path)
$(FILEDIR) File directory

$(FILENAME)

Filename (excluding path and including extension)

$(FILELEAF)

Filename (excluding path and extension)

$(EXTENSION)

File extension

$(WORKSPDIR)
$(WORKSPNAME)
$(PROJDIR)
$(PROJECTNAME)

Workspace directory
Workspace name
Project directory

Project name

$(CONFIGDIR)

Configuration directory

$(CONFIGNAME)

Configuration name

$(HEWDIR) HEW installation directory

$(TCINSTALL) Toolchain install directory (on option dialog)
$(TOOLDIR) Tool installation directory (Tools Administration)
$(TEMPDIR) Temp directory

$(WINDIR) Windows® directory

$(WINSYSDIR) Windows® system directory

$(EXEDIR) Command directory

$(USERNAME) User login (Version control)
$(PASSWORD) User password (Version control)

$(VCDIR) “Virtual” version control directory
$(COMMENT) Comment (Version control)

$(LINE) Line number of an error/warning

RENESAS

399



For example, the placeholders will be expanded as shown in table C.2.

TableC.2 Placeholder Expansions (Example)

Placeholder Expanded placeholder (example)
$(FULLFILE) c:\hew\workspace\project\file.src
$(FILEDIR) c:\hew\workspace\project
$(FILENAME) file.src

$(FILELEAF) file

$(EXTENSION)
$(WORKSPDIR)

src

c:\hew\workspace

$(WORKSPNAME) workspace
$(PROJIDIR) c:\hew\workspace\project
$(PROJECTNAME) project

$(CONFIGDIR)

c:\hew\workspace\project\debug

$(CONFIGNAME) debug

$(HEWDIR) c:\hew

$(TCINSTALL) c:\hew\toolchains\hitachi\sh\511
$(TOOLDIR) c:\hew\toolchains\hitachi\sh\511
$(TEMPDIR) c:\Temp

$(WINDIR) c:\Windows

$(WINSYSDIR) c:\Windows\System

$(EXEDIR) v:\ve\win32

$(USERNAME) JHARK

$(PASSWORD) 214436

$(VCDIR) “c:\project” is mapped to “x:\vc\project”
$(COMMENT) “Please Enter Comment” dialog is invoked
$(LINE) 12

In table C.2, we are assuming that

afile path is “c:\hew\workspace\project\file.src”.

aworkspace named “workspace” islocated at “c:\hew\workspace”.

a project named “project” islocated at “c:\hew\workspace\project”.

a configuration named “debug” has a configuration directory located at “c:\hew\workspace\project\debug”.
HEW.EXE isinstalled in “c:\hew".

a*.HRF file of atoolchain (i.e. compiler, assembler, linker) islocated at “c:\hew\tool chain\hitachi\sh\511" .
Thisisreferred to as $(TCINSTALL) on the option setting dialogs of the [Options] menu and as
$(TOOLDIR) on the “ Tools Administration” dialog.

the Windows® operating system isinstalled in “c:\Windows” and the Windows® system directory is
“c:\Windows\System”.

aversion control executable path is “v:\vc\win32\ss.exe”, a user name and its password to login the version
control system are “JHARK” and “214436" respectively, §COMMENT) is specified in acommand line to
the version control executable, and “c:\project” is mapped to “x:\vc\project” on the “ Projects” tab of the
“Version Control Setup” dialog, which isinvoked via[Tools->Version Control->Configure...].

an error of compiler or assembler occurred at line 12.
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Note:  Not all of the placeholders are relevant in every field. For example, the $(LINE) placeholder has no
meaning when specifying a dependent files location. $(USERNAME), $(PASSWORD), $(VCDIR), and
$(COMMENT) placeholders are acceptable only in version contral. If you enter a placeholder into an
edit field where it is not acceptable you might be informed.

c4 Placeholder Tips
Placeholders are there to allow you to create flexible paths to the various files used by the system.

* If thereis aplaceholder popup menu ([k]) next to an edit field into which you are about to enter a path or file,
you should consider how you can use a placeholder to make that path or file definition flexible.

» If you use several configurations, then the §(CONFIGDIR) placeholder is very useful to ensure that files can
be written to and from the current configuration’s directory.

» Wherever possible, use a placeholder. They can always be removed or added later so don’t be afraid to
experiment.
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Appendix D 1/0O File Format

HEW formats the [IO] window based on information it findsin an 1/O Register definition file. When you select a
debugging platform, HEW will look for a“<device>.10" file corresponding to the selected device and load it if

it exists. Thisfileisaformatted text file that describes the 1/O modules and the address and size of their registers.
You can edit thisfile, with atext editor, to add support for memory mapped registers or peripherals you may
have specific to your application (e.g. registersin an ASIC device mapped into the microcomputer's address
space).

The following describes two formats of the “<device>.10” file that supports or not the bit field.

D.1 Fileformat (Bit Field Not Supported)

Each module name must be defined in the [M odules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an /O regigter.

The [BaseAddress] definition is for devices where the location of I/O registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the 1/O registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the I/O register file is actually used, the [BaseAddress] value is subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

The [Register] definition entry is entered in the format <name> = <address> [<size> [<absolute>]].
1. <name> register name to be displayed.
2. <address> address of the register.
3. <size>which may be B, W or L for byte, word, or longword (default is byte).

4. <absolute> which can be set to A if the register is at an absolute address. Thisis only relevant
if the I/O area address range moves about on the CPU in different modes. In this case, if a
register is defined as absol ute the base address offset cal culation is not performed and the
specified addressis used directly.

Comment lines are dlowed and must start with a*“;” character.

An example is shown below.
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Example:

; H8S/2655 Series 1/0 Register Definitions File

[Modules]

BaseAddress=0

Module Modulel=Power_Down_Mode_Registers
definition Module2=DMA_Channel_Common

Module3=DMA_Channel_0

Comment

Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]
DMAWER=0xffff00 B A
DMATCR=0xffff01 B A
DMACROA=0x{fff02 B A
DMACROB=0x{fff03 B A
DMACR1A=0xffff04 B A
DMACR1B=0xffff05 B A
DMABCRH=0xffff06 B A
DMABCRL=0X{fff07 B A

Register
definition

[DMA_Channel_0]
MAROAH=0xfffeeO W A
MAROAL=0xfffee2 W A
IOAROA=0xfffeed W A
ETCROA=0xfffee6 W A
MAROBH=0xfffee8 W A
MAROBL=0xfffeea W A
IOAROB=0xfffeec W A

Register name
ETCROB=0xfffeee W A

Address
Size
Absolute address flag
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D.2 Fileformat (Bit Field Supported)

Each module name must be defined in the [M odules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an |/O regigter.

The user must define “FileVersion=2" at the start of the section. It meansthat this 1/O register file is described
with the version that supports the hit field.

The [BaseAddress] definition is for devices where the location of I/O registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the I/O registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the I/O register fileis actually used, the [BaseAddress] valueis subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

Each module has a section that defines the registers forming it along with an optional dependency. The
dependency is checked to seeif the moduleis enabled or not. Each register name must be defined in the section
and the numbering of each register must be sequentia. The dependency is entered in the section as dep=<reg>
<hit> <value>.

1. <reg>istheregister id of the dependency.
2. <bit> isthe bit position within the register.
3. <vaue> isthe value that the bit must be for the module to be enabled.

The [Register] definition entry is entered in the format id=<name> <address> [<size>
[<absolute>[<format>[<bitfields>]]]].

1. <name> register name to be displayed.
2. <address> address of the register.
3. <size>which may be B, W or L for byte, word, or longword (default is byte).

4., <absolute> which can be set to A if the register is at an absolute address. Thisisonly relevant
if the I/O area address range moves about on the CPU in different modes. In this case, if a
register is defined as absol ute the base address offset calculation is not performed and the
specified addressis used directly.

5. <format> format for register output. Valid values are H for Hexadecimal, D for decimal, and
B for binary.

6. <bitfields> section defining the bits within the register.

Bitfield sections define the bits within a register each entry is of the type bit<no>=<name>.
1. <no>isthebit number.
2. <name> isasymbolic name of the bit.

Comment lines are allowed and must start with a*;” character.

An example is shown below.
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Example:

Comment ; H8S/2655 Series 1/0 Register Definitions File
I [Modules]
FileVersion=2
BaseAddress=0
Modulel=Power_Down_Mode_Registers
Module2=DMA_Channel_Common
Module3=DMA_Channel_0
Module
Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]

reg0=regDMAWER

regl=regDMATCR

e reg2=regDMACROA

definition reg3=regDMACROB

reg4=regDMACR1A
reg5=regDMACR1B
reg6=regDMABCRH
reg7=regDMABCRL

L dep=regMSTPCRH 7 0

Module

Register name

Bit

Value

Register [regDMAWER]

__definition id=DMAWER 0xffff00 B A H dmawer_bitfields

Register name |

Address

Size

Absolute address flag

Format

Bit field
[dmawer_bitfields]

Bit-field bit3=WE1B

definition bit2=WE1A
bit1=WEO0B
bitO=WEOA
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Appendix E Symbol File Format

In order for HEW to be able to understand and decode the symbal file correctly, the file must be formatted asa
Pentica-B file:

1. Thefile must beaplain ASCII text file.
2. Thefile must start with the word “BEGIN”.

3. Each symbol must be on a separate line with the value first, in hexadecimal terminated by an
“H", followed by a space then the symbol text.

4. Thefile must end with the word “END”.
Example:

BEG N

11FAH Synbol _nane_1
11FCH Synbol _nane_2
11FEH Synbol _nane_3
1200H Synbol _nane_4
END
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Appendix F Menus

Table F.1 shows GUI menus.

TableF.1 GUI Menus

Toolbar
Menu Option Shortcut  Button Remarks
View Disassembly Ctrl + D Opens the [Disassembly]
window.
Command Line Ctrl+ L Opens the [Command Line]
window.
Workspace Alt + K Opens the [Workspace]
window.
Output Alt + U Opens the [Output] window.
CPU Registers Ctrl + R Opens the [Registers] window.
Memory... Ctrl + M Opens the [Memory] window.
10 Ctrl + 1 Opens the [I0] window.
Status Ctrl + U Opens the [Status] window.
Extended Monitor . Opens the [Extended Monitor]
= !
window.
Monitor  Monitor Shift + Opens the [Monitor] window.
Setting... Ctrl+E
Windows Opens the [Windows Select]
Select... dialog box to list, add, or edit
the [Monitor] window.
EEPROM... Opens the [EEPROM] window.
Sym-  Labels Shift + - Opens the [Labels] window.
bol Ctrl+ A
Watch Ctrl + W Opens the [Watch] window.
Locals Shift + Opens the [Locals] window.
Ctrl + W
Code  Eventpoints Ctrl+ E Opens the [Eventpoints]
window.
Trace Ctrl+T Opens the [Trace] window.
Stack Trace Ctrl + K Opens the [Stack Trace]
window.
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TableF.1 GUI Menus (cont)

Menu

Option

Toolbar
Shortcut  Button

Remarks

View
(cont)

Options

Gra- Image...
phic

Shift + E
Ctrl+ G

Opens the [Image] window.

Waveform...

Per- Performance
form-  Analysis
ance

Debug Sessions...

Debug Settings...

Radix  Hexadecimal

Shift +
Ctrl +V
Shift +
Ctrl+ P

Opens the [Waveform]
window.

Opens the [Performance
Analysis] window.

Opens the [Debug Sessions]
dialog box to list, add, or
remove the debug session.

Opens the [Debug Settings]
dialog box to set the
debugging conditions or
download modules.

Uses a hexadecimal for
displaying a radix in which the
numerical values will be
displayed and entered by
default.

Decimal

—
=

Uses a decimal for displaying
a radix in which the numerical
values will be displayed and
entered by default.

Octal

Binary

Emu-  System...
lator

Memory
Resource...

B [

Uses an octal for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Uses a binary for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Opens the [Configuration]
dialog box allowing the user to
modify the debugging platform
settings.

Opens the [Memory Mapping]
dialog box allowing the user to
view and edit the debugging
platform's current memory
map.
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TableF.1 GUI Menus (cont)

Menu Option

Shortcut

Toolbar
Button

Remarks

Debug Reset CPU

Go

F5

Resets the target hardware and
sets the PC to the reset vector
address.

Starts executing the user
program at the current PC.

Reset Go

Shift + F5

Resets the target hardware and
executes the user program from
the reset vector address.

Go To Cursor

Set PC To Cursor

Starts executing the user
program at the current PC until
the PC reaches the address
indicated by the current text
cursor position.

Sets the PC to the address at
the row of the text cursor.

Run...

Step In

F11

Launches the [Run Program]
dialog box allowing the user to
enter the PC or PC breakpoint
during executing the user
program.

Executes a block of user
program before breaking.

Step Over

Step Out

F10

Shift +
F11

Executes a block of user
program before breaking. If a
subroutine call is reached, then
the subroutine will not be
entered.

Executes the user program to
reach the end of the current
function.

Step...

Launches the [Step Program]
dialog box allowing the user to
modify the settings for stepping.

Step Auto
Mode

Assembly

Steps only one source line when
the [Source] window is active.
When the [Disassembly] window
is active, stepping is executed in
a unit of assembly instructions.

Executes stepping in a unit of
assembly instructions.

Source

Steps only one source line.
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TableF.1

GUI Menus (cont)

Toolbar
Menu Option Shortcut  Button Remarks
Debug Halt Program Esc Stops the execution of the user
(cont) program.

Initialize Disconnects the debugging
platform and connects it again.

Disconnect Disconnects the debugging
platform.

Download Modules Downloads the object program.

Unload Modules Unloads the object program.

Memory  Search... Searches for the specified value
from the specified memory area.

Copy... Copies the specified memory
area to the specified address.

Compare... Compares the specified two
memory areas.

Fill... Fills the specified value in the

specified memory area.

Test... Tests the specified memory

Refresh Forces a manual update of the
contents of all the [Memory]
windows open.

Configure Overlay... Selects the target section group
when the overlay function is
used.
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Appendix G Command Lines

Table G.1 lists the HEW commands.

TableG.1 HEW Commands

No. Command Name

Abbreviation Function

1 ! - Comment
2 ANALYSIS AN Enables or disables performance analysis
3  ANALYSIS_RANGE AR Sets or displays a performance analysis range
4  ANALYSIS_RANGE_ AD Deletes a performance analysis range
DELETE
5 ASSEMBLE AS Assembles instructions into memory
6  ASSERT - Checks if an expression is true or false
7  BREAKPOINT BP Sets a breakpoint at an instruction address
8 BREAKPOINT_CLEAR BC Deletes breakpoints
9 BREAKPOINT_ BD Displays a list of breakpoints
DISPLAY
10 BREAKPOINT_ENABLE BE Enables or disables a breakpoint
11 BREAKPOINT_ BS Sets sequential breakpoints
SEQUENCE
12 CHANGE_ CcC Sets the current configuration
CONFIGURATION
13 CHANGE_PROJECT CP Sets the current project
14 CLOCK CK Set the CPU clock rate in the emulator
15 CONFIGURE_ CPF Sets the debugging environment for the emulator
PLATFORM
16 DEFAULT_OBJECT_ DO Sets the default object (program) format
FORMAT
17 DEVICE_TYPE DE Selects a device type to emulate
18 DISASSEMBLE DA Disassembles memory contents
19 EEPROM_COPY EEPC Transfers data between EEPROMs or EEPROM and
normal memory
20 EEPROM_DISPLAY EEPD Displays the content of the EEPROM
21 EEPROM_EDIT EEPE Changes the content of the EEPROM
22 EEPROM_FILL EEPF Fills a block of the EEPROM with a specified value
23 EEPROM_SETMODE EEPS Selects the slave address of the EEPROM and the
mode for writing data
24 ERASE ER Clears the [Command Line] window
25 EVALUATE EV Evaluates an expression
26 EXMONITOR_DISPLAY EXMD Displays the content of the expansion monitor
27 EXMONITOR_SET EXMS Selects whether or not to display the items in the
expansion monitor
28 EXMONITOR_ EXMSR Sets the time to update the expansion monitor during
SETRATE emulation or a break
29 FILE_LOAD FL Loads an object (program) file
30 FILE_SAVE FS Saves memory to a file
31 FILE_VERIFY FV Verifies file contents against memory

413
RENESAS



TableG.1 HEW Commands (cont)

No. Command Name Abbreviation Function

32 GO GO Executes user program

33 GO_RESET GR Executes user program from reset vector

34 GO_TILL GT Executes user program until temporary breakpoint

35 HALT HA Halts the user program

36 INITIALIZE IN Initializes the debugging platform

37 LOG LO Controls command output logging

38 MAP_DISPLAY MA Displays memory mapping

39 MAP_SET MS Sets memory mapping

40 MEMORY_COMPARE MC Compares memory contents

41 MEMORY_DISPLAY  MD Displays memory contents

42 MEMORY_EDIT ME Modifies memory contents

43 MEMORY_FILL MF Modifies the content of a memory area by specifying
data

44 MEMORY_MOVE MV Moves a block of memory

45 MEMORY_TEST MT Tests a block of memory

46 MODE MO Sets or displays the CPU mode

47 MODULES MU Sets up or displays the on-chip peripheral functions

48 MONITOR_CLEAR MOC Deletes a monitor point

49 MONITOR_DISPLAY MOD Displays the content of the monitor

50 MONITOR_REFRESH MOR Controls an automatic update of the content of the
monitor

51 MONITOR_SET MOS Sets or displays a monitor point

52 OPEN_WORKSPACE OW Opens a workspace

53 QUIT QU Exits HEW

54 RADIX RA Sets default input radix

55 REFRESH RF Updates windows related to memory

56 REGISTER_DISPLAY RD Displays CPU register values

57 REGISTER_SET RS Sets CPU register contents

58 RESET RE Resets CPU

59 SLEEP - Delays command execution

60 STEP ST Steps program (by instructions or source lines)

61 STEP_MODE SM Sets the step mode

62 STEP_OUT SP Steps out of the current function

63 STEP_OVER SO Steps program, not stepping into functions

64 STEP_RATE SR Sets or displays rate of stepping

65 SUBMIT SuU Executes a command file

66 SYMBOL_ADD SA Defines a symbol

67 SYMBOL_CLEAR SC Deletes a symbol

68 SYMBOL_LOAD SL Loads a symbol information file

69 SYMBOL_SAVE SS Saves a symbol information file

70 SYMBOL_VIEW 5\ Displays symbols

414

RENESAS



TableG.1 HEW Commands (cont)

No. Command Name Abbreviation Function

71 TCL - Enables or disables the TCL

72 TIMER TI Sets or displays the timer resolution

73 TRACE TR Displays trace information

74 TRACE_ACQUISITION TA Sets or displays trace acquisition parameters

75 TRACE_BINARY_ TBC Compares a trace binary file with the current trace
COMPARE information

76 TRACE_BINARY_SAVE TBV Outputs trace information into a binary file

77 TRACE_STATISTIC TST Analyzes statistic information

78 TRIGGER_CLEAR TGC Deletes the trigger output condition for EXT.2

79 TRIGGER_DISPLAY  TGD Displays the trigger output condition for EXT.2

80 TRIGGER_SET TGS Sets the trigger output condition for EXT.2

81 USER_SIGNALS us Enables or disables the user signal information

For the syntax of each command, refer to the online help.
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Appendix H Diagnostic Test Procedure

This section describes the diagnostic test procedure using the E6000 test program.

H.1  System Set-Up for Test Program Execution

To execute the test program, use the following hardware; do not connect the user system interface cable and user
system.

ok w DN

E6000 emul ator (HS3664EPI61H)

Host computer

The E6000 PC interface board (select either from the followings according to the PC interface
specifications):

PCI businterface board (HS6000EICO1H or HS6000EICO2H)

PCMCIA interface card (HSG000EI PO1H)

Install the E6000 PC interface board in the host computer and connect the supplied PC interface cable to the
board.

Connect the PC interface cable to the emulator.

Connect the supplied AC adapter to the emulator.

Initiate the host computer to make it enter DOS prompt command input wait state.
Turn on the emul ator power switch.
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H.2 Diagnostic Test Procedure Using Test Program

Insert the CD-R (HS3664EPI61SR supplied with the emulator) into the CD-ROM drive of the host compuiter,
move the current directory to <Drive>:\Diag with acommand prompt, and enter either of the following
commands according to the PC interface board in use to initiate the test program:

1. PCI bus interface board (HS6000EICO1H or HS6000EICO2H)
> TM3664 —PCI (RET)

2. PCMCIA interface card (HSB000EI POLH)
> TM3664 —PCCD (RET)

The HEW must be installed before the test program is executed.

Be sure to initiate the test program from <Drive>:\Diag. Do not initiate it from adirectory other than
<Drive>:\Diag, such as > <Drive>:\Diag\TM 3664 —PCI (RET). If the test program isinitiated when the current
directory isnot <Drive>:\Diag, the test program will not operate correctly.

When -Sis added to the command line such as >TM 3664 —PCI —S (RET), steps 1 to 20 will be repeatedly
executed. To stop the execution, enter Q.

Notes: 1. <Drive>isadrive name for the CD-ROM drive.
2. Do not remove the CD-R from the CD-ROM drive during test program execution.
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The following messages are displayed during test. Thistest consists of steps 1 to 20.

M essage

E6000 H8/ 3664 Enul ator Tests Vx.Xx

Loading driver ............ .. ... .....
Initializing driver ..................

Searching for interface card .........

Checki ng emul ator is connected

Enmul at or Board | nformation:

Main Board |D:

Enmul ation Board |D:

SUB board | D:

Option nmenory board:

01) Test Register:

A) IDRO Register ..................
B) PAGE Register ..................
C TRACE G A Register..............
D) PERFM G A Register..............
E) CES GA Register................
F) IDRL Register...................
G IDR2 Register...................

02) Test DPRAM :

A) Decode Test ....................
B) Marching Test ..................

RENESAS

Description

Test program start
message. Vx.Xx shows the
versi on nunber.

Shows that the PC
interface board is
correctly installed in
the host conputer.

Shows that the E6000 is
correctly connected to
the host conputer.

Shows the I D nunber of
the | ower board of the
E6000 (al ways 5).

Shows the I D nunber of
t he upper board of the
E6000 (al ways 17).

Shows the | D nunber of
the E6000 (expansion I/0O
board) as f.

Shows whet her the SIMM
menory board is
instal |l ed.

Shows the check results
for the registers in the
E6000 ( nor mal
conpl etion).

Shows the results of
decodi ng test and
marching test for the
dual -port RAMin the
E6000 ( nor mal

conpl etion).
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03) Test Firmware RAM :
A) Decode Test page [H 700 - H 71f]

B) Marching Test page [H 700 - H 71f]

04) Test Trace nenory :

A) Decode Test page [H 000 - H 04f] (Lower
B) Marching Test page [H 000 - H 04f] (Lower
C) Decode Test page [H 000 - H 04f] (Upper
D) Marching Test page [H 000 - H 04f] (Upper
05) RESERVED

06) Test Internal ROM and RAM :

A) Decode Test (Internal ROV ..... K

B) Marching Test (Internal ROV ...

C) Decode Test (Internal RAM ..... 0.4

D) Marching Test (Internal RAM ...

07) RESERVED

08) Test Enul ati on RAM STEP Operation :

A) Step Operation ................. K

09) Test Keybreak :

A Key Break ...................... K

10) Test Emul ati on RAM Hardware Break :

A) GRDBreak ...................... (0.4

B) WPT Break ...................... RESERVED
C) WPT (ROM) Break ................ RESERVED
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32K)

32K)

32K)

32K)

Shows the results of
decoding test for the
firmware RAMin the E6000
(normal conpl etion).

Shows the results of
marching test for the
firmare RAM in the E6000
(normal conpletion).

Shows the results of
decoding test for the
trace RAM (first half) in
t he E6000 (nor nal

conpl etion).

Shows the results of
marching test for the
trace RAM (first half) in
t he E6000 ( nor nal

conpl etion).

Shows the results of
decoding test for the
trace RAM (last half) in
t he E6000 ( nor nal

conpl etion).

Shows the results of
marching test for the
trace RAM (last half) in
t he E6000 (nor nal

conpl etion).

Shows the results of
decodi ng test and

mar ching test for
internal ROM and RAM in
t he E6000 (nor nal

conpl etion).

Shows the check results
for the step execution
controlling circuits in
t he E6000 (nor nal

conpl etion).

Shows the check results
for the forced break
controlling circuits in
t he E6000 ( nor nal

conpl etion).

Shows the check results
for the illegal access
break controlling
circuits in the E6000
(normal conpl etion).



11) Test Internal ROM Wite Protect

A Wite Protect ....................... K

B) Wite Not Protect ................... K

12) Test Hardware Break

A) Break Point Initialized ............. XK

B) Event Detectors CES channel 1-12 .... X

C) Test Sequencing 1 ................... (0.4

D) Check Range Break ................... XK

E) Range Break Test for Data ........... K

F) Check Conpare Either ................ K

13) Test Emul ati on RAM Trace :

A) Free Trace .............cuiiiiiio... (0.4

B) Range Trace ....................u.... XK

C) Point to Point Trace ................ K

D) Start and Stop Event Trace .......... (0.4

E) Trace menory Overflow ............... XK

F) Tine STAMP Trace..................... K

G ASEBKTOA/B N Trace .................. RESERVED
14) Test Runtime Counter

A) Internal Cock 20MHz ..................... K
B) Internal Clock 16MHz ..................... XK
C) Internal Clock 10MHz ..................... K
D) Internal Cock 1IMHz ..................... (0.4
E) Internal Sub Clock 32.768KHz ............. X
15) Test Emul ation Monitor

A) EMA23-EMAO . ... ... (04

B) ACST2-ACSTO .......coviiiieinennn.. oK

C) ASEST3-ASESTO .............ccoivinunnn XK

D) ASEBRKACK (MONITOE) ................. XK

E) ONN ... oK

F) NOCLK ... ... e XK

16) Test PERFM G A :

A) Tinme Measurenment ................... K

B) Point to Point Tine Measurenent ....RESERVED
C) Subroutine Count Measurenment ....... K

D) Tineout Function (TIMOT Bit) ....... XK

E) Tineout Function (TIMOP Bit) ....... XK

17) Test Bus Monitor

A) Register .......... ... .. i XK
B) Parallel RAM ............. ... ... .. ....... 0.4
C SPRSEL2 ........ ... i K
D) RAMMNIitor ...t XK

RENESAS

Shows the check results
for the internal ROM
Wite-protection
controlling circuits in
t he E6000 (nornal

conpl etion).

Shows the check results
for the hardware break
control circuits in the
E6000 ( nor mal
conpl etion).

Shows the check results
for the trace controlling
circuits in the E6000
(normal conpl etion).

Shows the check results
for the run-tine counter
in the E6000 (normal
conpl etion).

Shows the check results
for the enulation nonitor
controlling circuits in
t he E6000 ( nor nal

conpl etion).

Shows the check results
for analysis controlling
circuits in the E6000
(normal conpl etion).

Shows the check results
for the bus nonitor
controlling circuits in
t he E6000 ( nor nal

conpl etion).
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A
B)
O]
D)
B
F
9
H)
D]
J)
K)
L

A
B

18) Test Parallel Access :
Internal ROM Parallel Read Access(WORD) ........... 0.4
Internal ROM Parallel Wite Access(WORD) .......... XK
Internal ROM Parallel Wite Access(High Byte) ..... K
Internal ROM Parallel Wite Access(Low Byte) ...... K
Internal RAM Parallel Read Access(WORD) ........... XK
Internal RAM Parallel Wite Access(WORD) .......... XK
Internal RAM Parallel Wite Access(H gh Byte) ..... K
Internal RAM Parallel Wite Access(Low Byte) ...... (04
Option RAM Paral l el Read Access(WORD) ............ RESERVED
Option RAM Parallel Wite Access(WORD) ............ RESERVED
Option RAM Parallel Wite Access(High Byte) ....... RESERVED
Option RAM Parallel Wite Access(Low Byte) ........ RESERVED

19) Test Go Reset:
Go Reset............ ... .. i, (0.4
Bus 00>FF............. .. ... .. ... .. ..... K

20) Test Normal Mbde:
Normal Mode Test ....................... K

A

B) Address 23:16=00 Tes

Tests run for xH xM xxS

Tests passed,
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Shows the check results
for the parallel access
controlling circuits in
t he E6000 (nor nal

conpl etion).

Shows the check results
for the Go RESET
controlling circuits in
t he E6000 ( nor nal

conpl etion).

Shows the check results
for Nornal Mde (nornal
conpl etion).

Total testing tinme.

Shows that the E6000 is
correctly operating.
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